18:03:15 <SergeyLukjanov> #startmeeting savanna
18:03:16 <openstack> Meeting started Thu Sep 26 18:03:15 2013 UTC and is due to finish in 60 minutes.  The chair is SergeyLukjanov. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:03:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:03:20 <openstack> The meeting name has been set to 'savanna'
18:03:32 <SergeyLukjanov> #topic Agenda
18:03:32 <SergeyLukjanov> #info News / updates
18:03:32 <SergeyLukjanov> #info Roadmap cleanup / update
18:03:32 <SergeyLukjanov> #info Action items from the last meeting
18:03:32 <SergeyLukjanov> #info General discussion
18:03:39 <SergeyLukjanov> #topic News / updates
18:03:45 <SergeyLukjanov> folks, please
18:03:54 <mattf> congrats all on incubating!
18:03:58 <aignatov_> We are incubated!!!
18:04:16 <SergeyLukjanov> yeah, we do it
18:04:47 <SergeyLukjanov> #info Savanna was accepted as an incubated project
18:04:49 <ogelbukh> now the interesting part begins )
18:05:02 <SergeyLukjanov> are there any other news? :)
18:05:44 <NikitaKonovalov> I've started removing code duplication in our dashboard and client repositories
18:05:45 <SergeyLukjanov> btw Savanna will be moved to openstack org around next weekend
18:05:50 <SergeyLukjanov> https://review.openstack.org/#/c/48491/
18:06:05 <NikitaKonovalov> hopefully we will have dashboard relying on a client
18:06:14 <aignatov_> update from Kolya, he worked on job-configs for EDP, 2 patches for savanna-core and UI are on the review
18:06:25 <ruhe> SergeyLukjanov,  will our docs be moved to openstack.org ?
18:06:42 <SergeyLukjanov> ruhe, yep, I hope
18:07:04 <ruhe> SergeyLukjanov, will our code be moved to github.com/openstack ?
18:07:10 <alazarev> regarding data locality, Alex Ignatov and me continue debugging of Alexander Kuznetsov's patch, probably will nbe done next week
18:07:33 <SergeyLukjanov> ruhe, yep, absolutely
18:07:48 <aignatov_> also we have integration tests on the review
18:07:49 <ruhe> excellent
18:07:52 <aignatov_> so. please review
18:08:29 <aignatov_> Nadya's patch of merging Jobs and jobsOrigin is merging today
18:09:09 <crobertsrh> I've got 3 or 4 bug fix reviews that will hopefully be merging soon.
18:09:36 <aignatov_> crobertsrh, good progress
18:09:59 <tmckay> I'm working on retrieval of job binaries from swift, I have a simple test case that works.
18:10:07 <tmckay> but I'm distracted by a machine that may be dying
18:10:20 <tmckay> I should upload my CR as a draft before I lose it :)
18:10:44 <aignatov_> yes, please do it
18:11:26 <SergeyLukjanov> #topic Roadmap cleanup / update
18:11:45 <SergeyLukjanov> 1. move next-gen architecture to the next release
18:11:54 <SergeyLukjanov> 2. move Monitoring support to the next release
18:12:10 <SergeyLukjanov> ^^ I think that it's time to postpone this blueprints
18:12:22 <ruhe> agree
18:12:23 <aignatov_> +1
18:12:36 <SergeyLukjanov> any objectives?
18:12:56 <alazarev> +1
18:13:16 <SergeyLukjanov> ok
18:13:22 <ruhe> something related to roadmap...
18:13:26 <ruhe> I think launchpad needs a major cleanup of blueprints
18:13:29 <ruhe> #link https://launchpad.net/savanna/+milestone/0.3a1
18:13:33 <SergeyLukjanov> #action slukjanov to move next-gen architecture to the next release
18:13:44 <SergeyLukjanov> #undo
18:13:45 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x310f890>
18:13:56 <SergeyLukjanov> #action SergeyLukjanov to move next-gen architecture to the next release
18:14:09 <SergeyLukjanov> #action SergeyLukjanov to move Monitoring support to the next release
18:14:18 <SergeyLukjanov> ruhe, agreed
18:14:25 <aignatov_> good point, ruhe
18:14:27 <SergeyLukjanov> + smth like bugday
18:14:59 <aignatov_> you mean to run bugdays regulary?
18:15:30 <SergeyLukjanov> I mean "bug triage day"
18:15:37 <aignatov_> anyway, it's good idea
18:15:43 <SergeyLukjanov> aignatov_, no need to run them regulary
18:16:38 <SergeyLukjanov> I'll take a look at blueprints tomorrow and schedule bug triage day in case of need
18:16:43 <SergeyLukjanov> and bugs
18:16:47 <aignatov_> ok, thx
18:17:03 <aignatov_> I can help you if needed
18:17:10 <SergeyLukjanov> thx
18:17:22 <SergeyLukjanov> #topic Action items from the last meeting
18:17:42 <SergeyLukjanov> #info ACTION: aignatov Update roadmap with Heat integration [DONE]
18:17:48 <aignatov_> done
18:17:54 <SergeyLukjanov> #topic General discussion
18:19:00 <SergeyLukjanov> any thoughts?
18:19:27 <ruhe> just in case if someone missed this blog-post http://www.zerobanana.com/archive/2013/09/25#savanna-incubation
18:20:23 <SergeyLukjanov> btw we have 4 slots at design summit
18:20:39 <SergeyLukjanov> feel free to suggest topics at http://summit.openstack.org
18:21:51 <aignatov_> I think we missed one more update - savanna 0.2.2 is released!
18:22:16 <SergeyLukjanov> I think that we need the following sessions: heat integration, edp future, scalable next-get architecture and overall savanna roadmap
18:22:18 <ruhe> with official HDP plugin!
18:22:38 <SergeyLukjanov> yeah, it's great, thanks for Hortonworks guys!
18:24:09 <SergeyLukjanov> looks like that's time to end meeting
18:24:18 <jspeidel> yes, big milestone.  Thanks all
18:24:53 <dmitryme> by the way guys, the summit is pretty close
18:25:12 <dmitryme> that means we need to prepare topics and discuss them prior the summit
18:25:43 <SergeyLukjanov> #info JFYI you can always use openstack-dev@lists.openstack.org mailing lists and #savanna irc channel to find us and ask your questions
18:26:09 <dmitryme> in case you don't know - the summit design sessions are mostly for confirming and finalizing design and arch questions
18:26:22 <dmitryme> most of the work is done prior to the summit
18:26:38 <dmitryme> via email and irc
18:26:47 <ruhe> one more topic I'd like to to discuss: will HDP plugin be able to support EDP jobs in Savanna v0.3 ?
18:27:04 <SergeyLukjanov> #link https://wiki.openstack.org/wiki/Summit#Before_the_Design_Summit
18:28:46 <SergeyLukjanov> anything else?
18:29:30 <jspeidel> we (HDP) don't have any EDP related tasks in our upcoming sprints for 0.3.
18:29:49 <jspeidel> how much work is needed to be implemented by a plugin?
18:30:02 <ruhe> not much actually...
18:30:21 <ruhe> plugin has to provision Oozie and Hive services
18:30:46 <jspeidel> Just finishing up work on Hive support
18:30:56 <jspeidel> Oozie shouldn't be difficult
18:31:04 <jspeidel> we should have this for 0.3
18:31:09 <ruhe> would oozie support Pig jobs?
18:31:26 <jspeidel> yes, I don't see any reason why it wouldn't
18:31:33 <ruhe> great
18:31:48 <aignatov_> HDP has Oozie 3.3.2, pig job is included
18:31:55 <aignatov_> as dar as i know
18:31:59 <aignatov_> *far
18:32:11 <jspeidel> yes, will be sure to functionally test through savanna
18:36:22 <jspeidel> aignatov: yes to clarify.  Yes we 0.3 will include HDP support for 1.3.2 which includes Oozie 3.3.2 which does support pig jobs
18:36:49 <aignatov_> that's great
18:37:03 <aignatov_> should work with edp
18:37:24 <jspeidel> looking forward to testing this
18:37:45 <jspeidel> is edp functionality ready to test in master now?
18:38:12 <aignatov_> actuallly edp is an active developement, but it's laready have all needed functional
18:39:01 <jspeidel> ok, we should have support for the necessary service by end of next week
18:39:07 <jspeidel> services
18:39:58 <aignatov_> ok
18:41:50 <aignatov_> btw, I'm going to write integration tests on edp, hope to have preliminaty functional by theend of the nex week too
18:43:01 <SergeyLukjanov> #endmeeting