18:07:39 <SergeyLukjanov> #startmeeting savanna
18:07:40 <openstack> Meeting started Thu Jul  4 18:07:39 2013 UTC.  The chair is SergeyLukjanov. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:07:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:07:44 <openstack> The meeting name has been set to 'savanna'
18:07:57 <aignatov3> hi all
18:08:02 <SergeyLukjanov> hi guys
18:08:07 <SergeyLukjanov> o/
18:08:20 <ruhe> Hi!
18:08:45 <SergeyLukjanov> #topic Agenda
18:08:45 <SergeyLukjanov> #info Savanna core updates
18:08:45 <SergeyLukjanov> #info REST API validation updates
18:08:45 <SergeyLukjanov> #info Manual scaling updates
18:08:45 <SergeyLukjanov> #info UI updates
18:08:46 <SergeyLukjanov> #info Documentation updates
18:08:46 <SergeyLukjanov> #info Releasing updates
18:08:47 <SergeyLukjanov> #info Other updates
18:08:47 <SergeyLukjanov> #info Action items from the last meeting
18:08:48 <SergeyLukjanov> #info General discussion
18:09:03 <SergeyLukjanov> #topic Savanna core updates
18:09:23 <SergeyLukjanov> there are several minor updates on this topic
18:09:28 <SergeyLukjanov> first of all
18:09:53 <SergeyLukjanov> #info multi-tenancy support has been implemented and merged into the repo
18:10:26 <SergeyLukjanov> #info several minor bug fixes and improvements
18:10:42 <SergeyLukjanov> SergeyLukjanov_, what are you doing? O_O
18:11:00 <SergeyLukjanov> #info support for attaching Cinder volumes has been implemented and merged into the repo
18:11:14 <SergeyLukjanov> it's now very basic and we are planning to improve it
18:11:48 <SergeyLukjanov> #info bug w/incorrect content type determination has been fixed (thanks for mattf)
18:12:06 <SergeyLukjanov> and the next topic is...
18:12:07 <SergeyLukjanov> #topic REST API validation updates
18:12:13 <aignatov3> it's me
18:12:15 <SergeyLukjanov> aignatov, please
18:12:16 <aignatov3> ok
18:12:49 <aignatov3> so, I've sent the first patch set to the review
18:13:02 <aignatov3> #link https://review.openstack.org/#/c/35675/
18:13:35 <aignatov3> it includes all jsonschema coverage for all REst calls
18:13:53 <aignatov3> just now see valuable comments from Sergey))
18:13:56 <aignatov3> thx
18:14:26 <aignatov3> will change it soon
18:14:29 <SergeyLukjanov> is that all from you side on this topic?
18:14:33 <SergeyLukjanov> your*
18:15:08 <aignatov3> from validation side, yes, please join to the review
18:15:22 <SergeyLukjanov> btw I hope that we'll use objects' schemas to generate some docs
18:15:27 <SergeyLukjanov> aignatov thx
18:15:34 <SergeyLukjanov> #topic Manual scaling updates
18:15:47 <SergeyLukjanov> Nadya isn't with us today
18:15:57 <aignatov3> I can do the update
18:16:01 <aignatov3> for her
18:16:10 <SergeyLukjanov> aignatov please
18:16:50 <aignatov3> so, implementation was done thos week, it was merged, thx for Nadya
18:17:04 <aignatov3> cluster scaling supports node groups resinig
18:17:28 <aignatov3> and adding new node groups to the existing clusters
18:17:48 <SergeyLukjanov> it supports increase instances count in existing node groups and adding new node groups
18:17:54 <aignatov3> only datanodes and tasktrackers properties are supported
18:18:01 <aignatov3> *processes
18:18:05 <SergeyLukjanov> additionally we are planning to support decreasing node group size
18:18:06 <aignatov3> not properties)
18:18:11 <SergeyLukjanov> yep)
18:18:23 <SergeyLukjanov> of course we are speaking about vanilla plugin
18:18:51 <SergeyLukjanov> the core savanna part is near to be done to support any scaling scenarios
18:19:18 <SergeyLukjanov> I think that's all for scaling
18:19:22 <aignatov3> thatt's all I think from scaling perspective
18:19:27 <SergeyLukjanov> #topic UI updates
18:19:37 <SergeyLukjanov> nkonovalov, please
18:19:43 <nkonvalov> ok
18:20:13 <nkonvalov> savanna-dashboard suppors templates copying now
18:20:34 <nkonvalov> for both node-group templates and cluster templates
18:21:04 <nkonvalov> cluster scaling flow was implemented and recently merged
18:21:11 <SergeyLukjanov> #info Savanna dashboard supports templates copying for both template types
18:21:25 <SergeyLukjanov> #info Savanna dashboard supports cluster scaling
18:22:02 <nkonvalov> some minor improvements were made, kig formatting status messages, when operations fail or succeed
18:22:47 <SergeyLukjanov> great
18:22:51 <nkonvalov> that's actually all dashboard updates for today
18:23:19 <SergeyLukjanov> btw a lot of small improvements has been done on UI side to make it sexy :)
18:23:43 <SergeyLukjanov> that's all about UI?
18:23:51 <nkonvalov> i think so
18:23:54 <SergeyLukjanov> ok, thx
18:23:57 <SergeyLukjanov> #topic Documentation updates
18:24:01 <SergeyLukjanov> ruhe, please
18:24:28 <ruhe> here is a link to the blueprint I filed today
18:24:32 <ruhe> #link https://blueprints.launchpad.net/savanna/+spec/docs-for-v0.2
18:24:51 <ruhe> you can find all the items we need to document before the v0.2 release
18:25:11 <ruhe> i hope docs will be finished in the mid of the next week
18:25:17 <SergeyLukjanov> rune, could you please add work items to the white board with assignments?
18:25:23 <ruhe> yep
18:25:27 <SergeyLukjanov> great
18:25:31 <ruhe> work items along with assignees
18:25:38 <ruhe> for each doc item
18:25:47 <ruhe> that's all about docs
18:26:22 <SergeyLukjanov> #action ruhe to add work items to the white board with assignments for docs bp
18:26:34 <SergeyLukjanov> ruhe, thx
18:26:37 <SergeyLukjanov> #topic Releasing updates
18:27:12 <SergeyLukjanov> we have some plans about releasing 0.2 version and some pre-releases of it
18:27:18 <SergeyLukjanov> #link https://launchpad.net/savanna/0.2
18:27:35 <SergeyLukjanov> here you can see several planned pre-releases with dates
18:28:09 <SergeyLukjanov> 0.2a1 version will be released today
18:28:34 <SergeyLukjanov> here is some info about it
18:28:39 <SergeyLukjanov> #info Savanna 0.2a1 version : https://launchpad.net/savanna/+milestone/0.2a1 : Bugs targeted: 1 Won't Fix, 16 Fix Committed && Blueprints targeted: 22 Implemented
18:29:04 <SergeyLukjanov> and here is our release schedule
18:29:16 <SergeyLukjanov> #info 0.2a1 - today
18:29:22 <SergeyLukjanov> #info 0.2a2 - Monday - July, 8
18:29:30 <SergeyLukjanov> #info 0.2a3 / 0.2-rc1 - Wednesday - July, 10
18:29:36 <SergeyLukjanov> #info 0.2 - Monday - July, 15
18:29:44 <aignatov3> releases table looks cool! didn't see that before)
18:30:12 <SergeyLukjanov> It was available for 0.1 too :)
18:30:13 <aignatov3> on the Launchpad I mean)
18:30:34 <SergeyLukjanov> we are planning code freeze for 0.2-rc1 version
18:30:46 <SergeyLukjanov> I think that's all about releaseing
18:30:57 <SergeyLukjanov> #topic Other updates
18:31:10 <SergeyLukjanov> guys, do you have any other updates?
18:31:22 <aignatov3> yep
18:32:10 <aignatov3> this week we merged patch which generates hadoop keypairs from Savanna
18:32:31 <aignatov3> appropriate dib elements were updated as well
18:32:52 <aignatov3> thx ruhe for these patches
18:33:06 <SergeyLukjanov> yep, it's a great challenge to implement it and test on different operation systems
18:33:13 <ruhe> welcome :)
18:33:46 <aignatov3> as I remember this week we merged the final elements for feddora images creation)
18:34:02 <ruhe> yes now vanilla plugin works on Fedora and on Ubuntu
18:34:02 <SergeyLukjanov> yep
18:34:25 <SergeyLukjanov> ruhe, what's about Centos?
18:34:46 <aignatov3> #info Now Savanna generates hadoop user keypairs for provisioned clusters
18:34:58 <ruhe> i've only tested that it's possible to install proper cloud-init on Centos. We don't have dib elements for Centos yet
18:35:06 <SergeyLukjanov> ok
18:35:28 <aignatov3> #info Fedora dib elements workking with Savanna 0.2 were checked in
18:35:57 <aignatov3> I have no updates)
18:36:16 <SergeyLukjanov> #info A lot of integration tests has been merged into the repo
18:36:55 <SergeyLukjanov> additionally we are now checking compatibility with different Folsom and Grizzly installations
18:37:03 <SergeyLukjanov> are there any other updates?
18:37:41 <SergeyLukjanov> it looks like that there are no more updates
18:37:50 <SergeyLukjanov> let's go on
18:37:53 <SergeyLukjanov> #topic Action items from the last meeting
18:38:12 <SergeyLukjanov> we have only one action item from the last meeting
18:38:17 <SergeyLukjanov> and it has been done
18:38:22 <SergeyLukjanov> #info DONE: Nadya to send info about manual cluster scaling plans to the mailing list
18:39:06 <SergeyLukjanov> and we have one new action item on ruhe
18:39:59 <SergeyLukjanov> oh, additionally we share some plans about 0.3 version
18:40:18 <SergeyLukjanov> akuznetsov, could you please write more about it?
18:40:24 <SergeyLukjanov> #topic General discussion
18:41:24 <akuznetsov> we  published a our thought about elastic data processing #link https://wiki.openstack.org/wiki/Savanna/EDP
18:41:38 <SergeyLukjanov> #link https://wiki.openstack.org/wiki/Savanna/EDP
18:42:18 <SergeyLukjanov> we are waiting for comments/questions/feedback on it ;)
18:42:26 <ruhe> it was published to encourage discussion of scope and details of Savanna v0.3
18:42:59 <SergeyLukjanov> mm, we are now in "General discussion", are there any questions?
18:43:17 <SergeyLukjanov> akuznetsov, thx for the update
18:44:42 <SergeyLukjanov> If there are no questions, I think we should end the meeting
18:44:58 <SergeyLukjanov> #info JFYI you can always use savanna-all@lists.launchpad.net mailing lists and #savanna irc channel to find us and ask your questions
18:45:01 <SergeyLukjanov> #endmeeting