15:00:05 <zns> #startmeeting satori
15:00:06 <openstack> Meeting started Mon Mar 17 15:00:05 2014 UTC and is due to finish in 60 minutes.  The chair is zns. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:10 <openstack> The meeting name has been set to 'satori'
15:01:08 <zns> Hi there. Anyone here yet for the satori meeting?
15:01:10 <samstav> o/
15:01:13 <caleb_> o/
15:01:14 <walker_> o/
15:01:35 <zns> #topic Review Action List
15:01:38 <gondoi> o/
15:01:44 <gusmaskowitz> o/
15:01:58 <hhoover> o/
15:02:11 <zns> walker_, jasonpgignac - Templated output has been merged, so I'll consider your action items complete. Anything to add?
15:02:18 <adrian_otto> o/
15:02:29 <walker_> zns: nope
15:02:30 <walker_> thanks
15:02:44 <zns> Cool. So all remaining action items are mine..
15:02:55 <zns> catch exceptions in CLI - done, merged.
15:03:39 <zns> implement plugins - not done. But ssh module was merged in, and there's a pending review for the ohai-solo plugin. I'll carry that over to next week.
15:03:49 <zns> #action zns implement plugins own establishing the connection to start with, but we provide a built-in ssh module that they can use
15:04:13 <zns> Create wiki page for naming suggestions - done #link https://wiki.openstack.org/wiki/Satori/NamingUnnamedThings
15:04:20 <zns> #link https://wiki.openstack.org/wiki/Satori/NamingUnnamedThings
15:05:03 <zns> #link https://review.openstack.org/#/c/79798/
15:05:14 <zns> That's the URL to the ohai-solo patch
15:05:49 <caleb_> The ohai-solo patch will be finished up this week, right?
15:06:01 <jasonpgignac> Sorry, o/
15:06:16 <zns> BTW, we also updated satori's pipeline. We now gate on PEP-257, python 33, and pypy. That's a pretty high bar, but I'm proud to say we've been getting patches through.
15:06:28 <zns> caleb_: yes (today, I hope)
15:06:49 <caleb_> re: naming. Should we add to the doc this week and then vote next week?
15:06:51 <zns> #topic general discussion
15:07:06 <adrian_otto> zns: the https://review.openstack.org/79798 was submitted as a work-in-progress, or as a legitimate merge candidate?
15:07:38 <zns> We also have a few new blueprints. Of special note is the one where we'd like to support discovery on localhost (no remote ssh connection).
15:08:06 <zns> adrian_otto: it's a legitimate patch.
15:09:29 <zns> I also would like to commend samstav on the ssh module patch. It has 100% test coverage.
15:09:31 <caleb_> zns: Can me move https://blueprints.launchpad.net/satori/+spec/satori-templated-output to Implemented?
15:09:38 <zns> #info We now gate on PEP-257, python 33, and pypy
15:09:48 <caleb_> 700+ lines of testing code. Nice work.
15:09:55 <zns> #info 100% test coverage for ssh_module
15:10:00 <samstav> shooting for 110 next time
15:10:11 <zns> adrian_otto: did you have a question about the patch?
15:10:24 <jasonpgignac> *watches in awe as samstav turn it to 11*
15:11:38 <zns> caleb_: the Templated Output implementation is lacking one small last piece; providing a file path as template. I'll close it once we implement that.
15:11:41 <adrian_otto> zns: no question. I was just curious if it was actually a WIP, but was not labeled that way.
15:12:13 <zns> It was WIP originally, but the latest patches are out there as merge candidates. I have outstanding comments from caleb_ .
15:12:39 <zns> And I'm only at 92% test coverage...
15:12:49 <walker_> 92%? That's unacceptable
15:12:51 <walker_> ;)
15:13:02 <zns> 406
15:13:04 <caleb_> I'm really interested in https://blueprints.launchpad.net/satori/+spec/satori-localhost
15:13:07 <adrian_otto> what are you using to measure coverage?
15:13:34 <zns> rm -rf cover && rm -rf covhtml && rm .coverage && tox -ecover  && coverage html -d covhtml -i && open covhtml/index.html
15:13:38 <caleb_> Is anybody assigned to pick that up this week? Are there things that it depends on?
15:14:13 <zns> caleb_: it _might_ depend on the 79798
15:14:29 <zns> No one assigned AFAIK
15:15:11 <caleb_> I agree. localhost discovery better include data plane :)
15:15:13 <gondoi> the ansible blueprint could do this as well as the ohai-solo one
15:15:15 <samstav> I know a  lot of us develop on os x. What about a package for macs, walkker_ ?
15:15:32 <zns> adrian_otto: that command is included in the read me: https://github.com/stackforge/satori#start-hacking (looking at it, it needs a formatting cleanup)
15:15:42 <samstav> walker_ ^
15:15:52 <gondoi> now that I'm back i'll be picking that ansible blueprint back up
15:15:54 <walker_> samstav, I could probably build something, but not sure how useful it would really be
15:16:00 <jasonpgignac> samstav: With our primary target audience at this point being system administrators, woudl that be a high priority?
15:16:05 <zns> samstav: I wonder if we could leverage http://www.etresoft.com/etrecheck maybe
15:16:05 <walker_> FPM supports OSX packages
15:16:25 <samstav> the fact that fpm supports was the only reason I brought it up.
15:16:28 <walker_> I don't feel like OSX discovery is really part of our scope
15:16:46 <zns> gondoi: cool. Looking forward to that.
15:16:49 <samstav> proposed in context of dev
15:17:00 <jasonpgignac> walker_: I agree. At this point, anyway, particularly.
15:17:02 <zns> It will be cool to explore using multiple plugins.
15:17:22 <zns> What's FPM?
15:17:27 <walker_> https://github.com/jordansissel/fpm
15:17:37 <walker_> It is what Omnibus uses to make packages
15:17:55 <zns> Cool
15:18:25 <gondoi> zns: since the ohai-solo is a first work at a plugin, i'll probably work off of it to add ansible
15:18:26 <zns> Is there an action item WRT localhost? Anyone picking that up?
15:18:46 <gondoi> erm I can take it re: ansible
15:18:48 <samstav> I was coincidentally looking at this on friday zns
15:18:56 <samstav> WRT localhost
15:19:01 <samstav> I can take that one.
15:19:07 <zns> gondoi: OK. Let me know if you want some help. I might need to alter that one as we make it all really pluggable.
15:19:29 <zns> #action samstav implement localhost blueprint.
15:19:36 <zns> Thanks, samstav
15:19:44 <caleb_> samstav: I'll assist
15:20:11 <jasonpgignac> Will the localhost assume its been run as root or sudo? Just curious
15:20:14 <samstav> đź‘Ś
15:20:39 <zns> This also brings up dependencies. Right now we are heavy because of nova client. We don't need nova client for localist. Hence the blueprint: https://blueprints.launchpad.net/satori/+spec/satori-minimal
15:21:17 <samstav> interesting...
15:21:23 <zns> localhost, I meant
15:21:44 <caleb_> Just FYI, after the data plane discovery blueprints lands I'll be writing a blueprint to add `--crawl` support to extend discovery to "related" machines. (e.g. server A has an active connection to server B, attempt to include server B too)
15:21:58 <zns> Any thoughts on having two packages. satori, and satori-full? Where satori-full has everything in it, and satori just does data plane discovery?
15:22:15 <caleb_> zns: There's not a clean mechanism or pattern that I've seen to do that.
15:22:22 <zns> Or the other way around, where satori is full and there is  a satori-light?
15:22:22 <caleb_> are there any good examples that we should follow?
15:23:22 <zns> I don't know one of the top of my head. I think nova client is pluggable...
15:23:43 <zns> https://pypi.python.org/pypi/novaclient-auth-secretkey
15:23:54 <zns> An auth plugin for novaclient...
15:24:19 <samstav> pip install satori --install-option
15:24:28 <caleb_> so `satori` and `satori-discover-nova`, `satori-discover-aws`
15:24:28 <jasonpgignac> What if we made a novaclient a plugin, but bundled it with Satori? That way you CAN turn it off if you aren't going to use it?
15:24:29 <caleb_> ?
15:24:36 <samstav> pip install satori --install-option='your_option_here'
15:25:12 <zns> samstav: that's a pip feature?
15:25:31 <samstav> I'm reading through some chatter… I'll get back to y'all on that.
15:26:09 <zns> OK. I wonder if we also want to support easy_install... so maybe try not to have it be a pip-specific implementation. But I like the interface.
15:26:14 <samstav> http://stackoverflow.com/questions/8874638/how-to-maintain-pip-install-options-in-requirements-file-made-by-pip-freeze
15:26:44 <caleb_> Lots of ideas here. Who is going to take the action to do a spike into this and complete the blueprint?
15:26:49 <zns> Alternative: pip install satori satori-nova satori-aws (separate packages). Maybe with a satori list-packages options.
15:27:28 <zns> samstav: you wanna give that one a shot?
15:27:37 <samstav> on it
15:27:41 <zns> Awesome.
15:28:11 <zns> #action samstav spike into exploring plugin install options for https://blueprints.launchpad.net/satori/+spec/satori-minimal
15:28:41 <samstav> ++ ask for help from caleb_ with localhost discovery
15:28:51 <samstav> ;)
15:28:51 <caleb_> samstav: All over it
15:29:38 <zns> Shall we talk about a release announcement? What do we need to have in place? Are we waiting for localhost? Plugins? Or just after we get ohai_solo merged in?
15:29:56 <caleb_> yes, lets discuss that, topic change?
15:30:07 <zns> #topic Release Announcement
15:30:25 <caleb_> I think localhost + data plane discovery is required to announce to user list
15:30:41 <caleb_> that means we'll have these two scenarios:
15:31:03 <caleb_> satori domain.com (remote things like DNS + Nova control plane discovery)
15:31:22 <caleb_> satori localhost --system-info=ohai-solo (local data plane discovery)
15:31:30 <caleb_> I think that's pretty compelling
15:31:34 <zns> satori 10.1.1.45 doesn't work right now.
15:31:54 <zns> caleb_: and would that be a minimal install (no nova client?)
15:32:05 <caleb_> and with the progress we've made on SSH, `satori domain.com` could include data plane discovery too.
15:32:21 <zns> Or, we could have it detect if nova client is installed and se, otherwise warn about not having it available.
15:32:31 <caleb_> zns: Personally, I don't think the nova dep is that heavy. I wouldn't vote for that being solved prior to announcement.
15:32:50 <zns> /se/se/use it
15:32:59 <caleb_> since we're announcing to a group that probably has it installed already
15:33:15 <caleb_> zns: DNS bug?
15:33:43 <zns> Should we relax the version requirement? Now, it's set to python-novaclient==2.15.0
15:34:10 <zns> caleb_: I'll file a big
15:34:34 <zns> #action zns file bug for satori not working with ip address
15:34:44 <caleb_> probably so. We could have somebody dig back into older versions to find a >= version to set.
15:35:12 <zns> Anyone volunteer to be "somebody"?
15:35:20 <gondoi> I can
15:35:46 <zns> #action gondoi find more relaxed novalent requirement
15:35:51 <zns> gondoi: thank you!
15:36:37 <zns> So, criteria for announcement; fix DNS bug, localhost, relaxed nova client dependency. Did I miss something?
15:37:44 <zns> #action gondoi find more relaxed novaclient (spelling) requirement
15:38:14 <caleb_> zns: At least 1 data plane discovery plugin.
15:39:22 <zns> #agreed criteria for announcement; fix DNS bug, localhost support, relaxed nova client dependency, and at least one data plane discovery plugin (ohai-solo most likely)
15:39:32 <jasonpgignac> Agreed.
15:39:38 <zns> Cool.
15:39:49 <zns> Anything else? Anyhone?
15:39:51 <caleb_> I like our progress.
15:40:00 <caleb_> Sounds like a bunch of stuff will land this week.
15:40:04 <zns> Anyone... I can't type...
15:40:23 <zns> caleb_: +1 feels like a lot got done last week.
15:40:25 <caleb_> And we'll be ready for a user list announcement early nexdt week
15:40:32 <gondoi> operationally i'm still waiting on the bot to be merged
15:40:46 <caleb_> gondoi: I've given up home on that review :)
15:40:56 <caleb_> ope*
15:40:58 <caleb_> hope*
15:41:06 <gondoi> :D i had a duplicate line and was out for vacation O_O
15:41:13 <gondoi> https://review.openstack.org/79058
15:41:17 <gondoi> fixed ^
15:41:55 <gondoi> i'll jump into the infra room and see if anything is outstanding to get that merged
15:42:10 <zns> I saw a request to move to #openstack-satori...
15:42:20 <zns> A comment on patch 3...
15:42:38 <zns> Is that a blocker?
15:42:44 <caleb_> I have an active review on doc updates. I'll probably do a little bit of work on that too this week.
15:43:15 <walker_> weird, that review was approved by a core reviewer and the it was removed?
15:43:28 <zns> I don't know that I am convinced it should be #openstack-satori. I feel as a related project, we're not dependent on openstack... yet...
15:43:39 <gondoi> zns: i don't see that comment, we are in #satori and have it registered
15:44:35 <zns> Joshua Hasketh's comment on patch 3
15:44:44 <zns> "Looks good to me but I don't know what the policy/standard is on channel names. Is it too late to move to #openstack-satori?"
15:45:17 <gondoi> ah
15:45:18 <hhoover> zns: there are other non "openstack-" channels out there
15:45:24 <hhoover> #link https://wiki.openstack.org/wiki/IRC
15:45:31 <walker_> yeah, I don't think that should be a requirement
15:45:47 <gondoi> I can try to push this one forward and just find out more details on channel names...?
15:45:59 <zns> Col.
15:46:02 <zns> Cool!
15:46:26 <zns> Are we done for today?
15:46:30 <caleb_> Quick question regarding docs
15:46:33 <zns> Nope.
15:46:38 <zns> caleb_: yes?
15:46:44 <walker_> No, we're done caleb_
15:46:47 <walker_> :)
15:47:11 <caleb_> adrian_otto: I noticed that Solum is using the OpenStack logo on docs. Can we do the same as a related project?
15:47:38 <annegentle> caleb_: the OpenStack logo is reserved, can you let us know where you see the logo being used?
15:47:48 <caleb_> *gulp*
15:47:50 <caleb_> :)
15:47:56 <walker_> #link https://www.openstack.org/brand/
15:47:57 <annegentle> caleb_: there's a brand guide at http://www.openstack.org/brand
15:48:27 <annegentle> caleb_: so possibly they're using the "Built for OpenStack" logo with a signed contract
15:48:29 <walker_> "/topic narc'ing out other projects"
15:48:35 <annegentle> lol
15:48:51 <annegentle> not at all, we all are responsible for following the guidelines
15:49:16 <hhoover> lol
15:49:19 <jasonpgignac> *huffs* If THEY get a logo-cookie, *I* want a logo-cookie!
15:50:01 <caleb_> I'm looking for the link...
15:50:17 <zns> caleb_: do we want to "sign a contract" to add the built for openstack logo on satori?
15:50:48 <caleb_> zns: I wouldn't oppose that.
15:50:59 <zns> caleb_: motivate.  Why?
15:51:16 <walker_> caleb_ Is this what you are talking about? #link http://solum.io/
15:51:17 <hhoover> looks legit
15:51:27 <caleb_> but I don't think aligning to the brand is an important step in a project that is so young
15:51:27 <walker_> at the bottom there is a link to stackforge with the OS logo
15:51:45 <zns> I think this is the link: http://solum.readthedocs.org/en/latest/
15:51:50 <caleb_> walker_: No theres a docs page for their sphinx stuff thats using the OS...
15:51:50 <caleb_> yes
15:52:05 <caleb_> annegentle: ^^
15:52:13 <zns> caleb_: sorry, I read that you *would* oppose that.
15:52:35 <annegentle> caleb_: ok, I think both are not uses that are sanctioned, I'll follow up with adrian_otto
15:52:45 <jasonpgignac> Its worth considering that keeping Satori as big a tent as possible is possibly helpful.
15:52:56 <caleb_> I owe him a beer for starting trouble :)
15:52:59 <zns> caleb_: do you want to take that action item? Say "No" and I can...
15:53:03 <jasonpgignac> We wouldn't want developers who are familiar with, say, Amazon, to think the tool is not for them.
15:53:05 <caleb_> annegentle: Thanks for clarifying
15:54:03 <zns> #action caleb_ buy adrian_otto  a beer
15:54:30 <walker_> #action caleb_ buy walker_ beer too
15:54:33 <caleb_> At Texas prices. None of that California junk.
15:54:38 <caleb_> We done?
15:54:39 <adrian_otto> ;-)
15:54:59 <zns> * NOW caleb_ wants to be done... *
15:55:10 <zns> Yes. Anyone? Anything else?
15:55:19 <adrian_otto> all set from me.
15:55:23 <samstav> I'm not qualified to address jasonpgignac's concern… anyone else?
15:55:52 <caleb_> I think we should punt all branding decisions until we have addressed more use cases
15:56:00 <zns> caleb_: I think jasonpgignac has a valid point. Will the logo exclude non-openstack uses?
15:56:22 <walker_> I agree with caleb_ on the punt
15:56:31 <zns> #agreed punt all branding decisions until we have addressed more use cases (no OpenStack logo yet)
15:56:32 <walker_> I don't think it is important at this stage
15:56:36 <hhoover> punt
15:56:59 <jasonpgignac> *rows the punt*
15:57:28 <zns> OK. Thank you all! See you on the internets...
15:57:34 <zns> #endmeeting