14:00:09 <tellesnobrega> #startmeeting sahara
14:00:11 <openstack> Meeting started Thu Jul 13 14:00:09 2017 UTC and is due to finish in 60 minutes.  The chair is tellesnobrega. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <openstack> The meeting name has been set to 'sahara'
14:00:21 <tosky> o/
14:00:39 <jeremyfreudberg> o/
14:04:08 <tellesnobrega> #topic News/Updates
14:04:49 <tellesnobrega> I got the CDH image to work, turned out big part of the problem was a timeout due to my not so great internet connection
14:05:55 <tellesnobrega> now I'm working on checking ambari and will move on to CDH 5.9.0 after that
14:06:06 <jeremyfreudberg> tellesnobrega, awesome!
14:06:21 <tosky> - fixed sahara-image-elements for master, reduced the number of dependencies on sahara-files
14:06:22 <tosky> - still working on doc, studying how it should be structured and how to import the only external doc (the configuration guide)
14:06:23 <tosky> - not yet done, but going to write the email to infra about how much resources we can use (i.e. if we want to add some heavier jobs with non fake plugin
14:07:52 <jeremyfreudberg> not working on anything big now, unfortunately internal stuff keeps me too busy. looking into other "easy" artifacts to migrate to sahara-files. keeping my eye on hadoop 2.8.1 release, but unfortunately i think it will come too late
14:08:42 <tosky> and S3? :)
14:08:58 <jeremyfreudberg> s3 i'll put out a patch to add the jar to the images soon
14:09:13 <tellesnobrega> jeremyfreudberg, about hadoop 2.8.1, the feature deadline is july 24th I believe, maybe we should focus on other stuff for pike, it probably won't come with enough time
14:09:16 <tellesnobrega> cool
14:09:34 <tellesnobrega> how is that spec progressing?
14:10:29 <tellesnobrega> anything that I can help with?
14:10:37 <jeremyfreudberg> i've been playing around with adding the s3 data source / jb types, like I said it's not that bad, but it'll take me a while to get it perfect
14:10:59 <jeremyfreudberg> and adding it to saharaclient / saharadashboard might be too much for this release
14:11:01 <tosky> about jar: do we need to add the binary jar somewhere? It would be generated as artifact by sahara-extra? Is it available "verbatim" upstream?
14:11:34 <jeremyfreudberg> tosky, about jar, every plugin that i've checked so far has the jar already on the image, it just needs to be moved into the classpath
14:12:03 <tosky> jeremyfreudberg: my question is a bit more basic: where does the source of this jar live?
14:12:49 <jeremyfreudberg> tosky, the sources are in apache/hadoop within hadoop-tools
14:13:29 <jeremyfreudberg> and as far as I can tell, it's a single source of truth for hadoop-aws.jar, unlike hadoop-openstack.jar which is awkwardly split between us and apache
14:13:34 <tosky> and can we consume them totally without patching them?
14:14:05 <jeremyfreudberg> there shouldn't be any need to patch
14:14:28 <tosky> perfect
14:14:36 <tellesnobrega> awesome
14:15:29 <tellesnobrega> iwonka, do you want to update us on your progress?
14:16:14 <iwonka> there's a working function for import of ngt in rest api, i'm going to add import and export of ngt to ui now
14:16:53 <tellesnobrega> import or export? working in rest api?
14:17:30 <iwonka> export, sorry
14:17:35 <tellesnobrega> great
14:18:16 <tellesnobrega> anymore news?
14:18:35 <jeremyfreudberg> tellesnobrega, iwonka, i really encourage you to finalize your exact ideas in the spec https://review.openstack.org/#/c/477671/ before doing too much more work
14:18:49 <tellesnobrega> jeremyfreudberg, true
14:19:08 <jeremyfreudberg> also, for more news, shyyingya has said hbase on vanilla will be up for review early next week
14:19:45 <tellesnobrega> iwonka, can you rewrite the spec to reflect what we are doing now?
14:19:50 <tellesnobrega> jeremyfreudberg, that is great
14:20:18 <iwonka> tellesnobrega: i think only changes about ui and cli should be added?
14:21:12 <jeremyfreudberg> iwonka, yep, i think the additions to the spec now will be pretty minimal
14:21:21 <jeremyfreudberg> just good to plan out what you do
14:21:41 <tellesnobrega> yeah, and remove the part where we say we will add import on the server side, that will be only on end user side
14:21:51 <jeremyfreudberg> yep
14:21:58 <tellesnobrega> that is basically it
14:24:20 <tellesnobrega> #topic Queens PTG
14:25:07 <tellesnobrega> About the PTG, I know tosky put up a topic for discussion, just want to bring this up again so we can always take sometime to go back there and write some stuff
14:25:18 <tellesnobrega> #link https://etherpad.openstack.org/p/sahara-queens-ptg
14:25:29 <tosky> there were few other topics already :)
14:25:53 <tosky> I just added a point to the deprecation part; I partially addressed with the "centos6 deprecation" spec
14:26:04 <tosky> but for example I didn't check (and I had no time for it) the status of ubuntu
14:26:43 <jeremyfreudberg> (speaking of ubuntu, anyone remember the limitation about ubuntu 16.04, if there is one? sorry, off topic)
14:27:21 <jeremyfreudberg> (in terms of sahara images, i mean)
14:27:35 <tosky> that's the point
14:27:56 <tosky> the deprecation is "can we migrate to 16.04 and deprecate 14.04?"
14:28:05 <tellesnobrega> I don't remember, I do have to check ubuntu images with the image gen process too
14:28:15 <jeremyfreudberg> tosky, i see
14:28:30 <tosky> first point is the upstream support
14:28:32 <jeremyfreudberg> it might be something about cloudera actually, i'll make a note to look into it
14:28:35 <tellesnobrega> #action check if we can create ubuntu 16.04 images with SIE and follow up with deprecating ubuntu 14.04
14:28:57 <tellesnobrega> jeremyfreudberg, ^ can you do that?
14:29:09 <jeremyfreudberg> tellesnobrega, sure
14:29:12 <tellesnobrega> thanks
14:29:24 <tosky> probably vanilla too is more straightforward; the other distributions require the official support
14:30:00 <tellesnobrega> changing the topic here
14:30:07 <tellesnobrega> #topic Open Discussion
14:30:16 <tellesnobrega> so we don't get confused
14:30:21 <jeremyfreudberg> NICE
14:30:25 <jeremyfreudberg> oops, caps lock was on
14:30:26 <jeremyfreudberg> *nice
14:31:58 <tellesnobrega> looks like the topic change kinda broke the flow
14:32:09 <jeremyfreudberg> true
14:32:28 <jeremyfreudberg> i have other things to say, should i just start saying them?
14:32:32 <tellesnobrega> go ahead
14:32:46 <jeremyfreudberg> the python-saharaclient docs need to be migrated too
14:33:06 <jeremyfreudberg> or actually, no
14:33:10 <jeremyfreudberg> i guess they don
14:33:16 <jeremyfreudberg> t even though we haven't done anything
14:33:26 <tellesnobrega> why is that?
14:34:01 <jeremyfreudberg> this is in reference to this email http://lists.openstack.org/pipermail/openstack-dev/2017-July/119483.html
14:34:24 <jeremyfreudberg> says we would have needed to migrate, but https://docs.openstack.org/python-saharaclient/latest/ is already a valid link
14:34:31 <jeremyfreudberg> i guess we still have to do the theme
14:34:57 <tosky> oh, I forgot that theme there
14:35:07 <tosky> the* theme
14:35:50 <tellesnobrega> I guess the theme is a start, not sure if anything else is going to be needed, tosky is working on a plan to migrate the whole thing
14:36:03 <tosky> for python-saharaclient probably only the theme
14:36:06 <jeremyfreudberg> my idea exactly, let's let tosky handle it
14:36:10 <tellesnobrega> cool
14:36:14 <tosky> iirc there was no much documentation in openstack-manuals to be migrated (sadly)
14:36:28 <tosky> the only thing that needs to be migrated is the configuration guide
14:36:38 <tellesnobrega> cool
14:36:41 <tosky> apart from that, the existing documentation should be reorganized a bit
14:36:55 <tosky> but first let's land the image building reviews which changes it
14:36:56 <tosky> :D
14:36:57 <tellesnobrega> after this migration we should take some time to do a big review on docs
14:37:12 <tosky> (note: remember the release notes for them, and in general, let's not forget to use reno more)
14:37:21 <tellesnobrega> true
14:37:21 <tosky> I'm guilty myself of not using it too much
14:37:34 * tellesnobrega is guilty as well
14:39:59 <tellesnobrega> ok, do we have anything else for today?
14:40:21 <jeremyfreudberg> thinking...
14:40:46 * jeremyfreudberg remembers
14:40:55 <tosky> not from me (I think)
14:41:01 <jeremyfreudberg> default templates are really out of date
14:41:20 <jeremyfreudberg> they should be updated before the release, for sure
14:41:32 <tosky> that makes totally sense
14:41:51 <tellesnobrega> true
14:42:03 <tosky> and we can do probably even after the feature freeze, if it's not possible before; it's a bug fix
14:42:10 <tellesnobrega> I can take a look into that
14:42:24 <tellesnobrega> I know both of you are extremely busy
14:42:56 <jeremyfreudberg> ++ thanks
14:42:57 <tellesnobrega> #action tellesnobrega to look into updating default templates
14:43:11 <tellesnobrega> thanks for bring it up
14:44:09 <tosky> technically you are busy too :)
14:44:29 <tellesnobrega> yeah, but you know... that is the job :)
14:45:34 <jeremyfreudberg> that's it for me
14:45:37 <tellesnobrega> I will try to squeeze that in
14:45:37 <jeremyfreudberg> thanks for listening
14:45:43 <tellesnobrega> :)
14:46:35 <tellesnobrega> I guess this is for me too
14:47:10 <tellesnobrega> thanks for the good work guys, lets try to keep this up
14:47:35 <tellesnobrega> #endmeeting