14:13:09 <dirk> #startmeeting rpm_packaging
14:13:10 <openstack> Meeting started Wed Nov 21 14:13:09 2018 UTC and is due to finish in 60 minutes.  The chair is dirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:13:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:13:14 <openstack> The meeting name has been set to 'rpm_packaging'
14:13:28 <dirk> ping toabctl, dirk, apevec, aplanas, IgorYozhikov, jpena, jruzicka, number80, kaslcrof, ykarel
14:13:35 <jpena> o/
14:13:53 <number80> o/
14:14:35 <openstackgerrit> Javier Peña proposed openstack/rpm-packaging master: update oslo.log to v3.40.1  https://review.openstack.org/605318
14:18:47 <dirk> #chair jpena  number80
14:18:48 <openstack> Current chairs: dirk jpena number80
14:19:03 <dirk> welcome back from the openstack week of things :)
14:19:09 <dirk> and sorry for being late on the meeting
14:19:16 <number80> no worries :)
14:19:17 <dirk> do we have topics?  please add them to the etherpad..
14:19:51 <dirk> should we do the meeting an hour earlier? its still scheduled for 13:00 UTC
14:22:03 <jpena> I don't have any special topic
14:22:27 <jpena> I see number80 created a review for openstack-macros: https://review.openstack.org/619042
14:22:59 <dirk> can you share some insight in how rhel8 is gonna affect the gating?
14:23:07 <dirk> e.g. which python version etc?
14:23:35 <dirk> now that the beta was announced I hope you could share some insights?
14:23:40 <jpena> once we get centos 8 (which I assume will take some time), we could replace the fedora 28 gate with a centos8-based one
14:23:49 <jpena> rhel8 has python 3.6
14:23:49 <number80> dirk: python3 will be default but because of swift, we have to enable a specific en variable to enable python2 in buildroot
14:24:33 <dirk> jpena: awesome, so same like SLE15 (3.6.5). thats great news
14:24:59 <number80> (yes, we can disclose some details, the "between 7 and 9" is just a light joke against our marketing folks ;-) )
14:25:26 <dirk> number80: so python2 is still available or only for swift?
14:25:42 <number80> only for swift which doesn't support python3 yet
14:25:49 <dirk> e.g. would we change renderspec to enable the py3 only flavor for singlespec purposes or both py2+py3 ?
14:26:13 <dirk> I think I would appreciate if we could change the renderspec defaults for rhel/centos8 quickly and do a new release..
14:26:25 <number80> dirk: no need of renderspec change, swift is specific case
14:26:58 <number80> for CentOS 8, we have no timeline, and for RHEL 8, it's still unclear even for us
14:27:29 <number80> But yes, as soon as possible, we want it to be default base OS for us
14:28:18 <dirk> number80: well, currently renderspec defaults to py2 only for any rhel flavor
14:28:26 <dirk> I would think you would want it to default to py3 then
14:28:54 <number80> ack, I'll look at it this week
14:29:09 <number80> #action number80 look at setting py3 default for EL
14:29:49 <dirk> thanks
14:29:55 <dirk> #topic open floor
14:30:09 <dirk> next week toabctl should be back, so we'll get back to normal mode of working
14:31:58 <dirk> any other topic?
14:33:03 <jpena> nothing for me
14:33:23 <dirk> #endmeeting