13:04:26 <dirk> #startmeeting rpm_packaging
13:04:27 <openstack> Meeting ended Wed Aug 29 13:04:24 2018 UTC.  Information about MeetBot at http://wiki.debian.org/MeetBot . (v 0.1.4)
13:04:28 <openstack> Minutes:        http://eavesdrop.openstack.org/meetings/rpm_packaging_/2018/rpm_packaging_.2018-08-29-13.04.html
13:04:29 <openstack> Minutes (text): http://eavesdrop.openstack.org/meetings/rpm_packaging_/2018/rpm_packaging_.2018-08-29-13.04.txt
13:04:30 <openstack> Log:            http://eavesdrop.openstack.org/meetings/rpm_packaging_/2018/rpm_packaging_.2018-08-29-13.04.log.html
13:04:31 <openstack> Meeting started Wed Aug 29 13:04:26 2018 UTC and is due to finish in 60 minutes.  The chair is dirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:04:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:04:32 <dirk> ping toabctl, dirk, apevec, aplanas, IgorYozhikov, jpena, jruzicka, number80, kaslcrof, ykarel
13:04:35 <openstack> The meeting name has been set to 'rpm_packaging'
13:04:35 <jpena> o/
13:04:38 <dirk> #topic roll call
13:04:44 <dirk> #chair jpena
13:04:45 <openstack> Current chairs: dirk jpena
13:05:51 <ykarel> o/
13:06:05 <dirk> #chair ykarel
13:06:06 <openstack> Current chairs: dirk jpena ykarel
13:06:31 <dirk> I don't expect anyone else to join
13:06:51 <dirk> do we have topics?
13:07:01 <dirk> please update https://etherpad.openstack.org/p/openstack-rpm-packaging
13:09:09 <dirk> #topic rpm-packaging branched to stable/rocky
13:09:20 <dirk> hopefully just in time we branched master as of yesterday into stable/rocky
13:09:28 <dirk> the .gitreview etc was merged this morning
13:09:45 <dirk> I'm currently adding the suse ci testing, it should be functional fairly soon
13:09:49 <jpena> yes. That reminds me I need to prepare the RDO CI bits for stable/rocky
13:09:57 <dirk> I also unblocked the reviews against master that were post-rocky
13:10:05 <dirk> so we can do new reviews and merges
13:11:05 <dirk> jpena: can you take the action item?
13:11:21 <dirk> #action dirk finish setup of SUSE CI for stable/rocky
13:11:23 <jpena> #action jpena to prepare the RDO CI bits for stable/rocky
13:11:30 <dirk> thank you ! :)
13:16:42 <dirk> #topic reviews
13:17:29 <dirk> I have nothing particular to point out other than there are still some reviews outstanding
13:17:43 <jpena> I've been going through some of them before the meeting
13:17:45 <dirk> unfortunately due to albertos and toabctl's leave we have no cores on suse side left
13:18:09 <dirk> I'm trying to ramp up more reviewers that I could suggest as core, but they also went on vacation this week and next week
13:18:10 <dirk> *sigh*
13:18:15 <dirk> hopefully its better soon
13:19:00 <jpena> yes, I saw Colleen working quite hard during the last few weeks
13:22:34 <jpena> on my side, I'm going to talk inside the RDO community to measure the desiered level of involvement. After several cycles, it still feels like we're in&out
13:22:43 <jpena> desired*
13:22:45 <dirk> yeah
13:22:55 <dirk> I was very happy to see the singlespec involvement
13:22:58 <dirk> what happened to it?
13:23:05 <dirk> it seems to have slowed down again
13:24:06 <jpena> the goal for rocky was to test keystone and glance. It worked for RDO Trunk (DLRN), but I'm not sure how well it'll work for the remaining bits
13:24:10 <jpena> ykarel: any info? ^^
13:25:27 <ykarel> jpena, hmm it worked with keystone and glance, but we started seeing issue recently due to spec diffs between rdo and rpm-packaging
13:25:54 <ykarel> hmm similar issue would arise in other projects as well
13:26:21 <ykarel> so currently we are working on RDO specs, may be later we can start utilizing rpm-packaging specs
13:27:15 <ykarel> jpena, just for info the new issue was https://bugs.launchpad.net/keystonemiddleware/+bug/1789351
13:27:15 <openstack> Launchpad bug 1789351 in oslo.config "Glance deployment with python3 + "keystone" paste_deploy flavor Fails" [Undecided,New]
13:28:09 <ykarel> and would need spec changes which i workaround here:- https://review.openstack.org/#/c/596652/4/run_tests.sh
13:29:19 <ykarel> on RDO specs those are handled as multiple deployment tools are using thoes
13:29:50 <dirk> ykarel: whats between "later start utilizing" and "now" ? other thean reality?
13:29:58 <dirk> I'm trying to understand what can be done to "start utilizing"
13:31:55 <ykarel> dirk, so target for rocky was to evaluate rpm-packaging specs with python3, which is finished and we have seen issue similar to ^^
13:32:27 <ykarel> and currently we got busy with the release stuffs so slowed down
13:33:02 <ykarel> we are looking for a way to get specs to python3 faster and compatible with the deployment tools
13:33:59 <ykarel> and that would be target for stein i guess so we have less time
13:35:58 <dirk> less time?
13:36:33 <dirk> ah, because still tied up with rocky?
13:36:45 <dirk> so if you have less time, maybe reduce amount of duplication could speed it up?
13:37:03 <dirk> I know its ramp up investment but it pays off fairly quickly I guess.
13:37:15 <ykarel> yes, we still have to decide on that, will start focusing again after the release
13:38:14 <dirk> can I help ? :-)
13:38:20 <dirk> should we check this again in a week or two?
13:39:05 <ykarel> yes sure we can talk again after two weeks
13:39:21 <dirk> thanks, lets do that
13:39:33 <dirk> #action dirk recheck topic about python3 packages for stein in 2-3 weeks
13:39:36 <dirk> #topic open floor
13:39:40 <dirk> any other topics?
13:41:44 <jpena> nothing for me
13:51:44 <dirk> #endmeeting