13:01:28 <toabctl> #startmeeting rpm_packaging
13:01:29 <openstack> Meeting started Thu Nov 30 13:01:28 2017 UTC and is due to finish in 60 minutes.  The chair is toabctl. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:32 <openstack> The meeting name has been set to 'rpm_packaging'
13:01:37 <toabctl> ping toabctl, dirk, apevec, aplanas, IgorYozhikov, jpena, jruzicka, number80, kaslcrof
13:01:50 <toabctl> #chair dirk jpena
13:01:51 <openstack> Current chairs: dirk jpena toabctl
13:01:52 <toabctl> #topic roll call
13:02:06 <jpena> o/
13:02:06 <number80> o/
13:02:17 <jpena> I'm in another meeting at the same time, so mostly listening
13:02:27 <number80> I'm in the same meeting ^^
13:02:30 <dirk> o/
13:02:51 <dirk> jpena: ah, so an hour later would be preferableß
13:03:01 <dirk> we could also do earlier now that Igor seems to have regained interest :)
13:03:34 <jpena> I have a sprint review&retro meeting every two weeks, so this time is mostly ok, unless we want to do it 12:00PM
13:03:50 <toabctl> one hour ealier/later would fine for me
13:04:15 <toabctl> #topic changing meeting time?
13:04:43 <number80> later should work for me, earlier depends on too many factors
13:05:04 <toabctl> so what about 14 UTC ?
13:05:24 <dirk> toabctl: 8pm for igor, might work
13:05:31 <number80> +1 for me
13:05:32 <dirk> it mostly works for me
13:05:56 <toabctl> jpena, is that ok for you, too?
13:05:58 <jpena> it's mostly ok for me (still some conflicts, but probably easier to handle them)
13:06:11 <toabctl> ok.
13:06:19 <toabctl> #agreed change meeting time to 14 UTC
13:06:43 <toabctl> ah. one thing. we might need to move to another room then...
13:07:00 <dirk> reportedly it is allowed to do meetings in your normal channel nowadays
13:07:07 <dirk> so we could do it in openstack-rpm-packaging
13:07:15 <number80> yes, it should be fine there
13:07:20 <toabctl> ok. then let's do it there. imo that;s even better
13:07:22 <dirk> we just need to invite the bot over
13:07:42 <toabctl> dirk, do you know how todo that?
13:07:56 <dirk> not offhand, but I can ask
13:08:52 <dirk> I'll take a look at that
13:09:18 <toabctl> dirk, ok. thanks. will you also update http://git.openstack.org/cgit/openstack-infra/irc-meetings/tree/ to reflect the new time?
13:09:51 <dirk> yep, can be done in a single review
13:10:18 <toabctl> #action dirk updates the meeting time in git and invites the meeting bot to #openstack-rpm-packaging
13:10:34 <toabctl> #topic PTG attendance
13:10:48 <toabctl> I got a mail about PTG attendance
13:11:21 <toabctl> I need to fillout a form until 5th december if we plan to attend
13:11:30 <dirk> I'll likely go
13:11:32 <toabctl> personally I'm not sure yet if I can attend
13:11:46 <toabctl> jpena, number80 are you going to Dublin?
13:12:18 <jpena> we have both requested it. I think that in a worst case at least one of us will go (or both if we are lucky)
13:12:19 <number80> toabctl: pending approval from management but we requested it
13:13:00 <number80> Well, we'll have someone there, I may yell if it doesn't happen :)
13:13:15 * number80 didn't check if someone from management was here before saying that /o\
13:14:15 * dirk neither :)
13:14:38 <number80> But we have good backups (e.g Alfredo also is in the list)
13:15:28 <toabctl> ok. I submitted that we have 2-5 people there and can share a room with other teams
13:15:42 <number80> +1
13:16:12 <toabctl> #topic open floor
13:16:16 <cousin_luigi> Hello.
13:16:17 <toabctl> anything else to discuss?
13:16:22 <toabctl> hey cousin_luigi
13:16:22 <cousin_luigi> Yes, if I may.
13:16:46 <toabctl> gop ahead
13:16:49 <cousin_luigi> I mentioned it yesterday to dirk, but the current openstack singlespec setup breaks the older leaps builds.
13:16:59 <cousin_luigi> Missing %python_subpackages macro.
13:17:05 <number80> oh
13:17:25 <toabctl> cousin_luigi, is that something we can solve in rpm-packaging? or can we just fix the macros for leap in the OBS project?
13:17:59 <cousin_luigi> toabctl: Possibly, but dirk mentioned simply updating the macros package as a solution.
13:18:19 <cousin_luigi> Or replacing it outright. I just wanted to make it official:)
13:19:18 <dirk> cousin_luigi: can you share the link to the package that has the issue? I forgot about that already
13:19:38 <dirk> cousin_luigi: I can take a look. a simple solution is to use python-rpm-macros buildrequires in addition
13:19:59 <cousin_luigi> dirk: It's not there yet, I had linked python-stevedore to my branch project. Do you want me to re-create it?
13:20:02 <toabctl> cousin_luigi, it sounds to me like a downstream openSUSE problem. nothing we can handle in openstack/rpm-packaging
13:21:35 * dirk volunteers toabctl  to take the action item and solve it until next week ;)
13:21:45 <cousin_luigi> dirk: https://build.opensuse.org/package/show/home:alois:branches:devel:languages:python/python-stevedore
13:21:53 <cousin_luigi> Well, you're the experts:)
13:23:58 <toabctl> ok. I think we can solve this within openSUSE
13:24:06 <toabctl> anything else to discuss?
13:24:19 <dirk> python3 feedback from RDO side?
13:24:21 <jpena> nothing for me
13:24:41 <dirk> it looks like master/ we are getting close to having the first clients available from single spec for both python2+3
13:24:46 <dirk> thanks for the speedy reviews btw
13:24:59 <dirk> I'll fix the current ci issue now and then we should be getting glanceclient working later today
13:25:20 <dirk> jpena: are there new plans related to python 3 in centos/rhel going forward that you can share ?
13:25:28 <dirk> would be good to enable singlespec for that as well
13:26:18 <jpena> afaik, we can only expect "proper" python3 support in centos/rhel when RHEL 8 is out, whenever that happens
13:27:44 <dirk> too bad
13:29:21 <toabctl> ok. let's close it here
13:29:24 <toabctl> thanks everybody!
13:29:28 <toabctl> #endmeeting