12:02:41 <toabctl> #startmeeting rpm_packaging
12:02:42 <openstack> Meeting started Thu Sep 28 12:02:41 2017 UTC and is due to finish in 60 minutes.  The chair is toabctl. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:02:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:02:46 <openstack> The meeting name has been set to 'rpm_packaging'
12:02:48 <toabctl> ping toabctl, dirk, apevec, aplanas, IgorYozhikov, jpena, jruzicka, number80, kaslcrof
12:03:02 <jpena> o/
12:03:08 <toabctl> #chair dirk jpena
12:03:09 <openstack> Current chairs: dirk jpena toabctl
12:04:11 <toabctl> please add your topics to the agenda
12:04:16 <toabctl> #link https://etherpad.openstack.org/p/openstack-rpm-packaging
12:06:39 <toabctl> #topic python-toml for monasca-agent
12:06:44 <toabctl> jpena, I guess it's your topic?
12:06:50 <jpena> yes
12:07:00 <jpena> it's a quick question about https://review.openstack.org/505204
12:07:20 <jpena> I understand the package is an optional dependency for monasca-agent, required when we use a specific backend, is this correct?
12:07:30 <toabctl> jpena, yes
12:07:46 <toabctl> jgr, ^^
12:08:03 <jpena> why don't we make that package be installed by the automation tool, instead of making it a hard dep?
12:08:17 <jgr> jpena: yes.
12:08:43 * dirk lost internet
12:08:55 <jgr> jpena: we've had that discussion before and agreed that it's ok for just one package (that doesn't pull in additional dependencies).
12:09:06 <jgr> jpena: also, this one's a bit of an odd duck.
12:09:12 <dirk> toabct: sorry, office is without network right now, need to skip meeting
12:09:25 <toabctl> dirk, oki
12:09:46 <jgr> jpena: the other optional dependencies (python-neutronclient, python-novaclient) are automatically there on machines where they are relevant (compute nodes).
12:10:30 <jpena> ok then
12:10:41 <jgr> jpena: for python-toml that is not the case because the service being monitored (influxdb) doesn't pull in python-toml (influxdb being written in go uses a Go library for TOML and does not need the Python one)
12:10:50 <toabctl> jpena, is it a problem to add it to the RDO CI?
12:11:01 <jpena> we'll have to import this dep in the RDO deps, it just takes a bit of time
12:11:29 <jpena> to unblock the review, could we enclose it in an %if condition that skips it for RDO for the time being?
12:11:45 <jpena> number80: ^^ we'll need to import python-toml
12:12:05 <jgr> Sure, I can %if it out for RDO.
12:12:26 <jpena> ok, deal :)
12:12:32 <toabctl> jgr, that might good for now
12:12:37 <toabctl> oki. cool
12:12:50 <toabctl> #action jgr make python-toml only a Requires for suse
12:12:54 <jpena> just add a FIXME(jpena), so I remember to remove it once the dep is in the repo
12:14:35 <toabctl> #topic packaging reviews
12:14:40 <toabctl> anything special?
12:15:26 <toabctl> keystone seems to be broken in the SUSE CI
12:15:46 <toabctl> #action toabctl fix SUSE CI keystone
12:17:35 <toabctl> #topic open floor
12:17:45 <toabctl> anything else? Otherwise this will be a short meeting....
12:17:57 <jpena> nothing for me
12:18:43 <toabctl> ok. thanks everybody
12:18:45 <toabctl> #endmeeting