12:01:47 <dirk> #startmeeting rpm_packaging
12:01:48 <openstack> Meeting started Thu Sep  7 12:01:47 2017 UTC and is due to finish in 60 minutes.  The chair is dirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:01:52 <openstack> The meeting name has been set to 'rpm_packaging'
12:01:57 <dirk> #topic roll call
12:01:59 <dirk> o/
12:05:13 <dirk> toabctl might be away today
12:05:15 <dirk> anyone else around?
12:05:18 <jpena> o/
12:06:37 <toabctl> hey
12:07:14 <dirk> ah, we have quorum :)
12:07:20 <dirk> #chair toabctl  jpena
12:07:21 <openstack> Current chairs: dirk jpena toabctl
12:07:33 <dirk> #topic  tracking master.tar.gz files for services?
12:07:54 <toabctl> that's from me. I wonder what we want todo in master for the services
12:08:32 <dirk> I think its a mixed bag
12:08:46 <toabctl> eg there is https://review.openstack.org/#/c/469589/ which adds the package for ocata but the reason for that is that other services are also on ocata
12:08:51 <dirk> in general we might want to track -master, but it breaks at unpredictable times, making other things hard to merge
12:09:19 <toabctl> tracking master does not mean that we update it automatically. we would still need todo that manually I think
12:09:48 <dirk> well, thats how it currently works.. every review gets the newest -master tarball I think
12:09:53 <toabctl> somehow we would need to trigger a job which fetches the new master.tar.gz
12:10:00 <jpena> tracking master for services is usually ok, as long as we keep libraries on their upper-constraints versions
12:10:08 <jpena> that's what we do during the cycle in RDO
12:10:25 <toabctl> yes. same for SUSE
12:10:52 <toabctl> ok. so agreement on changing the source to master for the services?
12:13:12 <toabctl> dirk, jpena ?
12:13:15 <jpena> +1
12:13:21 <dirk> worksforme
12:13:32 <dirk> #agreed track -master.tar.gz tarballs for services in rpm-packaging master
12:13:38 <toabctl> thx
12:13:43 <dirk> #topic pymod2pkg - py2/py3 support
12:13:59 <toabctl> I added it but had no time today to look at it
12:14:20 <toabctl> #link https://review.openstack.org/#/c/498420/
12:14:34 <toabctl> jpena, so you tested this and it works for you, right?
12:15:01 <jpena> toabctl: yes, I changed the python_module macro in a test env, and made it use pymod2pkg to get the package names
12:15:59 <toabctl> ok. I try to have a look today.
12:16:13 <toabctl> #action toabctl reviews https://review.openstack.org/#/c/498420
12:16:33 <dirk> great
12:16:35 <toabctl> I guess with that we can start to add python3 support to the packages
12:16:37 <dirk> I'll also try to find time for it
12:16:43 <dirk> yippe, that would be awesome
12:17:12 <dirk> #topic packaging reviews
12:17:43 <dirk> anything particular?
12:17:53 <dirk> I just unblocked the suse ci by fixing the python-cinderclient change
12:17:57 <dirk> and rechecking everything now
12:18:04 <dirk> https://review.openstack.org/#/c/469589/ was brought up, but jpena already commented on it
12:18:56 <toabctl> I'll go over all services and switch them to master. then we can fix that one.
12:19:26 <dirk> works for me
12:19:30 <dirk> anything else to discuss?
12:19:40 <toabctl> not from my side.
12:19:52 <toabctl> anything PTG related?
12:20:17 <toabctl> just to mention it - there is an etherpad for the PTG
12:20:19 <toabctl> #link https://etherpad.openstack.org/p/rpm-packaging-queens-ptg
12:22:52 <toabctl> I'm fine with closing the meeting now, dirk , jpena
12:23:30 <dirk> thanks
12:23:32 <dirk> #endmeeting