13:04:31 <IgorYozhikov> #startmeeting rpm_packaging
13:04:32 <openstack> Meeting started Thu Mar  2 13:04:31 2017 UTC and is due to finish in 60 minutes.  The chair is IgorYozhikov. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:04:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:04:35 <openstack> The meeting name has been set to 'rpm_packaging'
13:04:50 <IgorYozhikov> ping toabctl, dirk, apevec, aplanas, IgorYozhikov, jpena, jruzicka, number80, kaslcro
13:04:56 <jpena> o/
13:04:58 <toabctl> hi
13:05:37 <dirk> o/
13:05:44 * dirk is latent away, please don't wait for me
13:07:05 <IgorYozhikov> #chair IgorYozhikov jpena toabctl
13:07:06 <openstack> Current chairs: IgorYozhikov jpena toabctl
13:07:11 <toabctl> as usual, please add agenda points to https://etherpad.openstack.org/p/openstack-rpm-packaging
13:07:22 <IgorYozhikov> Let's spend a couple of minutes on agenda
13:09:53 <IgorYozhikov> #topic Adding CI mail addresses to Third Party CI mail filter list (see https://docs.openstack.org/infra/system-config/third_party.html )
13:10:19 <toabctl> I get a lot of mails from the CI systems and I wonder if we could add theses to the filter
13:10:30 <toabctl> I can do that if we agree on it
13:10:56 <jpena> +1 for me
13:11:05 <toabctl> it is about https://review.openstack.org/#/admin/groups/270
13:11:06 <IgorYozhikov> no objections
13:11:11 <number80> p/
13:11:17 <toabctl> ok
13:11:23 <number80> +1
13:11:33 <toabctl> #action toabctl will add the CI mail addresses to the filter group
13:11:39 <toabctl> next topic
13:11:59 <IgorYozhikov> #topic PTG results
13:12:42 <toabctl> hm. not sure if there are any results
13:12:50 <IgorYozhikov> I want to understand what has been discussed except AIO py2 & py3
13:13:09 <IgorYozhikov> because of etherpad is not updated
13:13:15 <toabctl> IgorYozhikov, nothing yet.
13:13:35 <toabctl> suse is currently switching to a single spec file appoach with a new macro set
13:13:53 <IgorYozhikov> yes, I saw that
13:14:15 <toabctl> #link https://github.com/openSUSE/python-rpm-macros
13:14:39 <toabctl> I pinged number80 about it. not sure how to go forward from here
13:14:40 <IgorYozhikov> what opinions have our rh colleagues?
13:15:05 <toabctl> afaiu it there are differences how fedora and centos/rhel handle py3
13:15:44 <IgorYozhikov> I know that Fedora have one spec for both 2 & 3 but with %if swirches
13:15:49 <IgorYozhikov> switches
13:15:56 <IgorYozhikov> like if with python3 ....
13:16:17 <IgorYozhikov> not sure about rhel and centos
13:16:41 <IgorYozhikov> number80, jpena ^^^^
13:16:46 <toabctl> number80, jpena are you already building py3 for RDO?
13:17:17 <jpena> we have some specs where py3 is enabled, using the fedora method. However, those are only used when building in Fedora
13:18:26 <IgorYozhikov> in mos packages we tried to apply same approach, it works but we have a very small amount of py3 packages
13:18:54 <IgorYozhikov> and we never tried to build OpenStack with py3
13:20:05 <IgorYozhikov> so using aio spec will lead to "bootstrapping" local mirrors with py3 dependencies
13:20:27 <toabctl> "aio spec" ?
13:20:29 <IgorYozhikov> and it could take time
13:20:49 <IgorYozhikov> all in one from perspective of py2 & py3
13:20:56 <IgorYozhikov> toabctl, ^^^^^
13:21:33 <number80> all-in-one spec
13:21:41 <number80> erm, I'm tired
13:22:46 <toabctl> it would be really nice to get some feedback on the suse macros. maybe we can use them for building.
13:22:58 <toabctl> otherwise renderspec should handle the different cases I guess
13:24:06 <IgorYozhikov> toabctl, is there any examples for single spec?
13:24:18 <toabctl> IgorYozhikov, there are plenty. one sec
13:24:45 <toabctl> # link https://build.opensuse.org/project/show/devel:languages:python:singlespec
13:24:49 <toabctl> eh
13:24:54 <toabctl> #link https://build.opensuse.org/project/show/devel:languages:python:singlespec
13:27:51 <IgorYozhikov> looks interesting, there are no additional ifs & other operators. Need to try
13:28:10 <IgorYozhikov> after that I'll provide feedback
13:30:51 <IgorYozhikov> ok, this is about technology. And there is still unanswered question - py3 versions of already existent py2 packages..
13:32:05 <toabctl> ?
13:32:10 <IgorYozhikov> It should be done locally fro each vendor || as toabctl mentioned will require some kind of switch, which will disable py3
13:32:36 <IgorYozhikov> toabctl, I'm about py3 version of dependencies
13:33:00 <IgorYozhikov> 4 now we have plenty py2 of them
13:33:07 <toabctl> well - you need py3 versions of all dependencies
13:33:10 <IgorYozhikov> and not py3
13:33:14 <IgorYozhikov> yes
13:33:20 <toabctl> so what is the question?
13:33:58 <IgorYozhikov> all of required py3 packages are need to be build
13:34:03 <toabctl> yes
13:34:07 <IgorYozhikov> ant this could take time
13:34:21 <toabctl> sure
13:34:27 <toabctl> but we need to start at some point
13:35:28 <IgorYozhikov> #action IgorYozhikov will investigate single spec and will talk to MOS infra folks.
13:35:42 <toabctl> cool. thx
13:37:14 <IgorYozhikov> anything else to add or we can proceed?
13:38:27 <toabctl> next please
13:38:31 <IgorYozhikov> #topic - packages reviews (https://review.openstack.org/#/q/project:openstack/rpm-packaging+status:open )
13:39:41 <IgorYozhikov> #action IgorYozhikov will propose updates of py OVS in MOS CI
13:40:05 <IgorYozhikov> also we finished with initial de-duplication
13:40:25 <IgorYozhikov> for packages between mos and centos
13:41:19 <IgorYozhikov> And now I'm going to proceed with nova
13:48:51 <toabctl> ping
13:48:54 <jpena> IgorYozhikov: can you ensure python-weakrefmethod is also available in the MOS CI?
13:49:12 <IgorYozhikov> jpena, sure, will do
13:49:16 <jpena> thanks
13:49:20 <IgorYozhikov> I saw errors
13:49:26 <jpena> with that and ovs, neutron will be able to pass
13:49:49 <IgorYozhikov> sounds good
13:51:35 <IgorYozhikov> it is 9 min to the end of meeting
13:51:46 <IgorYozhikov> may be OpenFloor?
13:52:07 <jpena> yes, there's nothing else pending from my side
13:52:20 <IgorYozhikov> #topic - Open Floor
13:53:45 <dirk> IgorYozhikov: sorry, I was afk, so ocata works with mos ci now?
13:53:48 <toabctl> nothing from my side
13:53:54 <dirk> there were a lot of issues due to the missing docker-py
13:54:27 <IgorYozhikov> dirk it should  - https://packaging-ci.fuel-infra.org/view/_RPM%20packaging/
13:54:48 <dirk> IgorYozhikov: thanks
13:55:14 <IgorYozhikov> I spoke with out infra team and they told me that it should work
13:55:32 <IgorYozhikov> jenkins jobs in place
13:55:57 <IgorYozhikov> dirk, https://packaging-ci.fuel-infra.org/view/_RPM%20packaging/job/ocata-rpm-packaging-build-centos7/
13:58:13 <IgorYozhikov> 3 min to go, anything else?
14:00:13 <IgorYozhikov> #endmeeting