13:03:27 <number80> #startmeeting rpm_packaging
13:03:28 <openstack> Meeting started Thu Dec  8 13:03:27 2016 UTC and is due to finish in 60 minutes.  The chair is number80. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:03:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:03:31 <openstack> The meeting name has been set to 'rpm_packaging'
13:03:33 <number80> agenda's here
13:03:37 <number80> https://etherpad.openstack.org/p/openstack-rpm-packaging
13:06:27 <number80> nobody?
13:07:01 <dirk> o/
13:07:12 <number80> #chair dirk
13:07:13 <openstack> Current chairs: dirk number80
13:07:44 <number80> let's wait few more minutes or I'll just review our current review queue
13:08:12 <dirk> toabctl is also here but I keep him busy :)
13:09:28 <number80> np
13:10:36 <number80> any controversies you want us to look at?
13:12:55 <number80> ok, closing meeting in 2 min :)
13:13:12 <toabctl> the renderspec version thing
13:13:27 <number80> ok
13:13:28 <toabctl> https://review.openstack.org/#/c/407102/
13:13:47 <toabctl> I wonder if you really want to throw away everything after the 3rd digit
13:13:48 <dirk> number80: I added potential topcs to the meeting agenda
13:13:53 <number80> #action number80 focus on renderspec reviews
13:13:57 <number80> ok
13:13:59 <toabctl> number80, is that what fedora wants to have?
13:14:30 <number80> toabctl: it's close, yes
13:14:42 <number80> #topic PTG planning
13:15:24 <number80> We are likely to have a representative from RDO team there, anyone else?
13:15:31 <dirk> so I have seen that we have a room
13:15:40 <dirk> for monday-tuesday and I booked a flight
13:15:42 <number80> Yes
13:15:45 <number80> goood
13:15:45 <toabctl> I'm pretty sure that I'll be there
13:15:46 <dirk> but I'll not stay a whole week
13:16:14 <dirk> number80: so you're not going?
13:16:32 <dirk> I haven't seen any response from travel support yet though :/
13:16:32 <number80> I have been designated, but I have yet to get final decision
13:17:29 <dirk> ok, so I guess then it would start to make sense to think about planning those two days
13:17:38 <toabctl> dirk, travel support will answer at 16th dec
13:17:42 <number80> Yes
13:17:42 <dirk> would be cool to get some more progress, on e.g. upstream building or improved gating
13:17:54 <number80> ack for both
13:18:00 <dirk> do we want to create an etherpad or the like for collecting topics?
13:18:08 <toabctl> dirk, yes
13:18:15 <dirk> also don't forget to hand in t-shirt sizes :)
13:18:29 <dirk> for our absolutely rocking packaging donkey shirt
13:18:31 <toabctl> oh. where?
13:18:45 <toabctl> ah. the registration?
13:18:45 <number80> dirk: for now, I'm adding suggestion on meeting etherpad
13:18:50 <number80> Yes
13:19:39 <dirk> toabctl: I think its via the registration. I didn't process that part yet, I just read about it somewhere
13:19:47 * dirk still has troubles finding a hotel though
13:20:49 <kaslcrof> sorry folks, can I have some recommendation about https://review.openstack.org/#/c/401200/ and https://review.openstack.org/#/c/401260/?
13:21:11 <number80> ack
13:21:31 <dirk> number80: whats the link to meeting etherpad?
13:21:43 <toabctl> kaslcrof, the topic is on the agenda
13:22:11 <dirk> kaslcrof: its the "xstatic packaging" meeting point on the agenda
13:22:15 <dirk> kaslcrof: agenda is here:
13:22:25 <dirk> #link https://etherpad.openstack.org/p/openstack-rpm-packaging
13:22:58 <dirk> number80: ah, I see you added it to the normal etherpad
13:23:01 <number80> yes
13:23:46 <kaslcrof> SUSE CI need wheels, but centos tests ignore this field in setup.py and passes..What can I do to make it pass?
13:25:11 <toabctl> hm. I wonder why upstream has wheel in the requirements
13:25:41 <kaslcrof> sorry, I say >><number80> ok, closing meeting in 2 min :) and decided to ask earlier
13:25:50 <kaslcrof> *saw
13:26:09 <number80> ah right
13:26:13 <number80> next topic
13:26:32 <number80> #topic xstatic packaging
13:27:16 <dirk> kaslcrof: I'm not sure this is related to wheels
13:27:25 <dirk> kaslcrof: you'r enot failing on build but on a suse specific packaging check
13:27:51 <dirk> kaslcrof: this is about the Requires: py2pack('XStatic') that I wanted to get removed in an earlier incarnation of that patch
13:28:00 <dirk> but maybe my request to remove it isn't correct
13:28:22 <dirk> I wanted to reseearch that before this meeting but was in other meetings all day so far and had no second of spare time :/
13:28:48 <dirk> currently I think if the Rrequires: would be added back then build would pass for SUSE CI
13:29:02 <dirk> but I darkly remember that there were file conflicts (multiple packages owning the same file) afterwards and that caused other issues
13:29:07 <dirk> but maybe I misremember that
13:30:00 <kaslcrof> dirk, i will check it now
13:30:27 <dirk> kaslcrof: just add the Requires back, and we'll get an answer from suse ci before the end of this meeting :)
13:31:03 <dirk> so in general, it seems the Requires on XStatic is in the MOS packages
13:31:16 <dirk> number80: how is the situation for RDO? do the XStatic-foo packages runtime-require XStatic?
13:31:36 <number80> no, since it's broken we don't
13:33:37 <dirk> number80: do you remember what is broken? I also darkly remember there were problems but I don't recall them
13:34:17 * number80 trying to remember
13:35:19 <number80> https://bitbucket.org/thomaswaldmann/xstatic/issues/2/cannot-build-a-new-xstatic-package-with
13:35:39 <number80> I think it's related to that issue (still unsolved)
13:36:18 <number80> Actually, I was wrong we have python-XStatic as Requires but not BuildRequires
13:40:28 <number80> next topic?
13:40:44 <number80> #topic systemd macros
13:42:11 <toabctl> hm. jpena|off is not here
13:42:30 <toabctl> I think the idea was to just use the macros from upstream instead of the ones suse introduced
13:42:51 <number80> yep, that's what we already do
13:42:54 <toabctl> dirk, are the upstream macros available in our CI now?
13:43:42 <dirk> toabctl: I think yes, didn't confirm yet
13:43:47 <dirk> toabctl: lets assume yes if not I'll fix it
13:44:22 <toabctl> ok.then we can abandon https://review.openstack.org/#/c/407026/
13:44:30 <dirk> number80: ok, so we agree to have XStatic in requires? can we record that as agreed?
13:44:42 <dirk> number80: then I can go revisit my -1's and we can finally get the swoop of xstatics done
13:45:06 <dirk> toabctl: imho yes. I wanted to refresh the keystone or mistral review iwth the new macros
13:45:19 <toabctl> I can do that now
13:45:38 <dirk> what? abandon or refresh the review?
13:46:07 <toabctl> refresh keystone review
13:46:18 <number80> dirk: yes
13:46:30 <number80> #agreed have XStatic as Requires in XStatic packages
13:48:20 <toabctl> let's also agree on using the upstream systemd macros
13:48:43 <kaslcrof> sorry, but why we should add Xstatic as Requires?
13:49:30 <number80> ok
13:49:42 <number80> kaslcrof: some directories are owned by base package
13:50:39 <dirk> kaslcrof: all Xstatic-$foo packages should runtime-require python-XStatic
13:50:52 <dirk> kaslcrof: to track ownership of directories. thats what the suse ci is complaining about
13:51:54 <number80> It's correct, only BR is breaking
13:52:00 <number80> R works fine
13:54:19 <dirk> next topic?
13:54:25 <toabctl> dirk, keystone does not use any systemd macros so there is no need for a refresh
13:54:27 <toabctl> yes
13:55:30 <number80> yep
13:55:50 <number80> let's skip RDO gate as jpena is not here
13:55:58 <number80> #topic pending reviews
13:56:07 <number80> packages reviews (https://review.openstack.org/#/q/project:openstack/rpm-packaging+status:open )
13:56:16 <number80> pymod2pkg reviews (https://review.openstack.org/#/q/project:openstack/pymod2pkg+status:open )
13:56:24 <number80> renderspec reviews (https://review.openstack.org/#/q/project:openstack/renderspec+status:open )
13:56:34 <toabctl> number80, https://review.openstack.org/#/c/406901/ could be merged imo
13:56:51 <toabctl> also https://review.openstack.org/#/c/407808/
13:57:08 <number80> https://review.openstack.org/#/c/406464/1 <- merged
13:57:11 <number80> ack
13:57:12 <toabctl> IgorYozhikov wanted to discuss https://review.openstack.org/#/c/408371/
13:57:18 <number80> Yep
13:57:36 <toabctl> but imo we should just accept it (with a normal review). nothing special there I thinkj
13:58:11 <number80> Yep, maybe I have some nitpicks about some comestic changes
13:58:16 <toabctl> there is no reason to not map package names for ubuntu if they need that
13:58:19 <toabctl> number80, yes
13:58:50 <number80> pymod2pkg, so such changes are acceptable by definition :)
13:59:14 <toabctl> https://review.openstack.org/#/c/406465/ could be merged
14:00:00 <number80> agreed
14:00:15 <number80> any other controversies before we close themeeting?
14:01:32 <toabctl> not from my side
14:03:22 <number80> okay, then thanks for attending and see you next week!
14:03:27 <number80> #endmeeting