13:00:11 <number80> #startmeeting rpm_packaging
13:00:12 <openstack> Meeting started Thu Nov  3 13:00:11 2016 UTC and is due to finish in 60 minutes.  The chair is number80. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:15 <openstack> The meeting name has been set to 'rpm_packaging'
13:00:19 <number80> #topic roll call
13:00:22 <number80> who's here?
13:00:29 <aplanas> number80: hi
13:00:34 <number80> hi :)
13:00:39 <jpena> o/
13:00:59 <number80> #chair aplanas jpena
13:01:00 <openstack> Current chairs: aplanas jpena number80
13:01:09 <number80> agenda is here: https://etherpad.openstack.org/p/openstack-rpm-packaging
13:01:16 <number80> feel free to complete it
13:01:43 <jruzicka> o/
13:03:10 <number80> #chair jruzicka
13:03:11 <openstack> Current chairs: aplanas jpena jruzicka number80
13:03:37 <number80> let's start I guess, toabctl will be late
13:04:11 <number80> #topic script to detect old packages in stable and master, based on global reqs, Tom dashboard and Pypi sources
13:04:13 <number80> aplanas:
13:05:03 <aplanas> right, I was planing to adapt and add some scripts that I have to automatically detect versions outdate of packages
13:05:16 <number80> excellent
13:05:52 <aplanas> we need to take care of packages that are listed in the release list (json from tom) and the ones that are not listed there
13:06:48 <aplanas> after that, I would like to test some ideas to find the required and buildrequred packages, that can be outdated too
13:06:48 <number80> aplanas: will you take into account upper-constraints files?
13:06:58 <toabctl> hi
13:07:27 <aplanas> number80: https://github.com/openstack/requirements/blob/master/upper-constraints.txt this?
13:07:44 <dirk> o/
13:07:47 <aplanas> sounds good
13:08:13 <number80> yes
13:08:15 <number80> #chair dirk
13:08:16 <openstack> Current chairs: aplanas dirk jpena jruzicka number80
13:08:18 <number80> hi :)
13:08:30 <aplanas> number80: was not in my radar, but now it is
13:08:37 <dirk> hi, sorry for being late, on pto and somehow forgot about time
13:08:54 <number80> dirk: no worries, DST is confusing all of us :)
13:09:06 <dirk> I live in utc ;-)
13:09:40 <number80> :)
13:10:06 <number80> #info aplanas is working on automatic detection of outdated package
13:10:11 <number80> anything else?
13:11:03 <dirk> I guess related to that, did you discuss..
13:11:14 <dirk> #link http://www.toabctl.de/openstack/
13:11:43 <number80> yep
13:11:46 <aplanas> dirk: right, this is one of the sources that I have
13:11:57 <number80> right, it uses generated json
13:12:58 <toabctl> and also shows u-c since some weeks. but its not using u-c for the status comment
13:13:38 <toabctl> aplanas, for non-openstack packages, opensuse has already http://osc-collab.opensuse.org/
13:13:40 <dirk> ok, nevermind then... awaiting the review against rpm-packaging-tools :)
13:13:54 <toabctl> I'm pretty sure fedora has something similar to show the package status
13:14:54 <number80> toabctl: we have multiple tools, but none is in good shape
13:15:17 <number80> I need 48h days :)
13:15:18 <aplanas> toabctl: it is working now? package status is blank
13:15:40 <toabctl> aplanas, it was working some month ago.
13:17:02 <number80> I run it locally and it works fine (last time was last week though)
13:17:14 <IgorYozhikov> o/
13:17:23 <number80> #chair IgorYozhikov
13:17:24 <IgorYozhikov> sorry i'm late
13:17:24 <openstack> Current chairs: IgorYozhikov aplanas dirk jpena jruzicka number80
13:17:25 <number80> hi
13:17:58 <number80> may I suggest that toabctl and aplanas, you check together what's the most appropriate plan to move forward?
13:18:12 <aplanas> number80: good for me
13:18:18 <number80> excellent
13:18:40 * number80 wants to leave time for reviews
13:18:45 <number80> #topic RDO CI status
13:18:49 <number80> jpena: ?
13:19:01 <jpena> so, after the fixes from last week, we're almost there
13:19:25 <jpena> we have two pending reviews: https://review.openstack.org/391856 and https://review.openstack.org/392472, and once we fix the taskflow requirements, we can go ahead
13:19:28 <number80> yep, remains gdal and networkx but that'll take some time for me to fix
13:20:31 <jpena> I've set up a WIP job: https://review.rdoproject.org/jenkins/job/DLRN-rpmbuild-rpm-packaging/ . It will not report to reviews for the moment, but I need to check why it hasn't checked any commit yet (it was enabled yesterday)
13:21:20 <number80> ack
13:21:32 <number80> #info RDO CI is WIP
13:21:42 <number80> #link https://review.rdoproject.org/jenkins/job/DLRN-rpmbuild-rpm-packaging/
13:21:47 <number80> anything else?
13:22:03 <dirk> jpena: so goal is to add it as a non-voting 3rd party report ot the reviews? that would be awesome
13:22:25 <jpena> dirk: correct. As soon as I'm sure we can build every package, I'll do that
13:22:26 <dirk> jpena: the two pending ones are merged :)
13:22:32 <jpena> great!
13:22:36 <toabctl> jpena, cool!
13:23:39 <number80> yes, first step is non-voting and after few weeks, we'll review its status (few weeks> 1 week as non-voting)
13:24:10 <IgorYozhikov> great
13:24:33 <number80> I'll try to get networkx fixed faster
13:24:42 <dirk> fwiw I plan to add an installation check at the end of the suse ci run soonish
13:24:46 <number80> #action number80 fix networkx on EL7
13:24:49 <dirk> to increase test coverage
13:24:51 <number80> good
13:25:01 <number80> DLRN already does it by default
13:25:04 <IgorYozhikov> dirk, about job you mentioned today for additional checks of uploading versions against u-c.
13:25:18 <IgorYozhikov> looks like a common job for all
13:25:34 <IgorYozhikov> and should this job be a part of linter?
13:25:51 <dirk> could be
13:25:51 <IgorYozhikov> or as a separate one?
13:26:21 <dirk> I haven't made up my mind on that one yet. its just a few lines of code of checking, but its worth having indeed to avoid merging something that hasn't landed in g-r yet
13:27:02 <IgorYozhikov> i c
13:27:24 <number80> yep
13:27:57 <dirk> it could be doneas part of the linter job, but that one would require network then, which it currently doesn't
13:28:03 <dirk> so I think a separate job makes more sense
13:28:32 <number80> ack
13:28:37 <IgorYozhikov> ++
13:29:01 <number80> #info dirk working on a job to check upper-constraints before merging
13:29:18 <number80> should we move to reviews?
13:29:35 <dirk> +1, I need to leave soon
13:30:10 <IgorYozhikov> let's move to reviews
13:30:52 <IgorYozhikov> https://review.openstack.org/#/c/391362/
13:30:56 <IgorYozhikov> looks fine
13:31:51 <dirk> IgorYozhikov: still building..
13:32:03 <IgorYozhikov> yes I see
13:32:17 <toabctl> ups. I merged it. shit
13:32:20 <toabctl> sorry
13:32:21 <dirk> jpena: I got pinged about magnumclient https://review.openstack.org/#/c/389688/ (and the stable/newton) variant
13:32:38 <dirk> jpena: could you revisit the -1 ? I think upper constraints is meanwhile updated
13:32:51 <dirk> hmm, its not actually
13:32:52 <jpena> dirk: oh yes, I saw the ping this morning, but went I went to the review it was already merged
13:32:54 <IgorYozhikov> https://github.com/openstack/requirements/blob/master/upper-constraints.txt#L205
13:33:02 <IgorYozhikov> https://review.openstack.org/#/c/393126/
13:33:04 <number80> #topic packaging reviews
13:33:06 <jpena> it's on stable/newton, but still no open review for master
13:33:07 <number80> https://review.openstack.org/#/q/project:openstack/pymod2pkg+status:open
13:33:26 <number80> erm wrong link
13:33:36 <number80> #undo
13:33:36 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x7fac54f2c890>
13:33:39 <number80> https://review.openstack.org/#/q/project:openstack/rpm-packaging+status:open
13:34:21 <IgorYozhikov> openstacksdk ?
13:34:36 <dirk> jpena: ok, I'll work on the g-r change for magnumclient now. we should get this in
13:34:39 <IgorYozhikov> u-c is 9.8
13:34:55 <IgorYozhikov> proposed change is 9.9
13:35:10 <dirk> I merged the u-c change a few minutes ago
13:35:25 <dirk> ah, no, I only +2ed it
13:36:14 <jpena> https://review.openstack.org/392410 is in the gate
13:37:15 <IgorYozhikov> jpena, so we need to wait until it will ^^ landed
13:37:25 <dirk> g-r is a bit of a mess with the summit and travels. cleaning it up soon
13:39:07 <dirk> jpena: number80 : any chance you could review https://review.openstack.org/#/c/380834/ ?
13:39:21 <dirk> I need this with the new suse ci implementation on mitaka
13:39:28 <dirk> basically it can only do templates now
13:40:05 <number80> yes
13:41:04 <number80> any controversies on the packaging queue?
13:41:08 <number80> *other
13:41:33 <dirk> yes
13:41:36 <dirk> the mistral one
13:41:50 <dirk> I remember we need mistral for some tripleo stuff that is waiting already since forever
13:42:07 <number80> tripleoclient right?
13:42:09 <IgorYozhikov> dirk, I faced that we have openstackclient with epoch
13:42:10 <dirk> IgorYozhikov: can you fix the lint fallout on https://review.openstack.org/#/c/382196/ soon ?
13:42:22 <IgorYozhikov> already working on that
13:42:30 <dirk> oh, great
13:42:49 <number80> tripleoclient pulls too much things to realistically land any soon
13:42:55 <dirk> I want to have some more openstack services in rpm-packaging before everone invents their own stuff downstream for ocata again :)
13:43:09 <dirk> number80: iirc it was the only missing dep
13:43:13 <IgorYozhikov> because of reuse of our templates:) some time ago osclient had epoch 1
13:43:16 <dirk> at least in the suse ci
13:44:04 <number80> dirk: it will likely not run, i do not see heat nor heat templates
13:44:12 <number80> but ack
13:44:21 <dirk> number80: iirc we just wanted to have the dep there..
13:44:47 <number80> I'll give it a look then
13:44:49 <dirk> I am fine with slightly pragmatic on it.. once we have the "useful" core package set there, we can setup functional testing and solve the rest
13:48:59 <number80> true, it's just that tripleoclient is a lot of work
13:49:16 <number80> no pymod2pkg reviews this week
13:49:56 <IgorYozhikov> dirk, tests issues https://build.opensuse.org/package/live_build_log/home:suse-cloud-ci:rpm-packaging-sles12-Master-957995289c7dfb5577605c12f0cd5b3305edf1e3/python-mistral/SLE_12_SP1/x86_64
13:50:39 <dirk> IgorYozhikov: yeah, functional tests are.not going to work
13:51:01 <dirk> There is no OpenStack environment to run against. You need to restrict to  unit tests
13:51:48 <IgorYozhikov> https://packaging-ci.fuel-infra.org/job/master-rpm-packaging-build-centos7/1456/consoleFull
13:51:57 <IgorYozhikov> tests passed
13:52:58 <IgorYozhikov> I see errors in docs building
13:54:30 <IgorYozhikov> anyway will look into it
13:54:53 <IgorYozhikov> do we have anything else ? 5 mins to go....
13:55:38 <jpena> I have a quick question
13:55:50 <IgorYozhikov> :)
13:56:01 <jpena> could we set a policy that, for version bumps, we set a Depends-On: to the corresponding change in openstack/requirements?
13:56:34 <jpena> going through the current list of open reviews, there are several that have been opened before the u-c bump has been done
13:56:57 <IgorYozhikov> good point until we have no job for version checking
13:56:57 <jpena> with that, we could review them and even +2+W the patch, but it would not be merged until the u-c review has been merged
13:58:08 <IgorYozhikov> and this should be also reflected on wiki
13:58:17 <IgorYozhikov> just imo
13:58:51 <IgorYozhikov> number80, toabctl ^^^ your thoughts?
13:59:27 <toabctl> sounds good
13:59:34 <number80> I agree with using depends-On even if it's informative
13:59:47 <IgorYozhikov> yey
14:00:03 <IgorYozhikov> we r on time
14:00:38 <number80> one last question
14:00:43 <number80> #topic next week chair
14:00:48 <number80> who wants it?
14:01:01 <IgorYozhikov> I can
14:01:11 <number80> #info IgorYozhikov is chairing next week
14:01:13 <number80> thanks :)
14:01:18 <number80> #endmeeting