13:01:48 <toabctl> #startmeeting rpm_packaging
13:01:49 <openstack> Meeting started Thu May 26 13:01:48 2016 UTC and is due to finish in 60 minutes.  The chair is toabctl. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:53 <openstack> The meeting name has been set to 'rpm_packaging'
13:02:37 <toabctl> not sure if there's anybody arround today but if so, please add your agenda points to https://etherpad.openstack.org/p/openstack-rpm-packaging
13:03:38 <IgorYozhikov> o/
13:04:00 <toabctl> hey IgorYozhikov
13:05:20 <toabctl> IgorYozhikov, dirk is out today - do you have any points?
13:07:23 <IgorYozhikov> toabctl, we resolved issue with python-keystoneclient
13:07:35 <IgorYozhikov> and now working on https://packaging-ci.fuel-infra.org/job/master-rpm-packaging-build/149/
13:07:44 <IgorYozhikov> https://review.openstack.org/#/c/311285/
13:07:48 <toabctl> IgorYozhikov, cool. then let's merge it!
13:08:01 <toabctl> oh. it is already - even better :)
13:08:16 <IgorYozhikov> toabctl, https://review.openstack.org/#/c/290472/ - merged
13:08:22 <IgorYozhikov> :)
13:08:36 <toabctl> let's start
13:08:39 <toabctl> #topic rpm-packaging-status
13:08:50 <toabctl> I updated http://toabctl.de/openstack/rpm-packaging-status.html
13:08:59 <IgorYozhikov> toabctl, great - I saw
13:09:15 <IgorYozhikov> and I want to figure out next steps
13:09:15 <toabctl> it has now a newton link. the missing packages there don't have a release yet so you have to look at the mitaka page for that.
13:09:44 <IgorYozhikov> 1st - resolve spec-cleaner issues from link i posted above
13:09:58 <IgorYozhikov> 2nd - update oslo.* according to Newton
13:10:00 <toabctl> #topic spec-cleaner issues
13:10:23 * toabctl checks the link ...
13:10:55 <toabctl> so for spec-cleaner there is another issue in the current released version
13:11:05 <IgorYozhikov> I mean that we have some issues according to commit
13:11:08 <toabctl> # link https://github.com/openSUSE/spec-cleaner/issues/137
13:11:37 <IgorYozhikov> spec-cleaner install going  fine
13:11:39 <IgorYozhikov> yes
13:12:11 <IgorYozhikov> but we've got unit tests problems - and working on them to make failed job green
13:12:50 <toabctl> IgorYozhikov, unittest problems? with spec-cleaner?
13:14:47 <IgorYozhikov> toabctl, https://review.openstack.org/#/c/311285/
13:14:57 <IgorYozhikov> I am about this commit ^^^
13:15:58 <toabctl> ah.ok. not sure how you test the commits but you need to rebuild all changed packages in the correct order. that's something the openbuildservice does automatically.
13:16:20 <IgorYozhikov> I see now 16:40:22 DEBUG:   File "/usr/lib/python2.7/site-packages/urllib3/packages/__init__.py", line 3, in <module>
13:16:20 <IgorYozhikov> 16:40:22 DEBUG:     from . import ssl_match_hostname
13:16:20 <IgorYozhikov> 16:40:22 DEBUG: ImportError: cannot import name ssl_match_hostname
13:16:45 <IgorYozhikov> urllib3 package was fixed today
13:17:29 <IgorYozhikov> so I just launched rebuild :)
13:17:43 <IgorYozhikov> http://gate.fuel-infra.org/
13:18:05 <IgorYozhikov> anyway - we need to fix it on our side 1st
13:18:14 <toabctl> ok. hopefully it passes now. but the lint job is still broken. I'm working on that but that's why it's currently WIP
13:18:54 <toabctl> anything else regarding spec-cleaner?
13:19:03 <IgorYozhikov> toabctl, no
13:19:08 <toabctl> #topic oslo.* updates
13:19:46 <toabctl> IgorYozhikov, your turn
13:20:28 <IgorYozhikov> toabctl, I suggest to update all oslo* in one week
13:20:40 <toabctl> that would be great!
13:20:43 <IgorYozhikov> using last released tarballs
13:21:40 <toabctl> yeah. I already did that for at least one package (which I need) but we are lacking reviews
13:21:52 <toabctl> IgorYozhikov, so are you planing to update the packages next week?
13:22:08 <IgorYozhikov> So, add please AI on me to do that, I'll provide PR for that and hope that all will built  more || less fine
13:22:31 <IgorYozhikov> Just scary a little bit about dependencies
13:22:37 <toabctl> #action IgorYozhikov updates the olso.* packages to latest released tarball
13:23:01 <toabctl> IgorYozhikov, you mean about needing to package more dependencies?
13:23:21 <IgorYozhikov> toabctl, yep
13:24:01 <IgorYozhikov> anyway - I'll try
13:24:08 <toabctl> let's see. I can definitely help with updating the oslo.* packages
13:24:12 <toabctl> great!
13:24:24 <toabctl> #topic reviews
13:24:41 <IgorYozhikov> https://review.openstack.org/#/q/project:openstack/rpm-packaging+status:open
13:24:57 <toabctl> I would like to merge https://review.openstack.org/#/c/316088/
13:25:03 <toabctl> can you review that, IgorYozhikov ?
13:25:53 <IgorYozhikov> toabctl, already saw it - look good
13:26:41 <IgorYozhikov> we have cherrypick
13:26:41 <toabctl> ok. then I try to get spec-cleaner fixed but imo it takes already to much time so I suggest to continue to merge the clients, too
13:26:46 <IgorYozhikov> https://review.openstack.org/#/c/321526/1/openstack/python-keystoneclient/python-keystoneclient.spec.j2
13:27:29 <toabctl> ah. right.
13:27:43 <toabctl> form the SUSE side, we need to adapt out CI to test branches now correctly
13:28:03 <toabctl> I think the tests are currently running always against the packages from master
13:28:25 <toabctl> #action toabctl adapts SUSE CI to test branches correctly
13:29:01 <toabctl> #action toabctl review client changesets
13:29:24 <IgorYozhikov> toabctl, I think that we need to rebase all py*clients 1st
13:29:41 <toabctl> ok
13:29:52 <IgorYozhikov> just to actualize them
13:31:02 <toabctl> #topic open discussion
13:31:06 <toabctl> anything else?
13:31:23 <toabctl> in general we don't have enough core reviewers imo.
13:31:48 <IgorYozhikov> wow - https://review.openstack.org/#/c/278397/4/openstack/python-ceilometerclient/python-ceilometerclient.spec.j2
13:32:06 <IgorYozhikov> I think that comments addressing required
13:33:00 <toabctl> yes
13:33:14 <IgorYozhikov> toabctl, I can do review once a day, so if you can do the same - think that we could merge all hanged reviews more || less quick
13:33:17 <MikhailIvanov> I think I should update my older reviews asap
13:33:30 <toabctl> MikhailIvanov, great
13:33:48 <toabctl> IgorYozhikov, yes. I try to do it daily.
13:34:11 <toabctl> ok. so any last topic?
13:34:38 <IgorYozhikov> nope
13:35:00 <toabctl> #endmeeting