13:00:40 <toabctl> #startmeeting rpm_packaging
13:00:40 <openstack> Meeting started Thu Apr  7 13:00:40 2016 UTC and is due to finish in 60 minutes.  The chair is toabctl. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:43 <openstack> The meeting name has been set to 'rpm_packaging'
13:00:47 <dirk> toabctl: thanks
13:00:51 <toabctl> hi all
13:00:56 <dirk> hey
13:01:28 <toabctl> please add your topics to the agenda at https://etherpad.openstack.org/p/openstack-rpm-packaging
13:01:34 <jruzicka> hello
13:04:38 <toabctl> looks like we have a short agenda today.
13:05:01 <toabctl> #topic stable branch creation
13:05:14 <toabctl> dirk: you added it...
13:05:43 <dirk> just wanted to announce that I plan to create the stable/mitaka branch today
13:05:50 <dirk> just haven't managed to get around doing so yet
13:06:04 <dirk> in rpm-packaging. just checking, we don't want to branch any of the other repositories?
13:06:19 <dirk> or do we want to create rpm-packaging-tools branches and renderspec?
13:06:28 <toabctl> do we plan to backport changes/new specs then?
13:06:43 <toabctl> or are we just go ahead and start with neton?
13:06:52 <toabctl> s/neton/newton/
13:07:15 <toabctl> dirk: I wouldn't create branches for the other repos. imo not needed yet
13:07:33 <dirk> fine by me
13:07:50 <dirk> toabctl: I"d be fine with tracking master in master and stable/mitaka in mitaka. backporting when needed, or creating new spec files in stable is fine by me
13:07:59 <dirk> probably we need to document the stable branch rules in the wiki though
13:08:23 <toabctl> #actipn dirk will create stable/mitaka branch for openstack-rpm-packaging repo
13:08:58 <toabctl> #action dirk will create stable/mitaka branch for openstack/rpm-packaging repo
13:09:47 <toabctl> so who want's to create the wiki for stable branches rules? or do we just want to see how it goes?
13:09:47 <dirk> thanks
13:10:22 <IgorYozhikov> toabctl, I can do that
13:10:30 <toabctl> IgorYozhikov: great. thanks!
13:10:49 <toabctl> #action IgorYozhikov creates a wiki page with rules for stable branches updates
13:10:57 <dirk> thank you IgorYozhikov
13:10:59 <toabctl> anything else on that topic?
13:11:04 <dirk> nope
13:11:19 <IgorYozhikov> just one question - when &
13:11:36 <IgorYozhikov> when stable will be cut?
13:11:56 <toabctl> IgorYozhikov: dirk said today
13:12:07 <IgorYozhikov> toabctl, ok.
13:12:41 <toabctl> #topic specs storage, where to publish possible specifications
13:12:45 <toabctl> IgorYozhikov: your topic
13:12:59 <IgorYozhikov> yep
13:13:52 <IgorYozhikov> I want to clarify next, if I have some proposal of something useful 4 example, where I can store it?
13:14:36 <toabctl> hm. I don't fully understand the question. what do you mean by "proposal of something useful" ?
13:15:05 <dirk> you mean an example template to start with?
13:15:09 <dirk> I think thats a great idea
13:15:16 <dirk> put it under doc/ ?
13:16:23 <IgorYozhikov> nope, I'm about document which describes, for example - how CI works
13:16:48 <jruzicka> Is there a common place for docs?
13:17:38 <toabctl> not yet in rpm-packaging
13:17:53 <dirk> do we want to doucment the CI in wiki or in git?
13:17:58 <toabctl> but maybe we should create the standard doc/source
13:18:12 <dirk> e.g. the standard sphinx documentation? works for me as well
13:18:36 <IgorYozhikov> dirk, ok, store in in rst format?
13:19:00 <IgorYozhikov> s/in/it/
13:19:47 <dirk> IgorYozhikov: yep.. well, depending on what we want to do . for CI I think we should just document in wiki
13:20:06 <IgorYozhikov> ah, ok,
13:20:11 <IgorYozhikov> I'll do that
13:20:31 <IgorYozhikov> just convert existing spec into wiki format
13:20:48 <IgorYozhikov> spec here != rpm spec :)
13:20:54 <toabctl> :)
13:21:08 <dirk> spec in the sense of blue prints ?
13:21:17 <IgorYozhikov> so, I'm fine with wiki.
13:21:18 <dirk> we are free to create blue prints as well.. would actually be good
13:21:22 <IgorYozhikov> dirk, yes
13:21:35 <IgorYozhikov> like BP, document describing something
13:21:42 <dirk> now would be a good time to start the newton "specs"
13:22:13 <IgorYozhikov> sure
13:22:18 <toabctl> can we call it blueprints and use specs in the rpm context please ?:)
13:22:32 <dirk> +1
13:22:37 <jasondotstar> +1
13:22:43 <toabctl> #agreed documentation about CI will be in the wiki
13:23:34 <toabctl> anything else on this topic?
13:23:42 <IgorYozhikov> nope
13:23:52 <toabctl> #topic epoch yaml, each maintainer has its own copy or centralized version for "fedora/centos"
13:23:55 <toabctl> IgorYozhikov: ^^ :)
13:24:00 <IgorYozhikov> :)
13:24:35 <IgorYozhikov> Just want to get clear and get your opinion
13:25:18 <IgorYozhikov> if there is already existent list of projects with epochs, where to store it?
13:25:51 <toabctl> I would add it to our git repo
13:26:15 <IgorYozhikov> in th root of rpm-packaging, right?
13:26:30 <toabctl> IgorYozhikov: I would say, yes
13:26:32 <IgorYozhikov> or under rpm-packagin/openstack/
13:27:05 <dirk> the other thought would be to create a vendor subdir, right?
13:27:05 <toabctl> I thought in the root of rpm-packaging/
13:27:13 <dirk> e.g. we'd have a fedora/epochs.yaml
13:27:26 <toabctl> or fedora-epochs.yaml
13:27:38 <toabctl> ^ that's also the default for renderspec
13:28:08 <toabctl> but if fedora and centos are different, we need to pass the epoch parameter to renderspec anyway. so I'm also fine with a vendor subdir
13:28:22 <toabctl> maybe we need this vendor specific dir anyway later to store different things...
13:30:03 <toabctl> opinions?
13:30:33 <IgorYozhikov> toabctl, folder epochs/default.yaml
13:30:51 <IgorYozhikov> or by style  name?
13:31:12 <toabctl> IgorYozhikov: I thought default is without any epochs. so I would prefer the style(vendor) name
13:31:24 * dirk doesn't care
13:31:44 <IgorYozhikov> epochs/style-fedora.yaml right?
13:31:52 <IgorYozhikov> epochs/style-centos.yaml right?
13:32:31 <toabctl> or just epochs/fedora.yaml
13:32:57 <toabctl> IgorYozhikov: just propose something and let's discuss it in the review then
13:33:11 <IgorYozhikov> ok
13:33:27 <IgorYozhikov> will do today
13:33:31 <toabctl> great
13:33:35 <toabctl> anything else on this topic?
13:34:08 <toabctl> #topic open discussion
13:34:19 <toabctl> anything else we need to discuss?
13:34:24 <IgorYozhikov> CI
13:34:35 <IgorYozhikov> As I promised
13:34:36 <IgorYozhikov> https://review.openstack.org/#/c/270826/
13:34:54 <toabctl> great!!!
13:34:58 <IgorYozhikov> 1steps made
13:35:15 <IgorYozhikov> and 4 now we need some days to fix it
13:35:40 <IgorYozhikov> like build missed, etc
13:36:01 <toabctl> sure. it's great to see another CI
13:36:07 <jasondotstar> hi guys
13:36:15 <jasondotstar> sorry i missed last week's meeting
13:36:18 <IgorYozhikov> in plans package publish
13:36:33 <dirk> IgorYozhikov: great!
13:36:36 <jasondotstar> talked to dirk and Igor in channel the other day about the openstack-salt effort to build RPMs
13:36:46 <IgorYozhikov> we are working on it, results will be published and reused in further tests
13:37:22 <IgorYozhikov> if you have any questions related to our ci work - feel free to ping me
13:37:57 <jasondotstar> I'm one of the core reviewers on the openstack-salt team, and at the moment the team is working on packaging up our salt formulas- both deb and rpm
13:38:29 <jasondotstar> besides that, I've a keen interest in learning more about the packaging process so
13:38:45 <jasondotstar> if there's something i can help out with, lmk.
13:38:51 <dirk> IgorYozhikov: I guess what we should do is document the contact persons in the wiki page for a particular ci
13:39:01 <dirk> this is something that we didn"t do either for the SUSE CI
13:39:07 <toabctl> +1
13:39:36 <IgorYozhikov> dirk, exactly, that is why I asked about space for BP & etc ^)
13:40:08 <dirk> IgorYozhikov: now I get it, thanks for thinking about it :)
13:40:21 <toabctl> btw. there is already https://wiki.openstack.org/wiki/ThirdPartySystems
13:40:47 <IgorYozhikov> also - re-trigger commit message for our  CI is - rebuild
13:41:36 <dirk> toabctl: sounds good
13:41:37 <IgorYozhikov> that is all news from my side :)
13:41:44 <dirk> #link https://wiki.openstack.org/wiki/ThirdPartySystems
13:41:47 <jasondotstar> toabctl: +1 on that link - never seen that one b4
13:42:14 <toabctl> IgorYozhikov: hm. would be good to have "recheck" to trigger *all* CIs and then recheck-FOO to recheck only FOO
13:43:06 <IgorYozhikov> toabctl, got it, will discuss with our infra team
13:43:13 <toabctl> IgorYozhikov: thx
13:44:23 <toabctl> jasondotstar: so how can we help with the salt formulas ?
13:45:01 <toabctl> jasondotstar: are you planing to propose the spec files in rpm-packaging? or do you want to consume the specs from rpm-packaging  for testing?
13:45:17 <dirk> the very short summary is that we could collaborate on both
13:45:28 <dirk> PRs against salt formulars could be integration tested against "our" packages
13:45:43 <dirk> and changes to "our" packages could be tested against the existing salt formulas
13:45:48 <dirk> I think both things have some value
13:45:52 <toabctl> ah. sounds good
13:46:03 <IgorYozhikov> dirk, any updates|news about fishbowl session with deb-packaging?
13:46:16 <IgorYozhikov> topics, suggestions, etc
13:46:46 <dirk> IgorYozhikov: no update yet, sorry
13:46:55 <IgorYozhikov> i c
13:46:55 <dirk> IgorYozhikov: deadline is to finish it end of this week though
13:47:27 <IgorYozhikov> where to look on it, add something?
13:47:48 <IgorYozhikov> may be I can help somehow
13:47:53 <dirk> I think we summarized all topics int he last meeting
13:48:00 <IgorYozhikov> ok
13:48:09 <jasondotstar> toabctl: yes, we are planning to propose spec files
13:48:55 <toabctl> jasondotstar: ok. great
13:49:04 <toabctl> so anything else before we close the meeting?
13:50:08 <IgorYozhikov> nope
13:50:09 <toabctl> ok. if there is something, go to  #openstack-rpm-packaging
13:50:15 <toabctl> #endmeeting