10:00:00 <tonyb> #startmeeting requirements
10:00:01 <openstack> Meeting started Wed Dec 14 10:00:00 2016 UTC and is due to finish in 60 minutes.  The chair is tonyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:00:04 <openstack> The meeting name has been set to 'requirements'
10:00:13 <tonyb> #topic rollcall
10:00:17 <tonyb> sigmavirus, prometheanfire, number80, dirk, coolsvap, toabctl
10:00:17 <coolsvap> o/
10:00:26 <toabctl> hey
10:00:29 <prometheanfire> o/
10:00:53 <dirk> o/
10:00:57 <tonyb> woot!
10:01:11 <tonyb> Getting the band back together :)
10:01:24 <tonyb> #topic Any controversies in the Queue?
10:02:20 <dirk> nothing major
10:02:23 <prometheanfire> gate's been a little wonky lately, bot don't think so
10:02:28 <tonyb> The kombu change is a little complex
10:02:29 <tonyb> https://review.openstack.org/410176
10:02:38 <dirk> the only topic I have is whether or not we use upper-constraints for our own gating
10:02:51 <tonyb> Yeah thet gate has been bad lately
10:03:18 <tonyb> there was the docutils issue, then kombu + lots of other random failures
10:03:46 <tonyb> sdague was right abiyt landing stuff in openstack/requiremenst geting hard with the more testing we add
10:04:31 <tonyb> dirk: I'd like to here youre thoughts on that in open discussion
10:04:37 <dirk> tonyb: wfm
10:04:56 <tonyb> #topic Requirements priorities for Ocata
10:05:03 <tonyb> #link https://etherpad.openstack.org/p/requirements-track-constraints-usage
10:05:28 <tonyb> dirk's been doign the good work of adding constraints support to projects that are missing it
10:05:47 <tonyb> we also need to work on the "incubated code" idea
10:05:53 <tonyb> and tools around that
10:06:45 <tonyb> dirk's also been working hard on geeting the constratints updates landed.
10:07:01 <dirk> yeah, surprisingly easy
10:07:13 <tonyb> dirk: can you give us aun update on the state of docker-py and pillow
10:07:15 <dirk> I was expecting more complaints, but the docutils breakage greatly helped
10:07:18 <tonyb> dirk: what can we do to help you
10:07:28 <dirk> pillow is blocked on sphinxmark
10:07:41 <tonyb> dirk: okay I'll poke bmoss
10:07:41 <dirk> https://github.com/kallimachos/sphinxmark/pull/21
10:07:52 <tonyb> dirk: did you PR pass unit tests?
10:07:55 <dirk> if anyone knows the maintainer and can poke him, this PR needs to get in and then we need release
10:08:14 <dirk> for docker-py we're still facing issues with conflicts, I think it was tripleo last time I looked
10:08:32 <tonyb> #action tonyb to talk to bmoss about sphinxmark
10:08:32 <dirk> I can take a closer look today at that, maybe that is solved with the new tripleo-common release
10:09:05 <dirk> #action dirk take a closer look at docker-py upper-constraints
10:09:11 <tonyb> dirk: that'd be awesom if you could look at that and drop an update into #openstack-requirements
10:09:28 <dirk> the new Pillow release is imho just a minor fix
10:09:44 <dirk> I don't think anyone is waiting for it so its annoying that the bot proposes it constantly but I don#t think there is any issue due to that
10:09:59 <tonyb> dirk: okay but it keeps coming up and causing you pain so we shoudl try to fix it
10:10:01 <dirk> docker-py is more urgent as there are teams waiting for the uncapping
10:10:21 <tonyb> ok
10:10:22 <dirk> tonyb: well, my secret weapin is that the bot will search for all open reviews with a magic topic and reverse-apply those patches
10:10:25 <dirk> and then I don't care anymore :)
10:10:49 <tonyb> dirk: Huh really?
10:10:51 <dirk> so far this secret weapon isn't implemented yet though, although I splitted the problematic components into separate reviews
10:11:05 <tonyb> #action tonyb go looking at the code for the constartints update bot
10:11:19 <prometheanfire> nice
10:11:49 <dirk> tonyb: so you'll implement that? or you just educate yourself about the code ? :)
10:12:08 <dirk> tonyb: the docker-py is isolated in https://review.openstack.org/#/c/406442
10:12:14 <dirk> I just rechecked that now, if it passes, we're good
10:12:20 <tonyb> dirk: I mis understood.  I thought you wre describing the state of the current code, not a new feature
10:12:33 <tonyb> dirk: Thanks
10:12:40 <dirk> tonyb: so far its only an idea,
10:12:53 <tonyb> dirk: okay I see
10:13:59 <tonyb> Can we get some people to look at that link I posted above and take a few projects
10:14:18 <tonyb> We're kinda blocked on that for the rest of the "fun" work this cycle
10:14:30 <prometheanfire> ya :(
10:14:34 <tonyb> Perhaps I've over estimated what we can do in one cycle
10:14:41 <dirk> not really
10:14:43 <tonyb> prometheanfire: Thanks.
10:14:49 <prometheanfire> I'll try, now that I have some time
10:15:01 <tonyb> prometheanfire: \o/
10:15:04 <dirk> tonyb: I think we can still do it. there is endless amount of time between christmas and new year, you know ;)
10:15:06 <prometheanfire> https://etherpad.openstack.org/p/requirements-track-constraints-usage right?
10:15:16 <tonyb> prometheanfire: ACK
10:16:03 <tonyb> dirk: Sure there is time but we're at milestone 2 and radically changing the infra of the whole openstack project after milestone3 is just a bad idea
10:16:28 <tonyb> dirk: so I tink we might just need to focus on adding the support and tools this cycle
10:16:34 <tonyb> then start again in pike
10:16:48 <tonyb> with slightly more lead time as the difficult design work is done
10:17:09 <dirk> maybe I'm misinformed, but wasn't the goal for ocata to just establish upper constraints everywhere and increase test coverage so that we can do the 2nd steps then?
10:17:34 <dirk> maybe thats why I'm relaxed because I still think we can totally reach *that* goal :)
10:17:41 <prometheanfire> we wanted it all
10:17:47 <prometheanfire> all the the todo :P
10:17:49 <tonyb> dirk: the goal was to hit divergent requirements in ocata
10:18:17 <tonyb> dirk: but I underestimated the pre-conditions of that work
10:18:48 <dirk> I see. ok
10:19:19 <tonyb> don't get me wrong more projects using constraints is a good thing and a reasonable outcome for the cycle
10:19:49 <tonyb> We have until Jan 26th 2017 to hit that target
10:20:15 <tonyb> Anything else for goals/priorities?
10:21:10 <tonyb> #topic Tasks from Etherpad
10:21:18 <tonyb> #link https://etherpad.openstack.org/p/requirements-tasks
10:21:46 <tonyb> prometheanfire: I see you've been movign items from the tracking etherpad to open bugs/issues
10:21:52 <prometheanfire> very slowly
10:22:11 <tonyb> prometheanfire: slow forward progress is still forward progress
10:22:17 <prometheanfire> deps between 'bugs' is hard on etherpad
10:22:49 <tonyb> prometheanfire: Yeah I *think* that's one of the things in StoryBoard
10:23:09 <prometheanfire> s/etherpad/launchpad
10:23:17 <tonyb> prometheanfire: before you do too many more it might be worth testing Storyboard for our task tracking
10:23:39 <tonyb> One of the open issues is defining our electorate.
10:23:53 <dirk> tonyb: can you add me to the launchpad group=
10:23:59 <dirk> it seems I can not close bugs..
10:24:04 <tonyb> Does anyone object to me adding all the PTLs of managed projects as extra-atcs?
10:24:14 <tonyb> dirk: I can try
10:24:23 <coolsvap> dirk: i can do that for you
10:25:07 <tonyb> coolsvap: Thanks
10:25:11 <dirk> coolsvap: thanks!
10:25:19 <prometheanfire> tonyb: sgtm
10:25:22 <tonyb> #action coolsvap to add dirk as a requirements-driver
10:25:28 <dirk> I agree a bugtracker is much better than an etherpad :)
10:25:48 <tonyb> for the record I seem to have permission to do that thing I just can't find your LP account
10:25:50 <prometheanfire> tonyb: atm, I'll not be a core at least because of my lack of commits to this repo, at least I think
10:26:15 <tonyb> prometheanfire: s/core/atc/ ok
10:26:42 <tonyb> prometheanfire: we can verify and fix that
10:26:45 <coolsvap> tonyb: i also could not find the correct acount for dirk
10:26:48 <prometheanfire> just mentioning
10:27:06 <tonyb> of course it's only an issue if we're havign an election ;P
10:27:44 <prometheanfire> lol
10:27:47 <prometheanfire> bdfl
10:28:11 <tonyb> coolsvap, dirk: dmllr and done
10:28:14 <tonyb> prometheanfire: :)
10:28:39 <coolsvap> tonyb: i think we can keep the electorate to lower priority
10:28:39 <tonyb> moving on?
10:29:02 <tonyb> coolsvap: Sure but if we're going to do it we have a deadline to do it RSN
10:29:38 <tonyb> Jan 6th
10:29:50 <tonyb> #topic Next meeting?
10:29:59 <prometheanfire> that is likely right after next meeting
10:30:19 <tonyb> So with Christmas coming up I'm thinking that we shoudl skip meetings until Jan 4th
10:30:28 <prometheanfire> fine by me :D
10:30:35 <tonyb> that gives people a little more flexibility to take leave etc
10:31:36 <coolsvap> i am fine either way (with or without meetings) :-)
10:31:55 <dirk> wfm
10:32:40 <tonyb> okay I think we'll skip'em
10:32:57 <tonyb> #action tonyb to setup meeting skips ofr requirements meetings
10:33:05 <tonyb> #topic Open Discussion
10:33:32 <tonyb> dirk: Tell me about using constraints in our own tox targets
10:34:08 <dirk> tonyb: so I was thinking that it would make sense to use our own proposed upper-constraints for testing
10:34:17 <dirk> currently our own check jobs are not using upper-constraints
10:34:41 <dirk> (so not use upper-constraints from master git like everywhere else) but the current git version in the working copy
10:34:55 <tonyb> dirk: Oh you'd like to add openstack/requirements to the gate-cross group alongside nova/glance etc?
10:35:19 <dirk> https://review.openstack.org/#/c/406505/
10:35:40 <prometheanfire> adding golang technical requirements (email) to the list of things to discuss/mention
10:35:41 <dirk> tonyb: just use the same way like we use it in other projects, but against the local copy so that we're selfgating changes to those files
10:36:00 <tonyb> dirk: Ahh okay
10:36:22 <tonyb> so we can't do that because many of out tools rely on the fact they're unconstrained
10:36:47 <tonyb> dirk: if we only install the stuff in u-c how will the bot find new versions to suggest?
10:37:26 <tonyb> dirk: what we *can* do is assess which tox environment need to be unconstrained and constrain the rest
10:38:22 <tonyb> dirk: which might just mean adding "install_commnd = pip install -U {opts} {packages}" to the [testenv:update] tox environment
10:38:44 <tonyb> dirk: so from my POV as long as we do it carefully we shoudl totally do it
10:38:55 <dirk> tonyb: yeah, good point, so the bot jobs need to be checked.
10:39:05 <tonyb> dirk: Yup
10:40:20 <tonyb> Actually s/update/generate/ and I think that's probably enough
10:40:40 <tonyb> dirk: Are you keen to look into this?
10:40:55 <dirk> tonyb: sort of, yeah
10:40:59 <dirk> lower prio
10:41:14 <tonyb> dirk: Or do you think you can convince number80 or tobctl to help ?
10:41:19 <tonyb> dirk: Sure.
10:41:57 <tonyb> dirk: if notthing else when we hit openstack/requirements in the constartints etherpad we can look at it then
10:42:41 <tonyb> dirk: You also suggested we add openstack-requirements to global-requirements ... is that still somethign you think we shoudl do?
10:43:38 <prometheanfire> sounds like a good idea to me (adding us to gr), wonder who our downstream would be for that
10:49:13 <dirk> tonyb: yeah, I still thought its logical, but you -1#ed
10:49:16 <dirk> I forgot the reason
10:49:27 <tonyb> prometheanfire: but g-r is about co-installability and no project shoudl depend on openstack-requirements that way
10:49:38 <prometheanfire> ya
10:50:01 <prometheanfire> like I said, wonder what our downstream would be for that (to require us being added to gr)
10:50:31 <dirk> tonyb: for me the reason was to control what version of openstack-requirements ends up in uc, but you said we can't restrict that anyway due to bootstrap issues
10:50:41 <dirk> tonyb: so for me it is also okay to just abandon that review
10:51:10 <dirk> tonyb: I don't see a major point in adding it in g-r
10:52:38 <tonyb> dirk: Are we seeing it in u-c?
10:53:04 <dirk> tonyb: no
10:53:14 <tonyb> dirk: phew!
10:53:15 <dirk> tonyb: its not in there, and as you explained it shouldn't be in there
10:54:06 <tonyb> dirk: okay
10:54:49 <tonyb> Changing tac befoer we close.  It seems that we need to alter our tox_install.sh in line with https://review.openstack.org/410018
10:55:25 <tonyb> I'll do that tomorrow and as long as noone minds I'll update all the open reviews adding tox_install.sh
10:55:42 <tonyb> and hope that we don't get more -1's
10:55:48 <prometheanfire> :)
10:56:20 <tonyb> so with that in mind please keep your open updates listed in the etherpad
10:57:31 <tonyb> Anything else?
10:58:17 <tonyb> Thanks everyone
10:58:21 <tonyb> #endmeeting