12:01:37 <tonyb> #startmeeting requirements
12:01:38 <openstack> Meeting started Wed Sep 28 12:01:37 2016 UTC and is due to finish in 60 minutes.  The chair is tonyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:01:41 <openstack> The meeting name has been set to 'requirements'
12:01:46 <tonyb> #topic rollcall
12:03:33 <toabctl> hi
12:03:43 <tonyb> toabctl: howdy.
12:04:16 <number80> o/
12:04:33 <tonyb> number80: \o
12:05:27 <tonyb> So lets get started ....
12:05:39 <tonyb> #topic Any controversies in the Queue?
12:06:25 <tonyb> https://review.openstack.org/374302 is up there
12:06:36 <tonyb> y'all have any thoughts on that one?
12:06:53 <tonyb> 'Add pykube to global-requirements'
12:08:02 <toabctl> hm. is pykube using k8sclient internally?
12:08:13 <tonyb> toabctl: no
12:08:37 <toabctl> from the description it sounds like k8sclient is autogenerated and for that reason difficult to extend.
12:08:43 <tonyb> toabctl: pykube is an external librarry that does pretty much the same thing only from some POVs better
12:09:00 <toabctl> toI'm reading now your comments.
12:09:02 <number80> well, pykube is okay-ish
12:09:05 <toabctl> eh, tonyb ^^
12:09:18 <number80> considering k8sclient state ...
12:09:28 <toabctl> tonyb, I agree with your comments in the review.
12:10:13 <number80> *nods*
12:10:22 <number80> let's give them time to discuss first
12:10:24 <tonyb> I missed that k8sclient was totally autogenerated
12:11:35 <tonyb> anything else?
12:12:22 <tonyb> ok moving on ....
12:12:25 <tonyb> #topic Barcelona Design Summit
12:12:33 <tonyb> #link https://etherpad.openstack.org/p/requirements-ocata-summit_ideas
12:12:53 <tonyb> The etherpad need work (specifially I need to flesh out those ideas)
12:13:01 <tonyb> but feel free to add your own
12:13:50 <tonyb> #topic Tasks from Etherpad
12:14:01 <tonyb> #link https://etherpad.openstack.org/p/requirements-tasks
12:14:31 <tonyb> Just the same old same old. If you have time to hack on stuff thats the *long* list of things to do
12:15:00 <tonyb> post summit we'll have a priority list but we can work on stuff not on the priority list
12:15:35 <tonyb> I wanted to discuss the meeting time but with only 3 of us here that's probably best done on the list or on a doodle poll
12:15:45 <tonyb> #topic py27-with-upper-constraints
12:16:05 <tonyb> So that's a pretty important test that we got 90% working and then let it rot
12:16:38 <tonyb> it's failign with Permission denied, and when it did run it wasn't deterministic
12:17:02 <tonyb> Are either of you free enough to look into it and get it working?
12:17:20 <dirk> o/
12:17:32 <tonyb> (It would have caught a problem with the murano-pgk-check review if it had been working)
12:17:37 <tonyb> hey dirk
12:17:43 <dirk> sorry, I'm late
12:17:48 <tonyb> dirk: no problem
12:18:37 <tonyb> dirk: thoughts on py27-with-upper-constraints?
12:18:58 <dirk> ehm, no
12:19:13 <tonyb> dirk: Do you have anytime to work on it?
12:19:39 <dirk> I can work a bit on things but not in the next 2-3 weeks
12:19:54 <tonyb> dirk: that'd be a great one.
12:20:07 <dirk> primary thing I'm probably interested in is  the lower-constraints testing though :-)
12:20:23 <dirk> and building more tooling around the review process
12:20:24 <tonyb> it's an important part of our testing strategy that we're missing but at the same time assuming is working
12:20:33 <dirk> it still feels difficult to me to judge the impact of approving a change
12:21:09 <dirk> which is why I'm a bit hesitant on reviews, even though it greatly aligns with my day-to-day work with keeping packaged openstack running
12:21:28 <tonyb> dirk: the lower-constraints is a good one buta lot of the design discussion around the goal will be done in Barcelona
12:21:49 <dirk> tonyb: I probably forgot the context of the py27-with-upper-constraints, is that documented somewhere?
12:22:11 <tonyb> dirk: Not really.  just in tox and the code.
12:22:32 <tonyb> dirk: basically it installs everythign in u-c and then verifies there are no conflicts
12:22:45 <dirk> oh
12:22:47 <dirk> that one
12:22:58 <dirk> so the topic is that it doesn't apss and is not voting and we should do something about that?
12:23:00 <tonyb> dirk: but it's failing in the early setup with permission denied so its basically doing nothing
12:23:17 <tonyb> dirk: Yup.  exactly that.
12:23:30 <tonyb> make it work, make it pass, make it vote
12:23:39 <dirk> yes, thats good
12:23:47 <dirk> ok, I'll put it on my todo
12:23:53 <tonyb> dirk: Great!
12:23:57 <dirk> but it will be slow for the next days for sure
12:24:16 <tonyb> dirk: No rush, it's never worked :(
12:24:38 * dirk checks if the error he has locally matches the jenkins error
12:24:49 <tonyb> but it *should* have caught a bug this week but I've trained myself to ignore it because it doesn't work and doesn't vote :(
12:25:26 <tonyb> okay ....
12:25:31 <dirk> hmm, the local error is a lot more meaningful than the server one
12:25:54 <tonyb> dirk: Yeah.  I can't get the Permission denied error locally
12:26:10 <tonyb> #action dirk to take a run at py27-with-upper-constraints
12:26:24 <tonyb> #topic Open Discussion
12:26:31 <tonyb> Anything?
12:28:43 <tonyb> going twice .....
12:30:53 <tonyb> Okay Thanks everyone
12:30:56 <tonyb> #endmeeting