12:00:10 <coolsvap> #startmeeting requirements
12:00:11 <openstack> Meeting started Wed Aug 31 12:00:10 2016 UTC and is due to finish in 60 minutes.  The chair is coolsvap. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:14 <openstack> The meeting name has been set to 'requirements'
12:00:27 <coolsvap> #topic Roll-call
12:00:37 <prometheanfire> o/
12:01:07 <dirk> o/
12:01:12 <coolsvap> prometheanfire dirk o/
12:04:14 <coolsvap> lets wait for a min before we start with meeting
12:05:25 <coolsvap> lets move
12:05:27 <coolsvap> #topic Announcements
12:05:37 <coolsvap> I have a session accepted in barcelona with dims
12:05:42 <coolsvap> #link  https://www.openstack.org/summit/barcelona-2016/summit-schedule/events/15330/openstack-requirements-what-we-are-doing-what-to-expect-and-whats-next
12:06:56 <coolsvap> #topic Any controversies in the Queue?
12:07:21 <prometheanfire> I don't think so
12:07:34 <coolsvap> #link https://review.openstack.org/#/c/358470/
12:07:37 <prometheanfire> the constant blocking of os-client-config sucks though
12:08:09 <coolsvap> #link https://review.openstack.org/#/c/333264/
12:08:15 <coolsvap> #link https://review.openstack.org/#/c/363150/
12:08:50 <prometheanfire> what's wrong with the gr-update?
12:09:25 <coolsvap> "Updated from generate-constraints" review needs some attention for libraries which are only updated with this review
12:09:51 <coolsvap> openstack libraries get updated with dims/dhellmann reviews
12:10:15 <coolsvap> but others are not
12:10:32 <prometheanfire> right
12:10:54 <prometheanfire> I think we should strip the openstack libs out from that and get it merged today
12:11:09 <coolsvap> prometheanfire: will you do that?
12:11:13 <prometheanfire> sure
12:11:45 <coolsvap> #action prometheanfire to update the g-r review to strip the openstack libs
12:11:50 <coolsvap> prometheanfire: thanks
12:11:53 <prometheanfire> that's just this review
12:12:10 <prometheanfire> not the actual job, but we should probably think about that
12:12:20 <coolsvap> prometheanfire: yes we might need some work on the job as well
12:13:02 <coolsvap> dhellmann: dims around?
12:13:15 <dims> pong coolsvap : what's up?
12:13:43 <coolsvap> dims: reg. review https://review.openstack.org/#/c/358470/
12:14:18 <coolsvap> we are thinking if we can strip openstack libs in the "Updated from generate-constraints" reviews
12:14:41 <coolsvap> dims: ^^
12:15:18 <coolsvap> prometheanfire: regarding the other two, I am not sure if we need a decision on the two new libraries before freeze
12:15:35 <dims> you mean the bot can propose 2 reviews? one with openstack libs and one without?
12:15:45 <dims> i'd run that by dhellmann for sure
12:16:20 <prometheanfire> dims: one the normal one by one updates, one outside deps
12:16:23 <coolsvap> currently openstack reviews are merged with your/dhellmann/ttx patches generated after release change merge
12:16:39 <coolsvap> openstack library updates i meant
12:17:01 <coolsvap> but other libraries are getting ignored in the process
12:17:04 <prometheanfire> I updated the gr review for today
12:17:26 <dims> coolsvap : not all openstack libs will get reviews filed by me/dhellmann/ttx
12:17:32 <dims> coolsvap : example python-k8sclient
12:18:09 <prometheanfire> oh, should I add that back in?
12:18:17 <coolsvap> dims: yeah thats another case
12:18:39 <prometheanfire> smaugeclient?
12:18:47 <dims> i'd rather have the bot differentiate into 2 buckets one from repositories owned by openstack and one outside
12:18:59 <dims> but remember it will make it harder to test
12:19:10 <dims> various combinations
12:19:19 <dims> so not sure what problem you are trying to solve here
12:19:22 <coolsvap> my initial thought process was to merge "Updated from generate-constraints" reviews but we decided to merge individual reviews
12:19:34 <coolsvap> but currently we are merging individual reviews
12:19:50 <coolsvap> so the consolidated reviews are kinda ignored
12:20:06 <dims> which is fine, the bot does not get mad :)
12:20:12 <coolsvap> either because it always fails with jenkins
12:20:29 <coolsvap> but then we are losing on the updates for non-openstack libs
12:20:42 * dhellmann arrives late
12:21:03 <dims> coolsvap : so then the bot logging 2 reviews is a better idea i think
12:21:09 <coolsvap> dims: yeah
12:21:33 <prometheanfire> well, added smaug/k8s
12:21:41 <prometheanfire> anyway, updated that review
12:21:44 <dhellmann> oh, we shouldn't be ignoring the bot updates
12:22:00 <coolsvap> dhellmann: yeah
12:22:01 <dims> dhellmann : ++ :)
12:22:21 <dhellmann> it will be pretty complex to have the bot submit 2 reviews, I think. unless we build the changes in one repo, then figure out which lines to add to which patch?
12:22:23 <prometheanfire> I wasn't ignoring it, I tended to work on client updates first to shrink down be bot update, then try to get that merged once a week (on the weekend typically)
12:22:37 <dhellmann> the idea is that all of the changes the bot proposes work together, so as soon as we start splitting them...
12:22:52 <dhellmann> it might be safer to rebase the bot patch by hand to let it merge safely, and then approve it
12:23:18 <prometheanfire> dhellmann: the problem is that the bot submits so many changes at once that it almost always fails
12:23:44 <prometheanfire> that's what I've been doing (by hand edits to prune down the changeset)
12:23:47 <dhellmann> ah
12:23:55 <coolsvap> prometheanfire: yeah but its kinda ignored most of the times
12:24:00 <dhellmann> well, maybe having it ignore our libs entirely would make it better?
12:24:03 <coolsvap> afaics
12:24:05 <prometheanfire> coolsvap: not by me :P
12:24:15 <dhellmann> though that might just lead to more failures
12:24:26 <prometheanfire> dhellmann: that's my early morning guess (before coffee)
12:25:00 <dhellmann> yeah
12:25:40 <coolsvap> lets monitor this for couple of weeks before making a decision
12:26:05 <coolsvap> if its feasible to make it work by hand everytime
12:26:08 <prometheanfire> agreed
12:26:17 <prometheanfire> I just wanted to have people start thinking about it
12:26:26 * coolsvap too
12:26:43 <dirk> can we just merge reviews that ignore the thigns that cause failures?
12:26:46 <prometheanfire> #note think about removing openstacklibs from gr updates (those that are already submitted seperately)
12:27:03 <dirk> e.g. if externallibfoo-newrelease causes the bot to fail, letst just exclude that one to keep the proposal bot things mergeable
12:27:22 <dirk> we just need to keep the backlog somewhere that investigates and fixes those issues as they happen
12:27:26 <prometheanfire> dirk: generally yes, last week was bad because there were a couple of updates that caused breakage
12:27:31 <prometheanfire> so it was multistep
12:27:48 <dhellmann> yeah, figuring out which library is bad is non-trivial
12:28:22 <coolsvap> lets move on
12:28:32 <coolsvap> #topic Requirements freeze R-5 (Aug 29 - Sept 02)
12:28:32 <prometheanfire> agreed
12:28:46 <coolsvap> #link https://releases.openstack.org/newton/schedule.html
12:29:00 <coolsvap> tonyb sent the announcement on mailing list
12:29:06 <coolsvap> #link http://lists.openstack.org/pipermail/openstack-dev/2016-August/102581.html
12:30:15 <dirk> I have a question regarding that.. is that only about g-r changes (new additions, new base versions) or also about uc changes?
12:31:14 <coolsvap> I think for both, dims dhellmann ^^
12:31:17 <prometheanfire> both
12:31:20 <prometheanfire> afaik
12:32:04 * dims defers to dhellmann
12:32:18 <dirk> so that means we should get an propsosal bot change merged pretty soon
12:32:21 <dhellmann> yes, completely frozen except in the case of a bug in one of our libs
12:32:25 <dirk> proposal..
12:32:59 <coolsvap> dirk: yeah thx dhellmann for the confirmation
12:33:13 <coolsvap> lets monitor the change proposed by prometheanfire
12:34:13 <dhellmann> coolsvap, dirk : I found it very helpful to create a process document for the release team in openstack/releases/PROCESS.rst. we could add details to that to make it clear about what is frozen when (if what I have there already isn't clear)
12:35:13 <coolsvap> dhellmann: ack
12:35:40 <prometheanfire> #link https://github.com/openstack/releases/blob/master/PROCESS.rst
12:35:40 <coolsvap> I think we have that down the agenda
12:35:49 <coolsvap> #topic Coordinating with the release team
12:36:14 <coolsvap> freezing requirements - http://git.openstack.org/cgit/openstack/releases/tree/PROCESS.rst#n107
12:36:35 <coolsvap> stable branch for openstack/requirements - http://git.openstack.org/cgit/openstack/releases/tree/PROCESS.rst#n138
12:36:40 <dirk> dhellmann: thanks for the pointer, I didn't see that yet
12:36:51 <dhellmann> I think I saw in the requirements channel that tonyb said he would apply the -2 to all pending patches on his Thursday
12:37:11 <dhellmann> or was it friday?
12:37:14 * dhellmann looks back
12:37:20 <coolsvap> dhellmann: Friday
12:37:24 <dhellmann> yeah, friday
12:37:43 <dhellmann> which I think is late our thursday? how do timezones work again?
12:37:51 <dhellmann> anyway, I think that's good
12:38:07 <coolsvap> yes its late thursday your time morning for tonyb
12:38:14 <prometheanfire> he said his thursday, our friday
12:38:29 <dhellmann> if we end up needing to land one of them that his -2 and he's away for the weekend we can start a new patch for the udpate
12:38:37 <prometheanfire> I may have that backwards
12:38:44 <dhellmann> it's unlikely, but we never know so it's good to have a plan
12:39:04 <prometheanfire> dhellmann: I'll keep that in mind
12:39:06 <dhellmann> prometheanfire : I checked the scrollback and he said friday
12:39:10 <dhellmann> his friday
12:39:23 <dhellmann> and since he lives in the future, that's our thursday
12:39:35 <prometheanfire> ah, right
12:40:04 * dhellmann hasn't had enough caffeine to do date math
12:40:33 <coolsvap> okay lets convey this to tonyb if he's online tomorrow
12:40:49 <coolsvap> #topic Barcelona Design Summit
12:41:10 <coolsvap> tonyb has requested a (fishbowl) session for Barcelona
12:41:14 <prometheanfire> not going :(
12:41:37 <coolsvap> maybe we can discuss the topics in some next meetings
12:42:05 <coolsvap> we have a requirements session accepted in main track (not sure if everyone saw the announcements)
12:42:21 <dirk> yep, saw that, good stuff
12:42:38 <prometheanfire> yarp
12:42:52 <coolsvap> lets move on
12:42:54 <coolsvap> #topic Mascot
12:43:12 <coolsvap> The only mascot idea that had multiple votes was waterfall so tonyb asked Heidi to select that one
12:43:40 * coolsvap has no idea what was waterfall
12:44:19 <dirk> I think its a good choice
12:44:22 <dhellmann> I liked that one, it made me think "upstream"
12:45:16 <coolsvap> cool
12:45:31 <prometheanfire> I think I proposed that one, it's our devel methodology right?
12:45:56 <prometheanfire> it fits for other reasons though
12:45:57 <dhellmann> haha
12:46:51 <coolsvap> #topic Tasks from Etherpad
12:46:58 <dhellmann> I have to step away. Thanks everyone, and congratulations on becoming a big tent team!
12:47:11 <coolsvap> thanks dhellmann
12:47:18 <coolsvap> #link https://etherpad.openstack.org/p/requirements-tasks
12:47:29 <coolsvap> any updates on this?
12:47:32 <prometheanfire> I've been keeping up on the other projects and failing requirements updates
12:47:34 * coolsvap has none
12:47:53 <prometheanfire> but no progress this week, one is stuck in legal, the other in review hell
12:48:10 <prometheanfire> that's all I have
12:48:39 <coolsvap> thanks prometheanfire for the update
12:48:50 <coolsvap> which one is stuck in review?
12:49:09 <prometheanfire> https://review.openstack.org/#/c/352501/
12:49:13 <prometheanfire> #link https://review.openstack.org/#/c/352501/
12:49:31 <prometheanfire> vitrage is the other one stuck in legal
12:49:46 <prometheanfire> it's the three under #20 in the list right now
12:50:07 <coolsvap> ah okay
12:51:36 * coolsvap thought something stuck in requirements queue
12:51:46 <coolsvap> moving on
12:51:50 <coolsvap> #topic Volunteer for next meeting
12:52:01 <coolsvap> I think we have volunteer for next two meetings
12:52:19 <coolsvap> Sep 07 - tonyb
12:52:19 <coolsvap> Sep 14 - prometheanfire
12:52:26 <coolsvap> anyone up for sep 21?
12:53:29 <coolsvap> alright lets see in next meeting again
12:53:47 <dirk> I might be able to do sep 21, not sure yet
12:53:52 <dirk> way too far in the future :)
12:54:08 <coolsvap> dirk: alright we can always check in next meetings
12:54:24 <coolsvap> skipping topic optional-requirements since did not see number80
12:54:36 <coolsvap> #topic Open Discussion
12:54:57 <coolsvap> anyone has anything to bring up in open discussion?
12:55:21 <prometheanfire> non
12:56:04 * dirk is good
12:56:26 <coolsvap> okay back to #openstack-requirements. Thanks folks
12:56:31 <coolsvap> #endmeeting