11:59:41 <dirk> #startmeeting requirements
11:59:42 <openstack> Meeting started Wed Jul 27 11:59:41 2016 UTC and is due to finish in 60 minutes.  The chair is dirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
11:59:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
11:59:45 <openstack> The meeting name has been set to 'requirements'
11:59:55 <dirk> #topic rollcall
12:00:02 <coolsvap> o/
12:00:06 <tonyb> o/
12:00:47 <prometheanfire> o/
12:01:12 <dirk> if anyone has agenda items to add, please add it to #link https://wiki.openstack.org/wiki/Meetings/Requirements#Weekly_Requirements_team_meeting
12:01:18 * tonyb has a hard stop in an hour because I have a bus to catch
12:01:39 <prometheanfire> tonyb: phone :P
12:01:59 <prometheanfire> we have https://etherpad.openstack.org/p/requirements-team-mascot as well
12:02:06 <prometheanfire> we need to decide that today
12:02:13 <tonyb> prometheanfire: If I need to I can switch to that using the hotel wifi now so there will be a blip
12:02:40 <prometheanfire> heh
12:02:46 <dirk> prometheanfire: ok, good point
12:02:57 <dirk> #topic agenda
12:03:01 <dirk> anything else for the agenda?
12:03:03 <prometheanfire> dirk: it is in the open discussion section
12:03:14 <dirk> ok
12:03:16 <number80> o/
12:03:31 <dirk> #topic Any controversies in the Queue?
12:04:08 <tonyb> Just the oslo.context stuff
12:04:09 <number80> except continuing oslo.context, no
12:04:15 <coolsvap> i think oslo.context
12:04:26 <prometheanfire> I'd like to get https://review.openstack.org/333650 in
12:04:36 <prometheanfire> Check for missing run-time requirements
12:04:56 <dirk> prometheanfire: I like it
12:05:09 <prometheanfire> but ya, oslo.context is ever the bear
12:05:30 <number80> prometheanfire: yep, it's ripe for merging
12:05:35 <dirk> I guess we need to followup with a infra change creating the job ?
12:05:38 <tonyb> It will be an issue until we get the "key people" in a room at the summit
12:05:59 <tonyb> dirk: for the pip thing? Yeah it's pretty simple
12:06:03 <prometheanfire> tonyb: cross repo stuff will help
12:06:18 <dirk> tonyb: yep; I was talking about the pip thing. sorry for causing confusion
12:06:53 <tonyb> prometheanfire: to an extent that is true but there is a base disagreement as to what the API is and therefore what users can depend on
12:06:55 <prometheanfire> ya, the pip/setuptools/etc stuff will need outside talking
12:07:13 <dirk> so what can we do with oslo.context as a next action?
12:07:21 <prometheanfire> tonyb: we talking about pip or cross repo?
12:07:22 <tonyb> pip/setuptools/etc ? what's that?
12:07:44 <tonyb> prometheanfire: I *thought* we were talkign about oslo.context
12:07:52 <prometheanfire> adding pip/setuptools/etc to requirements
12:07:59 <prometheanfire> ok, holding off on that for now
12:08:00 <tonyb> we can't do that
12:08:12 <prometheanfire> right, thought we discussed that already
12:08:44 <coolsvap> prometheanfire: yes we need to wait for the PoC
12:08:59 <dirk> #topic controversities in the queue: oslo.context
12:09:20 <tonyb> we can't bump oslo.context yet
12:09:29 <tonyb> we had a plan we need to get back to that
12:09:43 <dirk> is the plan documented somwhere?
12:10:01 <tonyb> that will unblock people and then we can resolve it with a ml thread or a design summit session
12:10:22 <tonyb> dirk: in the IRC logs
12:10:41 <prometheanfire> we should send that to the ML then
12:10:42 <tonyb> I have a draft email ready to send but I got distracted with testing stuff
12:10:56 <tonyb> prometheanfire: sure I messed up
12:11:13 <prometheanfire> tonyb: you are busy :P
12:11:30 <dirk> tonyb: can you paste the sample email into some etherpad/pastebin if you don't have time to finish it?
12:11:38 <dirk> maybe we can continue from there
12:11:40 <coolsvap> tonyb: or can you send the mail
12:11:50 <tonyb> coolsvap: sure
12:12:05 <tonyb> If I'd done that 2 weeks ago we wouldn't be here
12:12:06 <prometheanfire> anyway, guess that's the next step for oslo.context
12:12:07 <coolsvap> we can have more discussion over mailing list thread
12:12:26 <coolsvap> i got couple of PM request for oslo.context bump
12:12:28 <dirk> ok so tonyb has action to send email?
12:12:29 <tonyb> In short we can't land oslo.context changes right now
12:12:37 <tonyb> dirk: ACK
12:12:41 <coolsvap> tonyb: ack!
12:12:56 <dirk> #action tonyb send mail to devel list with the action plan for updating oslo.context
12:12:56 <prometheanfire> coolsvap: ack
12:13:20 <dirk> what is the next controversity?
12:13:33 <prometheanfire> that's it for me
12:13:53 <coolsvap> i don think anything else is controversial
12:14:06 <dirk> #topic Review Queue cleanup
12:14:20 <tonyb> elasticsearch requires care but it isn't a big problem
12:14:38 <prometheanfire> I think we've made good progress there (queue cleanup)
12:14:48 <dirk> yep, it looks great
12:14:56 <dirk> I can't even keep up with reviews, things are moving quick
12:15:00 <prometheanfire> we have a few DNM patches and of course oslo.context
12:15:26 <tonyb> and a few otehr things in merge conflict
12:15:30 <dirk> #topic Additional Gating - Updates - prometheanfire coolsvap
12:15:32 <prometheanfire> ya
12:15:39 <prometheanfire> sure
12:15:50 <tonyb> but the master queue is ~12 which is pretty good
12:16:12 <tonyb> Gateing
12:16:15 <prometheanfire> In talking to tony about cross project testing his way is better
12:16:20 <tonyb> I discussed that with infra
12:16:35 <prometheanfire> while mine can select 1 test at a time from a project it's still slightly hackish in doing so
12:16:45 <tonyb> the plan is the add/modify tools in project-config to enable this
12:16:59 <tonyb> we get a lot for free by doign that
12:17:49 <tonyb> the main cost is a change is that to change it we need to go via project-config but I see that as an advantage
12:17:57 <coolsvap> tonyb: that is good news
12:17:58 <dirk> +1
12:18:22 <coolsvap> I liked the change prometheanfire made
12:18:40 <tonyb> I have jenkins generating the new jobs but I have a syntax error somewhere
12:18:50 <prometheanfire> oh, nice
12:19:20 <coolsvap> tonyb: cool
12:19:27 <dirk> tonyb: any reviews/pointers you can share?
12:19:37 <tonyb> coolsvap: it's nice, it just goes in a direction the community rejected befoer Austin
12:20:05 <prometheanfire> needs a new template is the big thing iirc
12:20:10 <tonyb> dirk: not yet still testing locally, but it's similar to https://review.openstack.org/#/c/308739/1
12:20:16 <tonyb> just more typing
12:20:51 <dirk> #link https://review.openstack.org/#/c/308739/1
12:20:52 <dirk> thx
12:21:29 <tonyb> I'll probably re-use that review as the intent is the same and Clark is helping with "the plan"
12:22:42 <prometheanfire> next?
12:22:45 <dirk> anyone who can help with that or are you covered?
12:23:14 <tonyb> dirk: If I can;t get it done today I'll hand it off
12:23:26 <dirk> ok, great. thanks :)
12:23:37 <dirk> #topic u-c for setuptools and sometimes wheel
12:23:39 <prometheanfire> awesome
12:23:42 <dirk> odyssey4me: ..
12:23:46 <coolsvap> tonyb: we can work on this as a team
12:24:25 <prometheanfire> dirk: he might be a bit, I think he is having another meeting now
12:24:38 <coolsvap> dirk: not sure if odyssey4me is around, we can wait till he has the PoC ready
12:24:40 <dirk> ok, postpone this to later
12:24:49 <tonyb> Befoer he gets here
12:24:57 <dirk> :)
12:24:58 <tonyb> what are we trying to do *exactly*
12:24:59 <prometheanfire> he's in london, so is about
12:25:25 <prometheanfire> tonyb: OSA wants to lock down EVERYTHING
12:25:30 <prometheanfire> more or less, that's the use case
12:25:52 <prometheanfire> mainly to keep broken pips away, etc
12:26:01 <prometheanfire> setuptools have had problems too
12:26:01 * odyssey4me is lurking, but in another meeting
12:26:01 <tonyb> We can't add pip because itll break/be pointless setuptools is in there
12:26:24 <prometheanfire> tonyb: yep, it's a harder problem
12:26:57 <coolsvap> tonyb: so we needed more input in the last meeting from people who already tried it
12:27:07 <coolsvap> do you know some background around this?
12:27:18 <odyssey4me> I'm happy to go with the guidance of what everyone thinks is best - we have our own tooling to lock pip, setuptools and wheel down already... I just thought it may be of value to the broader community.
12:27:28 <tonyb> coolsvap: less than some but I have a little
12:27:41 <odyssey4me> happy to chat about this a bit later, after this meeting
12:27:48 <tonyb> wheel is strange I need to look into that
12:28:02 <coolsvap> odyssey4me: sure
12:28:11 <prometheanfire> odyssey4me: using virtualenvs to help allows you to do it, not sure it's as easy system wide
12:28:24 <dirk> good for next topic?
12:28:29 <prometheanfire> +1
12:28:33 <coolsvap> odyssey4me: welcome to add a WIP change for review so that we can talk/experiment
12:28:43 <coolsvap> dirk: yes
12:28:44 <dirk> #topic Tasks from Etherpad - PTL
12:29:11 <dirk> already a topic?
12:29:26 <prometheanfire> we should open nominations for a week and then have a week of voting imo
12:29:40 <prometheanfire> but that's all I have about that
12:30:06 <dirk> ptl self-nomination is Sep 12th onwards as far as I can see
12:30:12 <tonyb> Do we *need* an election
12:30:17 <dirk> do we want to setup a PTL for newton?
12:30:25 <tonyb> do we have multiple people that are commited to running?
12:30:38 <prometheanfire> dirk: that might be better
12:30:57 <prometheanfire> tonyb: I'd volunteer, I think you'd be good too :P
12:31:00 <tonyb> We need one in the interim becuase of the way the elections are run
12:31:49 <tonyb> prometheanfire: so if we open the nominations you *will* run or you *might* run?
12:31:57 <prometheanfire> will
12:32:34 <dirk> ok, so we should start a week of self nominations?
12:32:39 <dirk> like, e.g. next week? :)
12:32:44 <tonyb> okay so that's me and you so we will need to do the nominatons unless we agree as a core group on a candidate
12:32:53 <prometheanfire> it's not really an issue, but a lot of people can vote, given how requirements are done
12:33:07 <prometheanfire> tonyb: ya, that'd work
12:33:13 <dirk> tonyb: do we need to vote for the interim PTL?
12:33:32 <dirk> I remember that you can just propose one or a small group for bootstrap purposes
12:33:41 <tonyb> dirk: I'm pretty suer that the first PTL can be appointed
12:34:03 <tonyb> and then we'd run an offical process with the other PTLs
12:34:12 <dirk> yep, so if we can agree on one or two PTL interims until we have the Ocata cycle I think we can just ask the TC to appoint those one/two people
12:34:22 <coolsvap> I think we can appoint interim PTL
12:34:24 <tonyb> dirk: one PTL
12:34:39 <tonyb> a project can only have one name in the yaml ;/
12:34:43 <coolsvap> than having two elections in one cycle
12:35:22 <dirk> tonyb: I created a big tent projects iwth two PTLs. while it wasn't liked it was accepted for (half a ) cycle
12:35:34 <dirk> anyway, if we can agree on one person then thats fine
12:35:45 * dirk is not going to run and certainly fine with the options so far :)
12:36:07 <dirk> ok, now how do we move forward?
12:36:12 <prometheanfire> etherpad?
12:36:26 <tonyb> do it here
12:36:27 <dirk> candidates should just add themselves to section 3.2.1 ?
12:36:31 <tonyb> it's more transparent
12:36:32 <dirk> or expect an email on -dev mailing list?
12:37:00 <tonyb> I think we pick one here, that person uploads a review to governance and email os-dev
12:37:13 <prometheanfire> should we discuss pros/cons for each nominee then vote?
12:38:21 <tonyb> prometheanfire: sure, we can make statements that'll give dirk a change to read the meetbot docs on running a vote
12:38:31 <prometheanfire> heh
12:38:35 <dirk> #link https://etherpad.openstack.org/p/requirements-ptl-newton
12:38:45 <dirk> lets revisit this next week
12:38:51 <dirk> people who want to candidate update the etherpad
12:39:41 <prometheanfire> dirk: then I'd have to run the vote :P (and figure out how) lol
12:39:48 <dirk> does anyone volunteer to drop a mail about this to -dev ?
12:39:58 <prometheanfire> I can do that
12:40:10 <dirk> #action prometheanfire announce etherpad for interim PTL nominations
12:41:27 <dirk> #topic Tasks from Etherpad
12:41:29 <prometheanfire> next?
12:41:33 <dirk> anything else we need to discuss?
12:41:43 <dirk> 1.3 looks done, do we want to cross it off the list?
12:42:46 <dirk> 3.13 is now also done, right?
12:43:04 <prometheanfire> I'm not sure 1.3 can be considered done
12:43:14 <prometheanfire> it's non-voting
12:43:28 <prometheanfire> and not passing atm
12:43:40 <dirk> ah, thanks for the explanation
12:43:46 <dirk> lets add that as TODO then :)
12:43:57 <prometheanfire> yep
12:44:45 <dirk> we should be moving 3.1, 3.3, 3.4 to DONE
12:44:55 <prometheanfire> ya, so 3.13 is waiting on 1.3
12:44:58 <dirk> IMHO 3.6 as well
12:45:04 <tonyb> 2.x looks like it can go
12:45:40 <tonyb> 3.3 can go
12:45:53 <dirk> arghhh. deleting stuff changed all numbering
12:45:57 <dirk> uh oh.
12:46:20 <prometheanfire> +1 to 3.1 3.3 3.6
12:46:45 <coolsvap> can we just strike through the DONE items?
12:46:47 <prometheanfire> ctrl+z
12:47:06 <dirk> yeah, striking is better. sorry. I'll fix this up again after the meeting
12:47:07 <prometheanfire> 3.3.1 isn't done
12:47:18 <prometheanfire> (was 3.4.1)
12:48:09 <dirk> prometheanfire: its in the context of "goals for the requirements group", and that group was established so its done imho
12:48:53 <coolsvap> 3.5 is also done by number80
12:48:56 <tonyb> Can I suggest we move things around so the TODO items are in an independant section and start at 1.0 rather than the nested structure we have now
12:49:00 <prometheanfire> ya, just crossed it out
12:49:15 <prometheanfire> tonyb: works for me
12:49:35 <tonyb> okay lest do that after the meeting
12:49:41 <prometheanfire> section 3.3 should be moved under 3.1
12:49:43 <dirk> tonyb: yep, just moving stuff during the meeting jus tdestroys the workflow for the disucssion
12:49:48 <tonyb> strikethrough is good for now
12:49:57 <prometheanfire> ya, we can contune the etherpad cleanup to out of meeting
12:50:13 <prometheanfire> next topic?
12:50:17 <dirk> anything else we can strike through now or can we go on?
12:50:33 <dirk> #topic optional-requirement
12:50:36 <dirk> number80: ^^
12:50:45 <dirk> #link https://etherpad.openstack.org/p/optional-requirements-draft
12:51:56 <coolsvap> i think the draft looks good, we need review related to it
12:51:56 <prometheanfire> next? we still have to discuss mascots
12:51:59 <dirk> number80: wanna give a status update or a comment?
12:52:00 <coolsvap> and a mailing list thread
12:52:10 <coolsvap> that was the action item from last meeting
12:52:15 <dirk> ok, thanks
12:52:25 <dirk> #topic Volunteer for next 2 meetings
12:52:37 <prometheanfire> I have next one
12:52:39 <dirk> anyone for August 1th?
12:52:43 <dirk> August 10th?
12:53:00 <dirk> if not I can do it again
12:53:05 <tonyb> number80: we shoudl talk about the optional stuff as I'm very confused
12:53:19 <coolsvap> I can do 10th I might be PTO on 17th
12:53:31 <dirk> #agreed coolsvap  will run August 10th
12:53:41 <prometheanfire> ok
12:53:43 <dirk> #topic Open Discussion - Project Mascot?
12:53:51 <dirk> #link https://etherpad.openstack.org/p/requirements-team-mascot
12:53:54 <prometheanfire> https://etherpad.openstack.org/p/requirements-team-mascot
12:54:10 <number80> tonyb: yes
12:54:10 <dirk> we need to be quick as deadline is today
12:54:37 <number80> (sorry got disconnected from ssh)
12:54:49 <tonyb> I think we order the list of optionsa and make it the foundations problem
12:54:49 <coolsvap> I think beaver is good
12:54:52 <number80> well, we have a clear winner according votes
12:55:01 <tonyb> it gives them the ability to self manage
12:55:06 <prometheanfire> we need to give them a few
12:55:18 <prometheanfire> tonyb: +1
12:55:24 <tonyb> that way if 2 teams pick beaver then they can just fix it
12:56:17 <tonyb> Our preferene is beaver and here are 3 others
12:56:19 * dirk fails to understand why beavers manage requirements
12:56:20 <prometheanfire> so, anyone else have ideas to add?
12:56:28 <number80> *nods*
12:56:59 <prometheanfire> spiderweb was another option
12:57:12 <prometheanfire> as it demonstrates the linking going on
12:57:23 <tonyb> Yeah a web is good
12:57:56 <tonyb> T-3mins
12:58:10 <prometheanfire> added it
12:58:13 <prometheanfire> vote kthnx
12:58:22 <dirk> ok, so next step is? who is mailing Joy?
12:58:33 <tonyb> prometheanfire: ;P
12:58:39 <coolsvap> prometheanfire:
12:58:51 <prometheanfire> lol
12:58:54 <dirk> #action prometheanfire  send voting results today to Marketing team
12:58:58 <dirk> ;-)
12:59:09 <prometheanfire> that's fine, since it's in just a few minutes
12:59:15 <dirk> #topic Open Discussion
12:59:28 <coolsvap> to the channel I think
12:59:38 <prometheanfire> tonyb: take your bus :P
12:59:43 <coolsvap> less than 60 seconds
12:59:46 <prometheanfire> yep
12:59:47 <dirk> yep, lets end this here
12:59:54 <dirk> hanks, and sorry for running this a bit slow
12:59:56 <dirk> #endmeeting