12:00:34 <coreycb> #startmeeting requirements
12:00:35 <openstack> Meeting started Wed Jul 20 12:00:34 2016 UTC and is due to finish in 60 minutes.  The chair is coreycb. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:38 <openstack> The meeting name has been set to 'requirements'
12:00:41 <coreycb> #topic rollcall
12:00:46 <coreycb> o/
12:00:50 <number80> o/
12:00:58 <dirk> o/
12:00:59 <coolsvap> o/
12:01:13 <toabctl> hi
12:01:42 <coreycb> hey everyone
12:01:58 <prometheanfire> o/
12:02:01 <coreycb> #topic Any controversies in the Queue?
12:02:25 <coreycb> the queue seems to be fairly uncontroversial atm
12:02:35 <coreycb> anyone have anything to bring up ?
12:02:42 <prometheanfire> oslo-context still :P
12:02:46 <coolsvap> oslo.context
12:03:08 <coolsvap> we need to follow up with jamie with the proposed pathc
12:03:39 <coolsvap> there are two different patches proposed and different nova patch in between
12:04:55 <coolsvap> a patch from tonyb https://review.openstack.org/342603 and a patch from jamie https://review.openstack.org/344509
12:05:45 <coolsvap> based on nova patch merge we can decide
12:06:07 <coreycb> #action follow up with jamie on oslo.context patches
12:06:21 <coolsvap> yup
12:06:23 <dirk> who takes the action?
12:06:31 * dirk doesn't know mr. follow
12:07:06 <coolsvap> i will do
12:07:21 * coolsvap is not mr. follow though
12:07:25 <coreycb> thanks coolsvap
12:07:30 <coreycb> #action coolsvap to follow up with jamie on oslo.context patches
12:08:01 <coreycb> anything else for controversies?
12:08:21 <coreycb> it looks like we have a separate optional-requirements agenda item
12:08:28 <coolsvap> nothing else from my side
12:08:30 <coreycb> we'll get to that in a bit
12:08:52 <number80> not really, unless we have news from monasca
12:09:12 <number80> I haven't seen any discussions on the list about their previous patchsets
12:09:28 <odyssey4me> o/
12:10:18 <coolsvap> coreycb: can we talk about the topic u-c for setuptools and sometimes wheel proposed by odyssey4me
12:10:38 <coreycb> sounds good
12:10:44 <number80> *nods*
12:11:11 <prometheanfire> odyssey4me: go on :P
12:11:24 <odyssey4me> oh, you're ready now?
12:11:32 <odyssey4me> I thought other things were in discussion?
12:11:34 <coolsvap> odyssey4me: it was the first topic
12:11:41 <odyssey4me> ah ok, apologies
12:12:18 <coolsvap> #topic u-c for setuptools and sometimes wheel - odyssey4me
12:12:24 <odyssey4me> right ok - so one of the things we've found to be important in ensuring repeatable build results is to ensure that the same version of pip, setuptools and wheel are used to build and install python wheels
12:12:47 <coreycb> coolsvap, ah, sorry I missed that agenda item
12:12:58 <odyssey4me> we make use of the u-c and g-r files to provide the range for our wheel builds
12:13:07 <odyssey4me> by 'we' I mean the OpenStack-Ansible project
12:13:15 <number80> ack
12:13:26 <odyssey4me> this is an important part of our build process for building OpenStack from source
12:13:59 <odyssey4me> I am also aware of some package maintainers who make use of g-r and u-c to determine the appropriate range of python packages when building their packages.
12:14:18 <odyssey4me> at the moment, pip, setuptools and wheel are not in g-r and therefore not in u-c
12:14:52 <odyssey4me> well, I think they actually are - but a pip freeze doesn't output any of them except maybe wheel
12:15:43 <coolsvap> odyssey4me: based on the discussion we had at channel, it was previously attempted but did not work
12:15:44 <odyssey4me> I'd like to propose some changes to the tooling to ensure that these packages are in the u-c file so that we don't have to manage them ourselves seperately.
12:15:55 <odyssey4me> And hopefully other projects can choose to consume them as well.
12:16:00 <number80> odyssey4me: as a distro wrangler I don't mind having an upper bound if it's not too old versions
12:16:21 <coreycb> odyssey4me, I think it makes sense to add them, but I don't know the history of why they were removed
12:16:31 <number80> I'd rather keep compatibility with old versions as pip/wheel/setuptools don't change often in distro
12:16:35 <odyssey4me> number80 I expect that you would want the upper-bound to be the same upper-bound that was used to test OpenStack?
12:17:10 <number80> odyssey4me: works for me, but old versions will penalize some other distro (not my case though)
12:17:17 <number80> in u-c I mean
12:17:28 <number80> but having them is u-c is okay
12:17:34 <coolsvap> odyssey4me: I think a POC is very much what everyone would like to see
12:17:34 <dirk> its still good to document in u-c what has been used for testing
12:17:45 <number80> *nods*
12:18:04 <prometheanfire> for my distro we won't have issues keeping old/new around as long as no sec bugs exist
12:18:09 <odyssey4me> ok - I just wanted to give a heads up and make sure there was no violent opposal
12:18:48 <number80> odyssey4me: none, as long as we keep an honest range :)
12:18:53 <prometheanfire> odyssey4me: with it's history we just don't know if this will be a tarpit to get added :P
12:19:20 <coreycb> odyssey4me, thanks
12:19:25 <odyssey4me> so an option we could always consider is simply adding these special cases as a comment in U-C, rather than as an actual requirement
12:19:39 <odyssey4me> that would then allow downstream consumers of U-C to optionally consume them if desired
12:19:53 <odyssey4me> as long as the format is consistent, it's easy to consume
12:20:18 <prometheanfire> comment would mean no autoupdates, don't think that's a standard consumption method
12:21:28 <odyssey4me> yeah, I just thought it might be a way to appease the naysayers ;)
12:21:41 <odyssey4me> anyway, let me put a u-c patch up and let's see what happens :)
12:21:51 <coreycb> odyssey4me, +1
12:21:56 <coolsvap> odyssey4me: yes that would be first step +1
12:22:02 <prometheanfire> cool
12:22:11 <prometheanfire> I'd start with wheel before pip
12:22:12 <odyssey4me> I expect that it may be useful to have the nodepool images consume U-C to improve the stability of builds... but that's a patch for afterwards
12:22:51 <coreycb> ok I'm going to move on to the next topic
12:22:56 <odyssey4me> Part of the objective here is to try and avoid issues which we've all seen happen with pip, setuptools and wheel when they release versions which break things.
12:23:06 <odyssey4me> ok, thanks for the time and support
12:23:08 <prometheanfire> ok
12:23:23 <coreycb> thanks odyssey4me
12:23:30 <coolsvap> odyssey4me: thanks for bringing it up in meeting and looking forward to your patch
12:23:31 <coreycb> #topic Review Queue cleanup
12:23:48 <coreycb> #link https://review.openstack.org/338205
12:24:25 <prometheanfire> that shows as abandoned to me
12:24:27 <coreycb> this is from the agenda, do we want to discuss?
12:24:47 <coreycb> also from the agenda are:
12:24:47 <coolsvap> oh its abandoned after I added to agend
12:24:47 <coreycb> #link https://review.openstack.org/217824
12:24:48 <prometheanfire> not that one specifically I think
12:25:00 <coreycb> #link https://review.openstack.org/265226
12:25:47 <coolsvap> I wanted to highlight long term pending reviews
12:26:24 <prometheanfire> 824 just needs an rebase
12:26:25 <coreycb> those are long term alright :)
12:27:02 <prometheanfire> though we still are using posix_ipc, as long as the projects that show in in the codesearch don't use UC/GR then we can still remove
12:27:56 <coolsvap> prometheanfire: yes
12:28:04 <prometheanfire> asked for an update on 226 just now
12:28:13 <prometheanfire> the tempest-lib one
12:29:14 <coolsvap> prometheanfire: thanks
12:29:29 <coolsvap> coreycb: I think we can move to next topic nothing much to discuss here
12:29:40 <coreycb> #topic Additional Gating - Updates
12:30:19 <coreycb> coolsvap, are we looking for updates from someone in particular here?
12:30:45 <coolsvap> prometheanfire: ^^
12:31:17 <prometheanfire> no updates
12:31:21 <prometheanfire> next :P
12:31:37 <coreycb> :)
12:31:37 <coolsvap> also I wanted to add action item to discuss with harlowja
12:32:03 <coolsvap> my name was mentioned with oslo meeting after the oslo.context broke gate
12:32:22 <coreycb> coolsvap, go for it I think you can add an action item
12:32:55 <coolsvap> hehe
12:33:16 <coolsvap> #action coolsvap to discuss with harlowja regarding additional gating
12:33:33 <coolsvap> not sure if it will be added as action
12:34:07 <coolsvap> coreycb: lets move
12:34:13 <coreycb> #topic Tasks from Etherpad
12:34:21 <coreycb> #link https://etherpad.openstack.org/p/requirements-tasks
12:35:29 <coreycb> any updates?
12:35:41 <prometheanfire> we need to vote on ptl
12:35:43 <coolsvap> no particular updates from me
12:36:12 <coreycb> prometheanfire, can we do that in channel?
12:37:13 <prometheanfire> doesn't need to be formal here
12:37:18 <coolsvap> coreycb: we need to do it on mailing list as well
12:37:36 <coolsvap> if we dont have quorum
12:38:06 <coreycb> I could add it to next week's agenda
12:38:30 <prometheanfire> we could at least get nominees out the the way now (if we have time)
12:38:41 <coreycb> sounds good.  who wants this??
12:39:16 <prometheanfire> want is a 'strong' word :P
12:39:29 <coolsvap> :)
12:39:34 <coreycb> heh
12:39:44 <coreycb> coolsvap ?
12:39:45 <coolsvap> I am looking forward to it
12:40:02 <prometheanfire> but I'd nominate coolsvap at least :P
12:40:21 <coreycb> +1
12:40:25 <prometheanfire> was thinking tonyb as well, but he is already ptl of something (or two things I think)
12:41:52 <prometheanfire> if it's just coolsvap we can start the mailing list thing unless we want to wait til next week
12:42:27 <coreycb> prometheanfire, could do that or give it a week and see if anyone else is interested
12:43:00 <coolsvap> we cannot do it unless we know tonyb is present
12:43:01 <prometheanfire> I'm intrested, but not confident in being good at it
12:43:15 <prometheanfire> I can bug him tonight about it
12:43:34 <coreycb> ok
12:43:36 <coolsvap> prometheanfire: sounds good
12:44:07 <coreycb> #action coreycb to add agenda item for next week with ptl discussion
12:44:30 <coolsvap> we need time for optional-reqs
12:44:36 <coreycb> ok let's move on
12:44:38 <coolsvap> 16 mins remaining
12:44:43 <coreycb> #topic optional-requirements - number80
12:44:56 <number80> yeah
12:45:09 <number80> https://etherpad.openstack.org/p/optional-requirements-draft
12:45:09 <coolsvap> #link https://etherpad.openstack.org/p/optional-requirements-draft
12:45:46 <number80> actually meetbot implicitly do that if the first thing posted is an url :)
12:46:17 <number80> So I see that more people commented the draft
12:46:21 <coolsvap> number80: ah sorry we hit enter at the same time
12:46:31 <number80> np
12:46:36 <coolsvap> the draft looks good
12:46:52 <number80> yeah, so I'd like to figure the next step
12:47:19 <number80> submitting patchset to our README or add more people into the discussion (e.g openstack dev list)
12:47:26 <coreycb> number80, would optional-requirements also be in upper-constraints?
12:47:39 <number80> coreycb: ideally, yes
12:47:58 <prometheanfire> ya, a review would be the next step here
12:48:13 <number80> *nods*
12:48:25 <number80> #action number80 submit draft as review
12:48:31 <coreycb> thanks number80
12:48:34 <coolsvap> and mailing list discussion is also good idea
12:48:42 <number80> I'll do it too
12:48:47 <coolsvap> to get more views on it
12:48:54 <prometheanfire> once we have a draft to point them to imo
12:49:13 <number80> makes sense
12:49:29 <coreycb> anything else?
12:49:48 <coreycb> #topic Volunteer for next 2 meetings
12:49:54 <coreycb> dirk, you're up next week
12:49:58 <coolsvap> prometheanfire: yes mailing list discussion with both review and etherpad draft in place
12:50:19 <coreycb> any volunteers for Aug 3rd meeting?
12:50:40 <coolsvap> I am in if there's no one
12:51:02 <coreycb> coolsvap, ok, thanks
12:51:10 <coreycb> #topic Open Discussion
12:51:10 <prometheanfire> I can do it as well
12:51:20 <coreycb> prometheanfire, thanks
12:51:32 <coreycb> there's a note on the agenda about a Project Mascot
12:51:39 <coolsvap> prometheanfire: its yours
12:51:45 <coolsvap> I am not sure if we can do it
12:51:45 <prometheanfire> lol, ok
12:51:50 <prometheanfire> :D
12:51:51 <coolsvap> project mascot
12:52:05 <coreycb> any ideas for a mascot?
12:52:06 <prometheanfire> honeybadger :P
12:52:09 <coolsvap> just added as its an open discussion
12:52:10 <coreycb> lol
12:52:54 <prometheanfire> or an ant, some sort of basic worker is a good concept imo
12:52:54 <coreycb> honebadger it is :)
12:53:42 <coolsvap> ant would need a lot of zooming to be placed on a XXL tshirt
12:54:11 <prometheanfire> spider :D
12:54:39 <prometheanfire> tonyb would like this https://animalcorner.co.uk/wp-content/img/funnelweb.jpg
12:55:06 <prometheanfire> anyway, I guess it's something we can think of
12:55:12 <prometheanfire> iirc we have to decide quick though
12:55:12 <coolsvap> i think we are good here
12:55:18 <prometheanfire> yep
12:55:34 <coreycb> alright, needs more discussion
12:55:42 <coreycb> oh is there a deadline for this coming up?
12:55:44 <coolsvap> at the channel
12:55:46 <prometheanfire> I think
12:56:02 <coreycb> let's try to dig the date up, this is important!
12:56:19 <prometheanfire> 07:56 <      odyssey4me > prometheanfire can't recall - I think it has to be submitted by the start of next week or something
12:56:23 <prometheanfire> odyssey4me: thanks :D
12:57:09 <number80> beaver?
12:57:14 <number80> They build walls
12:57:26 <odyssey4me> #link http://lists.openstack.org/pipermail/openstack-dev/2016-July/099046.html
12:57:31 <prometheanfire> not sure that'd work
12:57:33 <odyssey4me> #link http://www.openstack.org/project-mascots
12:57:37 <prometheanfire> think we need a list/fallbacks
12:57:45 <odyssey4me> you need to submit 3-5 options
12:58:00 <prometheanfire> odyssey4me: didn't you just submit 2? :P
12:58:16 <coolsvap> july 27
12:58:24 <prometheanfire> ok, so we have a week
12:58:30 <number80> Yamato no orochi (8 headed snakes as we scare people)
12:58:55 <coreycb> alright time is almost up
12:58:55 <coolsvap> 2 mins
12:58:56 <prometheanfire> number80: that's why I said spider :D
12:58:58 <prometheanfire> ok
12:58:59 <coreycb> coolsvap, want to drive this offline?
12:59:03 <coolsvap> sure
12:59:04 <number80> prometheanfire: I like it too :)
12:59:20 <coreycb> #action coolsvap to drive list of mascots before july 27 deadline
12:59:28 <coreycb> thanks coolsvap
12:59:28 <coolsvap> thanks coreycb
12:59:32 <prometheanfire> cool
12:59:48 <odyssey4me> prometheanfire I have not submitted yet. We'll finalise the list at our meeting on Thu.
12:59:57 <coreycb> thanks everyone
13:00:01 <coreycb> #endmeeting