12:00:22 <coreycb> #startmeeting requirements
12:00:23 <openstack> Meeting started Wed Jun 15 12:00:22 2016 UTC and is due to finish in 60 minutes.  The chair is coreycb. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:27 <openstack> The meeting name has been set to 'requirements'
12:00:34 <coreycb> hi everyone
12:00:39 <tonyb> o/
12:00:44 <coreycb> #topic rollcall
12:00:45 <coolsvap> o/
12:02:39 <coreycb> ok I think we have prometheanfire, sigmavirus24 here as well
12:03:06 <prometheanfire> ya, I had to reconnect
12:03:13 <prometheanfire> freenode was fail
12:03:25 <coreycb> no problem. just doing roll call.
12:03:31 <coreycb> ok let's get started then
12:03:34 <coreycb> #topic Any controversies in the Queue?
12:03:44 <sigmavirus24> o/
12:03:49 <coreycb> any issues in the queue this week?
12:04:23 <tonyb> coreycb: not that I know of
12:04:24 <prometheanfire> no, queue has gone down too, which is nice
12:04:49 <sigmavirus24> I would just ask that stable requirements cores let other stable cores know when a minimum versino bump is coming down the pike
12:05:09 <sigmavirus24> It surprised some of us when a requirements sync bumped the min version of an oslo lib and we had to track down the originating review
12:05:16 <sigmavirus24> Warnings are nice, but that's it
12:05:32 <tonyb> sigmavirus24: You mean with an email to os-dev or similar?
12:05:42 <sigmavirus24> tonyb: yeah, even just with the [stable] tag
12:06:11 <coreycb> that seems like something that could be automated
12:06:16 <sigmavirus24> Also, as a side note, minimum version bumps are not cool on stable branches, so I'd appreciate it if the few reviews that do that don't get comment-less +1s from team members
12:06:34 <sigmavirus24> coreycb: right, I mean just as a head's up: "Read this to understand why your next sync is going to hvae a minimum version bump"
12:06:58 <tonyb> sigmavirus24: we can try to do that
12:07:24 <coolsvap> sigmavirus24, good point, we can do that
12:07:28 <sigmavirus24> tonyb: let me know if I can help with that
12:07:53 <coolsvap> tonyb, would you take that as an action item?
12:08:43 <tonyb> coolsvap: Sure but it'll be a long time before we do a minimum bump like that
12:09:24 <coreycb> tonyb, I'll add an action for you then
12:09:32 <coreycb> thanks tonyb
12:09:33 <coolsvap> tonyb, ack! we can revisit it later as well
12:09:59 <coreycb> #action: tonyb to ensure stable requirements cores let other stable cores know when a min version bump is coming down the pike (e.g email to os-dev or similar, with the [stable] tag)
12:10:08 <coolsvap> just something which we can also discuss with wider audience when they are available :)
12:10:23 <coolsvap> or they can get from meeting logs
12:10:54 <sigmavirus24> coolsvap: to be clear, min version bumps should be a very rare occasion. In this case it was security related and absolutely necessary
12:11:30 <tonyb> Yeah we try very hard to not do that thing
12:11:51 <prometheanfire> ya, I've missed that I was reviewing for an older branch once and +1 one, but I try to watch for that
12:11:59 <prometheanfire> wish gertty called that out louder
12:12:03 * sigmavirus24 too
12:12:09 <sigmavirus24> That's a side note
12:12:22 <coolsvap> sigmavirus24, ack!
12:12:45 <coreycb> ok, thanks sigmavirus24
12:13:05 <coreycb> do we have any other points to discuss regarding the review queue this week?
12:14:41 <prometheanfire> the tqdm review?
12:14:53 <sigmavirus24> harlowja_: should answer that prometheanfire
12:15:00 <prometheanfire> do we have a cutoff date for that?
12:15:05 <coreycb> https://review.openstack.org/#/c/325527/
12:15:22 <coolsvap> prometheanfire, we at kolla team didnt had this up for discussion
12:15:29 <coolsvap> i will bring this up in meeting
12:15:36 <prometheanfire> coolsvap: thanks
12:16:21 <coreycb> coolsvap, is the discussion regarding wether or not kolla actually needs tqdm?
12:16:44 <coolsvap> coreycb, the patch is up for review but it does not look stable atm with tqdm
12:17:05 <coolsvap> coreycb, i can say yes
12:17:23 <coolsvap> the discussion is regarding whether kolla needs tqdm
12:17:38 <coolsvap> i will provide update on the review
12:17:43 <coreycb> coolsvap, ok.  I'll give you an action if you don't mind to follow up on that.
12:17:50 <coolsvap> coreycb, ack
12:18:11 <coolsvap> i will mostly do it today itself
12:18:28 <coreycb> #action coolsvap to follow up on tqdm with kolla team and ensure it's needed or not
12:18:44 <sigmavirus24> coolsvap: can you share the related kolla review?
12:19:16 * coolsvap is searching wait
12:19:54 <coolsvap> #link https://review.openstack.org/#/c/325529/
12:19:59 <coolsvap> this is the kolla review
12:22:01 <sigmavirus24> thanks coolsvap
12:22:15 <prometheanfire> added a note to the review requirements side
12:22:21 <tonyb> My gut feel is that kolla doesn't need to to be co-installable with OpenSTack services ... it's a deployment tool
12:22:36 <coolsvap> sigmavirus24, np
12:22:52 <tonyb> so we probably can't justify adding it esp. if it isn't active in kolla
12:23:51 <coolsvap> tonyb, kolla is following requirements and it is adheres with requirements policies and updates
12:24:16 <coolsvap> tonyb, but in this particular review i think we can take a decision in couple of days
12:24:26 <tonyb> coolsvap: huh there you go ...
12:24:37 <coolsvap> its in my queue for couple of weeks
12:24:45 <coolsvap> but i couldn't attend last weeks meeting
12:24:52 <sigmavirus24> I tend to agree with tonyb
12:25:05 <sigmavirus24> But I'd like to let coolsvap resolve this on the kolla side first
12:26:17 <coolsvap> thanks sigmavirus24 tonyb i will update the review as soon as I get the update mostly today after the meeting
12:26:32 <tonyb> coolsvap: Thanks.
12:27:23 <coreycb> ok I think we're ready to move on
12:27:45 <coreycb> last chance for requirements controversies
12:28:32 <sigmavirus24> let's :)
12:28:43 <coreycb> #topic Tasks from Etherpad
12:28:50 <coreycb> #link https://etherpad.openstack.org/p/requirements-tasks
12:29:17 <coreycb> alright, what's new with requirements tasks?
12:30:39 <coolsvap> no update from me
12:31:01 <sigmavirus24> Nothing from me, but I haven't been to a meeting in a few weeks
12:31:11 <coreycb> coolsvap, are you done with all of your reviews for dropping requirements?
12:31:13 <prometheanfire> 3.13, should be completed by the uc sanity checker tox job I think
12:31:35 <coolsvap> coreycb, mostly i didn't had time to check it this week
12:31:41 <coolsvap> but more than 90% its done
12:31:54 <coreycb> prometheanfire, awesome, I'll add a note to the etherpad
12:32:02 <coreycb> coolsvap, cool
12:32:08 <coolsvap> i will complete it before next meeting
12:32:57 <coreycb> coolsvap, sounds good
12:33:05 <coreycb> anything else?
12:35:21 <coreycb> ok let's move on
12:35:35 <coreycb> coolsvap, should we talk about requirements-cruft today?
12:37:31 <coreycb> ok. I think we're done, unless someone has anything?
12:37:43 <coreycb> thanks for all the discussion today everyone.
12:37:50 <coreycb> #topic Volunteer for next 2 meetings
12:38:17 <coreycb> I'm not sure we'll get 2 weeks worth ,but can someone volunteer to host next weeks meeting?
12:38:31 * tonyb o/
12:38:44 <coreycb> tonyb, you win!
12:38:45 <sigmavirus24> I can help too if tonyb is away
12:39:07 <coreycb> sigmavirus24, awesome thanks
12:39:08 <tonyb> okay so me in +7 sigmavirus24 in +14 :)
12:39:13 <sigmavirus24> sure
12:39:22 <coreycb> excellent
12:39:25 <coreycb> #topic Open Discussion
12:39:41 <coreycb> does anyone have anything else?
12:39:52 <coolsvap> coreycb, sorry was in different discussion, but no update related to requirement cruft
12:40:13 <coreycb> coolsvap, no problem
12:42:16 <coolsvap> i have updated the meeting agenda for kolla for discussion related to tqdm
12:42:25 <coreycb> coolsvap, sounds good thanks
12:42:27 <coreycb> ok all, thanks for attending!
12:42:33 <coreycb> #endmeeting