12:00:27 <dims_> #startmeeting requirements
12:00:28 <openstack> Meeting started Wed May 18 12:00:27 2016 UTC and is due to finish in 60 minutes.  The chair is dims_. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:31 <openstack> The meeting name has been set to 'requirements'
12:00:34 <ttx> o/
12:00:41 <dims_> hey ttx
12:01:15 <promethe1nfire> hi
12:01:28 <tonyb> o/
12:01:51 <coolsvap> o?
12:01:56 <coolsvap> o/
12:02:04 <dirk> Hey
12:02:05 <promethe1nfire> tonyb: what time is it for you?
12:02:09 <amrith> ./
12:02:14 <dims_> tonyb : i don't see you on our new channel. #openstack-requirements
12:02:14 <amrith> sorry, am a bit late
12:02:16 <tonyb> 2200ish
12:02:28 <tonyb> dims_: I did not
12:02:41 * tonyb adds it to his IRC config
12:02:43 <ttx> ohhh new channel. shiny
12:02:53 <dhellmann> o/
12:03:07 <GheRivero> o/
12:03:35 <dims_> welcome everyone to the new team!
12:03:55 <dims_> #topic : is this day/time ok for you?
12:04:06 <dims_> i know we lost lifeless as it's midnight
12:04:19 <dims_> tonyb : would you like us to move one hour earlier?
12:04:38 <promethe1nfire> it's 7AM here
12:04:43 <ttx> day/time perfect for me
12:04:52 <tonyb> dims_: that would be nice but only if it isn't terrible for the people just starting for the day
12:05:03 <dims_> tonyb : ok, will keep that in mind
12:05:08 <dims_> promethe1nfire : ack.
12:05:21 <ttx> I think one hour earlier would make it difficult for promethe1nfire, and one hour later difficult for tonyb
12:05:40 <dims_> ttx : right, let's leave it at this time
12:05:42 <promethe1nfire> I think we have a people from each region
12:05:51 <tonyb> yeah
12:05:51 <promethe1nfire> ya
12:05:57 <mugsie> dims_: got a ping to join here?
12:06:17 <tonyb> I think leave it as it is while we bootstrap and then reevaluate in a couple of months
12:06:17 <dims_> #topic reviews with immediate attention
12:06:18 <GheRivero> It's ok to me.. but not today. I'm out of the office now, but can do almost any hour. I'm a night person
12:06:22 <dims_> https://review.openstack.org/#/q/status:open+project:%255E.*requirements.*+branch:master,n,z
12:06:27 <dims_> GheRivero : ack
12:06:30 <dims_> tonyb : ack
12:06:43 <dims_> mugsie : not sure if you were interested in the team meeting. hence the ping
12:06:55 <promethe1nfire> if it was 6 hours earlier that'd be fine
12:07:02 <dims_> Looks like we made excellent progress the last few days
12:07:04 <promethe1nfire> I'm also a night person
12:07:06 <dims_> with reviews
12:07:12 <dirk> yeah
12:07:16 <dirk> we're down to less than one page
12:07:17 <dirk> awesome!
12:07:29 <dims_> the only hiccup we had was with python-kafka. we had to revert for monasca
12:07:44 <dims_> #link https://review.openstack.org/#/c/316259/
12:08:17 <dims_> Though they are not subject to requirements process
12:08:21 <GheRivero> Is there a gerrit topic for priority reviews?
12:08:32 <dims_> their jobs seemed to use the versions in g-r/u-c
12:08:48 <dims_> GheRivero : no, we don't have one yet
12:09:33 <dims_> any questions on the kafka revert?
12:09:43 * dims_ lets folks look at the comments in review
12:10:46 <dirk> dims_: is there a general guideline for that? I mean the revert broke some other project right?
12:11:39 <dims_> dirk : ideally we would say no to revert. since oslo.messaging had not yet started using code depending on the new version, it was technically feasible to revert back
12:12:09 <dhellmann> dims_ : I don't think the test system differentiates between projects following requirements and not when it forces the use of the constraints file
12:12:45 <dhellmann> is someone working on fixing monasca?
12:13:27 <dims_> dhellmann : Joe Keen and Roland Hochmuth (not sure what their IRC nicks are)
12:13:27 <tonyb> dhellmann: I think they're waiting for anumber of kafka issues to be closed before they do that work.
12:13:33 * sigmavirus24 apologizes for being late
12:13:38 <dims_> hey sigmavirus24
12:13:49 <dhellmann> dims_, tonyb : ok, as long as it's not being ignored
12:14:16 <promethe1nfire> sigmavirus24: you up early too :P
12:14:21 <tonyb> dhellmann: yup
12:14:24 <dims_> dhellmann : when oslo.messaging folks are ready with newer kafka, monasca should not have a say, unless they are subject to the g-r process by then
12:14:29 <sigmavirus24> promethe1nfire: that I am
12:14:55 <dims_> So this monasca not being in g-r but wanting revert promoted me to post this email
12:14:57 <dims_> #link http://markmail.org/message/kb6jlhiuhmxea454
12:15:12 * dims_ lets folks click on the link
12:16:16 * tonyb had flagged that for reading tomorrow;P
12:16:18 <dhellmann> in principle I agree, but if the way we run tests forces folks to use the updates even when they aren't syncing then we need to be aware of that
12:16:36 * dirk clicked it
12:16:41 * coolsvap saw that just before the meeting
12:16:42 <dhellmann> because it doesn't sound like syncing requirements would have helped monasca here?
12:16:57 <promethe1nfire> that looks like what's been discussed
12:17:02 <dims_> dhellmann : it would have given them a heads up when the g-r change merged
12:17:19 <dims_> as the bot proposes a review in their project
12:17:42 <dims_> coolsvap : y, giving background on what prompted that email
12:17:45 <dhellmann> dims_ : that's true. it still would have broken their jobs, but at least there would have been some sort of notice of what changed
12:18:01 <dims_> right, and they would have the right to ask for a immediate revert
12:18:13 <dhellmann> sure
12:18:23 <coolsvap> dims_, ack
12:18:43 <dhellmann> it would be good to get them off of the fence, and either start participating in g-r or stop using the constraints in their jobs (if that's even possible)
12:19:08 <dims_> yep, in general we need to push people more to understand requirements process better. another example - https://review.openstack.org/#/c/313835/
12:19:28 <tonyb> dhellmann: it isnt possible in a dsvm job
12:19:34 <dims_> Steven Hardy was asking about instack-*
12:19:40 <dhellmann> tonyb : that's what I was afraid of
12:19:45 <tonyb> dhellmann: we made it mandatory at some point
12:19:55 <dims_> needing some packages that we were trying to remove
12:20:10 <dhellmann> tonyb : it's really the only way to ensure it's going to work
12:21:01 <tonyb> dhellmann: Yeah.  I'm sure it seemed like a good idea at the time
12:21:45 <dims_> #topic - sniff test matrix
12:22:01 <dims_> we have a bunch of jobs in the requirements reviews themselves
12:22:03 <dirk> dims_: I'm not sure I understand teh concerns in that review so far
12:22:44 <dims_> dirk : instack-* is welcome to maintain any package versions they want they should not dictate what's in g-r
12:23:16 <dims_> and i maintain a set of sniff tests - https://review.openstack.org/#/q/status:open+branch:master+topic:dims/test/constraints
12:23:43 <dims_> dirk and i have been diligently checking failures in these tests before letting in the nightly proposed updates to u-c
12:23:57 <dirk> dims_: right.. lets talk about that some other time
12:24:02 <dims_> does anyone want another project added to my sniff test?
12:24:16 <dirk> sounds like monasca wants to be on that list :)
12:24:45 <dims_> dirk : LOL, if they get into g-r/u-c/projects.txt then yes :)
12:25:17 <tonyb> dims_: keystone, glance, swift
12:25:34 <mugsie> dims_: designate, if possible?
12:25:56 <tonyb> dims_: with what you have and those you'll be covering >55% of all the items in g-r
12:26:30 <dims_> mugsie tonyb : if you can add the reviews like the ones i have then that would be great - they key is the topic "dims/test/constraints" as i have a cron job that maintains these reviews once they are created - https://gist.github.com/dims/094ac0e8d8bd8c4a096b6b391157aef5
12:26:43 <dims_> tonyb : right
12:27:05 <dims_> #topic - release process updates that affect requirements
12:27:19 <dims_> dhellmann : any thoughts/plans here?
12:27:25 * tonyb will review the gist and then add the required jobs ;P
12:27:36 <dirk> dims_: painful projects are probably sahara, ceilometer, magnum
12:27:41 <dims_> #action tonyb	will review the gist and then add the required jobs
12:27:52 <dirk> they integrate a lot of dependencies and from my experience break often due to inter-project dependency issues
12:27:57 <dims_> dirk : i tend to add one when i break them once :)
12:28:06 <tonyb> A releated topic is runing $projects unit tests in u-c changes
12:28:11 <dirk> it seems ceilometer got broken so often that they opted out already ;)
12:28:26 <dims_> dirk : i don't want to get started on telemetry team :)
12:28:37 <tonyb> IIRC there was some interest in that at the summit and the issue was "which" tests.
12:28:53 <dirk> dims_: ;)
12:29:10 <dirk> tonyb: good point..
12:29:14 <dims_> tonyb : can you please add TODO(s) in https://etherpad.openstack.org/p/requirements-tasks ?
12:29:21 <tonyb> (that's how I know the project set that covers 55% of g-r)
12:29:25 <promethe1nfire> tonyb: ya, I thought it was a good idea, should we just pick some and see what still breaks?
12:29:36 <tonyb> better coverage is hard to get as we have lots of leaf items :(
12:30:10 <dhellmann> dims_ : we've merged the patch to automatically submit constraint updates when needed. I just submitted another to give all of those reviews a consistent topic of "new-release"
12:30:13 <dims_> tonyb : my sniff wip reviews run the unit tests too
12:30:24 <tonyb> promethe1nfire: Well we need to do some infra work first which will be mildly cumbersome
12:30:36 <promethe1nfire> ah, ya
12:30:42 <dhellmann> dims_ : those are the only release changes I can think of, unless you had something else in mind?
12:30:46 <dims_> dhellmann : nice thanks!
12:30:56 <tonyb> dims_: Sure this was aimed at offical gateing
12:31:06 <dims_> tonyb : ack
12:31:21 <dims_> who wants to help tonyb ? :)
12:31:46 <tonyb> dims_: we need to decide if it's a good idea ;P
12:31:56 <tonyb> dims_: Sean was against it at the time
12:32:22 <dims_> tonyb : we don't want to add *all* projects, we need a good representation or we would never land anything
12:32:37 <dims_> guessing that was sdague 's concern as well?
12:32:56 <promethe1nfire> projects that have good coverage would be nice, or ones that use more esoteric things
12:32:58 <tonyb> dims_: sure.  We'd need to have a *very* good reasin for adding projects to the list if it was gateing
12:33:18 <tonyb> dims_: Yeah I think that was the crux of it.
12:33:30 <dims_> ok switching topics
12:33:43 <dims_> #topic TODO(s) from our backlog - https://etherpad.openstack.org/p/requirements-tasks
12:33:52 <dhellmann> we should probably leave out projets that use the more obscure requirements, since they're likely to be the teams proposing changes in the first place
12:34:03 <dims_> dhellmann : ++
12:34:08 <dims_> anyone interested in picking up something to work on?
12:34:51 <tonyb> dims_: It seems a few poeple are working on the cruft problem
12:35:04 <dims_> tonyb : right, almost done i think
12:35:39 <promethe1nfire> dhellmann: right, I was speaking of more esoteric usage, not the requirements themselves
12:35:47 <dims_> under "proactive tasks" we unblocked the keystone team to experiement with packages that work under python3 for LDAP
12:35:51 <tonyb> dims_: probably :)
12:36:05 <promethe1nfire> dims_: for both libraries :|
12:36:47 <dims_> promethe1nfire : you mean they have 2 sets of possible things to use?
12:37:07 <sigmavirus24> So other than those dim/test/constraints reviews, how can we improve test coverage?
12:37:15 <sigmavirus24> Is that the only axis we're measuring test coverage on?
12:37:52 <dims_> sigmavirus24 : the oslo team has a set of periodic jobs to test several projects with oslo.* from master repos
12:38:02 <dims_> sigmavirus24 : that's about it
12:38:27 <dirk> dims_: how ot find those jobs?
12:38:28 <prometheanfire> dims_: keystone has pyldap and python-ldap both supporting python3
12:38:44 <dims_> dirk : https://etherpad.openstack.org/p/dims-periodic-jobs
12:39:03 <dirk> dims_: great!
12:39:05 <prometheanfire> they added pyldap a couple of days ago and just requested a bump of python-ldap yesterday
12:39:13 <dims_> prometheanfire : by m1/m2, we should make sure they use one set
12:39:25 <prometheanfire> ya, it needs to be tracked
12:39:26 <dims_> they are still experimenting i think
12:39:34 <prometheanfire> I can bug stanek and dolphm
12:39:46 <dims_> stevemar : bknudson : dolphm : ^^
12:39:47 <dims_> :)
12:39:54 <prometheanfire> :D
12:39:58 <dims_> prometheanfire : agree
12:40:14 <dims_> #topic - daily reviews
12:40:52 <dims_> around this time every day, starting about 7 AM my time (we started the meeting at 8 AM my time), me and dirk and others have been trading comments on reviews as well as on IRC
12:41:03 <dims_> is anyone else available to join us?
12:41:30 <dims_> this way, we push a bunch of things out, then see if anything fails by end of day, then start again next day with a fresh slate
12:41:35 <coolsvap> +1 although its almost eod for me, but i can join for couple of hours
12:41:45 <dims_> coolsvap : nice!
12:41:45 <dirk> I actually put it on my morning routine (which is like 4-5 hours before dims_ ;) )
12:41:46 <prometheanfire> I'd be available to do that at 10 or 11 your time
12:42:01 <tonyb> dims_: I can check in at the start of my day which would be toward the end of yours but no overlap with the others
12:42:21 <dims_> tonyb : ack. i am usually still around when you begin your day :)
12:42:22 <dirk> dims_: one of the action items is to publish the information that people should come and ping in openstack-requirements channel for issues..
12:42:29 <sigmavirus24> dims_: It's 7am for me, but I can join later
12:42:35 <IgorYozhikov> I can try to review from 12 gmt+3
12:42:37 <dims_> sigmavirus24 : awesome
12:42:47 <prometheanfire> dirk: +1
12:42:48 <dims_> IgorYozhikov : ack. cool
12:43:11 <dims_> dirk : action to send an email to the ML tomorrow about the channel?
12:43:23 <tonyb> I can add the channel to IRC wiki page, dims do you want to email the list?
12:43:24 <dirk> I can take that action
12:43:31 <dirk> but I think a more permant place is better
12:43:34 <dims_> dirk : thanks!
12:43:40 <dirk> I just don't know where.. somewhere on elastic check pages or so?
12:43:42 <prometheanfire> radme?
12:43:52 <prometheanfire> readme
12:44:03 <dirk> "we noticed that g-r broke your fancy project. please come to irc and tell us about it"
12:44:27 <dims_> dirk : +1
12:44:41 <dirk> does anyone have a good place to put that information?
12:44:42 <prometheanfire> ah, right
12:45:11 <dirk> https://wiki.openstack.org/wiki/Requirements might be a good candidate for refreshment
12:45:33 <dims_> #topic - adding folks to team roster
12:45:42 <dims_> ttx, dhellmann - thoughts here?
12:46:04 <prometheanfire> tonyb wanted to be ptl, was practicaly begging for it
12:46:07 <dims_> since we officially started today, probably check back in a month on reviews, engagement and figure out who we can add?
12:46:14 <dhellmann> prometheanfire : that's how I remember it, too
12:46:16 <dims_> all hail tonyb :)
12:46:27 <tonyb> prometheanfire: uuuuummmm that's not how I remember it
12:46:31 <dhellmann> dims_ : yeah, let's run as a team for a few weeks and see how it goes
12:46:38 <dhellmann> tonyb : you might not have been in the room at that point ;-)
12:46:47 <ttx> yes, we should definitely revisit core once we know who is sticking
12:46:48 <dims_> :)
12:46:49 <prometheanfire> tonyb: you're welcome, and I'm sorry
12:47:12 * dims_ leaves "when" on ttx and dhellmann 's hands
12:47:24 <dims_> #topic open discussion
12:47:36 <dims_> So was the info in the etherpad enough?
12:47:55 <dims_> do folks have an idea of what we need to do here? :)
12:47:58 <dhellmann> I want to reiterate my thanks for all of you joining the team. It's good to see this work have some dedicated folks looking at it.
12:48:14 <dims_> ++ dhellmann !
12:48:27 <prometheanfire> I think so
12:48:29 <dhellmann> And thank you dims, for taking the lead in organizing the meeting and the todo list and everything else.
12:48:38 <tonyb> dhellmann: Thanks for picking a scary title to get us in a room :)
12:48:41 <dims_> my pleasure dhellmann
12:48:45 <prometheanfire> heh, ya
12:48:46 <dims_> LOL
12:49:14 <dhellmann> tonyb : yeah, I'll have to be more careful at future summits or folks won't come to my sessions :-)
12:49:21 <tonyb> dhellmann: :)
12:49:45 <prometheanfire> you only get to use that once in 2-4 summits
12:49:47 <dims_> one another ML thread i'd like to bring to everyone's attention is from IgorYozhikov : http://markmail.org/message/awlpe5huktysxslj
12:49:50 <tonyb> So if this is a happening thing I'll make a calendar entry (probably in #openstack-meeting)
12:49:56 <tonyb> sound good?
12:50:10 <dims_> tonyb : please go ahead to do the calendar entry
12:50:25 <sigmavirus24> Thanks tonyb
12:50:32 <dims_> tonyb : please add yourself as chair for now
12:50:39 * sigmavirus24 snickers
12:50:40 <IgorYozhikov> dims_, I believe that we already discussed it or new questions appears?
12:50:52 <dims_> IgorYozhikov : want to be sure more folks read that thread
12:50:57 * dhellmann has to drop off early
12:51:03 <dims_> thanks dhellmann
12:51:03 <IgorYozhikov> dims_, i c, thanx
12:51:03 * sigmavirus24 was snickering about tonyb being the chair
12:51:05 <tonyb> dims_: ;P
12:51:16 <sigmavirus24> bye dhellmann
12:51:28 <prometheanfire> sigmavirus24: will you be a stool?
12:51:38 <dims_> yew!
12:51:49 <sigmavirus24> prometheanfire: as long as I'm the useful kind and not the smelly kind
12:53:02 <prometheanfire> sigmavirus24: dunno, some days you do kinda have an 'air' about you
12:53:07 <coolsvap> thanks dims for arranging the meeting!
12:53:30 <dirk> dims_: one action item from that thread imho is to review those cases where requirements and uc diverge significantly if that is still correct
12:54:01 <dirk> so does anyone want to help revive https://wiki.openstack.org/wiki/Requirements ?
12:54:05 <prometheanfire> dirk: you mean if there's a big diff in versions?
12:54:06 <dirk> it is currently marked as deprecation
12:54:09 <dirk> prometheanfire: yep
12:54:35 <dirk> prometheanfire: either that, or just by git commit messages (like e.g. uc got updated in 2016 but lower bounds last time in 2014 or so)
12:54:41 <prometheanfire> not a problem for me, luckilly
12:54:48 <coolsvap> dirk, yes we need to update the page
12:55:15 <dims_> so folks feel free to self-organize :) we can go back to our channel
12:55:20 <dims_> thanks everyone
12:55:21 <coolsvap> can we open an etherpad to first to finalize the content
12:55:28 <prometheanfire> cya
12:55:34 <coolsvap> thanks dims
12:55:37 <dims_> #endmeeting