14:00:01 <hberaud> #startmeeting releaseteam
14:00:01 <opendevmeet> Meeting started Fri Sep  8 14:00:01 2023 UTC and is due to finish in 60 minutes.  The chair is hberaud. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:01 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:01 <opendevmeet> The meeting name has been set to 'releaseteam'
14:00:08 <hberaud> ping elodilles armstrong
14:00:13 <hberaud> Meet you at line 389 => https://etherpad.opendev.org/p/bobcat-relmgt-tracking
14:00:23 <elodilles> o/
14:01:27 <hberaud> Thierry is traveling so I don't think we will see him today
14:01:32 <hberaud> so let's go
14:01:41 <hberaud> #topic Review task completion
14:01:47 <hberaud> 1. Process any remaining client library freeze exception
14:01:55 <hberaud> https://review.opendev.org/q/topic:bobcat-milestone-3+is:open
14:02:02 <hberaud> 3 patches remains opened because as you said (elodilles) their gates are broken
14:02:10 <hberaud> We didn't get feedback from PTLs
14:02:18 <elodilles> :S
14:02:18 <hberaud> 2 patches are even without PTLs' votes
14:02:21 <diablo_rojo> o/
14:02:26 <hberaud> What can we do here? The problem is on the deliverable side and not on our side, so...
14:02:41 <diablo_rojo> Which PTLs?
14:02:46 <diablo_rojo> err projects?
14:02:51 <diablo_rojo> I can try to poke at them.
14:03:09 <hberaud> barbican, murano, and sahara
14:03:21 <hberaud> for those patches https://review.opendev.org/q/topic:bobcat-milestone-3+is:open
14:03:25 <hberaud> thanks diablo_rojo
14:03:29 <elodilles> with a quick check i see that python-saharaclient's gate was fixed (at least what i see)
14:03:36 <fungi> yeah, it can also be brought to the attention of the tc
14:04:13 <elodilles> (so python-saharaclient's patch can be updated at least)
14:04:19 <diablo_rojo> I can poke at Barbican and Murano if you'd like, otherwise the TC yeah.
14:04:21 <hberaud> ah yes
14:05:25 <elodilles> we have to ping requirements team (via ML) anyway, with RFE's regarding these 3 releases, right?
14:05:55 <opendevreview> Hervé Beraud proposed openstack/releases master: Release final python-saharaclient for 2023.2 Bobcat  https://review.opendev.org/c/openstack/releases/+/892957
14:06:14 <hberaud> I updated the SHA ^
14:06:22 <elodilles> ++
14:06:51 <hberaud> elodilles: as the deadline is behind us, I think that yes
14:07:48 <hberaud> #action diablo_rojo to ping the sahara and the barbican team about the broken gates
14:08:01 <elodilles> well, i'm hesitant between pushing through the releases anyway (as we did last week with non-client libs) or wait for gate fixes / team responses
14:08:11 <diablo_rojo> I will get on that right now :)
14:08:19 <elodilles> thanks diablo_rojo o/
14:08:19 <hberaud> thx
14:08:30 <diablo_rojo> elodilles: nor Murano?
14:08:34 <diablo_rojo> *not
14:08:50 <elodilles> OK, then let's wait a bit, and we can get back to it on Monday
14:09:18 <hberaud> elodilles: I'd suggest to wait early monday and if the things are still stuck, I'd suggest to push through, thoughts?
14:09:31 <hberaud> wfm
14:09:38 <hberaud> you beat me
14:09:42 <elodilles> hberaud: sounds like a plan
14:09:43 <elodilles> :)
14:10:18 <elodilles> diablo_rojo: you meant hberaud :) and yes, barbican & murano o:)
14:10:40 <diablo_rojo> elodilles: yes I did lol
14:10:55 * diablo_rojo has had no caffeine this morning
14:11:17 <elodilles> and you are still awake?! :-o magic!!! :-o
14:11:25 <elodilles> :)
14:11:25 <hberaud> I added a related line for the next week tasks
14:11:28 <diablo_rojo> Its painful and flawed.
14:11:38 <elodilles> hberaud: thx \o/
14:11:50 <hberaud> ok move on
14:12:02 <hberaud> 2. Early in the week, email openstack-discuss list to remind PTLs that cycle-highlights are due this week so that they can be included in release marketing preparations
14:12:09 <hberaud> https://lists.openstack.org/pipermail/openstack-discuss/2023-September/034959.html
14:12:40 <hberaud> and AFAIK I see many related patches submitted after that
14:12:47 <elodilles> yepp, cycle higlights patches have been arriving during the week, so ++
14:13:03 <diablo_rojo> Yayayayay
14:13:11 <hberaud> 3. Freeze all cycle-based library releases except for release-critical bugs. Independently-released libraries may still be released, but constraint or requirement changes will be held until after the freeze period
14:13:45 <hberaud> Do you noticed things like that? ^
14:13:55 <elodilles> nope
14:14:11 <hberaud> I think oslo patches will arrive soon
14:14:14 <fungi> speaking of critical bugs, there's been more upheaval in the oslo.messaging security bug, seems like the fix caused a regression so another change and new release on stable/2023.2 is likely
14:14:17 <elodilles> but we will have the above mentioned 3 client lib
14:14:24 <hberaud> as we discussed about that on the oslo channel
14:14:40 <elodilles> oh, good to know O.o
14:15:09 <frickler> also some set of reqs bumps might still be open for recently released libs
14:15:23 <hberaud> ack
14:15:25 <frickler> there were a couple of merge conflicts
14:15:36 <frickler> and two libs are failing cross testing
14:15:46 <hberaud> which ones?
14:15:53 <frickler> castellan and oslo.db
14:16:13 <frickler> even oslo.db 13.1.0 is failing. not to speak of 14.0.0
14:16:30 <hberaud> ugh
14:17:34 <hberaud> lets continue to discuss about that on the oslo channel
14:17:39 <frickler> https://review.opendev.org/c/openstack/requirements/+/883141 and https://review.opendev.org/c/openstack/requirements/+/887261
14:18:09 <hberaud> thanks
14:18:33 <diablo_rojo> ftr, I have now reached out to those 3 PTLs
14:18:48 <hberaud> ack thx
14:20:11 <elodilles> I think we should track oslo.db & castellan issues as well next week, to get it sorted out as soon as possible :S
14:20:26 <hberaud> yeah
14:20:37 <hberaud> let me add it to our agenda
14:22:05 <hberaud> done
14:22:12 <elodilles> thanks ++
14:22:23 <hberaud> ok next task
14:22:36 <hberaud> 4. Propose stable/$series branch creation for all client and non-client libraries that had not requested it at freeze time
14:22:43 <hberaud> https://review.opendev.org/q/topic:bobcat-stable-branches
14:23:31 <elodilles> i went through the still open patches earlier today and all look fine to me. +2'd & PTL-Approved+1'd them.
14:23:35 <hberaud> I'll merge all the remaining patches after the meeting
14:23:42 <elodilles> ++
14:24:09 <hberaud> so this point seems in good shape
14:24:30 <hberaud> 5. List cycle-with-intermediary deliverables that have not been refreshed in the last 2 months and send a separate email targeted to teams with such old deliverables to remind them to release (if needed) otherwise a probably outdated version will be used for the final release
14:24:38 <hberaud> https://lists.openstack.org/pipermail/openstack-discuss/2023-September/034973.html
14:25:38 <hberaud> so only the QA team was listed in this mail and they replied, so I think this topic is on the rails
14:25:48 <elodilles> ++
14:25:49 <hberaud> thanks gmann
14:26:14 <hberaud> and that's all for the weekly tasks
14:26:39 <hberaud> #topic Assign next week tasks
14:27:04 <elodilles> all taken as i see \o/
14:27:16 <hberaud> thanks elodilles for putting your name
14:27:24 <hberaud> \o/
14:27:53 <hberaud> #topic Review countdown email
14:28:01 <hberaud> https://etherpad.opendev.org/p/relmgmt-weekly-emails
14:28:49 <elodilles> looks good!
14:28:55 <hberaud> thx
14:30:10 <hberaud> and sent
14:30:40 <hberaud> #topic Open Discussion
14:30:54 <hberaud> Anything else that you want to discuss today?
14:31:18 <frickler> maybe a short question about branch cleanup
14:31:43 <frickler> what we discussed earlier with noonedeadpunk about deleting old branches predating release automation
14:32:09 <frickler> do you think you could grant deletion powers in gerrit to volunteering ptls? or would that have to be a TC decision?
14:32:45 <elodilles> it's an project-config (infra) change anyway
14:33:14 <frickler> on the technical side, yes, my question is more about policy
14:33:49 <hberaud> then if this is a policy change I'd argue that's a TC decision
14:33:57 <fungi> ultimately, the tc can authorize granting permission for that
14:34:07 <opendevreview> Merged openstack/releases master: [blazar] Create 2023.2 branch for client and non-client libs  https://review.opendev.org/c/openstack/releases/+/893626
14:34:37 <fungi> for clear separation of concerns, it would probably be best as an acl change to the specific projects affected rather than openstack-wide
14:34:51 <frickler> maybe the release team already has the permission to delegate this
14:34:57 <elodilles> fungi: sounds good to me
14:35:10 <frickler> but I think we can create a change in project-config and then ask TC for feedback
14:35:13 <hberaud> fungi: +1
14:35:31 <elodilles> frickler: it's more like what fungi says
14:36:17 <elodilles> frickler: i mean, not a single change, but a specific change for a specific project
14:36:21 <elodilles> but yes
14:36:36 <frickler> yes, we only have one volunteer so far, so that's fine
14:37:05 <elodilles> ++
14:37:08 <opendevreview> Merged openstack/releases master: [zun] Create 2023.2 branch for client and non-client libs  https://review.opendev.org/c/openstack/releases/+/893645
14:37:12 <frickler> I'll check who else could get involved in the things blocking global job cleanup
14:37:19 <fungi> i'm assuming noonedeadpunk is only volunteering to be responsible for deleting old branches of deliverables for a specific team, not across all of openstack
14:37:31 <frickler> yes, that was for osa repos
14:38:41 <frickler> ok, that's fine then for me, thx
14:39:05 <hberaud> anything else?
14:39:25 <elodilles> nothing from me
14:41:00 <hberaud> Then I think we are done!
14:41:03 <hberaud> thanks everyone!
14:41:06 <hberaud> #endmeeting