14:00:35 <elodilles> #startmeeting releaseteam
14:00:35 <opendevmeet> Meeting started Fri Feb 17 14:00:35 2023 UTC and is due to finish in 60 minutes.  The chair is elodilles. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:35 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:35 <opendevmeet> The meeting name has been set to 'releaseteam'
14:00:40 <hberaud> o/
14:00:43 <elodilles> Ping list: hberaud armstrong elodilles
14:00:53 <elodilles> #link https://etherpad.opendev.org/p/antelope-relmgt-tracking
14:00:58 <elodilles> we are almost at the bottom
14:01:12 <elodilles> @ line 324
14:01:17 <elodilles> o/
14:01:38 <fungi> that's a good place to be
14:02:23 <elodilles> yepp :) a bit scary, but yes :)
14:02:34 <elodilles> ttx is travelling, so let's not wait for him
14:02:56 <elodilles> #topic Review task completion
14:03:23 <elodilles> 1st task was: 'Process any remaining library freeze exception (all)'
14:03:52 <elodilles> and there's no open lib release patch
14:04:06 <elodilles> so this is done
14:04:19 <elodilles> anything i missed?
14:04:48 <hberaud> nope
14:04:52 <hberaud> I don't think
14:05:03 <elodilles> cool, then next task:
14:05:20 <elodilles> 'Propose autoreleases for cycle-with-intermediary client libraries (hberaud)'
14:05:29 <hberaud> https://review.opendev.org/q/topic:antelope-milestone-3
14:05:33 <elodilles> patches proposed ^^^
14:05:43 <hberaud> I think we can force those without response
14:05:47 <elodilles> so here the situation is a bit different
14:05:57 <elodilles> yepp, today is the deadline,
14:06:27 <elodilles> however as a later task of mine showed, we have some deliverables with broken gates
14:06:32 <elodilles> mostly due to tox4
14:06:46 <elodilles> what should be the way forward:
14:07:12 <fungi> projects which haven't fixed their ability to merge changes since december are likely inactive, so good feedback to the tc
14:07:26 <elodilles> 1) force merge now the patches AND ask for RFE for deliverables with broken gates - when they are fixed
14:07:46 <elodilles> 2) wait some days and propose RFE
14:08:16 <elodilles> fungi: not that simple, but yes, it's a good indicator
14:08:35 <hberaud> if they are not yet fixed, then, I think we are ready to follow 2)
14:09:00 <elodilles> fungi: sometimes projects forget some of their rarely used deliverables (python-*clients)
14:09:47 <elodilles> hberaud: ack, we can track this anyway as there is a task in next week's task list
14:10:17 <elodilles> i've +2'd some that are ready to force-merge anyway (no response from the team, but gate seems OK)
14:10:30 <hberaud> same thing here
14:10:31 <elodilles> and -1'd some that have broken gates
14:11:12 <elodilles> I'll review the rest after the meeting
14:11:22 <hberaud> ack thanks
14:11:46 <elodilles> hberaud: will you be available after the meeting? in case there will be some patch to force-merge or discuss
14:12:02 <elodilles> if not then we can discuss things on Monday
14:12:52 <hberaud> I've a school meeting in ~1h
14:12:59 <hberaud> so I'll be AFK
14:13:27 <elodilles> #action (all) review open releases with broken gates + send RFE's if needed ( https://review.opendev.org/q/topic:antelope-milestone-3 )
14:13:54 <elodilles> hberaud: ack, no problem, then we can discuss patches (if needed) on Monday
14:14:00 <hberaud> sure
14:14:19 <elodilles> school meetings are important
14:14:26 <hberaud> :)
14:14:33 <elodilles> even if they are not the most exciting things :D
14:14:39 <hberaud> indeed
14:14:59 <elodilles> okay, next task then
14:15:21 <elodilles> 3rd task: 'Evaluate any non-client libraries that did not have any change merged over the cycle to see if it is time to transition them to the independent release model (hberaud)'
14:15:42 <hberaud> So I think that we have nothing to transition here
14:15:54 <elodilles> ack
14:16:12 <hberaud> only tidly coupled libraries appeared in the list
14:16:21 <elodilles> i agree
14:16:45 <hberaud> so I think they should remains with their parent projects
14:17:05 <elodilles> meanwhile i remember i marked monasca-common monasca-statsd as they need a release, but i forgot to propose release patches for them :/
14:17:22 <elodilles> the reasin is that they haven't merged any patch
14:17:33 <hberaud> yeah
14:17:42 <elodilles> hberaud: ack, let's keep them synced with monasca
14:17:50 <hberaud> ok
14:18:16 <elodilles> i'll propose release patches after the meeting and next week we can do an 'empty' release for them
14:18:23 <hberaud> ok
14:18:25 <hberaud> wfm
14:18:55 <elodilles> #action elod to propose 'convenient' releases for monasca-common and monasca-statsd (they haven't merged a single patch during the cycle)
14:19:22 <elodilles> i guess they will need gate fixes as well, but i will check that too
14:19:41 <elodilles> anything else to mention hberaud ?
14:20:02 <hberaud> no
14:20:47 <elodilles> #agreed keep monasca-common and monasca-statsd as cwi
14:20:49 <elodilles> ok
14:20:54 <elodilles> next task then:
14:21:12 <elodilles> 'List cycle-with-intermediary deliverables that have not been released yet and send a separate email targeted to teams with such unreleased deliverables to remind them that they need to release before $rc1-deadline (elod)'
14:21:25 <elodilles> and mail was sent: https://lists.openstack.org/pipermail/openstack-discuss/2023-February/032234.html
14:21:55 <elodilles> no response yet, but hopefully they will prepare releases soon
14:22:16 <hberaud> ack
14:22:18 <elodilles> we have to keep an eye on them
14:22:26 <opendevreview> Merged openstack/releases master: Release final python-tackerclient for Antelope  https://review.opendev.org/c/openstack/releases/+/873542
14:22:29 <opendevreview> Merged openstack/releases master: Release final python-zaqarclient for Antelope  https://review.opendev.org/c/openstack/releases/+/873547
14:22:32 <opendevreview> Merged openstack/releases master: Release final python-aodhclient for Antelope  https://review.opendev.org/c/openstack/releases/+/873517
14:23:00 <elodilles> #action (all) keep an eye on cwi deliverables without release: https://lists.openstack.org/pipermail/openstack-discuss/2023-February/032234.html
14:23:09 <elodilles> just to highlight it a bit ^^^
14:23:25 <hberaud> ok
14:23:37 <elodilles> next task:
14:24:02 <elodilles> 5th maybe
14:24:14 <elodilles> prometheanfire: 'On Friday, remind the requirements team to freeze changes to openstack/requirements by applying -2 to all open patches. Ensure that reviewers do not approve changes created by the proposal bot, but do approve changes for new OpenStack deliverable releases. (elod)'
14:24:42 <elodilles> tonyb: ^^^ (when you read the meeting logs o:))
14:25:41 <elodilles> prometheanfire: tonyb: well, maybe we should wait until today's releases get merged and their upper-constraints bumps as well
14:26:42 <elodilles> prometheanfire: tonyb: otherwise, please be prepared to RFE's as there are 10-20 libraries with broken gates at the moment that might need some simple fix & releases in the coming week
14:27:13 <elodilles> i think that's all for this
14:28:09 <elodilles> any comment maybe?
14:29:05 <hberaud> nope
14:29:33 <elodilles> ack, cool, then last task
14:29:41 <elodilles> we actually discussed this a bit:
14:29:53 <elodilles> 'Propose DNM changes on repositories where no patches merged recently to check that tests are still passing with the current set of dependencies (elod)'
14:30:07 <elodilles> proposed DNM patches where last merge happened only in 2022, failing gates: https://review.opendev.org/q/topic:release-health-check-cwi-antelope+label:Verified%253D-1
14:30:30 <hberaud> I submitted patches to fix oslo.* https://review.opendev.org/q/topic:release-health-check-oslo
14:30:37 <elodilles> and this uncovered ~30 broken gates
14:30:58 <elodilles> hberaud: cool, thanks! i will look at them
14:31:04 <hberaud> thanks
14:31:07 <elodilles> mail was sent, too: https://lists.openstack.org/pipermail/openstack-discuss/2023-February/032247.html
14:31:34 <elodilles> and just as hberaud, other teams also fixed some gates already \o/
14:31:53 <hberaud> cool
14:33:17 <elodilles> i think i'll do the same for cycle-with-rc deliverables (next week?) and hopefully we can catch early some broken gates there as well
14:33:48 <elodilles> anyhow, this was all our tasks
14:33:58 <elodilles> continuing with the next topic:
14:34:12 <elodilles> #topic Assign next week tasks
14:34:26 <elodilles> i've added my name already to some tasks
14:34:41 <elodilles> thanks hberaud for volunteering as chair
14:34:55 <elodilles> i've added you for the 'send countdown mail' task o:)
14:35:17 <elodilles> as it is usually handled by the chair of the given meeting o:)
14:35:19 <hberaud> thanks
14:35:34 <hberaud> I think the third task is for everybody, isn't?
14:35:42 <elodilles> yepp, indeed
14:35:47 <elodilles> ++
14:35:56 <elodilles> all taken then
14:35:57 <elodilles> thanks!
14:36:14 <elodilles> #topic Review countdown email
14:36:24 <elodilles> #link https://etherpad.opendev.org/p/relmgmt-weekly-emails
14:36:28 <elodilles> please review ^^^
14:37:35 <hberaud> why some part are crossed?
14:37:48 <hberaud> Can't we remove them instead?
14:37:59 <elodilles> oh, the -stricked- were the original content, which should be deleted
14:38:05 <hberaud> ok
14:38:20 <elodilles> just wanted to call your attention that there were some bigger changes
14:38:29 <elodilles> they won't be part of the mail to send
14:38:52 <hberaud> LGTM
14:38:58 <hberaud> ack
14:39:11 <hberaud> thanks
14:39:20 <elodilles> like: hard string freeze is not $rc-final-date but $rc1-deadline according to the schedule
14:39:34 <hberaud> I see
14:39:57 <hberaud> you did well
14:40:05 <elodilles> thanks, I'll send it later today
14:40:10 <hberaud> ok
14:40:41 <elodilles> #topic Open Discussion
14:40:57 <elodilles> anything to mention?
14:41:23 <hberaud> nope
14:41:57 <elodilles> i also think everything was mentioned that needid during the other topics
14:42:31 <elodilles> okay, then don't waste more time now, let's end the meeting
14:42:47 <hberaud> thanks elodilles
14:42:48 <elodilles> thanks hberaud fungi for joining o/
14:43:05 <elodilles> #endmeeting