19:00:13 <tonyb> #startmeeting releaseteam
19:00:14 <openstack> Meeting started Thu Jul 25 19:00:13 2019 UTC and is due to finish in 60 minutes.  The chair is tonyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:17 <openstack> The meeting name has been set to 'releaseteam'
19:00:48 <evrardjp> o/
19:01:07 <tonyb> evrardjp: Hey there!
19:01:10 <diablo_rojo> o/
19:01:28 <fungi> i'm around, though multitasking on yardwork
19:01:39 <fungi> also welcome back tonyb!
19:02:05 <tonyb> diablo_rojo, fungi: good to see you
19:02:11 <tonyb> fungi: Thanks
19:02:16 <evrardjp> tonyb: :)
19:03:40 <tonyb> I think this might be everyone  ttx and smcginnis are traveling / have just gotten home
19:04:58 <tonyb> #topic task list
19:05:03 <diablo_rojo> Quite possibly. I saw messages from ttx saying he was fading fast several hours ago
19:05:13 <tonyb> Membership Freeze
19:05:46 <diablo_rojo> As of yesterday I think there were 16 governance deliverables that don't exist in the train dir
19:06:01 <diablo_rojo> but I think the majority wont be
19:06:06 * diablo_rojo grabs etherpad linl
19:06:22 <diablo_rojo> #link https://etherpad.openstack.org/p/train-membership-freeze
19:07:17 <tonyb> diablo_rojo: Thanks!
19:07:30 <tonyb> sorry took a while to digest that
19:07:37 <diablo_rojo> No worries
19:07:52 <diablo_rojo> Havent had a response on the helm ones
19:08:17 <diablo_rojo> the compute-hyperv
19:08:21 <diablo_rojo> too
19:08:34 <evrardjp> I will ping OSH to make sure they are in this channel
19:09:36 <tonyb> evrardjp: Thanks
19:09:37 <evrardjp> I just pinged pete for that -- it's not the first cycle OSH isn't taking decisions for releases
19:09:54 <tonyb> diablo_rojo: Looks like you have that under control
19:10:35 * tonyb steps away and tries not to slow you down
19:10:51 <diablo_rojo> tonyb, heh more or less I can harp on people a little more to get the 16 --> 0
19:12:52 <tonyb> diablo_rojo: :) Well 0 repos without a response at least
19:13:09 <tonyb> M-2 tasks
19:14:00 <tonyb> Do stable autoreleases around milestones - https://storyboard.openstack.org/#!/story/2005701
19:14:29 <tonyb> I think that's blocked by: https://review.opendev.org/#/q/status:open+project:openstack/releases+branch:master+topic:feature/new_tools
19:15:03 <tonyb> But I'll run them today to process the missing m-2 releases (assuming that's needed)
19:15:26 <tonyb> and then next week we can test them with the stable stuff
19:15:34 <tonyb> does that sound ok?
19:16:33 <diablo_rojo> Sounds fine to me (with the disclaimer that she's only reading process now)
19:16:36 <evrardjp> let's say yes?
19:16:51 <tonyb> hehe
19:17:01 <diablo_rojo> I know we need to get the unreleased libraries done.
19:17:25 <tonyb> Well I messed that (the process) up last week but I htink that'll get us back on track
19:17:56 <diablo_rojo> Oh and deliverables that are intermediary that havent released yet
19:18:31 <diablo_rojo> Sounds right to me.
19:18:38 <diablo_rojo> (again, being no expert in the process)
19:18:39 <tonyb> \o/
19:20:17 <tonyb> We missed a few things we were supposed to do befoer m-2 but we'll get that back on track
19:20:31 <diablo_rojo> Indeed we will.
19:20:39 <tonyb> Look up progress on must-do/should-do improvements ...
19:20:42 <diablo_rojo> Was a long stretch of a lot of us being out
19:20:56 <tonyb> #link https://etherpad.openstack.org/p/relmgmt-train-ptg
19:21:01 <tonyb> around lin 93
19:22:06 <tonyb> The must do iteam all look to be in progess and -W'd by me so I shoudl fix that ;P
19:22:27 <tonyb> Engage with QA on communicating classification rates regularly
19:22:32 <evrardjp> well they are not all reviewed, so let's wait for the -w to disappear first :)
19:22:46 <tonyb> I don;t know if we started doign that ?
19:22:51 <diablo_rojo> tonyb, I dont think so
19:22:52 <evrardjp> s/let's wait/I was waiting/
19:23:13 <diablo_rojo> Am happy to talk to them but idk what I'm supposed to talk about exactly lol
19:23:15 <tonyb> evrardjp: That's cool that kinda why I had them with -W
19:23:58 <evrardjp> I can't remember what said "classification rates" is.
19:24:03 <tonyb> Basically we thought it'd be good for the QA team to drive getting bugs classified in terms of e-r
19:24:19 <evrardjp> ohh
19:24:49 <tonyb> Leaving things as unclassified doesn't help us understand if we have a couple of big bugs that'd be bad to realease
19:25:08 <evrardjp> got it
19:25:17 <tonyb> It's quite a bit of work to do it and I think we just wanted to start the conversation
19:27:14 <tonyb> It'd be good to have someone signed up to do that ... just start the conversation
19:27:36 <diablo_rojo> Basically just to put it on their radar?
19:27:50 * diablo_rojo goes to look up when the QA meeting is
19:28:10 <tonyb> diablo_rojo: Yes and Thanks
19:28:12 <diablo_rojo> *office hours
19:28:14 <diablo_rojo> Okay
19:28:33 * diablo_rojo is all signed up and looks at evrardjp for all other open items ;P
19:28:54 <tonyb> Audit OUI traning material to make sure it matches the current process/tools
19:29:30 <evrardjp> should I really sign up for ^ while you're such an expert on this diablo_rojo? ;)
19:29:59 <tonyb> hehe
19:30:26 <tonyb> evrardjp: You totally can ;P
19:31:11 <tonyb> We can leave that and 'Update branch creation script to add new python job template on master as part of opening a new series' for next week to assign
19:31:32 <evrardjp> I guess I will tackle https://storyboard.openstack.org/#!/story/2005706
19:31:42 <evrardjp> if I don't take the OUI training material, it seems fair
19:32:02 <tonyb> evrardjp: \o/
19:33:05 <tonyb> evrardjp: do you need any pointers?
19:33:49 <evrardjp> will check with dhellmann if necessary but that looks okay.
19:34:22 <evrardjp> we can discuss stuff on reviews anyway.
19:34:28 <tonyb> cool
19:34:49 <tonyb> I think it's mostly a project-config review but we can totally do that
19:35:24 <tonyb> I expect there will be a little setup work (unless that part of the existing goal) and then a reasonably simple bash chnage
19:35:29 <evrardjp> I thought it was building the tooling to, so it's ... more than just this
19:35:37 <evrardjp> but yeah
19:36:16 <dhellmann> the tricky bit for that is going to be telling that script the name of the next series
19:36:31 <dhellmann> it already has the name of the series for the branch being created, but that's not the name we need for the job template
19:37:29 <evrardjp> I see
19:37:54 <tonyb> dhellmann: We should have a 'future' release in series_status right? and the job name shoudl be well formed right?
19:37:55 <dhellmann> we should have all of that information in the releases repo, though, so it's just a matter of exposing it to the script
19:38:03 <dhellmann> right
19:38:15 <tonyb> dhellmann: okay
19:38:27 <evrardjp> ok
19:39:10 <dhellmann> the way I usually test changes to those project config scripts is by commenting out the "git review" or "git push" calls so they do their thing and then I can look at my local directory to see the results
19:40:06 <dhellmann> the script to be changed is in project-config: roles/copy-release-tools-scripts/files/release-tools/make_branch.sh
19:41:12 <evrardjp> I had it :)
19:41:20 <dhellmann> see the call to add_release_notes_page.sh at the end of that script for an example of a similar modification
19:41:22 <evrardjp> I was planning to do it that way, cool we are in sync
19:41:41 <dhellmann> and then there are some things in goal-tools that may be useful for adding jobs to zuul yaml files
19:41:51 <dhellmann> that's the openstack/goal-tools git repo
19:42:03 <evrardjp> I was just checking if the release repo is available as required project to be able to load that lib
19:42:34 <evrardjp> oh good thinking, I don't need to come up with code if someone already wrote that. Thanks for the pointer dhellmann!
19:43:38 <tonyb> moving on?
19:43:49 <dhellmann> the tag-releases job that runs make_branch.sh runs when things merge in the releases repo, so it's not a dependency it's the *main* repo being processed
19:44:18 <dhellmann> yeah, evrardjp and I can chat about other details later if he has questions
19:44:36 <evrardjp> dhellmann: thanks again
19:45:20 <tonyb> Thanks dhellmann
19:46:10 <tonyb> and thanks evrardjp for doign that
19:46:30 <tonyb> We're almost done
19:47:08 <tonyb> #topic weekly emails
19:47:13 <tonyb> #link https://etherpad.openstack.org/p/relmgmt-weekly-emails
19:47:21 <tonyb> Around line 295
19:47:50 <diablo_rojo> Looks like the only thing thats needed is the list of cycle-with-intermediary that havent released yet
19:48:23 <tonyb> diablo_rojo: Yeah ... and to releas-type change proposal
19:49:07 <tonyb> I'll do both of those today
19:50:15 <diablo_rojo> Cool :) Let me know if you get busy with more important work and need someone to pick it up.
19:50:32 <tonyb> diablo_rojo: Thanks
19:51:01 <tonyb> I *really* want to get it done today but if I fail I'll ping you
19:51:13 <tonyb> #topic open discussion
19:51:16 <tonyb> Anything?
19:51:20 <diablo_rojo> tonyb, sounds good.
19:51:23 <diablo_rojo> I got nothing
19:51:31 <tonyb> evrardjp: ?
19:51:44 <evrardjp> checking on the yaml stuff, just a sec
19:51:54 <tonyb> evrardjp: okay
19:52:29 <evrardjp> yeah just wondering if that's not a bazooka to kill a fly: https://review.opendev.org/#/c/672545/
19:53:01 <evrardjp> do we really need to ensure some form of presentation validation, instead of just yaml semantics validation? that was asked on the channel
19:53:39 <dhellmann> the yaml linter complains about indentation
19:53:44 <evrardjp> (it's just to know more about the context of why this was done, but the convo can happen outside the meeting)
19:53:52 <evrardjp> except that, no real item
19:53:55 <dhellmann> since yaml is white-space sensitive it seems reasonable to be consistent there
19:54:16 <evrardjp> dhellmann: yeah that sounds very strict in terms of presentation vs semantics as yaml can allow the items to not be indented
19:54:33 <dhellmann> I don't know anything about that. I didn't write the linter.
19:54:40 <evrardjp> I am fine with consistency
19:54:41 <evrardjp> ok
19:54:53 <diablo_rojo> +2 for consistency
19:54:54 <evrardjp> got it, it's just using defaults. Sounds good enough to me as a validation
19:55:08 <evrardjp> who wants to tweak a yaml linter anyway? :p
19:55:16 <dhellmann> I know that the indentation validation has caught logical errors in the content in the past
19:55:30 <dhellmann> things that should have been inside lists and weren't, or vice versa
19:55:39 <evrardjp> yeah yaml still being relying on valid indentations
19:55:49 <dhellmann> even though we give them tools, some people still modify those files by hand
19:56:21 <evrardjp> yeah I am not complaining about the presence of linting -- just about its strictness compared to yaml standards
19:56:23 * tonyb is one of those people ;P
19:56:54 <tonyb> evrardjp: for me it really helps with review if we're strict
19:56:55 <evrardjp> should ppl generate using another lib, they wouldn't care as long as it's valid. But anyway, here we decided a style guide
19:57:08 <evrardjp> tonyb: yeah that too
19:57:14 <evrardjp> also, it looks nice the way it is now
19:57:23 <tonyb> ;P
19:57:23 <evrardjp> :D
19:57:38 <dhellmann> yeah, I think PyYAML gets confused if the content isn't indented consistently, too, so it may be making assumptions that the standard doesn't require/support
19:57:56 <dhellmann> also this just cuts down on bikeshedding of formatting
19:58:44 <evrardjp> I just wanted to know because there is always someone that will ask, and I can point to this convo. Assuming future me remembers this
19:58:57 <evrardjp> sorry to have taken that long for this!
19:59:01 <diablo_rojo> evrardjp, future you can get the meeting logs
19:59:08 <dhellmann> np, it's good to share background on this stuff
19:59:20 <evrardjp> diablo_rojo: present me is not good at grepping meetings logs across years
19:59:35 <diablo_rojo> evrardjp, I dont think anyone is
19:59:37 <dhellmann> #action evrardjp to remind past-evrardjp why we chose to be strict in the linter
19:59:48 <evrardjp> hahaha
19:59:57 <tonyb> :)
20:00:42 <tonyb> anything else?
20:00:46 <evrardjp> none
20:00:55 <tonyb> Thanks everyone
20:00:58 <tonyb> #endmeeting