15:00:17 <smcginnis> #startmeeting releaseteam
15:00:18 <openstack> Meeting started Fri Dec 14 15:00:17 2018 UTC and is due to finish in 60 minutes.  The chair is smcginnis. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:22 <openstack> The meeting name has been set to 'releaseteam'
15:00:36 <ttx> o/
15:00:48 <smcginnis> ping - ttx dhellmann evrardjp diablo_rojo_phon
15:01:00 <smcginnis> #link https://etherpad.openstack.org/p/stein-relmgt-tracking Agenda
15:01:10 <dhellmann> o/
15:01:11 <smcginnis> Around line 202
15:02:04 <evrardjp> o/
15:02:10 <smcginnis> #topic Outstanding Semver patches
15:02:11 <armstrong> o/
15:02:13 <smcginnis> #link https://review.openstack.org/#/q/status:open+branch:master+topic:sem-ver
15:02:22 <dhellmann> I added this one
15:02:33 <smcginnis> dhellmann: Wanted to take it away?
15:02:34 <dhellmann> mostly I was thinking we should include a reminder in the next weekly update
15:02:51 <dhellmann> I guess I could have just added that reminder right to the etherpad...
15:02:53 <dhellmann> I'll do that
15:03:15 <smcginnis> Works for me.
15:03:19 <dhellmann> oh, well, there's no content at all in the r15 etherpad
15:03:28 <dhellmann> or r16 for that matter
15:03:38 <smcginnis> I skipped this weeks countdown since there wasn't much and it was a busy week.
15:03:50 <smcginnis> Yeah, I need to get the template in the rest of them I think.
15:04:05 <smcginnis> If you want to throw the note in there for now, I can get it formatted and updated with other things.
15:04:12 <dhellmann> ok, I'll work on that
15:04:33 <smcginnis> Some of those semver patches have had several rechecks and they keep failing from other issues.
15:04:44 <smcginnis> Literally no code changes in them, so it should be OK.
15:05:32 <evrardjp> it should be easy to review, wonder why people are not doing them?
15:05:32 <smcginnis> dhellmann: Have you heard anything internally at Red Hat about anyone missing those bumps?
15:06:18 <dhellmann> I haven't, but can ask
15:06:25 <dhellmann> I'm not sure where we are in our testing phase right now
15:06:37 <smcginnis> That's OK, I just think it's interesting that it hasn't been an issue so far.
15:06:40 <evrardjp> should we rebase them so that it shows up on top of the people's list, or ping on the ML?
15:07:05 <dhellmann> yeah, it's possible the QE team is still dealing with wrapping up rocky, so hasn't done much with the upgrade tests for stein yet
15:07:09 <ttx> pining would be less of a resource hog
15:07:15 <smcginnis> ++
15:07:16 <ttx> pinging*
15:07:29 * dhellmann pines for them, too
15:07:34 <evrardjp> lol
15:07:39 <smcginnis> :)
15:07:59 <evrardjp> ok I will ping a few ppl
15:08:05 <fungi> pining for the fjords?
15:08:17 <dhellmann> for the semver patches
15:09:31 <smcginnis> So plan is: ping some folks, add mention to next countdown email.
15:09:43 <smcginnis> I will recheck some of those failing ones too.
15:10:02 <dhellmann> notes added to https://etherpad.openstack.org/p/stein-email-r15
15:10:03 <smcginnis> Maybe getting some more +1's on some of them might raise it up in some lists.
15:10:07 <smcginnis> dhellmann: Thanks!
15:10:09 <dhellmann> if it's too long, feel free to cut it back
15:10:47 <evrardjp> I am just commenting who I pinged, it should help on seeing it 'changed' :)
15:10:51 <evrardjp> we'll see
15:11:01 <fungi> in the future, putting the sem-ver footer at the end of the commit message with the other footers is probably safer
15:11:13 <smcginnis> fungi: Safer?
15:11:43 <fungi> well, they're called "footers" because they're all expected to be in the final "paragraph" of the commit message, one-per-line
15:12:06 <smcginnis> Ah, yeah. We did some tests though and verified this works.
15:12:22 <smcginnis> But probably good in the future to try to keep it last.
15:12:22 <fungi> mixing them into the middle of the commit message isn't technically correct, though pbr seems to honor it anyway
15:12:54 <dhellmann> did we ever update the release machinery to add those automatically when we create the branches?
15:13:05 <smcginnis> Yes, I believe so.
15:13:09 <dhellmann> ok
15:13:54 <smcginnis> Can't find it right now, but will double check that after the meeting.
15:14:11 <smcginnis> #topic Release governance tracking
15:14:17 <smcginnis> ttx: Want to take this one?
15:14:19 <ttx> yes
15:14:25 <ttx> I wanted to give a quick update
15:14:46 <ttx> Been contacting all teams with corner-cases and processed most of them
15:15:12 <ttx> We'll be left with a lost of deliverables that shall be considered "new" and reviewed around milestone-2
15:15:16 <ttx> a list*
15:15:23 <smcginnis> #link https://etherpad.openstack.org/p/UChiqxElUV
15:15:53 <dhellmann> smcginnis : http://git.openstack.org/cgit/openstack-infra/project-config/tree/roles/copy-release-tools-scripts/files/release-tools/add_release_note_page.sh#n48 is the change
15:16:00 <ttx> just waiting for answers from Heat, Horizon and Kolla
15:16:22 <smcginnis> dhellmann: Thanks!
15:16:25 <ttx> Once done I'll run the script again and triplecheck
15:16:28 <smcginnis> Last line too.
15:16:36 <ttx> Will clean it up and post it too
15:17:42 <dhellmann> that's a lot of repos
15:17:54 <ttx> yeah
15:18:33 <ttx> Will create a storyboard story to track this work
15:18:59 <smcginnis> Maybe e0ne is around to take a look at the horizon ones.
15:19:52 <e0ne> ttx, I'm sorry for the delay. I'll send you response tonight
15:20:23 <smcginnis> So next steps are finalize with those few teams, recheck the data, then post it to the ML?
15:20:33 <ttx> e0ne: it's fine, not really time-sesntive :)
15:20:51 <ttx> smcginnis: https://storyboard.openstack.org/#!/story/2004616
15:21:10 <e0ne> smcginnis, ttx: we didn't release tempest plugin for rocky because there we no changes
15:21:14 <ttx> adding tasks right now
15:22:50 <smcginnis> e0ne: I think those shoud still probably be tagged even if it is the same sha as the last one. Just for tracking.
15:23:36 <ttx> that is all I needed
15:23:50 <smcginnis> #topic Moving meeting time
15:24:14 <ttx> diablo_rojo is trying to get involved but current meeting time does not help
15:24:21 <ttx> I'm free over the next hour
15:24:29 <smcginnis> So etherpad says moving one hour later, but I think Tony had posed the question of moving it completely to another day so it isn't Friday night for some.
15:24:30 <ttx> at least in winter time
15:24:36 <fungi> 7am in her vicinity
15:24:51 <e0ne> smcginnis: ok, will do it
15:25:02 <ttx> ah, hm, ok. Maybe move to one hour later for now and then discuss moving to another day ?
15:25:03 <dhellmann> I can move later in the day. I have meetings in that time slot over the next couple of weeks, but I can catch up after until those meetings are done.
15:25:03 <smcginnis> Thanks e0ne!
15:25:27 <dhellmann> we talked about tuesday, iirc
15:25:44 <smcginnis> I think I would rather find a good time slot for all/most rather than moving it around multiple times.
15:26:06 <smcginnis> Thursday would work well as far as finalizing any countdown email content.
15:26:13 <ttx> hmm Thursday 1600utc is free here
15:26:13 <smcginnis> But Tuesday would work too.
15:26:22 <ttx> Tuesday is busier
15:26:28 <evrardjp> I have conflict in this hour, so I am fine with moving later
15:26:36 <smcginnis> That Thursday timeslot would be perfect for me
15:26:41 <dhellmann> thursday 1600 wfm
15:26:50 * dhellmann wonders if it works for diablo_rojo_phon and tonyb
15:27:04 <smcginnis> Not sure if that helps Tony, but it's at least a little later for diablo_rojo_phon
15:27:10 <ttx> We likely won't get an answer. Can't be worse at least
15:27:29 <dhellmann> yeah
15:27:55 <smcginnis> I can propose a patch to switch it if folks so far think that would be a better time.
15:28:04 <ttx> ack
15:28:08 <smcginnis> Then we can use the review as a way to see if it works for most.
15:28:11 <evrardjp> We can discuss in the patch anyway
15:28:12 <dhellmann> ++
15:28:20 <dhellmann> while we're talking about meeting times...
15:28:31 <smcginnis> #action smcginnis to propose meeting time change to Thursday 1600
15:28:43 <dhellmann> evrardjp : diablo_rojo_phon and I are meeting this Monday at 1900 UTC to do some onboarding training. You're welcome to join if you like, although I know that's late.
15:28:58 <smcginnis> Oh, great!
15:29:12 <smcginnis> Just in the -release channel?
15:29:17 <dhellmann> we haven't worked out any details other than the time, so we'll probably start there
15:29:26 <ttx> hmm, I could try to be around. laptop couch tv setup probably
15:29:42 <ttx> but that works
15:29:45 <dhellmann> I was going to walk through some open reviews with her, like I did with anne
15:30:26 <smcginnis> I still hope to record some videos to post to Youtube walking through doing some reviews.
15:30:45 <smcginnis> Would be nice if we had a set of onboarding material to point people to.
15:31:10 <armstrong> @dhellmann: am also interested for the on-boarding training
15:31:16 <evrardjp> dhellmann: thanks for the invite :) Will add to agenda
15:31:33 <dhellmann> great, the more the merrier
15:31:58 <smcginnis> #topic Ansible role releases
15:32:17 <smcginnis> Who's was this?
15:32:21 <dhellmann> I just added that one
15:32:38 <dhellmann> we've had a few issues with ansible role releases in the last week because of confusion about which jobs count and where they should be set
15:32:40 <evrardjp> should I be scared?
15:32:54 <dhellmann> see https://review.openstack.org/616632 for example
15:33:13 <dhellmann> I just wanted to make sure everyone was aware, since there was travel this week
15:33:18 <smcginnis> Was this that the release jobs were defined in repo instead of in project-config?
15:33:30 <smcginnis> Saw some notes, but haven't been tracking.
15:33:30 <dhellmann> I'm not doing much to drive the fixes, other than trying to correct whatever bad advice they were given
15:34:20 <dhellmann> so this was more of an informational note for the team than anything
15:35:08 <smcginnis> Do they have the correct advice now? Or does something need to be figured out here yet?
15:35:20 <dhellmann> it's not clear that they're accepting my advice
15:35:39 <dhellmann> most of that conversation happened on the review
15:35:40 <smcginnis> Maybe evrardjp can help?
15:36:03 <dhellmann> there are 1-2 steps to fixing this
15:36:13 <dhellmann> 1. move the release job settings back into project-config
15:36:29 <dhellmann> 2. (possibly) update the release validation logic to look for the new release job for that new type of deliverable
15:36:46 <dhellmann> I don't know what jobs run when an ansible role is released so I don't know what's involved in 2
15:36:59 <smcginnis> And "look for the new release job" would be looking in the repo's .zuul.conf?
15:37:05 <dhellmann> no
15:37:14 <dhellmann> we don't want to encourage that by having the release validation look there
15:37:20 <smcginnis> I didn't think so.
15:37:27 <dhellmann> it may have a name different from the publish-to-pypi job we use for python packages
15:37:49 <dhellmann> so it's more like what we have for xstatic or puppet modules, where there's actually a different type of thing that looks for a different project template
15:38:23 <dhellmann> we would need to update this data structure: http://git.openstack.org/cgit/openstack/releases/tree/openstack_releases/project_config.py#n138
15:38:52 <dhellmann> and possibly the schema, I don't remember if we validate those values with the schema or in code
15:38:57 <evrardjp> I am curious of what they actively need -- I will ping on tripleO channel with the content of this conversation
15:39:03 <dhellmann> thanks, evrardjp
15:39:55 <dhellmann> it looks like we already support release types that don't have jobs, so if that's the case we just need to add the type
15:40:31 <dhellmann> that's all I had on that one
15:41:02 <smcginnis> #topic Open discussion
15:41:10 <smcginnis> Anything else to go over today?
15:41:20 <ttx> nope
15:41:23 <dhellmann> not from me
15:42:04 <smcginnis> OK, nothing more from me either.
15:42:11 <smcginnis> Thanks everyone for being here.
15:42:20 <dhellmann> o/
15:42:26 <smcginnis> #endmeeting