15:03:02 <smcginnis> #startmeeting releaseteam
15:03:03 <openstack> Meeting started Fri Nov  2 15:03:02 2018 UTC and is due to finish in 60 minutes.  The chair is smcginnis. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:06 <openstack> The meeting name has been set to 'releaseteam'
15:03:13 <smcginnis> Sorry for the delay.
15:03:37 <smcginnis> #link https://etherpad.openstack.org/p/stein-relmgt-tracking
15:03:40 <smcginnis> Currently around line 125
15:04:29 <ttx> o/
15:04:41 <dhellmann> o/
15:04:44 <armstrong> o/
15:04:46 <smcginnis> #topic Should we allow cycle-with-rc final releases without RC first
15:05:10 <smcginnis> #link  https://review.openstack.org/#/c/613444/
15:05:16 <smcginnis> Patch where this was noticed. ^
15:05:29 <smcginnis> #link http://git.openstack.org/cgit/openstack/releases/tree/openstack_releases/tests/test_validate.py#n3223
15:05:38 <smcginnis> I think we talked about it a little in channel.
15:05:47 <ttx> yes, I fear it's easy to miss on human review
15:06:04 <smcginnis> dhellmann: I think you confirmed my assumption that we don't enforce that in case we need to do something unusual.
15:06:30 <smcginnis> ttx: I agree. I wonder how likely it would be that we would a) want, and b) need to release something without at least a cursory RC first.
15:06:44 <dhellmann> smcginnis : I'm assuming that, too. I may just have been lazy when I wrote the validation
15:06:46 <ttx> Also I'm not sure how we'd fix it if we ended up letting one pass
15:06:58 <dhellmann> if we do have an "emergency" we can easily change the release model at the same time
15:07:39 <smcginnis> Yeah, seems to be safer if we don't rely on human eyes to notice that.
15:07:43 <dhellmann> so I think if we're concerned about it we can add the validation
15:07:58 <smcginnis> ttx: Did you want to take that action?
15:08:03 <ttx> unless it's extra impossible to test for
15:08:28 <ttx> I can take the action, unless we want it really soon
15:08:47 <smcginnis> Eh, we've gone this long. I wouldn't consider it a high priority item.
15:08:51 <fungi> what's the risk? that neutron almost tagged 14.0.0 when they didn't mean to release this early in the cycle?
15:09:28 <smcginnis> Yeah. Then if they wanted to make any significant changes for the rest of the cycle they would need to bump another major version in one cycle.
15:09:30 <ttx> at the very least it would be a violation of their release model
15:09:31 <dhellmann> fungi : yes, basically that someone would say they're going to publish release candidates and then they don't
15:09:38 <smcginnis> Which I suppose is OK, but a little different than normal.
15:09:43 * ttx creates SB story
15:10:13 <smcginnis> #action ttx to follow up with adding RC check to validation
15:10:23 <ttx> I think it's OK, IF they change to cycle-with-intermediary on the same request
15:10:44 <dhellmann> right
15:11:10 <smcginnis> That would be OK since they would then still be following the declared release model.
15:11:26 <smcginnis> #topic Summit prep
15:11:57 <smcginnis> I have slides put together for the onboarding.
15:12:02 * smcginnis goes to look that up...
15:12:23 <smcginnis> #link https://gitpitch.com/stmcginnis/presentations/master?p=Berlin2018/ReleaseTeam
15:12:30 <dhellmann> we had a slide deck in git somewhere, didn't we? did you update that or start over?
15:12:33 <smcginnis> I will likely add some more notes and tweaks there.
15:12:39 <ttx> #link https://storyboard.openstack.org/#!/story/2004239 for the previous topic
15:12:47 <smcginnis> Yeah, it was in the retired release-tools repo. :/
15:12:52 <dhellmann> I can be present in the room to help answer questions
15:12:54 <dhellmann> oh, bummer
15:13:02 <ttx> I have a conflict, last time I checked... when is it?
15:13:14 <smcginnis> That's OK, it was a useful exercise putting together a new one.
15:13:30 <smcginnis> ttx: We'll just tell attendees to direct all future questions to you.
15:13:45 <ttx> sounds fair... wait NO
15:13:49 <smcginnis> :)
15:14:33 <diablo_rojo> I'm planning on being there to learn!
15:14:43 <smcginnis> Awesome!
15:14:45 <dhellmann> oh, good, we can tell everyone to ask diablo_rojo instead
15:14:45 <diablo_rojo> Assuming I have no conflicts :/ Havent checked that yet.
15:15:06 <ttx> ah yes, I'll stuck in a "press conference"
15:15:11 <diablo_rojo> dhellmann, I'm there to learn not to teach :)
15:15:19 <smcginnis> Any suggestions for the presentation, just let me know.
15:15:22 <dhellmann> diablo_rojo : the best way *to* learn is to teach!
15:15:29 <smcginnis> I don't believe we have any other release related sessions there.
15:15:30 <ttx> dhellmann: nice try
15:15:32 <diablo_rojo> dhellmann, touche
15:15:37 <smcginnis> Anything else we need to prep for?
15:16:00 <ttx> any session worthy of our divine presence?
15:16:06 <smcginnis> Hah
15:16:45 <smcginnis> I expect to spend my time walking from session to session and not actually getting there due to hallways conversations like in Vancouver.
15:16:53 <ttx> dhellmann: if you want to see how that company used reno, come attend https://www.openstack.org/summit/berlin-2018/summit-schedule/events/22954/zuul-and-other-openstack-tools-used-at-leboncoin-the-odyssey
15:17:16 <dhellmann> ttx: yes, I spotted that one after you mentioned their name
15:17:21 <dhellmann> it's definitely on my schedule
15:17:28 <smcginnis> Oh, intersting.
15:17:44 <dhellmann> I haven't really looked through the other presentations closely, yet
15:17:54 <dhellmann> I have a bunch of forum sessions selected
15:18:04 <ttx> ok, well, if you see something we (relmgt) should probably attend, let team know
15:18:13 <smcginnis> Same here, I focused on forum sessions and will fill in with summit sessions where I can.
15:18:15 <fungi> will do
15:18:20 <ttx> although my schedule starts to be pretty full
15:19:01 <armstrong> @dhellmann: I am interested in learning Reno too
15:19:24 <smcginnis> #topic Next two meetings
15:19:41 <smcginnis> With travel starting next week and then the Summit, I think skipping is in order.
15:19:49 <dhellmann> armstrong : I'm happy to help!
15:19:53 <dhellmann> smcginnis : ++
15:20:13 <smcginnis> #info No meeting the next two weeks due to Summit travel and event
15:20:44 <armstrong> @smcginnis : are you given any special training during the summit at Berlin?
15:21:21 <smcginnis> We have a release team onboarding session. That's the only release management specific thing.
15:21:25 <dhellmann> #link https://www.openstack.org/summit/berlin-2018/summit-schedule/events/22855/release-team-project-onboarding
15:21:41 <armstrong> ok
15:21:42 <smcginnis> diablo_rojo and others will be part of a general new contributor session that is always useful too.
15:21:48 <smcginnis> #topic Open discussion
15:22:10 <smcginnis> That happens just prior to the actual Summit.
15:22:20 <armstrong> super interesting
15:22:39 <smcginnis> armstrong: Are you going to Berlin?
15:22:49 <armstrong> let me save it on my agenda right now
15:22:55 <smcginnis> Great!
15:22:56 <armstrong> Yes I am
15:23:13 <diablo_rojo> armstrong, its Upstream Institute- the day and a half long training you've already come to a few times ;)
15:23:33 <diablo_rojo> I see you RSVPed again though :)
15:23:52 <armstrong> @diablo_rojo:OK i see
15:24:12 <smcginnis> I've found it useful mentoring. Still learning things from the different questions folks ask.
15:24:31 <smcginnis> Any other meeting items to discuss?
15:25:35 <dhellmann> did we end up with any b1 tags?
15:25:42 <armstrong> I just got one of two papers I was working on accepted for SANER 2019, but I have minor corrections to submit final paper
15:25:51 * ttx looks up current reviews
15:26:00 <armstrong> OpenStack release team was my case study
15:26:18 <smcginnis> armstrong: Oh, interesting. I would be interested in seeing that.
15:26:25 <armstrong> sure
15:26:27 <smcginnis> dhellmann: We had searchlight.
15:26:49 <dhellmann> it looks like I should update list-deliverables to support that sort of query
15:26:55 <dhellmann> so far it just lists missing things
15:27:30 <dhellmann> I see horizon and searchlight with grep though
15:27:53 <smcginnis> Oh yeah, horizon too since they are still kind of a library for their plugins.
15:28:11 <dhellmann> I wonder how they'll get a beta library to install, but ok
15:28:19 <smcginnis> armstrong: Do you know if the sessions from SANER are recorded and publicly available?
15:28:43 <smcginnis> dhellmann: I try to remain ignorant with all of that. :)
15:29:09 <dhellmann> smcginnis : yeah, I'm worried they'll work around the constraints system somehow
15:29:12 <ttx> any reason to hold on https://review.openstack.org/#/c/613038/ ?
15:29:26 <armstrong> @smcginnis: Yes, its recorded but I don't know if its available for the public since its an IEEE event
15:29:44 <armstrong> but in any case, I will record  my talk
15:29:48 <dhellmann> ttx: I don't think so.
15:29:57 <ttx> pleas w+1 then
15:29:58 <smcginnis> ttx: Approved
15:30:00 <ttx> thx
15:30:21 <smcginnis> https://review.openstack.org/612850 is also ready.
15:30:30 <ttx> dhellmann: https://review.openstack.org/#/c/606862/ too
15:30:31 <smcginnis> I had it -2 so I think it didn't show up in the list.
15:31:00 <dhellmann> I'll take a look at those after the meeting
15:31:28 <ttx> smcginnis: that one is a library on a Friday, we usually don't approve those
15:31:35 <smcginnis> Yeah
15:31:52 <smcginnis> Although we've relaxed that a bit since there is the requirements checkpoint to go through too.
15:31:54 <ttx> ok, if nothing else, I would not mind getting 30 minutes extra time on this day
15:32:04 <dhellmann> wfm
15:32:13 <smcginnis> OK, thanks all!
15:32:17 <fungi> thanks smcginnis!
15:32:26 <ttx> thanks smcginnis !
15:32:27 <diablo_rojo> thanks smcginnis!
15:32:30 <smcginnis> #endmeeting