15:03:21 <dhellmann> #startmeeting releaseteam
15:03:22 <armstrong> ok
15:03:22 <openstack> Meeting started Fri Jan 26 15:03:21 2018 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:25 <openstack> The meeting name has been set to 'releaseteam'
15:03:32 <dhellmann> #link https://etherpad.openstack.org/p/queens-relmgt-tracking
15:03:43 <dhellmann> we're in week R-5 line 241
15:03:57 <dhellmann> #topic release job failures
15:04:17 <dhellmann> we had several failures yesterday as part of the log volume issue zuul had
15:04:20 <dhellmann> #link https://etherpad.openstack.org/p/6GloEgik8b
15:04:49 <dhellmann> we re-enqueued the jobs that needed to be run and they seemed to pass ok
15:05:00 <dhellmann> we have some other failures that just came in this morning
15:05:42 * ttx uses the release meeting to catch up
15:06:10 <dhellmann> #link http://lists.openstack.org/pipermail/release-job-failures/2018-January/date.html#start for the notices
15:06:19 <lbragstad> i know our review board for patches we need to land went from 42 to 31 overnight, so that's a good sign
15:06:39 <dhellmann> dmsimard is looking now and I'll join him after the meeting
15:06:53 <dhellmann> so we should hold off approving more releases until we know what's going on there
15:07:00 <ttx> ok
15:07:56 <dhellmann> #topic extending milestone deadline
15:08:11 <dhellmann> we've had quite a few gate issues this week, infra issues and bugs
15:08:22 <dhellmann> and so we've also had more than the usual number of requests to extend the deadline
15:08:48 <dhellmann> I propose that we go ahead and lock down the milestone today but allow libraries another day or two
15:08:58 <dhellmann> I guess until monday, since it's friday
15:09:07 <dhellmann> thoughts?
15:09:11 <lbragstad> does that include clients?
15:09:23 <dhellmann> yes, at this point it would almost exclusively be clients
15:09:24 <ttx> dhellmann: how far along are we with q3 tags ?
15:09:28 <lbragstad> ok
15:09:32 <dhellmann> although there's a critical bug in oslo.versionedobjects that we're tracking
15:09:34 * ttx looks up
15:09:36 <lbragstad> that's what i though, just double checking
15:10:02 <dhellmann> #link https://releases.openstack.org/queens/index.html
15:10:25 <dhellmann> looking at that without actually counting it seems like maybe 1/2 way?
15:10:27 <ttx> looks like most of the misses are in the pipe
15:11:01 <ttx> cinder is a notable exception
15:11:09 <dhellmann> cinder, glance, and heat aren't
15:11:34 <ttx> yeah
15:11:51 <dhellmann> who is the heat ptl?
15:11:57 <ttx> how likely are they to ask today ?
15:12:05 <ttx> heat = ricolin
15:12:37 <dhellmann> ricolin isn't in the release channel :-|
15:12:44 <ttx> also missing mistral
15:12:55 <ttx> he also is in a far away TZ
15:13:28 <ttx> dhellmann: we could extend the milestone to Monday, and libs to Tuesday ?
15:13:45 <dhellmann> sure, I can support that
15:13:52 <ttx> increases the chances projects will use it as a true FF
15:14:01 <dhellmann> true
15:14:03 <ttx> rather than start piling up FFEs on Monday
15:14:22 <lbragstad> what if a project has already submitted milestone 3?
15:14:30 <ttx> lbragstad: well they are fine
15:14:35 <dhellmann> #agreed extend the queens 3 milestone deadline to Monday
15:14:38 <lbragstad> can we resubmit?
15:14:48 <dhellmann> #agreed extend the client library release deadline to Tuesday
15:14:54 <ttx> lbragstad: if it's not merged yet yes
15:14:56 <dhellmann> is #agreed not a command?
15:15:01 <dhellmann> #info we agreed to extend the queens 3 milestone deadline to Monday
15:15:02 <ttx> #agree ?
15:15:26 <dhellmann> #undo
15:15:27 <dhellmann> #agree extend the queens 3 milestone deadline to Monday
15:15:27 <openstack> Removing item from minutes: #info we agreed to extend the queens 3 milestone deadline to Monday
15:15:28 <dhellmann> #agree extend the client library release deadline to Tuesday
15:15:32 <dhellmann> #info we agreed to extend the queens 3 milestone deadline to Monday
15:15:37 <dhellmann> #info we agreed to extend the client library release deadline to Tuesday
15:15:42 <ttx> dhellmann: I think #agreed is a command yes but no visual feedback
15:15:44 <dhellmann> at least one of those variations will make it into the notes
15:15:45 <dhellmann> ok
15:15:59 <ttx> yes #agreed works
15:16:21 <dhellmann> #action dhellmann to send email announcing deadline extensions
15:17:04 <dhellmann> #topic open discussion
15:17:11 <dhellmann> is there anything else to talk about today?
15:17:25 <ttx> nothing on my side
15:17:37 <ttx> dhellmann: will smcginnis be back on Monday?
15:18:19 <dhellmann> I thought he said he'd be back today but maybe I misunderstood and he was going to be in and out
15:18:54 <dhellmann> I know he was online late last night debugging some failures
15:19:27 <dhellmann> shall we go back to debugging failures in #openstack-infra?
15:19:37 <ttx> sounds good
15:19:40 <dhellmann> #endmeeting