15:00:22 <smcginnis> #startmeeting releaseteam
15:00:22 <openstack> Meeting started Fri Jan 12 15:00:22 2018 UTC and is due to finish in 60 minutes.  The chair is smcginnis. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:26 <openstack> The meeting name has been set to 'releaseteam'
15:00:30 <dhellmann> o/
15:00:32 <smcginnis> Ping list: dhellmann, dims, fungi, tonyb, lbragstad, ttx
15:00:36 <smcginnis> Morning dhellmann.
15:00:41 <lbragstad> o/
15:00:47 <ttx> oh, that time already?
15:00:48 <dhellmann> hi, smcginnis
15:01:27 <smcginnis> ttx: Time flies when you're having fun, huh? :)
15:01:35 <smcginnis> #link https://etherpad.openstack.org/p/queens-relmgt-tracking Agenda
15:01:38 <dhellmann> it's always meeting time somewhere?
15:01:48 <fungi> yeah, still trying to get caught up this morning
15:01:52 <EmilienM> o/
15:02:05 <smcginnis> Looks like we are on line 213 of the tracker.
15:02:29 <smcginnis> And looks like we have the usual suspects all here, so let's get to it.
15:02:41 <smcginnis> #topic TripleO stable/pike request
15:02:51 <smcginnis> #link https://review.openstack.org/#/c/532224/ Release review
15:03:23 <EmilienM> hi
15:03:37 <smcginnis> ttx: So you commented on there we should discuss. Do you want to bring up concerns?
15:03:54 <EmilienM> do you want me to move it as independent for Pike and starting from Queens, move it along other tripleo deliverables?
15:04:13 <dhellmann> EmilienM : what's the plan for queens? will there be a queens release during queens, or is it going to come after, too?
15:04:16 <ttx> Well, we usually do not add to a release after the fact, and creating stable/pike could be construed as that
15:04:18 <EmilienM> (please note that I woke up for you this morning :-P)
15:04:18 <smcginnis> EmilienM: Would that work for whatever workflow they need. I have to be honest, I still don't quite understand that part.
15:04:36 <dhellmann> ttx: we've said in the past it was ok to create stable branches after the fact because the names are an artifact of our testing setup
15:04:41 <ttx> so I think that's exceptional enough to warrant a discussion
15:04:55 <EmilienM> the long term plan is to release it as any other tripleo project
15:05:09 <dhellmann> but that we didn't want to include the deliverable on the pike page, which we can avoid here by moving the file to the _independent directory
15:05:28 <EmilienM> works for me for Pike
15:05:43 <dhellmann> I can work with EmilienM on that if everyone agrees?
15:05:58 <smcginnis> So release for now as independent. Then sometime before the end of the cycle do another one as an official queens deliverable.
15:05:58 <EmilienM> is it just a file copy/paste ?
15:06:06 <dhellmann> smcginnis : right
15:06:09 <ttx> dhellmann: that would work for me -- as long as it doesn't appear on the page I think it can't be misinterpreted
15:06:25 <dhellmann> EmilienM : rename the file
15:06:29 <smcginnis> Sounds like this will work for everyone. Sound good EmilienM?
15:06:32 <dhellmann> ttx: right, I think that's why we don't validate that the stable branch being created matches the deliverable filename
15:06:33 <ttx> dhellmann: alt solution being to have some kind of #do-not-show directive that would make it skipped
15:07:00 <dhellmann> sure. I think we have several of these in the independent directory, where we imported history after the fact
15:07:04 <ttx> but that is probably more complex
15:07:14 <EmilienM> sounds good to you, sounds good to me
15:07:18 <ttx> alright
15:07:27 <smcginnis> EmilienM: Cool, you can go back to bed then. :)
15:07:37 <fungi> also arguably more correct in indicating that this release was independent of the coordinated pike rlease
15:07:43 <dhellmann> EmilienM : do you want to update the patch before you go back to sleep, or should I do it for you? :-)
15:07:49 <smcginnis> fungi: ++
15:08:33 <EmilienM> ahah I'm working now :P
15:08:46 <smcginnis> That was quick.
15:09:01 <smcginnis> OK, anything more to discuss on this topic before we move on?
15:09:03 <dhellmann> ok. I'll watch for the jobs to finish and approve that after the meeting
15:09:33 <smcginnis> #topic
15:09:47 <smcginnis> #topic
15:09:59 <smcginnis> Total keyboard failure. :/
15:10:06 * dhellmann wonders where smcginnis gets his invisible e-ink
15:10:13 * lbragstad hands smcginnis another coffee
15:10:18 <smcginnis> #topic Create stable/queens specific ACL
15:10:18 <EmilienM> apparently I'm not the only one who woke up early :-P
15:10:20 <smcginnis> Whew
15:10:25 <dhellmann> \o/
15:10:29 <lbragstad> lol
15:10:30 <smcginnis> That was more difficult than it should have been :)
15:10:30 * EmilienM runs and leave
15:10:38 <smcginnis> EmilienM: Thanks!
15:10:47 <smcginnis> #link https://review.openstack.org/#/c/532205/
15:10:56 <smcginnis> I was going to ask about this, it's mentioned in PROCESS.
15:10:56 <ttx> yes I need infra to process https://review.openstack.org/#/c/532205/ so that I can move to next step (populate the group)
15:11:20 <fungi> i'll take a look
15:11:41 <ttx> It's the usual ACL dance that lets us switch stable/$foo control
15:11:43 <smcginnis> Already has a +2 from Andreas on there, so we should be in good shape.
15:11:45 <ttx> around release time
15:12:13 <smcginnis> #action fungi to review ACL change
15:12:18 <smcginnis> #topic PTG needs
15:12:34 <smcginnis> Heh, look at that. Two commands and no screw ups. I'm on a roll.
15:12:54 <smcginnis> So just wanted to bring up the PTG and see if there's anything extra we need to plan for.
15:13:08 <ttx> We have asked for 0.5 days
15:13:23 <ttx> I think the best is for us to schedule it on the spot
15:13:26 <dhellmann> that seemed to be plenty of time last time
15:13:31 <ttx> let me expand a bit on that
15:13:51 <ttx> PTGbot now has a list of rooms and tracks. Some tracks are pre-assigned to rooms
15:14:03 <ttx> but otherwise any track can book an available room
15:14:09 <ttx> and appear on the schedule
15:14:30 <smcginnis> ttx: So you think we should withdraw our request for .5 day and just utilize the ptgbot to grab a space when needed?
15:14:34 <ttx> as simple as #relmgt book Missouri-MonAM
15:15:05 <ttx> smcginnis: no, but we'll likely ask anyone who asked for 0.5 days to dynamically schedule it whenever works best for participants
15:15:16 <smcginnis> Ah, OK. That works for me.
15:15:29 <dhellmann> is that to avoid someone having to coordinate the schedule in advance?
15:15:30 <ttx> I think it's a lot better than generating arbitrary conflucts in advance
15:15:32 <smcginnis> And most of us have enough overlaps during the week that I'm sure we can handle anything else that comes up.
15:16:20 <ttx> dhellmann: yes, but also add some dynamic scheduling and retrofit "reservable rooms" into the PTGbot system
15:16:29 <dhellmann> makes sense
15:16:40 <smcginnis> I'm sure everyone is aware, but just to point out due to where things fell, the PTG week is also the Queens release week this time around.
15:16:55 <ttx> So you can book a room for an afternoon, and still use the PTGbot to brag about the current discussion topic
15:17:06 <fungi> smcginnis: didn't that happen for pike too?
15:17:21 <ttx> all you need is a "track" (team name, theme) to reserve it under
15:17:22 <smcginnis> I thought it was the week before? Maybe.
15:17:23 <dhellmann> didn't we do that on purpose?
15:17:31 <fungi> yeah ;)
15:17:41 <ttx> and we can be pretty flexible in handing those out
15:17:52 <dhellmann> nice
15:18:05 <ttx> https://git.openstack.org/cgit/openstack/ptgbot/tree/README.rst shows the new commands
15:18:08 <dhellmann> I still want to add twitter support to that bot for notifications
15:18:18 <smcginnis> Release was two weeks before PTG last time: https://releases.openstack.org/queens/schedule.html
15:18:29 <ttx> http://ptg.openstack.org/ptg.html is a bit bare right now, will be clearer once that's populated
15:18:30 <dhellmann> oh, maybe it was atlanta where it lined up the same
15:18:55 <fungi> ahh, yep, i forgot we've had two ptgs already
15:19:04 <fungi> it was ocata/atlanta
15:19:12 <dhellmann> ttx: will that page show some sort of list of "available time slots" too?
15:19:20 <ttx> yes
15:19:23 <dhellmann> k
15:19:26 <ttx> for the whole week. Tabbed interface
15:19:28 <ttx> shiny
15:19:42 <dhellmann> fancy
15:19:43 <smcginnis> Speaking of which schedule, please take a look if you haven't at the proposed schedule for any issues.
15:19:47 <ttx> aka ttx does ugly Bootstrap
15:19:50 <smcginnis> #link https://review.openstack.org/#/c/528772/ Proposed Rocky Schedule
15:20:49 <ttx> I think we should approve it at this point
15:21:07 <ttx> would reinforce that Rocky is a 6-month cycle despite the discussion we've been having
15:21:11 <ttx> since some people are still confused
15:21:12 <smcginnis> Not set it stone, so we can always alter later.
15:21:13 <dhellmann> good point
15:21:29 <dhellmann> approved
15:21:30 <smcginnis> ttx: Still no word on the next PTG?
15:21:32 <ttx> also yes, worst case scenario if the PTG4 lands in a weird spot we can adjust the later weeks
15:21:47 <ttx> smcginnis: I'm having a meeting next week to discuss the details
15:22:03 <smcginnis> OK, great.
15:22:34 <smcginnis> Worse case scenario, we have plenty of lead time to work around any weird timing issues.
15:22:38 <ttx> but at best that will mean knowing there will be one, and the target weeks, not a confirmation of the place and time
15:22:46 <smcginnis> ack
15:22:59 <smcginnis> #topic Open Discussion
15:23:08 <smcginnis> Anything else to discuss in-meeting?
15:23:16 <ttx> nothing from me
15:23:50 <smcginnis> OK, let's wrap it up then. Thanks everyone.
15:24:01 <smcginnis> #endmeeting