15:01:13 <ttx> #startmeeting releaseteam
15:01:14 <openstack> Meeting started Fri Jun  2 15:01:13 2017 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:18 <openstack> The meeting name has been set to 'releaseteam'
15:01:26 <ttx> #link https://etherpad.openstack.org/p/pike-relmgt-tracking
15:01:42 <ttx> Agenda is on week R-13 of that doc ^
15:01:55 <dhellmann> o/
15:02:08 <ttx> #topic Milestone-2 week tasks vs. team availability
15:02:28 <ttx> I'll be traveling to various places between Monday and Friday next week, which coincides with Pike-2 milestone
15:02:45 <fungi> good choice
15:02:45 <ttx> I don't think we expect any specific task beyong approving stuff
15:03:02 <ttx> dhellmann: anything special we need to do ?
15:03:26 <ttx> I'll be reviewing release requests on-and-off, just won't commit to doing my "release day" as much as usual
15:03:31 <dhellmann> I'm on a call, can we come back to this?
15:04:02 <fungi> infra team isn't planning any disruptive maintenance next week, so should hopefully be smooth on our end
15:04:04 <ttx> sure, but I fear all topics require your input :) So maybe better to just pause the meeting ?
15:04:23 <ttx> dhellmann: ping us when ready ?
15:05:23 <dhellmann> ok, I'm back, sorry
15:05:28 <dhellmann> that call always runs over a few minutes
15:05:39 <ttx> no pb
15:05:57 <dhellmann> I don't think there's anything special for the second milestone week, it's just approving the tags
15:06:01 <ttx> right
15:06:12 <dhellmann> I see you mentioned to library owners that they should be planning a release
15:06:21 <dhellmann> we may want to push on that a bit if we don't get them by next week
15:06:23 <ttx> so we should be able to survive my relative absence, as long as dims/dhellmann can cover a bit
15:06:25 <dhellmann> to make sure we have them before M3
15:06:36 <ttx> yes
15:06:44 <dhellmann> yeah, I'll be working next week for sure
15:06:53 <ttx> #topic Pike-2 TODOs update
15:07:13 <ttx> Looking at https://etherpad.openstack.org/p/pike-relmgt-plan there are a few things still open for PIKE-2
15:07:23 <ttx> * Documenting Being more relaxed about independent library releases during the freeze period (ttx)
15:07:42 <ttx> looks like you approved it, so I consider it commpleted now
15:08:01 <dhellmann> yes, I reviewed that this morning
15:08:02 <ttx> Support storyboard in openstack/releases (ttx)
15:08:10 <ttx> so this won't be completed by pike-2
15:08:25 <dhellmann> what's needed there?
15:08:27 <ttx> I fear that my "dev time" will be consumed by things like the ptgbot between now and pike-3
15:08:41 <dhellmann> is that updating stories/tasks when something is released?
15:08:45 <ttx> yes
15:08:49 <dhellmann> ok
15:09:00 <ttx> "step 3: support updating tasks in storyboard when a release is cut, like we do with leaving comments for launchpad bugs"
15:09:24 <ttx> I mean, I may end up doing it, but I can't promise anything, just too much travel in June/July
15:09:48 <dhellmann> that's a pretty focused task, maybe we can ask on the ML for a volunteer
15:10:00 <ttx> So I propose we move it to PIKE-3 and look for a volunteer
15:10:16 <ttx> I can certainly send an email
15:10:33 <dhellmann> do we have any cycle-based projects relying on storyboard
15:10:37 <dhellmann> ?
15:10:51 <fungi> the shortlist of project groups may be useful
15:10:53 <ttx> hmm, probably not
15:10:59 <fungi> #link https://storyboard.openstack.org/#!/project_group/list project groups in storyboard
15:11:14 <dhellmann> I see shade and requestsexceptions do
15:11:16 <fungi> cloudkitty, monasca...
15:11:24 <ttx> cloudkitty is milestone-based I think
15:11:31 <fungi> including their client?
15:11:39 <dhellmann> ok, they don't have storyboard set up in the releases repo
15:11:58 <ttx> no, it's intermediary
15:12:01 <fungi> oh, is that being tracked separately from where we declare it in the project-config repo?
15:12:13 <fungi> (the storyboard usage i mean)
15:12:27 <dhellmann> the deliverable file has a place to specify the storyboard id (looks like a number)
15:12:35 <fungi> ahh, got it
15:12:48 <ttx> anyway, I'll send an email asking for volunteer
15:12:49 <dhellmann> I think adding that was the first step to adding storyboard support
15:12:52 <dhellmann> ++
15:13:03 <fungi> that number isn't known until after they move to sb, so we'll need to remember to remind teams to update that in releases
15:13:09 <ttx> #action ttx to ask for volunteer to take over releases/storyboard link
15:13:31 <dhellmann> fungi : good point
15:13:43 <fungi> longer term, we might be able to use api queries against sb to figure that out instead of tracking it separately in a file
15:13:56 <ttx> #topic "High" TODOs status update
15:14:13 <ttx> there are a number of "HIGH" TODOs that are not completed yet in the plan
15:14:20 <ttx> * Consolidate the release tools that use the releases repository data in the releases repository (dhellmann)
15:14:26 <fungi> diablo_rojo_phon: ^ you might want to make a note of the discussion in that last topic
15:14:35 <ttx> dhellmann: what's left to do in there ?
15:14:58 <dhellmann> there's one more task for that, to have the team name pass through to the announce script instead of it looking the value up
15:15:13 <ttx> OK, should we target that to PIKE-3 ?
15:15:18 <dhellmann> I will spend some time on that early next week to try to get it off the list
15:15:23 <dhellmann> yeah, let's move to pike-3 though
15:15:28 <ttx> ok
15:15:44 <diablo_rojo_phon> fungi: I followed it a bit; thanks for the heads up!
15:16:04 <ttx> *Port all release tools to work under python 3
15:16:15 <ttx> again I think it's pretty close to completion
15:16:24 <dhellmann> yes, the only thing I have listed to do for that is add a unit test job
15:16:34 <dhellmann> the tools all work, we just need the test job to ensure they keep working
15:16:38 <dhellmann> I'll try to do that one today
15:16:38 <ttx> did we work around the lazr stuff ?
15:16:55 <dhellmann> oh, hmm
15:17:08 <dhellmann> the one tool to update launchpad bugs that lives in project-config still needs lazr
15:17:15 <dhellmann> everything else has been ported
15:17:30 <dhellmann> and I guess there are still tools in the release-tools repo that use lazr, too
15:17:40 <ttx> should we revise the goal to exclude that tool ?
15:17:46 <fungi> launchpadlib depends on lazr-restful right?
15:17:59 <ttx> something like that
15:18:08 <dhellmann> although https://review.openstack.org/#/c/460649/ removes launchpadlib from the release-tools requirements list
15:18:09 <patchbot> patch 460649 - openstack-infra/release-tools - remove launchpadlib from requirements list (MERGED)
15:18:16 <fungi> so probably not a lot to do about that until we finally get away from lp
15:18:25 <fungi> oh?
15:18:53 <fungi> ahh, i see
15:19:01 <dhellmann> some of the tools clearly still use it, so I think I just did that to get the tox setup to work
15:19:15 <dhellmann> we mostly don't use those tools any more
15:19:34 <dhellmann> all of the critical stuff except the announcement stuff is in project-config now
15:20:01 <fungi> got it
15:20:08 <ttx> just wondering what the next step is
15:20:11 <ttx> if there is one
15:20:22 <dhellmann> I was going to set up a python 3 unit test job
15:20:27 <ttx> ok
15:20:33 <dhellmann> now I wonder if it makes more sense to move the announce script over to project-config instead
15:20:49 <dhellmann> or even the releases repo itself
15:21:03 <ttx> and/or refine the scope of the goal so that it aligns better with what we can actually do
15:21:04 <dhellmann> either would let us use it in the list-changes job to verify that the announcement email will work properly
15:21:08 <dhellmann> or that
15:21:12 <ttx> Pike-3 ?
15:21:15 <dhellmann> I'll set up the unit test job, that's easy
15:21:25 <dhellmann> we should have a longer conversation about the other things
15:21:32 <dhellmann> should I start a ML thread?
15:21:50 <ttx> sounds like a good idea
15:22:02 <dhellmann> ok
15:22:14 <dhellmann> #action dhellmann set up py35 unit test job for release-tools repo
15:22:32 <dhellmann> #action dhellmann start ML thread about what to do with the release announce tools
15:23:15 <ttx> #topic Volunteers to run countdown email and meeting (or skip)
15:23:48 <ttx> Given my limited availability I was wondering if we still want to have meetings/ countdown email next week, and if yes if we have volunteers to run them
15:24:11 <ttx> The meeting in particular, I'll be in a likely-wifi-less highspeed train
15:24:28 <ttx> I still think a meetign would be useful
15:24:42 <ttx> since we may want to decide what to do with Pike-2 stragglers
15:24:53 <ttx> (and anyone who hasn't done their lib release yet)
15:25:09 <ttx> anyone up for chairing that in my absence ?
15:25:18 <dhellmann> I can run the meeting, if we need to have it
15:25:30 <ttx> Thx dhellmann
15:25:44 <ttx> The countdown email, i can probably send it
15:26:04 <ttx> Although we could also decide to skip it
15:26:22 <ttx> The only thing I would put in it would be Pike-2 straggelrs
15:26:38 <dhellmann> I can send a separate email just on that topic
15:26:51 <dhellmann> I'll do that Friday after the meeting, based on the discussion
15:26:57 <ttx> right, better timing
15:27:04 <ttx> OK, let's skip the countdown email then
15:27:10 <ttx> and do one the week after
15:27:12 <dhellmann> it will let me tag those projects in the subject, too
15:28:33 <ttx> #topic Open discussion
15:28:44 <ttx> Alright, anything else
15:29:06 <dhellmann> I have a series of patches to add jsonschema to the releases repo
15:29:10 <fungi> nothing for me
15:29:17 <ttx> We have a number of things blocked on stable team still. I read something about tonyb being back though
15:29:18 <dhellmann> https://review.openstack.org/#/q/project:openstack/releases+topic:use-jsonschema
15:29:30 <lbragstad> ttx: that's good news!
15:29:37 <ttx> lbragstad: that was a tweet.
15:29:56 <ttx> But I hear it's OK those days to govern using tweets
15:30:15 <lbragstad> #link https://twitter.com/tonybreeds/status/867562132820246528
15:30:35 <ttx> dhellmann: any hint on when "real soon now" actually is ?
15:30:45 <ttx> or whether he'll be able to work on stable ?
15:30:54 <dhellmann> I don't know the answer to either of those, unfortunately
15:31:10 <ttx> OK, let's patiently wait then
15:31:13 <lbragstad> we've lost a few of our stable project cores recently - so it'd be good to sync back up with tonyb at some point
15:31:15 <dhellmann> I'm not exactly sure what his role is going to be
15:31:32 <ttx> If nothing else... let's close the meeting
15:31:40 <dhellmann> that's all I had
15:31:54 <ttx> Alright. Have a great week-end (and week)
15:32:00 <lbragstad> o/
15:32:03 <dhellmann> you, too, ttx
15:32:10 <ttx> #endmeeting