15:00:23 <dhellmann> #startmeeting releaseteam
15:00:24 <openstack> Meeting started Fri Jan 27 15:00:23 2017 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:26 <ttx> o/
15:00:27 <openstack> The meeting name has been set to 'releaseteam'
15:01:11 <dhellmann> courtesy ping: ttx, dims, fungi, tonyb, stevemar, sigmavirus
15:01:23 <dims> o/
15:01:27 <sigmavirus> o/
15:01:32 <dhellmann> our agenda is under week r-4 in the etherpad
15:01:44 <dhellmann> #link https://etherpad.openstack.org/p/ocata-relmgt-tracking
15:03:18 <ttx> looks like os-*-config request is up now
15:03:19 * dhellmann finishes his call
15:03:29 <dhellmann> #topic Last minute ocata-3 requests
15:03:44 <dhellmann> I think we have requests for all of them now
15:03:52 <dhellmann> oh, not zaqar
15:04:23 <dhellmann> I also have a patch up to drop neutron-vpnaas from ocata, since that is no longer part of the neutron team's set of deliverables
15:04:32 <dhellmann> shall we go ahead and approve these?
15:04:47 <dims> +1 from me dhellmann
15:05:00 <ttx> flaper87: any news from zaqar-land ?
15:05:08 <ttx> dhellmann: go for it
15:05:11 <dhellmann> hmm, the os-*-config releases are not milestones
15:05:21 <dhellmann> EmilienM : did you mean to cut final releases of those? ^^
15:05:33 <ttx> ah!
15:06:28 <dhellmann> I've approved the trove tag
15:06:34 <ttx> EmilienM: other question, what's the deal with instack
15:06:41 <dhellmann> dims or ttx, will one of you approve the vpnaas thing
15:06:48 <ttx> I'm on it
15:06:49 <dhellmann> please
15:07:12 <dhellmann> I'll catch up with EmilienM later. He may have confused my suggestion to change release models in pike with this release
15:07:14 <ttx> done
15:07:16 <flaper87> ttx: nothing that I'maware of
15:07:27 <dhellmann> flaper87 : there's no milestone 3 release set up yet
15:07:33 <EmilienM> I'm currently in a room waiting for the doc
15:07:50 <dhellmann> EmilienM : ping me when you're done so we can discuss, please?
15:07:59 <EmilienM> Yes i will
15:08:02 <dhellmann> thanks
15:08:14 <dhellmann> #topic missing branches
15:08:34 <dhellmann> there's a list there in the etherpad, produced from the latest master set of data
15:08:38 <dhellmann> line 374
15:08:39 <ttx> instack, python-magnumclient and python-searchlightclienbt are missing the library deadline
15:09:00 <ttx> For the others I'd say we can propose the stable branch aggressively
15:09:14 <sigmavirus> magnum seems to not have a PTL candidate either
15:09:23 <dhellmann> yeah, I suspect instack is either idle or being treated as only used by tripleo -- I suggested that EmilienM change all of the release models for their deliverables to cycle-trailing for pike
15:09:23 <sigmavirus> so perhaps that team is not doing well this cycle
15:09:24 <EmilienM> #action EmilienM to figure tripleo release questions with Doug asap
15:09:48 <dhellmann> sigmavirus : ack
15:09:52 <ttx> sigmavirus: they are doing well enough, I think.
15:10:24 <ttx> just a tradition of not being very... aligned with deadlines
15:10:24 * sigmavirus shrugs
15:10:26 <dhellmann> ttx: I will send a reminder to the mailing list, but I don't want the release team to handle the branches ourselves. We need to continue to distribute this work out to the liaisons.
15:10:37 <ttx> dhellmann: your call
15:11:30 <ttx> the main concern are those three things without a release
15:11:34 <dhellmann> I've already sent at least one reminder about those libraries
15:11:37 <ttx> + zaqar
15:12:02 <dhellmann> #action dhellmann send a reminder to the mailing list for missing branches
15:12:14 <dhellmann> #action dhellmann track down flwang about zaqar release
15:13:02 <sigmavirus> dhellmann: so, if python-magnumclient is released today, I think the requirements team will still freeze it out
15:13:06 <dhellmann> at this point the missing clients will end up needing to be released as independent projects, and their requirements updates won't be allowed for ocata
15:13:08 <sigmavirus> dims: might have insight on that
15:13:17 <dhellmann> sigmavirus : no, you're likely to be right
15:13:28 <dhellmann> we'd certainly have to have that conversation, instead of it being automatic
15:13:37 <ttx> dhellmann: the missing 0b3 tag is not critical
15:13:39 <sigmavirus> I agree
15:13:50 <sigmavirus> ttx: missing the client freeze deadline though probably is
15:13:52 <ttx> (on zaqar)
15:13:53 <dhellmann> ttx: true, I'm more concerned with those libs
15:13:56 <ttx> right
15:14:09 <dhellmann> right, zaqar has 2 others so they qualify to be included in the final
15:14:17 <ttx> so if we are to do some pinging, I'd prioritize Magnum and Searlight over Zaqar
15:14:27 <dhellmann> makes sense
15:14:40 <ttx> also TripleO but EmilienM is around already
15:14:44 <dims> i can ping those two
15:14:54 <dhellmann> ttx: but what do we say to them?
15:14:55 <dims> dhellmann : give me an action item please
15:15:11 <dhellmann> dims, sure, let's figure out what to say first
15:15:18 <dims> right
15:15:19 <dhellmann> we want them to do a release, but we're going to tell them it can't be used?
15:15:26 <ttx> "You appear to be missing the deadline, please fix now"
15:15:27 <dhellmann> that is, the constraints won't be updated?
15:15:57 <ttx> we'll have to update the contraints I think
15:16:03 <dhellmann> oh, magnum has had no releases of anything so far
15:16:12 <dims> ugh
15:16:14 * ttx wonders if we should not enforce a lib release by milestone 2 to have a fallback
15:16:30 <dhellmann> ttx: yeah, that seems like a good idea
15:16:47 <dhellmann> searchlight has only missed their lib; the service and horizon plugin have b3 tags
15:16:48 <ttx> then we can say "we'll just use that if you don't get your act together"
15:17:07 <dhellmann> yeah, let's figure out that policy for pike -- maybe a ptg discussion
15:17:13 <fungi> like tag projects whether or not they're ready? seems prudent
15:17:14 <ttx> but with no release at all, we are a bit screwed
15:17:24 <ttx> dhellmann: adding to the plan
15:17:34 <dhellmann> well, we're not screwed. their project is just not part of the release.
15:17:52 <ttx> then the users are screwed
15:18:00 <ttx> not a lot better
15:18:09 <dhellmann> true
15:18:21 <dhellmann> ok, dims, is the communication clear?
15:18:31 <EmilienM> dhellmann, ttx: I'm back online (for a few) - so I sent a os-*-config patch to release final ocate and branch stable/ocata. We have zero blocker to release it now AFIK.
15:18:48 <fungi> but yeah, if they're not around to prepare to release, i doubt they're around to fix bugs caused by i either
15:18:49 <dims> dhellmann : y, will ask questions later if i think of it
15:19:05 <EmilienM> dhellmann:, ttx: "instack" is a bit special, as we are deprecating it and it has no future. I'll take care of its release today or next week
15:19:08 <dhellmann> EmilienM : the issue is some of those deliverables need milestone tags, not final releases. Unless you definitely want them to be release candidates.
15:19:23 <EmilienM> dhellmann: +1 for rc
15:19:40 <dhellmann> EmilienM : ok, we can go ahead with that, then. I'll review the patch more closely after our meeting
15:19:52 <ttx> shoudl be 0rc1 if RC
15:19:53 <EmilienM> dhellmann: thanks & sorry for confusions
15:20:13 <ttx> i.e. skip 0b3 and go direct to RC1
15:20:17 <dhellmann> ttx: yeah, that's true. EmilienM ^^
15:20:29 <dhellmann> #action dims contact magnum and searchlight ptls about missing releases for libraries
15:20:30 <ttx> in all cases requires a tag
15:20:34 <EmilienM> ok I'll update it
15:20:45 <ttx> only difference is that you can branch from 0rc1 :)
15:21:18 <dhellmann> anything else on this topic?
15:21:34 <ttx> no
15:21:41 <dhellmann> #topic team availability for RC1 tagging
15:21:52 <dhellmann> just like last week, I wanted to touch bases in case folks are traveling next week
15:22:05 <ttx> I'll be on/off next week, can process things when I pass by
15:22:09 <dims> i am available all days
15:22:10 <dhellmann> I may be, but I'll be online for a normal work day thursday if I am.
15:22:17 <ttx> but I can't take my usual "release day"
15:22:34 <ttx> I don't expect much RC1 requests before Thursday
15:22:34 <dhellmann> ttx: I think we can cover for you. Thursday is going to be the big day.
15:22:51 <ttx> since RC1 is so early after 0b3
15:22:58 <dhellmann> right
15:23:04 <ttx> Also we should be ready to cut some slack
15:23:09 <dhellmann> and fungi already said he'd be sequestered
15:23:16 <fungi> yup
15:23:27 <dhellmann> yeah, that's going to be a pretty soft deadline next week
15:23:27 <ttx> i.e. late RC1s will happen
15:23:34 <ttx> just not a full week after
15:23:43 <dhellmann> maybe say sunday? monday?
15:24:13 <ttx> We can say Monday and catch the last ones Tuesday morning
15:24:18 <dhellmann> ok
15:24:33 <dhellmann> that's logged here, but I won't advertise it unless we end up needing it
15:24:38 <ttx> right
15:25:02 <dims> ack
15:25:19 <dhellmann> moving on then
15:25:25 <dhellmann> #topic PTG "scheduling"
15:25:42 <dhellmann> we have our list of team topics to discuss, but we also have some topics for which we're going to want to coordinate with other groups
15:25:56 <ttx> shall we have an etherpad beyond https://etherpad.openstack.org/p/pike-relmgt-plan ? Like something in common with the others ?
15:26:16 <dhellmann> I have a couple of examples in the etherpad (the usual retrospective, addressing the way we do stable releases to cut down on backlog, etc.)
15:26:32 <ttx> requirements has https://etherpad.openstack.org/p/requirements-ptg-pike (empty for now)
15:26:42 <dhellmann> I think it might make sense to either put them in a separate section of the existing planning pad, at least
15:26:56 <dhellmann> but I was more concerned about how we will coordinate the times when we'll talk about those things
15:27:15 <dhellmann> are we sharing physical space with any other groups?
15:27:31 <ttx> no, it's just a common room for requirements/stable/relmgt
15:27:39 <ttx> we could split the time more formally
15:27:52 <ttx> or meet all together
15:27:56 <dhellmann> are we going to be there for both days? I know I'm going to need to be in the python 3 goal room for at least some of that time
15:28:07 <ttx> I'm certinaly not going to be there for two days
15:28:15 <ttx> max I can do is two half-days
15:28:20 <dhellmann> ok
15:28:27 <ttx> i.e. max 0.5 day on Monday and 0.5 day on Tuesday
15:28:36 <ttx> have to attend SWG and ArchWG a bit
15:28:41 <dhellmann> right
15:28:46 <ttx> We could say we'll only be there in afternoons
15:28:46 <fungi> i expect to be in the infra room the majority of monday/tuesday (no surprise i hope)
15:29:05 <dhellmann> we've done OK the past 2 times with a single half day, but saying both afternoons may make sense
15:29:06 <ttx> lets us put the other rooms on good rails
15:29:16 <dhellmann> maybe we can plan out which topics to cover each day, too
15:29:29 <ttx> I think we should have a single etherpad for all teams
15:29:48 <ttx> the room won't be so big it can fit 3 parallel discussions at all times
15:29:54 <dhellmann> what's the limit on the usable amount of text you can put in an etherpad?
15:30:21 <dhellmann> are you suggesting keeping the notes in it, or just organizing the topic list?
15:30:29 <fungi> around a thousand lines it gets sloooow
15:30:30 <ttx> how about we do stable on Monday morning, RelMgt on Monday afternoon, Stable on Tuesday morning and all together Tuesday afternoon
15:30:45 <ttx> lets us use the last period for catching up
15:30:55 <dhellmann> that seems like a good plan
15:30:59 <dims> ++
15:31:16 <ttx> we should reach out to the others but they dfon't seem to have planned much yet
15:31:29 <ttx> I'll set up the unique etherpad and propose the time split
15:31:47 <dhellmann> #action ttx set up ptg etherpad and contact requirements and stable teams to collaborate on planning
15:32:17 <dhellmann> is there anything else we need to do to prep for the ptg?
15:32:44 <dhellmann> if not, we can move on
15:32:46 <dhellmann> #topic mascot
15:33:03 <dhellmann> the foundation team has taken our feedback on the last draft of the mascot and produced a new version
15:33:05 <dhellmann> #link old: https://dl.dropboxusercontent.com/u/7152077/release-mascot/old.png
15:33:15 <dhellmann> #link new: https://dl.dropboxusercontent.com/u/7152077/release-mascot/new.png
15:33:27 <dhellmann> I think the primary change is to the coloring
15:33:45 <dhellmann> Heidi said they looked at a "face-on" version and no one liked the results, so they didn't even share it with us
15:34:15 <dhellmann> it sounds like they're looking for approval to go with the new version and prep materials for the ptg
15:34:32 <dhellmann> any thoughts?
15:35:08 <dims> dhellmann : looks better than the old one for sure
15:35:41 <dhellmann> I'm no expert, but the coloring does look closer to what I would expect
15:36:03 <ttx> yes, at least we get the meaning now
15:36:31 <dhellmann> if we're agreed, I'll reply to heidi that this version is good
15:37:28 <dhellmann> ok, hearing no objections, I'll do that
15:37:46 <dhellmann> #action dhellmann respond to heidi's email, accepting the mascot design
15:37:52 <dhellmann> #topic open discussion
15:37:58 <dhellmann> that's all we had on the formal agenda for today
15:38:04 <dhellmann> does anyone have any other topics to raise?
15:38:17 <ttx> is there a PTl candidate for requirements ?
15:38:25 <ttx> (or stable)
15:38:33 * ttx looks up proposals
15:39:10 <dims> no to both ttx
15:39:11 <dhellmann> I asked prometheanfire about that and he said tonyb had promised to put in his nomination by the deadline but if it isn't there then prometheanfire will propose himself
15:39:16 <dhellmann> that's for requirements
15:39:23 <dhellmann> I don't know about stable
15:39:44 <ttx> nobody yet
15:39:44 <dims> mriedem and tonyb both on vacation
15:39:49 <dhellmann> yeah
15:39:54 <ttx> guess the TC might have to fix that one
15:40:15 <dhellmann> mriedem put himself up for nova again, didn't he?
15:40:37 <ttx> yes
15:40:38 <dims> yes
15:40:58 <dhellmann> that's a big enough job, I wouldn't expect him to take on stable, too
15:41:35 <dhellmann> it will be interesting to see how the discussion goes if we have no volunteers for that
15:42:22 <dhellmann> I think that's all we have for today, then
15:42:31 <fungi> it will seem reminiscent of plenty of older discussions
15:42:32 <dhellmann> enjoy the extra 17 minutes in your day!
15:42:43 <dims> :)
15:42:52 <dhellmann> fungi : exactly
15:43:02 <sigmavirus> I would run for stable but I don't think I would qualify
15:43:31 <dhellmann> sigmavirus : why not? do you do stable reviews?
15:43:33 <sigmavirus> Also, highly doubt work would give me the time to be PTL
15:43:40 <dhellmann> that's a bigger concern
15:43:43 <sigmavirus> Also, won't be at the PTG so seems silly to run for PTL
15:43:47 <fungi> i can't imagine a less qualified ptl than none at all
15:44:04 <sigmavirus> dhellmann: I do glance stable reviews. I don't have bandwidth to do them for everyone =/
15:44:08 <sigmavirus> Or to review stable releases
15:44:33 <dhellmann> ack
15:44:45 <dhellmann> ok, down to an extra 15 minutes
15:44:50 <dhellmann> have a good day, folks!
15:44:52 <dhellmann> #endmeeting