15:02:26 <dhellmann> #startmeeting releaseteam
15:02:27 <openstack> Meeting started Fri Jan 20 15:02:26 2017 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:32 <openstack> The meeting name has been set to 'releaseteam'
15:02:45 <dhellmann> this is week R-5
15:03:32 <dhellmann> our agenda is in the etherpad, as ususal
15:03:34 <dhellmann> #link https://etherpad.openstack.org/p/ocata-relmgt-tracking
15:03:48 <dhellmann> #topic review late releasing libraries
15:04:03 <dhellmann> looking in the inbox, I only see a client lib so that can wait
15:04:16 <dhellmann> and the oslo branches can be processed when harlowja +1s that patch
15:04:27 <ttx> any idea if we have cycle-with-intermediary libraries that weren't refreshed within ocata ?
15:04:28 <sigmavirus> o/
15:04:32 <ttx> and do we care ?
15:04:48 <dhellmann> ttx: so far only client libs, I sent a list to the ML today
15:05:01 <dhellmann> http://lists.openstack.org/pipermail/openstack-dev/2017-January/110582.html
15:05:23 <dhellmann> oops, forgot to courtesy ping ttx, dims, sigmavirus, fungi, stevemar
15:05:31 <ttx> everything else was refreshed at least once ?
15:05:35 <dims> o/
15:05:42 <dhellmann> ttx: yes, according to list-deliverables
15:05:52 <ttx> let's trust list-deliverables!
15:06:12 <dhellmann> all of the things that existed in newton had stub data files copied to the ocata dir, and list-deliverables produced the list in the email linked above
15:06:28 <ttx> not bad, given ocata is short and a bit low
15:06:33 <dhellmann> yeah
15:06:46 <dhellmann> I'd like to figure out a way to notice that clients aren't releasing earlier in the cycle, though
15:06:57 <dhellmann> maybe add a step to the process at milestones or something
15:07:06 <ttx> we coudl introduce a notive by milestone-2
15:07:11 <ttx> notice
15:07:15 <dhellmann> good idea
15:07:20 * ttx writes it down
15:07:39 <dhellmann> ideally we wouldn't have patches to libs go unreleased for more than a week
15:08:11 <dhellmann> because if a release breaks something, and the change is 2 months old, it's not going to be fresh in anyone's mind for debugging
15:08:25 <sdague> dhellmann: ++
15:08:38 <dhellmann> maybe a periodic job could send a list out
15:08:47 <ttx> maybe a week is a bit short, but yes
15:08:48 <dhellmann> we have the tools to produce the list
15:09:16 <dhellmann> anyway, ideas for next cycle
15:09:18 <dhellmann> moving on
15:09:20 <dhellmann> #topic team availability next week for b3 tagging
15:09:41 <dhellmann> it's not a very big concern, but I wanted to make sure I knew who would be around next week
15:09:50 <dims> i'll be around dhellmann
15:09:53 <dhellmann> I expect to be, though it's possible I'll be working remotely
15:09:58 <ttx> I'll be around
15:10:15 <dhellmann> fungi : does the infra team have someone lined up to fight fires for the feature freeze deadline?
15:10:16 <ttx> travel madness starts Saturday morning next week
15:10:18 <dims> i may be off for some time on 26th
15:10:37 <dims> ttx : where are you off to?
15:10:40 <dhellmann> dims : ack, noted
15:10:48 <ttx> so many places I can't list them all
15:10:53 <dhellmann> oof
15:10:56 <dims> safe travels :)
15:11:16 <ttx> because everyone knows January/February are the best months to travel
15:11:28 <fungi> i'll be sequestered january 29 through february 3, but am otherwise available
15:11:38 <fungi> at least up until ptg time
15:11:46 <dhellmann> "sequestered" sounds ominous
15:11:52 <ttx> but accurate
15:12:25 <dhellmann> ok then
15:12:32 <fungi> but yeah, next week you can count on me to focus on any release-blocking fires
15:12:40 <dhellmann> cool, thanks
15:12:40 <dims> thanks fungi
15:12:53 <dhellmann> ttx, I think you're up next here
15:12:55 <dhellmann> #topic Review remaining tasks in Ocata plan
15:12:58 <ttx> yep
15:13:08 <ttx> I listed the things still in Ocata plan
15:13:20 <ttx> want to discuss if they should stay there and be completed in the coming month
15:13:22 <ttx> or moved to pike
15:13:24 <ttx> or abandoned
15:13:51 <ttx> #link https://etherpad.openstack.org/p/ocata-relmgt-plan
15:14:03 <ttx> First one is Automation 7 "we need to add to the checklist for marking a release EOL to update the info on releases.o.o"
15:14:22 <ttx> ok, let's comment on the etherpad directly
15:18:05 <ttx> OK, so a couple TODOs and otherwise add to backlog for final call in ATL
15:18:12 <dhellmann> sounds good
15:18:14 <ttx> Nothing needing to be completed by EOC
15:18:24 <ttx> except the one HIGH TDO
15:18:33 <dhellmann> the pike release schedule?
15:18:35 <ttx> #action ttx to move last TODOs to Pike plan
15:18:38 <ttx> yes
15:18:40 <ttx> next topic
15:18:48 <dhellmann> yes, I'm getting questions about that more often
15:20:00 <dhellmann> is there anything else on this topic?
15:20:03 <ttx> no
15:20:06 <dhellmann> ok
15:20:09 <dhellmann> #topic open discussion
15:20:15 <dhellmann> that's all we had on the formal agenda for today
15:20:21 <dhellmann> does anyone have anything else to bring up?
15:20:22 <ttx> err no there was one more
15:20:28 <dhellmann> ?
15:20:33 <dims> we use "security-supported" on https://releases.openstack.org/, do we define it anywhere (exactly?)
15:20:41 <ttx> HIGH TODO status review - Define and publish Pike release schedule
15:20:50 <dhellmann> oops
15:20:51 <dhellmann> #undo
15:20:52 <openstack> Removing item from minutes: #topic open discussion
15:20:58 <dhellmann> #topic pike schedule
15:21:02 <ttx> So we are now 60% sure that we can have PTG2 during Sept11 week (rather than Sept18) so I think we can start working on a strawman schedule
15:21:07 <dhellmann> I misread the indentation level there
15:21:20 <ttx> in the spare time between release work next week
15:21:38 <ttx> try to see where we can make milestones fall wrt. events / holidays and all
15:21:54 <ttx> Release August 31, Ff July 27, RC1 Aug 10
15:22:00 <dhellmann> oh, good
15:22:10 <ttx> It's not sure at all though
15:22:19 <ttx> It's just that it's the most likely option at this stage
15:22:25 <ttx> used to be 40/40/20
15:22:31 <ttx> Now it's 60/40/0
15:22:48 <ttx> but I think strong enough that we can prepare something
15:23:03 <dhellmann> should we prepare copies of both schedules, or focus on 11 sept?
15:23:29 <ttx> I guess we could prepare two versions
15:23:49 <dhellmann> it's only a week, they won't be *that* different
15:23:57 <ttx> won't work on it today anyway, and might have more news early next week
15:23:58 <fungi> i have a feeling it wouldn't look too different as they're only a week offset
15:24:01 <dhellmann> ok
15:24:17 <ttx> let's just plan to spend a few minutes into strawmen next week
15:24:21 <fungi> declare an extra rc week or extra dead week or something
15:24:22 <dhellmann> let's focus on the slightly shorter schedule. no one is going to complain if we end up giving them an extra week.
15:24:46 <ttx> that is all I had
15:24:47 <dhellmann> ttx: do you want to take that on, or should I start it?
15:25:08 <ttx> I can work on it you can break it down
15:25:12 <dhellmann> ok
15:25:16 <ttx> takes two to play strawman
15:25:21 <dhellmann> ++
15:25:29 <dhellmann> #topic open discussion
15:25:35 <fungi> dims: support phases are defined (at least) in the stable branches section of the project team guide
15:25:36 <dhellmann> dims, you had a question about security-supported
15:25:38 <fungi> #link http://docs.openstack.org/project-team-guide/stable-branches.html#support-phases
15:25:44 <dhellmann> ah, yes, thanks, fungi
15:25:58 <dhellmann> we should probably link to that
15:26:05 <fungi> sgtm
15:26:16 <dhellmann> I'll throw together a patch
15:26:36 <dims> fungi : dhellmann : does "security-supported" mean phase II or III?
15:26:58 <dims> "Current stable release, security-supported" == Phase II?
15:27:02 <fungi> phase 3 is when we only support in a security capacity
15:27:11 <dims> Security-supported == Phase III?
15:27:25 <fungi> so depending on how you interpret the term, security support would be from phase 1 through 3
15:27:51 <dims> fungi : dhellmann : so we should publish phase number in the https://releases.openstack.org/ ?
15:27:53 <fungi> critical fix support is provided only in phases 1 and 2
15:27:54 <dhellmann> it would be good of the 2 sites used the same terminology
15:28:06 <dims> right
15:28:12 <fungi> yeah, i agree we should settle on one term and not use conflicting models for the same concepts
15:28:22 <dims> ++
15:28:26 <dhellmann> maybe we can update the PTG to use the more descriptive terms?
15:28:33 <dhellmann> or combine them somehow?
15:28:42 <ttx> or stop using confusing acronyms :)
15:29:10 <fungi> we should combine the project team guide with the project teams gathering
15:29:31 <dhellmann> http://www.writethedocs.org
15:29:35 <dims> LOL
15:29:49 <ttx> fungi: I thought they were the same thing
15:30:09 <dhellmann> alright, I'll take a stab at clarifying/unifying the guide and the releases site early next week
15:30:16 <dims> thanks dhellmann
15:30:27 * ttx jumps to next meeting
15:30:37 <dhellmann> I think that's it, then
15:30:42 <dhellmann> thanks, everyone!
15:31:07 <dhellmann> #endmeeting