14:12:48 <dhellmann> #startmeeting releaseteam
14:12:49 <openstack> Meeting started Fri Nov 13 14:12:48 2015 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:12:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:12:53 <openstack> The meeting name has been set to 'releaseteam'
14:13:03 <dhellmann> our agenda is near the bottom of https://etherpad.openstack.org/p/mitaka-relmgt-plan
14:13:17 <dhellmann> #topic actions from last week
14:13:24 <dhellmann> - Propose stable team split (ttx)
14:13:32 <ttx> That was proposed. I just posted a summary
14:13:50 <dhellmann> cool, I haven't seen that yet but I'll look for it
14:13:55 <ttx> I think most of the objections are mostly about skepticism that this won't change a thing, rather than opposition to the change
14:14:07 <dhellmann> that was my impression, too
14:14:26 <dhellmann> how many of the folks chiming in are actually active on stable work?
14:14:28 <ttx> Personally I think the teams are already split in effect, we just diempower them by not giving them their own identity
14:14:41 <ttx> disempower*
14:14:50 <dhellmann> I agree
14:14:57 <ttx> so setting them up as their own team can only be positive
14:15:14 <dhellmann> we need to get the folks involved to actually set up a team, though :-)
14:15:18 <ttx> The only potential negative is if they start getting wild about what they have authority over
14:15:31 <ttx> like thinking they can unilaterally expand support periods
14:15:48 <ttx> I'll just make it clear that this is a cross-project decision and needs support from Infra and QA
14:16:03 <dhellmann> right
14:16:16 <dhellmann> ok, next up
14:16:19 <dhellmann> - follow-up to reno thread on ML with instructions for multi-repo deliverable projects (dhellmann)
14:16:21 <ttx> So Erno volunteered to lead, I'm taking names
14:16:31 <ttx> I think we have enough people
14:16:41 <ttx> Coming from the stable liaisons ranks
14:16:56 <dhellmann> ah, right, Jokke_ did tell me he was going to be active on the work
14:17:05 <ttx> more deeply embedded in openstack dev than the first generation, which came from packagers
14:17:24 <ttx> (1st gen would be Daviey, apevec...)
14:17:35 <dhellmann> right
14:17:45 <ttx> so rebooting the effort could actually prove a great move
14:17:46 <dhellmann> ihar has been very active on it, too
14:18:08 <ttx> right
14:18:09 <dhellmann> stable-maint 2.0 (note the semver major version bump)
14:18:30 <ttx> ok, next topic
14:18:35 <dhellmann> - follow-up to reno thread on ML with instructions for multi-repo deliverable projects (dhellmann)
14:19:01 <dhellmann> I did that, and answered a few more questions. rollout so far has been pretty good.
14:19:21 <dhellmann> - contact stackalytics maintainers about possible breakage (dhellmann)
14:19:41 <dhellmann> it sounds like we don't need to worry, but I submitted https://review.openstack.org/#/c/244142/ just in case
14:19:48 <dhellmann> oh, and that merged
14:20:09 <dhellmann> - reschedule the meeting 1 hr later (dhellmann)
14:20:19 <dhellmann> done (and here we are)
14:20:23 <dhellmann> #topic urgent releases
14:20:33 <dhellmann> mordred suggested we find a way to flag releases that are urgent in some way, aside from using IRC. Maybe a special topic?
14:21:08 <dhellmann> pinging us in this room is good too, but he and I were not aligned in timezones and I missed his ping the first time
14:21:50 <dhellmann> toughts?
14:21:52 <dhellmann> thoughts even
14:21:54 <mordred> wee
14:22:20 <dhellmann> whatever we do, it would be good to be able to add a special section to the review dashboard
14:22:29 <mordred> yeah - my last 'priority' release wasn't THAT priority, but it did make me thnk that in a real priority there was no _good_ way to signal that
14:22:57 <dhellmann> yeah, that's a good point. I've been less responsive the last 2 weeks since the summit. That should settle down some, except we're entering US holiday season soon, too.
14:23:51 * dhellmann wonders if we lost ttx
14:23:54 <ttx> nope
14:24:17 <ttx> I think the easiest is to ping on channel
14:24:26 <ttx> me, dims, dhellmann
14:24:56 <ttx> I check IRC pings more often than topics on the reviews
14:25:24 <dhellmann> hmm, yeah
14:25:57 <dhellmann> ok, let's stick with irc pings for now and give that more thought
14:26:18 <dhellmann> #topic priority code reviews
14:26:33 <dhellmann> I have one doc review I wanted to add to this list
14:26:36 <dhellmann> - Add documentation to the project team guide for setting up release notes builds: https://review.openstack.org/244279
14:26:52 <dhellmann> I suspect we'll have more reviews in the next week or so when we start dealing with tool changes
14:27:15 <dhellmann> ttx, do you have anything open that needs attention?
14:27:31 <ttx> nope, I'm sorting out Solum
14:27:36 <dhellmann> ok
14:27:51 <dhellmann> #topic releases.openstack.org vs. docs.o.o/releases
14:28:20 <dhellmann> you brought this up in email, and I like the idea. I'm not sure how much effort is involved in moving everything, though
14:28:22 <ttx> so I proposed this because I think the releases site will become a major destination
14:28:41 <ttx> and it's really not doc
14:29:10 <dhellmann> would we move release notes under this domain, too? or just the content of the releases repository?
14:29:14 <ttx> it's also easier to communicate, since apparently a lot of people still don't know about it (including PTLs)
14:29:46 <ttx> dhellmann: both options are on the table. I don't mind if the notes end up in docs and are linked from the main site
14:30:58 <dhellmann> ok, AJaeger just finished making the publishing job for the notes work to the site where it's going now. I suppose moving them is a relatively simple config change, once we have the new domain set up.
14:31:07 <dhellmann> I could see them continuing to live in docs.o.o though
14:31:50 <dhellmann> #action dhellmann check with infra about the difficulty of moving the release repo publish site to a new domain
14:31:56 <ttx> We could also use a slightly-less doc-oriented sphinx theme
14:32:29 <ttx> i.e. less table of contents, less "releases 0.0.1.dev420 documentation"
14:32:30 <dhellmann> yes, I agree. it would be nice to have a good looking site.
14:32:38 <ttx> not urgent at all
14:32:59 <ttx> there is the question of whether we should keep the instructions there
14:33:17 <dhellmann> we could put those in the project-team-guide
14:33:18 <ttx> they sounds like they are for a different audience
14:33:21 <ttx> right
14:33:50 <ttx> anyway, that's not urgent work. But would be great to have it done for mitaka release
14:34:05 <dhellmann> ok, I'll add it to the plan
14:34:21 <dhellmann> #action dhellmann add details about moving release publishing to the mitaka plan
14:34:21 <ttx> cool, happy to help with some bots of that effort
14:34:25 <ttx> or bits
14:34:33 <dhellmann> k
14:34:41 <dhellmann> that's all I see on the agenda
14:34:45 <dhellmann> #topic open discussion
14:34:48 <ttx> short agenda++
14:35:16 <ttx> dhellmann: so I'm traveling Tuesday-Thursday
14:35:17 * Jokke_ has been lurking
14:35:36 <dhellmann> ttx: ack
14:35:39 <Jokke_> happy to hear that you're not planning to just disappear ttx
14:35:39 <dhellmann> Jokke_ : hi!
14:35:48 <ttx> I'll still be around for the TC meeting
14:36:09 <dhellmann> ok, I'll make a note to ensure I'm at the project meeting
14:36:12 <Jokke_> ttx: I was more ref to your mail around helping the stable work
14:36:28 <Jokke_> not like "It's your's now, Bye!"
14:36:47 <ttx> Jokke_: yes, I want to help in the spin off until the team stands on both its legs
14:37:24 <dhellmann> I wonder if we should ask the folks who are on that team to re-affirm that they are interested in participating?
14:37:33 <ttx> dhellmann: that's what my email is about
14:37:34 <Jokke_> perfect ... In that case I'm still willing to take the lead now when I have time to dedicate to that if community approves
14:37:46 <dhellmann> ttx: ah, ok, I'll stop suggesting things until I read that thread :-)
14:37:46 <Jokke_> dhellmann: ttx ++
14:38:06 <ttx> I want to reboot the team so that there is more of a culture of being present and active
14:38:22 <ttx> because current presence requirements fro stable-maint-core are pretty low
14:38:46 <ttx> I prefer a team of 3 active people to a team of 12 zombies
14:38:54 <dhellmann> I'd also like to be able to hand of the task of reminding projects to cut releases from stable branches, if that turns into a problem
14:39:03 <dhellmann> right
14:39:04 <Jokke_> and last thing I want to see anyone doing is piss off the sacred few who knows the voodoo of fixing gate and are using it
14:39:51 <dhellmann> agreed
14:39:58 <dhellmann> it sounds like we're done for today, then
14:40:06 <Jokke_> and the other thing I'd like to ask from you
14:40:14 <dhellmann> oops, not yet...
14:40:24 <ttx> dhellmann: they are still our team :)
14:40:41 <Jokke_> either of you have time after closing to help Fausto with the Freezer Branching?
14:41:02 <dhellmann> ttx: ?
14:41:03 <ttx> I think he is on #openstack-release asking already
14:41:17 <Jokke_> oh cool, sorry then
14:41:27 <dhellmann> Jokke_ : I gave him some guidance. I can create the branch if he needs me to do that.
14:41:52 <Jokke_> dhellmann: yeah I was looking it with him and it looks like he doesn't have the rights to do it himself
14:41:54 <ttx> dhellmann: we need to atlk about stable in our meeting since stable is still part of our project team until we spin them out
14:42:10 <ttx> anyway, I think we are done :)
14:42:15 <dhellmann> ttx: oh, right, of course
14:42:17 <Jokke_> by me thanks
14:42:22 <dhellmann> yes, I think that's it for today
14:42:25 <dhellmann> have a good weekend
14:42:29 <dhellmann> !
14:42:33 <dhellmann> #endmeeting