13:02:21 <ttx> #startmeeting releaseteam
13:02:23 <openstack> Meeting started Mon Sep 21 13:02:21 2015 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:26 <openstack> The meeting name has been set to 'releaseteam'
13:02:28 <ttx> dhellmann: o/
13:02:43 <ttx> Agenda for today at https://wiki.openstack.org/wiki/Release_Cycle_Management
13:02:52 <ttx> #topic Liberty release coordination
13:02:59 <ttx> #link https://etherpad.openstack.org/p/liberty-final-release
13:03:03 <dhellmann> o/
13:03:15 <ttx> So... We are a bit late
13:03:32 <dhellmann> :-(
13:03:53 <ttx> Chasing libs takes more time than expected, and FFEs are still up
13:04:04 <dims__> o/
13:04:08 <ttx> Let's have a look one thing at a time
13:04:27 <ttx> Oslo libs are all released and branches now
13:04:30 <ttx> branched*
13:04:41 <dhellmann> congrats, dims__ !
13:04:52 <ttx> dhellmann: Other libs... what's the status now ?
13:04:57 <dhellmann> some of the constraints for those libs need to be updated by landing https://review.openstack.org/#/c/223596/
13:05:22 <dhellmann> it sounds like zaqarclient needs a release, based on the recent discussion in #openstack-relmgr-office
13:05:30 <dims__> dhellmann: should we push out os-client-config and land that to upper constraints too? https://review.openstack.org/#/c/225520/
13:05:54 * dhellmann looks for the pastebin with unreleased lib changes
13:06:42 <ttx> dhellmann: which libs are still in a state where we can't even create the liberty branch ? I don't really mind if they do another point release before final
13:07:03 <dhellmann> I had a list, but I've lost the link, just a sec
13:07:56 <ttx> Other question, can we cut RC1s / stable branches for services /before/ we have the stable branches for all libs ? Apart from triggering a RC2 for the constraints bump when the "final" libs are in... any drawback ?
13:07:58 <dhellmann> well, to start, anything on that list starting line 73 of https://etherpad.openstack.org/p/liberty-final-release since those constraints are out of date
13:08:16 <dhellmann> but when we land that patch, all constraints will be updated
13:08:37 <ttx> I'm fine with merging it with dims+1
13:08:46 <dhellmann> ok, I'll do that right after the meeting
13:08:59 <dhellmann> we need to do the os-client-config release and bump its constraint, as dims__  pointed out
13:09:04 <ttx> I'll approve it now based on lifeless previous approval
13:09:37 <dhellmann> found it!
13:09:38 <dhellmann> #link http://paste.openstack.org/show/469795/
13:09:43 <dhellmann> etoomanytabs
13:09:48 <dims__> haha
13:09:51 <ttx> dhellmann: https://review.openstack.org/223596 approved
13:10:56 <dhellmann> python-designateclient has quite a few changes unreleased
13:11:02 <dhellmann> (line 568)
13:11:21 <ttx> novaclient might want one too
13:11:27 <ttx> (672)
13:11:42 <dhellmann> yeah, we just got one from them I thought
13:11:46 <ttx> neutronclient / zaqarclient
13:12:03 <dhellmann> the zaqar team is going to request one today
13:12:10 <ttx> dhellmann: should we block RC1s on getting all the stable/liberty branches for libs ?
13:12:15 <dhellmann> neutronclient just requested one, too
13:12:21 <dhellmann> that's odd
13:12:58 <dhellmann> ttx: hmm, I'm not sure. I don't think that's necessary, but I also think we can sort out the libs today.
13:13:27 <ttx> dhellmann: ok, let's wait until eod then
13:13:35 <ttx> and start tagging/branching services tomorrow
13:13:37 <dhellmann> does the plan call for that, though?
13:13:42 <dhellmann> sounds good
13:13:51 <ttx> the plan dates kind of hint to that.
13:14:55 <ttx> dhellmann: so you plan to have all/most libs with stable branches and converged constraints in by EOD ?
13:15:03 <dhellmann> yes, that's the goal
13:15:22 <ttx> OK. I'll have my hands full chasing down FFEs and RC1s
13:15:30 <dhellmann> ok
13:16:04 <ttx> I'll have to put the hammer down on FFEs, PTLs have been a bit too tolerant about those
13:16:20 <ttx> I guess that's the downside of no longer requiring release management control over them
13:16:58 <dhellmann> yeah, we'll get better at that, I'm sure
13:17:11 <ttx> If we manage to close FFEs and get all libs done today, we are back on track
13:17:20 <ttx> track being: tagging RC1s starting this week
13:17:51 <ttx> questions on liberty final release plan ?
13:18:36 <ttx> I'll take that as a no
13:18:38 <ttx> #topic stable/liberty point releases plan
13:18:39 <dhellmann> I think that's all clear. release and branch remaining libs today; start tagging projects tomorrow
13:19:05 <ttx> So, I wanted to discuss what's left to do to enable stable/liberty past release day
13:19:11 <ttx> there were two chnages:
13:19:33 <ttx> stable point releases: we'll be tagging on-demand
13:19:50 <ttx> since we could not get alignment on tagging every commit, that's an intermediary solution
13:19:58 * dhellmann notes the designate team reports their gate is wedged
13:20:30 <dhellmann> that makes sense
13:20:31 <ttx> we haven't communicated that much about that fallback plan, though. and Mitaka PTLs will need to know about it
13:20:40 <dhellmann> no coordinated synchronized milestones, though?
13:21:13 <dhellmann> I expect a long "here is how releases will work during mitaka" email thread for right after the summit
13:21:14 <ttx> How about we send newly elected Mitaka PTLs a release management update so that they are up to speed with recent changes ? We can draft the content this week
13:21:33 <dhellmann> sounds good
13:21:41 <ttx> The second part is reno
13:21:56 <ttx> We kinda want people to start using that ASAP once the release barnch turns into the stable branch
13:22:17 <ttx> we should start communicating about that too
13:22:28 <ttx> before release
13:22:34 <ttx> (not necessarily today)
13:22:56 <ttx> Any other things we ned to do before release/summit on that front ?
13:22:57 <dhellmann> yeah, I want to get that sphinx integration landed and then write some docs for how to use it
13:23:24 <ttx> #action ttx & dhellmann to draft a Mitaka release management update for Mitaka PTLs to read next week
13:23:27 <dhellmann> did we decide not to worry about having the release notes in the tarball?
13:23:53 <ttx> dhellmann: we decided not to worry right now
13:24:08 <ttx> I still think that would be a good addition, but we haven't those right now
13:24:17 <dhellmann> ok, sounds good
13:24:59 <ttx> dhellmann: ping me if you need help landing those last reno changes / preparing reno doc for before final release
13:25:19 <ttx> anything else on this topic ?
13:25:33 <dhellmann> ttx: if we don't need the tarball thing, I just need the existing patches to land for now. Docs still have to be written.
13:25:39 <dhellmann> I think that's it
13:25:41 <ttx> #topic Mitaka cycle-with-milestones changes (post-versioning ? unsync milestones ?)
13:25:54 <ttx> So... I propose we defer the discussion on this one to the summit
13:25:59 <dhellmann> ++
13:26:01 <ttx> I just can't focus on it enough
13:26:05 <dhellmann> same here
13:26:13 <dhellmann> let's get this release done, and then figure out those plans
13:26:17 <ttx> yep
13:26:23 <ttx> that brings us to the next topic
13:26:23 <dhellmann> we should think about it before our summit talk, though :-)
13:26:32 <ttx> #topic Release management session content brainstorming
13:26:58 <ttx> We have one fishbowl and one workroom
13:27:04 <ttx> we need to make the best use of them
13:27:14 <ttx> Let me open an etherpad
13:27:47 <ttx> #link https://etherpad.openstack.org/p/mitaka-release-management
13:31:55 <ttx> OK, that's a good start
13:32:38 <ttx> feel free to brainstorm there
13:32:54 <dhellmann> in the work room, the automation blocker on gpg keys is much more important than the refactoring, i think
13:33:16 <ttx> dhellmann, dims__: that is all I had for this meeting. Anything else
13:33:17 <ttx> ?
13:33:30 <dims__> nothing else from me ttx thx
13:33:35 <dhellmann> neutron is going to request another client release
13:33:40 <dhellmann> nova is looking
13:33:45 <dhellmann> designate is blocked
13:33:51 <dhellmann> and zaqar has requested one
13:34:03 <dhellmann> so when those are done and the designate situation is cleared up I can finish branching the libs
13:35:44 <dims__> dhellmann: sounds good
13:36:05 <ttx> alright, let's close the meeting then
13:36:06 <dhellmann> I'll go ahead and start with the other libs now
13:36:13 <ttx> #endmeeting