17:06:20 <luzC> #startmeeting refstack
17:06:20 <openstack> Meeting started Tue Oct 31 17:06:20 2017 UTC and is due to finish in 60 minutes.  The chair is luzC. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:06:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:06:24 <openstack> The meeting name has been set to 'refstack'
17:06:40 <luzC> hello, sorry for the delay
17:07:13 <luzC> anyone here for the refstack meeting?
17:07:42 <mguiney> o/
17:07:46 <mguiney> ofc
17:07:50 <pvaneck> o/
17:08:09 <luzC> #link  https://etherpad.openstack.org/p/refstack-meeting-17-10-31 agenda
17:08:40 <luzC> ok, let's get started
17:09:10 <luzC> #topic refstack-client Tempest Autoconfig
17:09:27 <luzC> #link https://review.openstack.org/#/c/489421/ spec
17:10:19 <luzC> chandankumar: are you around?
17:10:37 <mguiney> it looks like chandankumar was not going to be at the meeting, still had to update autoconfig spec
17:10:46 <mguiney> according to chatter in channel, at least :)
17:11:20 <luzC> ahh cool, thanks for the update
17:11:54 <luzC> #action chandankumar is updating the spec
17:12:31 <luzC> #link https://review.openstack.org/#/c/515494/ - Added sample tempest conf files
17:12:51 <luzC> this one was submitted by Chris
17:13:38 <luzC> he is adding tempest config file with the known config values that works for refstack
17:14:29 <luzC> **refstack-client
17:14:57 <mguiney> i definitely agree with your comment that they should be in a separate file
17:15:16 <mguiney> it makes a lot of sense, that
17:16:46 <luzC> ok, feel free to leave comments on the patchset
17:17:07 <mguiney> can do!
17:17:37 <luzC> the next 2 patches are from python-tempestconf, not directly on refstack
17:17:53 <luzC> if you have time please review them
17:18:10 <luzC> #link https://review.openstack.org/513330  - WIP Add initial .zuul file and zuulv3 devstack job
17:18:22 <luzC> #link https://review.openstack.org/#/c/515046/ - fix keystone v3 on python-tempestconf
17:18:51 <luzC> #topic zuul v3 migration
17:20:02 <luzC> I have an open to review migration documentation and submit the patches... we can revisit next week
17:20:33 <luzC> this is linked to patch under maintenance work:
17:20:38 <luzC> #link https://review.openstack.org/#/c/512936/ (zuul v3 migration)
17:20:58 <luzC> that will be the first step
17:21:12 <luzC> questions/ comments?
17:21:57 <luzC> #topic Subunit Upload
17:22:20 <mguiney> alright
17:22:29 <luzC> #link https://review.openstack.org/#/c/506826/
17:23:11 <mguiney> so we I have one change I have to make to this, but i'm hoping it's close to ready
17:23:23 <mguiney> well two, really
17:23:55 <mguiney> I will be removing the list subunit uuids in favor of a "list all subunit data"
17:24:43 <mguiney> and changing the show subunit data to take the test id of the corresponding test result, rather than the subunit uuid
17:25:45 <mguiney> the idea behind that being to make it so that the end user doesnt have to deal with as much as the details management themselves, while referencing data
17:26:08 <mguiney> and this should work because there should never really be subunit data without a corresponding test result
17:27:09 <luzC> agree
17:27:39 <luzC> sounds good to me, please add the changes and details on the spec
17:27:43 <pvaneck> I will give it another review after your next patch
17:28:23 <luzC> me too
17:28:31 <luzC> something else on this topic?
17:29:03 <mguiney> nope!
17:29:17 <luzC> #topic Result Verification Field and Update
17:29:23 <mguiney> meant to get that pushed last night, but got caught up doing trab=vel logisitcs!
17:29:32 <luzC> #link https://review.openstack.org/#/c/507695/ (disable anonymous upload)
17:31:02 <mguiney> still runiing into unit test issues on that one
17:31:31 <mguiney> i am working through and adding the apprpriate cases that will prevent that from running into issues now
17:32:11 <mguiney> because the main issue is that, of course, it has been trying to do post operations sans pubkey, which if that has been disabled, causes issues
17:32:18 <luzC> ok, try using tox command locally, once unit test is fixed push the patch for review
17:32:27 <mguiney> yep!
17:32:48 <luzC> moving on
17:32:53 <luzC> #link https://review.openstack.org/#/c/503495/ (token checking)
17:33:42 <luzC> a new patch was submitted last night
17:34:00 <luzC> I'll try to test it...
17:35:07 <luzC> #topic Maintenance work
17:36:12 <luzC> #link https://review.openstack.org/#/c/512936/ (zuul v3 migration)
17:36:45 <luzC> we briefly covered this one, feel free to review/ left comments
17:37:26 <luzC> I'll take a look at the complete migration process so expect more related patches in the near future
17:37:39 <luzC> #link https://review.openstack.org/#/c/513580/ (py35)
17:38:34 <luzC> please review it (testing it would be awesome too) :)
17:39:13 <luzC> #topic API Docs
17:39:38 <luzC> I carried this topic from last agenda, but I don't recall what it is about
17:40:06 <luzC> pvaneck: mguiney: do you know?
17:40:26 <mguiney> I think it pertained to the zuul stuff, mostly
17:40:30 <pvaneck> hmm, not entirely sure
17:40:37 <mguiney> the upgrades/migration stuff
17:41:12 <mguiney> oh wait wati
17:41:19 <mguiney> i remember
17:41:28 <mguiney> i thought we were still on migration stuff
17:42:07 <mguiney> ok so, though we have the specs, which are useful, we don't really have dinalized api documentation
17:42:45 <mguiney> its been on my backburner for a while now, because there always seems to be higher priority tasks
17:43:15 <mguiney> but i'm going to be on a plane for 15 hours, and api writing is great offline work, so i may have a little time to put into those
17:44:11 <luzC> ah ok, is it for the full Refstack API or just the subunit upload changes?
17:44:24 <mguiney> full refstack api
17:45:04 <mguiney> because it would be handy to have a unified source
17:45:29 <mguiney> *docs writing, not api writing
17:45:29 <luzC> sounds really, thanks mguiney
17:45:42 <luzC> **really good
17:46:01 <mguiney> i'm kinda psyched about it
17:46:33 <mguiney> the api isnt awful to figure out as is, but as a newcomer to just about everything, i am a big bg fan of thorough documentation
17:48:12 <luzC> yes, I agree, and in general I think documentation can be improved, for instance separate or rename current content into install guide, contributors guide, end user guide
17:48:25 <luzC> etc
17:48:38 <luzC> ok, anything else on this topic
17:48:39 <luzC> ?\
17:48:59 <mguiney> noop
17:50:13 <luzC> ok, next week is Sydney summit
17:50:32 <luzC> #topic Sydney Summit
17:51:10 <luzC> any comment?
17:51:34 <luzC> mguiney you are attending right?
17:51:42 <mguiney> yep!
17:52:05 <pvaneck> how long is the plane ride?
17:52:41 <mguiney> 15 hours
17:53:26 <pvaneck> aah, not tooo bad
17:53:26 <mguiney> a solid chunk of which i plan to sleep through, but should still be a long ride
17:53:38 <mguiney> heh. long for me, though
17:53:49 <luzC> I think is way too long
17:54:50 <mguiney> i'm pretty hype about it, to be honest
17:55:10 <mguiney> i love traveling in general, flying included
17:55:16 <luzC> :-)
17:55:48 <luzC> ok, I guess next week meeting will be canceled
17:56:42 <luzC> pvaneck, mguiney: any other open item? anything to discuss?
17:56:54 <mguiney> nope, not that I am aware of
17:58:05 <luzC> if not, I think we can close the meeting
17:58:20 <luzC> mguiney enjoy the summit and have a safe trip
17:59:11 <mguiney> thank you, i'll try :)
17:59:11 <luzC> hopefully will talk again Nov 12 (in 2 weeks
17:59:15 <pvaneck> yep, enjoy sydney
17:59:18 <pvaneck> sounds good
17:59:23 <luzC> #endmeeting