19:00:21 <catherine_d|1> #startmeeting refstack
19:00:22 <openstack> Meeting started Tue Aug  1 19:00:21 2017 UTC and is due to finish in 60 minutes.  The chair is catherine_d|1. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:25 <openstack> The meeting name has been set to 'refstack'
19:01:54 <mguiney> o/
19:02:02 <catherine_d|1> mguiney: Hello
19:02:05 <mguiney> hello!
19:02:38 <pvaneck> o/
19:02:42 <catherine_d|1> #link meeting agenda and notes,  https://etherpad.openstack.org/p/refstack-meeting-17-08-01
19:02:45 <luzC2> o/
19:03:07 <catherine_d|1> Alright let's start
19:03:42 <catherine_d|1> #topic Run tool to update the verification field
19:03:44 <mguiney> (i may have to duck out for a minute or two, wrangling volunteers at a conference
19:03:46 <mguiney> )
19:04:00 <catherine_d|1> ok.
19:04:20 <pvaneck> whoa, which conference?
19:04:27 <mguiney> DevOpsDays PDX
19:04:54 <mguiney> (hype)
19:05:33 <catherine_d|1> mguiney: seems like JWT token is working for you in Python 3.x?
19:05:55 <catherine_d|1> and not 2.7?
19:05:56 <mguiney> yes it is!
19:06:16 <mguiney> but the pyjwt command works in 2.7
19:06:29 <catherine_d|1> It worked for me in 2.7 before but I will check again
19:06:54 * mguiney nods
19:06:54 <hogepodge> o/
19:07:07 <catherine_d|1> pvaneck: did you test JWT earlier?
19:07:55 <pvaneck> yea, a while back
19:08:05 <pvaneck> worked for me then
19:08:25 <pvaneck> though i think i used jwt3
19:08:33 <catherine_d|1> ic
19:08:35 <mguiney> it might just be something weird about my environment. I can recheck, but it did follow the setup steps verbatim
19:09:01 <catherine_d|1> let me double check againon 2.7
19:09:58 <catherine_d|1> will add message on the patch about  testoing on 2.7 result
19:10:06 <mguiney> k, thank you
19:10:16 <mguiney> i can adjust, if need be, of course :)
19:10:19 <catherine_d|1> mguiney: were you able to run the update now that jwt works
19:10:26 <mguiney> yes! i was
19:10:47 <mguiney> i still need to run it in prod, but the testing went very well and so it is ready to go
19:10:55 <catherine_d|1> mguiney: that is great!
19:11:10 <mguiney> i do of course plan on backing up the original, just in case
19:11:24 <catherine_d|1> mguiney: +++
19:11:35 <catherine_d|1> mguiney: thank you
19:11:51 <catherine_d|1> anything else on thiis topic?
19:12:19 <mguiney> nope!
19:12:34 <catherine_d|1> alright
19:12:40 <catherine_d|1> #topic subunit result files upload
19:13:56 <mguiney> testing with subunit2sql was successful in that, with the modification mtreinish suggested, it is absolutely possible to create the tables in the existing db
19:14:11 <catherine_d|1> great
19:14:36 <mguiney> but because it requires a different alembic table name, this is a distinction that will need to be made while setting up refstack server
19:15:02 <mguiney> so existing installs will be unable to use subunit2sql internally.
19:15:51 <catherine_d|1> mguiney: you mean we need to merge mtreinish's patch first ?
19:16:22 <mguiney> I believe he mentioned that it might break existing installs
19:16:44 <catherine_d|1> so I tested that patch with new install ...
19:16:49 <mguiney> and that we would need to include it as a configuration option
19:17:01 <catherine_d|1> will test with existing install scenario later today or tomorrow
19:17:24 <catherine_d|1> pvaneck: will take a look too ...
19:17:26 <mguiney> excellent. I can also do some testing, but if it doesnt break existing installs that would be even better!
19:18:12 <catherine_d|1> and we may also add a new revision
19:19:28 <mguiney> excellent. I think that the concern was because we are renaming refstack's version table rather than the existing tool, anything that uses that table would end up pointing to the wrong table/a nonexistant table, in existing installs
19:19:52 <mguiney> which would require an adjustment, but then we would have to migrate the data from old table to new, etc.
19:20:00 <catherine_d|1> assuming that the new tables will be created in RefStack DB ... are you able to move on to the next task?
19:20:10 <mguiney> yes!
19:20:40 <mguiney> I am ready either way, because the implementation differences are fairly minor between the two options
19:20:53 <mguiney> its just a matter of making a decision
19:21:01 <catherine_d|1> excellent
19:22:01 <catherine_d|1> I don;t think we need to go through the high level tasks again today ... let's us know if you have questions
19:22:10 <mguiney> awesome, thank you!
19:22:34 <catherine_d|1> moving on
19:22:44 <catherine_d|1> #topic Pending reviews
19:22:48 <catherine_d|1> #link     Add token auth instructions to documentation (  https://review.openstack.org/#/c/487228/  )
19:23:22 <catherine_d|1> I will retest witj Python 2.7 and give update ... it should be ready to go ...
19:23:26 <luzC2> I'll take a look
19:23:39 <catherine_d|1> luzC2: thx ..
19:24:01 <mguiney> cool. I can make whatever adjustments are needed, itll be good to have this officially in docs :)
19:24:03 <catherine_d|1> it just that the default for refstack-client is Python 2.7
19:24:46 <catherine_d|1> so the user will have to switch to Python 3.x to use jwt ..
19:25:32 <catherine_d|1> ideal case is that jwt work for both .. now that luzC2: has a patch to add 3.x support to refstack-client
19:25:33 <mguiney> would it be a problem to just use pyjwt?
19:25:42 <mguiney> given that it is installed anyways?
19:25:56 <catherine_d|1> mguiney: that may make sense
19:26:58 <luzC2> in theory both 2.7 and 3.5 should work, I haven't test pyjwt
19:27:07 <luzC2> I'll give it a try later this week
19:27:55 <catherine_d|1> mguiney: was pywt require at refstack-client ?  I think we only have that in refstack
19:28:13 <mguiney> ahhh yes, i think it may be, actually
19:28:51 <catherine_d|1> it is OK if you put that as a requirement in refstack-client if it makes senses ..
19:29:11 <catherine_d|1> let's wait for luzC2: and my tests then we can decide
19:29:39 <catherine_d|1> mguiney: meanmwhile this should not be a blocker for you right?
19:29:58 <mguiney> it should not be, no
19:30:09 <catherine_d|1> mguiney: great
19:30:21 <mguiney> it's fairly minor, just a thing users of the token tooling might have trouble with
19:30:32 <mguiney> (minor to my purposes, i mean)
19:31:08 <catherine_d|1> #action luzC2: catherine_d|1: test jwt in 2.7 and 3.x environments
19:31:26 <catherine_d|1> #link     Add python35 support  (  https://review.openstack.org/#/c/483999/  )
19:31:56 <catherine_d|1> luzC2: I finnally can test iton a Ubuntu env ... looks good
19:33:15 <catherine_d|1> luzC2: will you consider to make update per chandan's suggestion?
19:33:36 <luzC2> yes... I was on it, I'll update ptch today
19:33:46 <luzC2> *patch
19:33:51 <catherine_d|1> luzC2: thx
19:34:33 <catherine_d|1> #link     Switch to refstack-client binary and some cleanup (  https://review.openstack.org/#/c/486910/  )
19:34:44 <catherine_d|1> this one just merged
19:35:00 <catherine_d|1> #link     WIP: Set a custom alembic_version for refstack (  https://review.openstack.org/#/c/487185/ )
19:35:34 <catherine_d|1> We discussed this already pvaneck: and catherine_d|1: will run some tests
19:35:43 <mguiney> that's the one that will need to be added as an option but not a default, most likely
19:35:46 <mguiney> ++
19:36:27 <catherine_d|1> #link     Add UI support for interop schema 2.0 (  https://review.openstack.org/#/c/484625/ )
19:37:05 <catherine_d|1> pvaneck: any update?
19:37:57 <pvaneck> ah, sorry. still needs tests
19:38:14 <pvaneck> have more time this week, so i will work on it now that the schema change has been merged
19:38:23 <catherine_d|1> pvaneck: thx
19:39:01 <catherine_d|1> #topic Open discussion
19:39:25 <catherine_d|1> anything else to discuss ?
19:39:38 <hogepodge> Any PTG discussion?
19:40:22 <hogepodge> mguiney and I will be there
19:41:17 <mguiney> \o/
19:41:37 <luzC2> I'm not attending this time, but I'll follow the therpads
19:41:42 <luzC2> etherpads
19:42:45 <catherine_d|1> hogepodge: is it OK to use the same etherpad with Interop-wg as we did last time?
19:43:50 <catherine_d|1> and the same room too beause both groups have the same participants
19:48:17 <catherine_d|1> I wonder how many people from the RefStack and Interop-WG teams will be at PTG
19:48:59 <mguiney> what would be the best way to get an approximate headcount, do you think?
19:50:24 <catherine_d|1> so far we know that mguiney: hogepodge: is going luzC2: is not ...
19:50:32 <hogepodge> I think sharing would be good
19:51:02 <hogepodge> catherine_d|1: are you or pvaneck going to make it?
19:51:03 <catherine_d|1> I still need to request for travel approval
19:51:20 <pvaneck> I likely won't make it
19:52:47 <catherine_d|1> I guess we will know more at the Interop-wg irc tomorrow
19:52:56 <catherine_d|1> anything else to discuss?
19:55:03 <catherine_d|1> if not let's end the meeting ..
19:55:19 <catherine_d|1> thank you all
19:55:21 <catherine_d|1> #endmeeting