19:00:15 <catherineD> #startmeeting refstack
19:00:15 <openstack> Meeting started Tue Jul 18 19:00:15 2017 UTC and is due to finish in 60 minutes.  The chair is catherineD. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:18 <openstack> The meeting name has been set to 'refstack'
19:01:13 <pvaneck> o/
19:01:17 <chandankumar> \o/
19:01:34 <mguiney> o/
19:02:47 <catherineD> chandankumar: Welcome to the RefStack team !
19:02:59 <chandankumar> catherineD: Thanks :-)
19:03:21 <luzC> o/
19:03:24 <catherineD> Let's wait for a couple minutes ..
19:03:39 <catherineD> #link meeting agenda and notes,  https://etherpad.openstack.org/p/refstack-meeting-17-07-18
19:04:36 <catherineD> Alright let's start
19:04:55 <catherineD> #topic Run tool to update the verification field
19:05:09 <mguiney> currently in the middle of testing for that one
19:05:29 <catherineD> mguiney: great .. thx
19:05:58 <catherineD> Please make sure to take a copy before the real update
19:06:05 <mguiney> absolutely
19:06:12 <catherineD> Thanks
19:06:20 <catherineD> #topic subunit result files upload
19:06:53 <mguiney> there actually are a few things i wanted to bring up rgarding this one
19:07:07 <catherineD> chandankumar: please take a look at https://review.openstack.org/#/c/480298/ for background information
19:07:28 <mguiney> most importantly the way we want to manage the new data within refstack
19:07:59 <chandankumar> catherineD: sure!
19:08:41 <catherineD> first we need to decide on the formats pls see 2.1.1, 2.12, and 2.13 in the agenda
19:09:05 <catherineD> we can discuss the pro and con of each option
19:09:34 <mguiney> ah yes
19:09:43 <sslypushenko_> o?
19:09:48 <sslypushenko_> o/
19:10:37 <catherineD> sslypushenko_: Hi ... we have a new RefStack member joining us ... please meet chandankumar:
19:10:54 <catherineD> chandankumar: you are from RedHat right?
19:11:11 <sslypushenko_> Hi chandankumar! Welcome to the team =)
19:11:37 <catherineD> sslypushenko_: we are now at topic 2: subunit result files upload
19:11:45 <chandankumar> catherineD: yup, I am basically gatekeeper for tempest and its plugins for RDO and RHOS.
19:11:53 <catherineD> we are discussing the option to save the subunut data in RefStack
19:12:03 <chandankumar> sslypushenko_: Thanks :-)
19:12:56 <sslypushenko_> catherineD:  it is hart decision
19:13:03 <catherineD> chandankumar: good then you must be familiar to subunit file and subunit2SQL
19:13:19 <chandankumar> yes
19:13:51 <catherineD> sslypushenko_: absolutely ... l would like us to discuss the pro and con before making the best decision for RefStack
19:14:31 <sslypushenko_> I don't really understand benefits from saving subunit data... but looks like hogepodge  does
19:14:46 <catherineD> I trust that everyone knows why RefStack adopted to process the subunit data into a json file of on passed test for uploading to RefStack
19:15:44 <catherineD> sslypushenko_: yea we discussed a lot in the early days of RefStack/DefCore ...
19:15:46 <hogepodge> Many companies reach out to get help with their tests, this gives me a place to receive that which is common and won't get lost like in email
19:16:19 <catherineD> but for today ... we already decide to implement it ... so we need to discuss the best way for implementation
19:16:30 <hogepodge> This also allows for validation of test results. The json passed test list is really forged
19:16:47 <hogepodge> Using a service is much more secure than plain text email
19:17:17 <sslypushenko_> Basically, I'm pretty  sure that it can be done without significant changes in RefStack security policy
19:17:35 <luzC> so subunit2sql creates a DB to register the file as 1 execution plus each test case on that execution and whether or not it passed or failed... if it is used I see some duplication with current DB schema...
19:17:52 <chandankumar> I like the idea of using a service instead of saving in a file
19:17:55 <hogepodge> It's signed and transmitted over TLD, much better than email
19:17:58 <sslypushenko_> For example we can encrypt subunit data before saving
19:18:49 <sslypushenko_> I guess only Foundation admins really need access to these data
19:18:50 <luzC> but the api will still receive the file just instead of saving it, it would be processed right?
19:19:06 <catherineD> sslypushenko_: I understand ... but we have discussed this and the direction today is to save the entire subunit data not just the passed test
19:19:31 <sslypushenko_> catherineD:  that is clear
19:19:51 <catherineD> I all cases we will need to to create REST APIs ..
19:19:56 <sslypushenko_> so, lets save all the data, but in encrypted way
19:20:37 <catherineD> sslypushenko_: option is in what format do we save the data ...
19:20:53 <catherineD> in a file as is ? in DB?
19:21:07 <catherineD> if in DB separated DB or RefStack DB
19:21:11 <mguiney> I'm a big fan of storing in a db
19:21:26 <sslypushenko_> DB should work good enough
19:21:55 <mguiney> and using a separate db vs a refstack db of whether it is worth the effort to reinvent the wheel, from what i have seen
19:21:59 <catherineD> luzC: hogepodge: pvaneck: your thoughts?
19:22:37 <sslypushenko_> Object store will be more suitable  here , but we don't have such option
19:22:38 <luzC> +1 on the db
19:23:01 <catherineD> chandankumar: how about you?
19:23:02 <hogepodge> DB, we have upstream tooling for it
19:23:21 <hogepodge> I'm indifferent on single or separate
19:23:33 <chandankumar> I am good with DB, but i am not sure with which DB,
19:23:43 <catherineD> #agreed The subunit data will be saved in database
19:23:54 <sslypushenko_> +1 for separate database
19:24:05 <catherineD> +1 for separate database
19:24:38 <chandankumar> But as above said using seperate db, we need to reinvent the wheel?
19:24:51 <mguiney> +1 for separate database
19:24:52 <chandankumar> or using refstack DB we donot need to add extra stuff.
19:25:03 * chandankumar does not looked at refstack DB.
19:25:16 <catherineD> chandankumar: we don't ... this give us a path to eventually migrate to subunit2SQL
19:25:20 <mguiney> we would have to add a significant amount of tooling and 7 tables to refstack to keep it in the refstack db
19:25:35 <catherineD> mguiney: ++
19:25:40 <luzC> +1 for separate database
19:25:47 <mguiney> to use the internal db would require us to reinvent the wheel
19:26:00 <catherineD> for the DB path, it is cleaner with separated db
19:26:24 <chandankumar> Go it, +1 with seperate DB
19:26:34 <chandankumar> *got
19:26:42 <luzC> agree on having a future path to have test results only on subunit2sql db, hence somehow deprecate that from current refstack db
19:27:17 <luzC> catherineD do you refer to that wiht " a path to migrate to subunit2sql"
19:27:18 <luzC> ?
19:27:42 <catherineD> luzC: yea that is the idea .. if we are goiing to do it now .. let do it in a way that it has a migration path in thefuture
19:27:48 <catherineD> luzC: yes
19:28:20 <catherineD> the reason we do not use subunit2sql before because we only want to save passed data ...
19:28:22 <luzC> catherineD: totally agree
19:29:02 <catherineD> now that we decide to save everything it makes sense to use upstream tooling
19:30:24 <catherineD> #agreed Use subunit2SQL to save the entire subunit data in a separated db.
19:30:41 <catherineD> great .. thank you all!
19:30:44 <mguiney> excellent. I'll update the spec
19:31:07 <catherineD> This is much cleaner ...
19:31:21 <catherineD> since RefStack has a meta data table in place ...
19:32:19 <catherineD> Initiallty, we can add a key value pair to the meta data table to tie back the test in the new db to RefStack
19:32:41 <catherineD> sslypushenko_: the meta data table design comes in handy :-)
19:33:12 <catherineD> we do not need any change to the RefStack data model at this time
19:33:39 <mguiney> awesome.
19:33:41 <sslypushenko_> catherineD:  that was the main intention to have meta table)
19:34:00 <catherineD> sslypushenko_: yup ..
19:34:16 <catherineD> anything else to discuss?
19:34:49 <pvaneck> if subunit will be the primary way to upload data, should probably have a reference in the refstack.test table to the subunit2sql.test_runs table to link the two in a more direct way
19:34:52 <mguiney> that was the main matter to be discussed on this patch for the moment
19:35:23 <catherineD> pvaneck: that link will be saved in the meta table for kow as a key-value pair
19:35:40 <mguiney> i do plan on fleshing out plans for what changes will need to be made to the api, but havnt gotten there yet
19:35:56 <catherineD> pvaneck: for phase 1, it is not the primary way to upload data ... but it may be in the future
19:37:52 <pvaneck> sure
19:37:53 <catherineD> pvaneck: is it doable ? or should we go ahead adding a reference to the test table?
19:38:59 <pvaneck> both are doable, but if all test runs are going to eventually be linked to a subunit2sql test set, then should probably make the reference first class
19:39:16 <catherineD> pvaneck: agree
19:39:39 <mguiney> ++
19:39:58 <catherineD> for phase one let just do not change any data model in RefStack yet ...
19:40:08 <mguiney> can do
19:40:14 <mguiney> will update
19:41:06 <catherineD> we may learn more as time go by and when we decide to migrate we will make change at that time ... because we will need to change RefStack data model anyway ..
19:41:19 <catherineD> anything else?
19:41:48 <catherineD> alright ...
19:41:55 <catherineD> moving on
19:42:13 <catherineD> #topic Automated tempest.conf Create spec and flow chart
19:42:51 <catherineD> Daniel Mellado referred Chandan Kumar to work with us on this topic ...
19:43:48 <chandankumar> I have tried python-tempestconf tool with refstack https://gitlab.com/snippets/1668319
19:44:16 <chandankumar> I have gone through the notes mentioned here https://etherpad.openstack.org/p/refstack-pike-ptg
19:45:07 <catherineD> chandankumar: thank you
19:45:09 <chandankumar> Recently we have recently introduced os-cloud-config as well as test account files.
19:45:30 <chandankumar> as well as remove option to remove something which we donot want
19:46:25 <chandankumar> Below is the list of things which is missing from the etherpad or not decided.
19:46:44 <catherineD> one of the main reason why RefStack user has issues with tempest config is because of the env
19:47:15 <chandankumar> 1. config tool does not generate config for volume but generates for volume api extensions.
19:47:46 <chandankumar> 2. It looks for flavors if got missing it will create it
19:47:59 <chandankumar> that's it from myside
19:48:17 <catherineD> RefStack test cloud that are built and maybe customized by the provider .. a lot of the default & assumption that exist in devstack  are not applicable
19:48:24 <chandankumar> catherineD: you mean env = openstack deployment environment
19:48:29 <catherineD> yes
19:49:46 <chandankumar> catherineD: python-tempestconf really need love to satisfy the different cloud env customization
19:49:54 <catherineD> a good trial may be built a RDO env from scratch and see how the tempest.config shoudl be built
19:50:08 <catherineD> chandankumar: ++
19:51:11 <chandankumar> catherineD: we generally run tempest config tool with tripleo https://github.com/openstack/tripleo-quickstart-extras/blob/master/roles/validate-tempest/templates/configure-tempest.sh.j2#L135
19:51:30 <chandankumar> in tripleo ci against periodic tempest jobs
19:52:03 <catherineD> not all variable can be discovered ... and even that the variables are discovered .. often those may involve choices that a user need to make
19:52:27 <chandankumar> catherineD: yes, correct.
19:52:42 <catherineD> for example in an environment that have 2 fix netwoks .. which one should be used?
19:53:56 <catherineD> anyway let us review https://gitlab.com/snippets/1668319 and we can discuss some more next week
19:54:08 <catherineD> #action everyone please review https://gitlab.com/snippets/1668319
19:54:15 <chandankumar> currently if we have the multiple networks there is an options --network-id through which can specify network we want to use.
19:54:44 <chandankumar> catherineD: what are the action items from here?
19:54:51 <catherineD> chandankumar: correct ... so a human being will have to do that by editing the config file ...
19:55:29 <catherineD> for me I want to see how https://gitlab.com/snippets/1668319 works
19:56:21 <catherineD> the goal is to ease user pain when starts with RefStack test ...
19:56:46 <catherineD> those users are usually not very familiar with Tempest .
19:57:54 <catherineD> for me this is a very hard task .. thus we still do not have a good solution so far ..
19:59:04 <catherineD> we are about to run out of time ...
19:59:18 <catherineD> let's move on .. we will revisit this topic next week
19:59:25 <chandankumar> yup
20:00:01 <catherineD> everyone please review the patches listed in the pending review section
20:00:10 <catherineD> thank you all !!!
20:00:20 <luzC> bye
20:00:27 <catherineD> I am glad that we had made the decision for the subunit format
20:00:29 <mguiney> have a good day, y'all!
20:00:31 <catherineD> bye everyone
20:00:42 <mguiney> glad to have updates so i can move it forward
20:00:46 <catherineD> #endmeeting