19:00:10 <catherineD> #startmeeting refstack
19:00:11 <openstack> Meeting started Tue Jun 27 19:00:10 2017 UTC and is due to finish in 60 minutes.  The chair is catherineD. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:15 <openstack> The meeting name has been set to 'refstack'
19:00:53 <luzC> o/
19:01:06 <pvaneck> o/
19:01:17 <catherineD> hello luzC: pvaneck:
19:02:17 <mguiney> o/
19:02:35 <catherineD> mguiney: hi
19:02:51 <catherineD> Let's start
19:03:26 <hogepodge> o/
19:03:38 <catherineD> #link meeting agenda and notes,  https://etherpad.openstack.org/p/refstack-meeting-17-06-27
19:04:00 <catherineD> #topic No meeting next week
19:04:16 <catherineD> #topic Displaying RefStack documentation
19:04:47 <catherineD> Now that all the needed patches were merged ...
19:05:06 <catherineD> We target to make a tag release and update the website on Friday
19:05:31 <catherineD> #topic Tools to check whether test links in a spreadsheet are marked as verified in RefStack
19:05:51 <mguiney> patch merged!
19:06:07 <catherineD> yep ...
19:06:57 <catherineD> so all the tools are in ... I think it is time to doscuss about making the update
19:07:16 <catherineD> #topic Plan to run tool to update the verify field
19:07:57 <catherineD> before running the tools to update ... we need to make sure that we have a good backup of the database
19:08:47 <catherineD> pvaneck: hogepodge: do you think we need extra effort to make sure that we have a bacckup copy or do we just rely on the infra routine copy?
19:09:12 <pvaneck> we can double check with an infra folk
19:09:40 <catherineD> I think it is necessary because we will be touching the data ...
19:09:52 <mguiney> its better to be safe than sorry, i think
19:10:22 <catherineD> hogepodge: depending on how big the backup is ... you may want to have a copy of the backup file
19:11:45 <hogepodge> check with infra
19:11:50 <catherineD> pvaneck: who will we work with fungi: ?
19:12:09 <hogepodge> yeah, or clarkb, but I think fungi knows more about the database maintenance
19:12:46 <fungi> any infra-root sysadmin can make a on-the-spot database dump right before if you reach out to us in #openstack-infra at the desired time
19:13:19 <catherineD> fungi: thanks!  That is exactly the information we need ...
19:14:05 <mguiney> thank you!
19:14:10 <fungi> sorry not to go into additional detail, but am chairing the infra team meeting at the same time you have your refstack meeting ;)
19:14:34 <catherineD> hogepodge: mguiney: only Foundation Admin in RefStack can run the tools ... not sure who will perform it ... we need to have a backup before that
19:15:22 <catherineD> fungi: understand .. thanks for your response to the question ..
19:15:27 <sslypushenko_> o/
19:16:09 * catherineD waves to sslypushenko_:
19:18:15 <hogepodge> catherineD: megan and I can do it together
19:18:30 <catherineD> hogepodge: mguiney: also when you run the update.  do you want to create a sample spreadsheet with just a few records to test first?
19:18:55 <mguiney> i can spin up a sample spreadsheet, no problem
19:18:59 <mguiney> if needed
19:19:45 <catherineD> yea I think it may help ..
19:20:12 <mguiney> i'll take care of that, then :)
19:20:37 <catherineD> after your update .. we may want to display the verify field ..
19:21:02 <catherineD> moving on ,,
19:21:04 <catherineD> #topic Pending reviews
19:21:27 <catherineD> #link     Added Defcore additional properties waiver  https://review.openstack.org/#/c/370534/
19:22:06 <luzC> I bring it to interopwg meeting last week... waiver is going to be over 2017.08
19:22:43 <catherineD> luzC: great ... so it makes sense to abandon the patch?
19:22:54 <luzC> yes, well they said is up to us
19:24:07 <catherineD> Personally I vote for abandon it ... It does no make sense to complicate RefStack-client for a feature being used for 2 months
19:24:08 <luzC> I would prefer to abandon it at this point in time... rationale: waiver is almost over, and just a few companies using it
19:24:20 <catherineD> luzC: ++
19:24:23 <luzC> catherineD totally agree
19:25:18 <hogepodge> +1 abandon
19:25:23 <catherineD> anyone againsts abandon this patch?
19:25:45 <pvaneck> nope
19:26:05 <catherineD> #action luzC: to abandon https://review.openstack.org/#/c/370534/
19:26:20 <catherineD> #link     Switch from pycrypto to cryptography  https://review.openstack.org/#/c/476221/
19:26:34 <catherineD> everyone please review
19:26:46 <sslypushenko_> cool!
19:27:08 <catherineD> moving on
19:27:14 <catherineD> #topic Review Pike action items
19:27:48 <catherineD> There were 4 action items discussed at PTG https://etherpad.openstack.org/p/refstack-pike-ptg
19:27:58 <catherineD> we have worked on 2 of the 4
19:28:11 <catherineD> 1) Customized guideline
19:28:33 <catherineD> For this one we are waiting for the schema
19:28:47 <catherineD> 2) Update existing certified data with the verified flag
19:29:09 <catherineD> all tools are completed ... just need to run and update the data
19:29:24 <catherineD> 3) Displaying RefStack documentation
19:29:43 <catherineD> This should complete Friday when a new tag is created
19:29:57 <catherineD> #topic Automated tempest.conf Create spec and flow chart
19:30:05 <catherineD> sorry
19:30:09 <catherineD> #4) Automated tempest.conf Create spec and flow chart
19:30:41 <catherineD> we spent a lot of time discussing this topic at the PTG ... no progress so far ..
19:31:42 <catherineD> should this still be our priority?
19:32:12 <luzC> catherineD I think so... last time I checked Daniel and Gema were working on it right?
19:32:20 <catherineD> yea
19:32:41 <catherineD> if it is still our priority ... I will contact them
19:34:07 <catherineD> ah we have 5 action items from Pike PTG ...
19:34:21 <catherineD> 5) subunit result files upload
19:35:09 <catherineD> hogepodge: do we still want this feature?
19:36:32 <hogepodge> yes
19:36:49 <luzC> also I'm wondering about the old legal implications/restrictions about collecting it?
19:37:10 <catherineD> luzC: yep good point ...
19:37:29 <luzC> hogepodge: are you revisiting that? or someone else?
19:37:31 <catherineD> since the subunit is actually text file
19:37:59 <hogepodge> I don't understand any limitations. It's not available to the world at large
19:38:05 <hogepodge> tempest doesn't leak personal data
19:38:56 <catherineD> hogepodge: it does include log and if there is print statement of password for example it will show
19:39:01 <catherineD> in plain text
19:39:17 <hogepodge> showing a password in plain text is a bug
19:39:22 <hogepodge> mtreinish: right?
19:39:42 <luzC> I agree, if displayed it is a bug
19:40:08 <catherineD> password is just an example
19:40:30 <catherineD> basically any print statement will show
19:41:20 <hogepodge> in my opinion, refstack is too easily cheated without data to back it up, and this isn't sensitive data
19:41:30 <hogepodge> and right now, it would be voluntary
19:41:58 * mguiney nods
19:42:08 <mguiney> makes a lot of sense, tbh
19:42:47 <hogepodge> and the data would be private, under the standard rules. it's not publicly available, and would help us in debugging and in making sure vendors remain honest.
19:43:37 <luzC> my only question is if it just a design preference or if refstack would need an actual legal disclaimer or something? and if it is needed who provides it?
19:43:39 <catherineD> hogepodge: luzC: do we just make the decision here or do we need to check with someone else?
19:46:10 <hogepodge> I don't see any reason to not spec the feature out
19:46:37 <luzC> I agree with Chris about the usefulness of the file, and that it does not contain private data
19:46:48 <luzC> not sure about the decision
19:46:58 <luzC> hogepodge: +1
19:46:59 <catherineD> luzC: hogepodge: on day one (by Rob, Josh, David ..  the decision to create the JSON file is exactly to not have any risk of exposing vendor data unnecessary  ..
19:47:03 <luzC> a spec sounds good
19:47:50 <hogepodge> it was a bad decision imo, and it should be revisited
19:47:53 <catherineD> if it is time to change, my question is ... do we just make decision here or do we need to check with someone else ... at the minimum Interop WG?
19:47:59 <sslypushenko_> catherineD:  I still think that it makes sence
19:48:13 <hogepodge> yeah, interopwg is the place to check in on this
19:48:19 <catherineD> sslypushenko_:  +1
19:48:36 <catherineD> yea let's do that ... then we can procedd ..
19:48:39 <sslypushenko_> Definitely, it needs wide discussion
19:49:16 <hogepodge> I know from experience that the test results can not be trusted without context.
19:49:37 <catherineD> #action Check with Inter WG to see whether there is any concern if RefStack starts to collect subunit data file
19:50:04 <catherineD> anything else on this topic?
19:50:53 <catherineD> alright moving on ..
19:51:02 <catherineD> #topic Open discussion
19:51:27 <catherineD> is there any other topic anyone want to bring up?
19:52:55 <mguiney> just to review:
19:53:08 <mguiney> what are the planned actionable steps for this next week?
19:54:00 <catherineD> 1) update the data ... 2) check with Interop WG on subunit file upload
19:54:59 <mguiney> excellent, thank you
19:55:24 <mguiney> just wanted to make sure I wasn't missing any of the immediate future steps :)
19:56:14 <catherineD> tool to upload the subuni file will be the next task if we get the green light
19:56:54 <catherineD> mguiney: thanks for asking ...
19:57:04 <catherineD> anything else ?
19:57:48 <catherineD> hearing nothing.  I think we can close up for the day
19:57:59 <catherineD> thank you all!
19:58:12 <mguiney> have a good day, y'all!
19:58:25 <catherineD> #endmeeting