19:00:26 <catherineD> #startmeeting refstack
19:00:28 <openstack> Meeting started Tue Apr 11 19:00:26 2017 UTC and is due to finish in 60 minutes.  The chair is catherineD. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:33 <openstack> The meeting name has been set to 'refstack'
19:00:42 <mguiney> hello all!
19:00:51 <pvaneck> o/
19:00:53 <catherineD> mguiney: hi
19:01:15 <catherineD> #link meeting agenda and notes,  https://etherpad.openstack.org/p/refstack-meeting-17-04-11
19:02:53 <catherineD> should be a short meeting today ....
19:04:35 <catherineD> let's start ...
19:04:51 <catherineD> #topic Displaying RefStack documentation
19:05:17 <catherineD> #topic Hosting at RefStack
19:05:47 <catherineD> So the spec merged ... next step is implementation
19:05:52 <pvaneck> yea, i will put the patches together to get the docs on the about page
19:06:16 <catherineD> pvaneck: great thanks ...
19:06:19 <sslypushenko_> o/
19:06:27 <mguiney> o/
19:06:59 <catherineD> sslypushenko_: hi ... agenda ... https://etherpad.openstack.org/p/refstack-meeting-17-04-04  .. should be a short meeting today ...
19:07:04 <sslypushenko_> thx!
19:07:24 <catherineD> #topic Hosting at OpenStacl doc site
19:07:48 <catherineD> This is completd   Thanks to luzC:
19:08:29 <catherineD> #link RefStack doc at OpenStack developer site https://docs.openstack.org/developer/refstack/
19:08:57 <catherineD> moving on ...
19:09:09 <catherineD> #topic Update existing certified data with the verified flag
19:09:17 <mguiney> new patch pushed!
19:09:29 <catherineD> mguiney: thanks!
19:09:45 <catherineD> everyone please review this new patch ...
19:10:02 <mguiney> yoyou can now use the default name specified in the rst, or use the --file flag to supply your own filename
19:10:08 <mguiney> *you
19:10:25 <mguiney> which is just a matter of convenience, but i thought i'd at it in while I was at it
19:10:53 <catherineD> mguiney: that is great ...
19:11:37 <mguiney> cool! thank you for taking the time to review, y'all!
19:11:46 <catherineD> This script now taking a CSV as input, could you descrive the columns (fields) of the csv somewhere as comment?
19:12:23 <catherineD> descrive --> describe
19:13:05 <catherineD> I will review some more after this meeting ..
19:13:38 <pvaneck> i will test it locally as well
19:14:08 <catherineD> pvaneck: thanks
19:14:13 <catherineD> moving on ...
19:14:35 <catherineD> #topic Pending reviews
19:14:51 <catherineD> #link     Optimize the link address ( https://review.openstack.org/#/c/455208/ )
19:15:15 <catherineD> do you think this change is necessary ?
19:16:18 <pvaneck> eh maybe if we are going to be serving it on the website, nice to have no mixed content with everything https
19:16:36 <catherineD> definitely won't hurt
19:17:08 <pvaneck> yea
19:17:33 <catherineD> sure then we can merge the two patches
19:18:01 <catherineD> #link     Fix to not run any test when the input test list is empty (  https://review.openstack.org/#/c/451599/ )
19:19:04 <catherineD> mguiney: sslypushenko_: please review ..
19:19:57 <catherineD> moving on ...
19:20:04 <catherineD> #link  Change doc references from DefCore to Interop Working Group  (  https://review.openstack.org/#/c/390881/  )
19:20:26 <catherineD> I think we are still waiting for DefCore rename patch to be merge
19:20:47 <catherineD> last one ..
19:20:58 <catherineD> #link     Add scripts for running refstack-client in docker (  https://review.openstack.org/#/c/430701/  )
19:21:19 <sslypushenko_> It is still in progress
19:21:28 <catherineD> thanks ...
19:22:05 <catherineD> #topic Open discussion
19:22:36 <catherineD> any other discussion  ?
19:22:45 <sslypushenko_> I have one thing in my mind
19:22:56 <catherineD> please the floor is yours ..
19:23:37 <sslypushenko_> because refstack become an public API, it would be nice to have at least some rate limiters
19:23:42 <sslypushenko_> in API
19:24:13 <sslypushenko_> in order to prevent too frequent requests
19:24:51 <sslypushenko_> I guess now we don't have anything behind our API
19:25:18 <catherineD> that is a good idea ... I know this time will come
19:25:44 <sslypushenko_> yeap and it will be better to be prepared
19:25:44 <catherineD> I thought everything is behind our API  ..
19:25:53 <catherineD> sslypushenko_: agree ..
19:26:15 <sslypushenko_> Maybe we can ask infra team
19:26:54 <catherineD> typically how would it be done ?
19:27:14 <sslypushenko_> I guess they already have encountered with problems likes this
19:27:28 <catherineD> I wonder whether any other project have done that the n we ccan follow
19:27:38 <sslypushenko_> I guess some special config in web server
19:28:08 <catherineD> our traffic is not hogh now but I think it is good for us to prepare ..
19:28:19 <sslypushenko_> or... I don't know) There a lot of ways to make such limiters
19:28:51 <catherineD> let me put this as one of our action item ...
19:29:43 <sslypushenko_> Good, thank you!
19:29:50 <catherineD> #action Investigate the possibility toadd request rate limit to RefStack API server
19:30:03 <catherineD> I also have an topic to discuss
19:30:34 <catherineD> I think it is about time to stop anonymous data upload
19:30:38 <catherineD> what do you think?
19:30:59 <sslypushenko_> +1 )
19:31:05 <sslypushenko_> as usual))
19:31:18 <catherineD> I know the Chris should be on this conversation .. we will need to follow up with him
19:31:41 <sslypushenko_> absolutely
19:31:49 <catherineD> pvaneck: mguiney: your thoughts?
19:32:33 <rockyg> Hey.  Again sorry I'm late.  Am I needed?  If not, I have other high priority stuff to get to.
19:32:53 <pvaneck> i say it's fine to stop it.
19:33:15 <catherineD> rockyg: you join at the time we need your opinion ...
19:33:16 <pvaneck> force people to actually go through the key upload process and use their openstackids
19:33:31 <mguiney> ahhhhhh yes that would make sense
19:33:40 <catherineD> we are discussing about stop allowing anonymous data upload .. what is your thought?
19:34:04 <catherineD> pvaneck: correct ... that is the intention ..
19:34:38 <catherineD> I guess for that we will need to give warning via email to openstack-dev
19:35:07 <mguiney> I feel like that would make things a lot more secure, which is always nice
19:35:09 <sslypushenko_> catherineD:  also it will be good now to get rid of key signature during key upload
19:35:15 <rockyg> Definitely.  Need to stop anonymous
19:35:51 <rockyg> We need to be able to see when/whether the system is being gamed.
19:36:00 <catherineD> sslypushenko_: the key signature does give us more proection ..
19:36:11 <sslypushenko_> It was my intention to provide such patch, but looks like I don't have enough time, at least  now
19:36:12 <rockyg> Either for some company or against some company.
19:36:42 <sslypushenko_> catherineD:  yes, but now it is not so important
19:36:55 <catherineD> sslypushenko_: agree
19:37:07 <rockyg> Channeling hogepodge here.  But, also, it means you stand behind your work.  The identities can be private, but we need them.
19:38:11 <hogepodge> hi
19:38:22 <catherineD> rockyg: yea we can implement this in 2 phases ... 1) upload with signature but share anonymously 2) upload and share verified data with identity
19:38:53 <rockyg> Hey hogepodge just discussing the logistics of getting rid of anonymous upload.
19:38:54 <catherineD> hogepodge: Hi.. we are discussing to stop allowing upload data anonymously
19:38:57 <mguiney> makes sense. plus that might open interesting doors as far as allowing for the ability to validate against an outside source without actually having direct access to that source?
19:39:01 <mguiney> ^just a thought
19:39:59 <hogepodge> I have a list of results that have been used for trademark, so we can preserve those
19:40:24 <hogepodge> I'm happy to get rid of anonymous, we just need to document how to do it so vendors don't get upset about it
19:40:35 <catherineD> hogepodge: that is mguiney: patch .. once we have that patch merge we will be able to identify thos
19:40:59 <catherineD> those
19:41:26 <catherineD> Upload with signature has been available at RefStack for a year now ...
19:41:47 <catherineD> I know not every vendor use it because we still allow anonymous upload ..
19:42:11 <catherineD> I think it is time now
19:42:52 <mguiney> awesome!
19:43:21 <rockyg> ++
19:43:46 <catherineD> #startvote Stop allowing anonymous test result upload at RefStack ? yes, no
19:43:47 <openstack> Begin voting on: Stop allowing anonymous test result upload at RefStack ? Valid vote options are yes, no.
19:43:48 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:44:00 <sslypushenko_> yes
19:44:10 <sslypushenko_> #vote yes
19:44:36 <mguiney> #vote yes
19:45:10 <catherineD> #vote yes
19:45:28 <pvaneck> #vote yes
19:46:07 <hogepodge> #vote yes
19:47:02 <catherineD> vote ends in 1 mins
19:47:36 <rockyg> #vote yes
19:47:56 <catherineD> #endvote
19:47:56 <openstack> Voted on "Stop allowing anonymous test result upload at RefStack ?" Results are
19:47:57 <openstack> yes (6): rockyg, pvaneck, catherineD, hogepodge, sslypushenko_, mguiney
19:48:28 <catherineD> wow unanimous !!!
19:49:26 <catherineD> #agreed Stop allowing anonymous upload of test result at RefStack.  Share data will still be anonymous until further new decision.
19:49:42 <catherineD> that is all the topics we have today ..
19:50:03 <catherineD> I guess we can end 10 mins early ...
19:50:11 <rockyg> yay!
19:50:15 <catherineD> thank you all!!
19:50:23 <mguiney> \o/
19:50:35 <catherineD> #endmeeting