19:00:14 <catherineD> #startmeeting refstack
19:00:15 <openstack> Meeting started Tue Mar  7 19:00:14 2017 UTC and is due to finish in 60 minutes.  The chair is catherineD. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:19 <openstack> The meeting name has been set to 'refstack'
19:01:35 <pvaneck> o/
19:01:52 <catherineD> #link meeting agenda and notes,  https://etherpad.openstack.org/p/refstack-meeting-17-03-07
19:04:37 <catherineD> Let's start ...
19:04:56 <catherineD> #topic Displaying RefStack documentation
19:05:27 <catherineD> so mguiney: had merged the 2 specs into one .. Thanks!
19:05:34 <luzC> o/
19:06:06 <catherineD> #topic Action items from last week:
19:06:37 <catherineD> pvaneck: Investigate whether docutils can be used for more basic html to match RefStack site's look&feel
19:06:43 <catherineD> any update?
19:06:46 <mguiney> yes, and i just saw the new comments on the last patch i uploaded, so i will go make the mentioned changes asap
19:07:05 <pvaneck> catherineD: sorry didnt get a chance to investigate last week. will do so this week
19:07:25 <catherineD> mguiney:  thx  .. just wait for after the meeting .. we may have to add more inf
19:07:46 <catherineD> pvaneck: no problem ...
19:08:08 <catherineD> luzC: Investigate how documentation team hosting and converting the rst to html
19:08:29 <catherineD> any update?
19:08:42 <luzC> yes, they are using sphinx https://docs.openstack.org/contributor-guide/project-install-guide.html
19:10:12 <luzC> each project implement a tox venv with sphinx and have a gate job to build the documentation I only looked at install/deployment guidelines...
19:10:52 <catherineD> ic .. but the hosted in an independent website, and that is the look & feel for them ..  sphinx is built into RefStack but witrh diff look & feel
19:11:50 <catherineD> luzC: the gate job run each time there are changed to the RST doc ?
19:13:12 <luzC> I didn't dig that deep... not sure how ofter the job is run
19:13:21 <luzC> *often
19:14:50 <Rocky_g> o/
19:14:55 <catherineD> I see that Anne Gentle is one of the lead for API document ...https://docs.openstack.org/contributor-guide/team-structure.html
19:15:18 <catherineD> Rocky_g: hello  agenda https://etherpad.openstack.org/p/refstack-meeting-17-03-07
19:15:46 <catherineD> we are discussing the best way to host RefStack doc
19:16:47 <catherineD> Let's wait for pvaneck: 's evaluation next week ... to see how big a job it is ..
19:17:19 <Rocky_g> Supposedly the job is run on every gate.
19:17:28 <catherineD> if  it make sense for us tocreate tools ourself for RefStack ...
19:18:18 <catherineD> Rocky_g: the different also is that those docs are hosted on the openstack doc website   ... where as we want to host RefStack docs at RefStack website ...
19:18:42 <Rocky_g> We should be able to repolace our sphynx with oslo sphynx?  we should do a quick test.  I bet we can change the target of where to deploy
19:18:47 <catherineD> on the other hand, I really do not want us to create one-off tool
19:19:34 <catherineD> Rocky_g: the look and feel of the html create by sphynx is very differnent from what we have at the RefStack site ...
19:19:38 <Rocky_g> especially since refstack is in o.o domain
19:20:09 <catherineD> that is one of the reason why we think we want to create our own tool to convert the RST to HTML ...
19:20:37 <Rocky_g> Yeah,  I would thing just having separate style files would work.
19:20:55 <Rocky_g> takse oslo.sphynx and then import our style files
19:22:55 <catherineD> pvaneck: what do you think of using out own style with sphynx .. not sure that works with angular ?
19:23:04 <catherineD> out -> our
19:24:07 <pvaneck> sphinx generates some beefy html files that are meant to be standalone html pages
19:24:27 <catherineD> pvaneck: yea ..
19:24:29 <pvaneck> if we do use them, they would have to separate from the angular component of our website
19:24:43 <pvaneck> which begs the question if you even want them directly on refstack.openstack.org
19:25:08 <catherineD> make senses ...
19:25:38 <Rocky_g> definitely need as consult with annegent_ I think
19:25:47 <catherineD> Rocky_g: luzC: the diff is the doc team hosts their docs at an indepenent website ...
19:25:57 <catherineD> Rocky_g: yup
19:26:04 <catherineD> I will contact her
19:26:50 <catherineD> I think this is not a top priority item ... since the doc currently are accessible via link to the RST site .. it is not pretty but the information is there
19:27:06 <catherineD> let's take time to do the right direction ..
19:27:50 <catherineD> Let's revisit next week after pvaneck: does some investigation ..
19:27:59 * mguiney nods
19:28:01 <mguiney> makes sense
19:28:42 <catherineD> alright moving on ...
19:28:57 <catherineD> #topic Update existing certified data with the verified flag
19:29:18 <catherineD> mguiney: any update?
19:29:25 <mguiney> yes, actually!
19:30:14 <mguiney> in scripting this task, i have come across a phenomena which makes it rather difficult to determine whether the cited result link is valid/the test result exists
19:31:12 <mguiney> the issue is that, when you follow links to a test result that doesnt exist, rather than 404'ing out, it returns a 200 code, despite citing 400 on the page.
19:32:10 <mguiney> the root of this issue is that the visible 404 code is on the page under a "sr-only" header, which means that it is visible only to eyes and screen readers
19:32:24 <catherineD> are yo using the API URL?
19:32:50 <catherineD> for example if the link is https://refstack.openstack.org/#/results/72e7b554-2c6a-4c2a-bda8-36b4764036b3
19:33:15 <mguiney> yes.
19:33:26 <catherineD> the API url would be https://refstack.openstack.org/api/v1/results/72e7b554-2c6a-4c2a-bda8-36b4764036b3
19:33:46 <Rocky_g> That seems like a serious design flaw.
19:35:17 <pvaneck> when I try it, a 404 return code is given for nonexistent test results
19:35:23 <mguiney> looks like that should fix the issue, and it will be a trivial change to make to the code, so that should solve things!
19:35:56 <pvaneck> ah okay
19:35:59 <catherineD> here is my response json : { code: 404, title: "Test result 72e7b554-2c6a-4c2a-bda8-36b4764036b2 not found" }
19:36:25 <mguiney> same here, it looks like since i was pulling from the spreadsheet, i forgot to change the url to the api url
19:36:40 <catherineD> mguiney: yea I think so
19:37:02 <mguiney> excellent. that will make it an easy issue to fix
19:37:03 <catherineD> yea the user only gives the UI link to Chris ... yup that make sense
19:37:33 <catherineD> mguiney: great
19:38:12 <Rocky_g> Not a design flaw ;-)
19:38:42 <catherineD> this is a very import item ... since we can only discuss data retention policy at RefStack after we are able to marked the vendor verified results for keeping
19:39:06 <catherineD> mguiney: thanks for working on this ..
19:40:09 <catherineD> any other discussion on this one ?
19:40:12 <mguiney> it's a very interesting task, thank you for allowing me to work on it
19:40:48 <mguiney> well given the modifications i will be able to make, i should hopefully be able to get it to full functionality by next week
19:41:18 <mguiney> it is almost there already, but there are a few wrinkles and additional tests to iron out
19:41:55 <catherineD> mguiney: thx so much ..  it is a very important task  but it involve vendor info so it only make sense for someone from the Foundaion to do it ..
19:42:26 * mguiney nods
19:42:36 <catherineD> moving on ...
19:42:49 <catherineD> #topic RefStack webstite update
19:43:23 <catherineD> first of all, does everyone see the RefStack mascot ( the bee) on the site?
19:43:36 <mguiney> yep!
19:43:44 <catherineD> I really like it!
19:44:09 <Rocky_g> high five!
19:44:09 <catherineD> so we will update the site on Friday .. mainly to update the openstack logo ..
19:44:27 * catherineD nobs
19:44:37 <catherineD> nods :-)
19:45:11 <catherineD> luzC: I am not sure this one is ready https://review.openstack.org/#/c/390881/
19:45:46 <catherineD> as I remember we are waiting for the defcore repo to be renamed to interop-wg ...
19:46:02 <catherineD> I do not think it is done ..
19:46:48 <luzC> no, still waiting
19:47:09 <catherineD> alright no hurry ... we can make that update next time
19:47:27 <luzC> i need to add a depends-on to this patch...
19:47:27 <catherineD> #topic Pending reviews
19:48:07 <Rocky_g> If the patch is ready, I can go ping infra for a date for defcore to interop
19:48:17 <catherineD> I think we have discussed     https://review.openstack.org/#/c/390881/  (  Change doc references from DefCore to Interop Working Group  )
19:48:30 <catherineD> and     https://review.openstack.org/#/c/437175/ (   updated spec to reflect discussion from 2/28/17 refstack meeting  )
19:48:47 <catherineD> Rocky_g: I think DefCore patch is not ready ..
19:49:14 <luzC> I think defcore patch is https://review.openstack.org/#/c/433414/
19:49:42 <luzC> **at infra/project-config
19:50:28 <catherineD> luzC: thanks for the link ... yea we need to wait for that patch to merge
19:50:59 <catherineD> #link Rename DefCore Committee -> Interop WG  ( https://review.openstack.org/#/c/433414/  )
19:51:27 <catherineD> moving on ..
19:51:31 <catherineD> #link     https://review.openstack.org/#/c/430701/ (  Add scripts for running refstack-client in docker )
19:52:09 <catherineD> This is from Sergey ... I am having problem bring up a refstack-client container ... I have left a message
19:53:10 <catherineD> if you have time please help review this one
19:53:45 <catherineD> #topic Open discussion
19:53:46 <luzC> I'll try later this week, need some time to test it
19:53:53 <catherineD> luzC: thx
19:54:22 <catherineD> anything else to discuss today ?
19:54:26 <luzC> yes, reading email thread... http://lists.openstack.org/pipermail/openstack-dev/2017-March/113269.html
19:55:07 <luzC> goals: goal-deploy-api-in-wsgi
19:55:07 <luzC> goal-python35 ... for refstack I guess only the second one applies...
19:55:28 <luzC> is it everything ok with goal-python35?
19:56:28 <catherineD> pvaneck: I recall you were doing some test with  35?
19:56:35 <pvaneck> I will revist getting the functional tests working with python 3.5
19:56:53 <pvaneck> was blocked by pycrypto issues last time
19:57:00 <catherineD> luzC: BTW, THANKS so much for keep an eye on this for us ...
19:57:48 <catherineD> #action pvaneck: revisit getting the functional tests working with python 3.5
19:57:49 <luzC> NP ;)
19:58:14 <catherineD> #linl Community Goals for Pike thread http://lists.openstack.org/pipermail/openstack-dev/2017-March/113269.html
19:58:35 <catherineD> #link Community Goals for Pike thread http://lists.openstack.org/pipermail/openstack-dev/2017-March/113269.html
19:59:07 <catherineD> any other comments?
19:59:53 <catherineD> alright let's end the meeting ...
20:00:00 <catherineD> thanks everyone ...
20:00:06 <catherineD> bye
20:00:06 <mguiney> have a good day!
20:00:40 <catherineD> #endmeeting