19:00:40 <catherineD> #startmeeting refstack
19:00:40 <openstack> Meeting started Tue Feb  7 19:00:40 2017 UTC and is due to finish in 60 minutes.  The chair is catherineD. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:43 <openstack> The meeting name has been set to 'refstack'
19:01:28 <hogepodge> o/
19:01:48 <catherineD> #link meeting agenda and notes,  https://etherpad.openstack.org/p/refstack-meeting-17-02-07
19:03:22 <catherineD> hogepodge: let's wait for a few mins for other to join ...
19:04:49 <sslypushenko_> o/ Hi, folks!
19:05:08 <hogepodge> hi sslypushenko_ ! long time no chat. :-D
19:05:40 <sslypushenko_> hogepodge yeap)
19:06:08 <catherineD> Let's start ...
19:06:23 <catherineD> #topic RefStack mascot
19:06:26 <pvaneck> o/
19:06:42 <catherineD> #link   http://lists.openstack.org/pipermail/openstack-dev/2017-February/111718.html
19:06:44 <hogepodge> I want to introduce mguiney
19:06:46 <mguiney> o/
19:06:49 <mguiney> hello!
19:07:07 <hogepodge> She just started with the Foundation, and will be helping out with RefStack and the Interop WG
19:07:13 <catherineD> mguiney: Welcome to RefStack ...
19:07:19 <pvaneck> Hello :)
19:07:33 <sslypushenko_> mguiney:  Hi!)
19:07:50 <catherineD> Today's agenda https://etherpad.openstack.org/p/refstack-meeting-17-02-07
19:07:53 <mguiney> nice to meet you!
19:09:12 <catherineD> so the mascot looks good to me know with bee+honeycomb  .. that is what we want ...
19:09:27 <catherineD> your thoughts?
19:10:05 <hogepodge> The logo looks great. #link http://lists.openstack.org/pipermail/openstack-dev/attachments/20170206/763c5546/attachment.gif
19:10:17 <sslypushenko_> Cool!
19:10:54 <catherineD> hogepodge: sslypushenko_: ++ I really like this one  ..
19:11:36 <catherineD> so I take that we agree to use that as our mascot ?
19:11:53 <sslypushenko_> for sure)
19:12:43 <mguiney> that does look nice
19:12:56 <catherineD> #agreed Use http://lists.openstack.org/pipermail/openstack-dev/attachments/20170206/763c5546/attachment.gif as RefStack mascot
19:12:59 <luzC> +1
19:13:19 <catherineD> hogepodge: thanks for your idea on bee+honeycomb ...
19:13:31 <catherineD> moving on ...
19:13:55 <catherineD> #topic PTG
19:14:19 <catherineD> #link     Please add RefStack PTG topics to https://etherpad.openstack.org/p/RefStackInteropWGAtlantaPTG
19:14:34 <catherineD> too bad sslypushenko_:  will not join us this time ...
19:14:49 <sslypushenko_> sad but true (
19:14:54 <catherineD> mguiney: will you be at  PTG?
19:15:50 <mguiney> I am based out of portland, so most likely not, unfortunately
19:16:24 <catherineD> mguiney: oh ..
19:16:33 <catherineD> #topic Update RefStack website
19:16:53 <catherineD> we target to update the website on this Friday ...
19:17:23 <catherineD> there are a few reviews that we would like to  merge before the update
19:17:49 <catherineD> let's go through the reviews
19:18:00 <catherineD> #topic Pending reviews
19:18:22 <catherineD> #link Added tox target which checks requirements.txt   (  https://review.openstack.org/#/c/410443/   )
19:19:05 * Rockyg sneaks in
19:19:13 <luzC> ahh yes... I'm submitting new patch this afternoon
19:19:39 <luzC> with agreements from last meeting
19:20:07 <catherineD> luzC: sure thanks ... please also update the readme in that patch
19:20:14 <pvaneck> right, this was also submitted to puppet-refstack: https://review.openstack.org/#/c/429117/
19:20:52 <luzC> cool, I'll take a look
19:21:08 * catherineD waves to Rockyg:
19:21:25 <catherineD> pvaneck: luzC: thanks
19:22:26 <catherineD> #link     Add ability to edit products in UI (  https://review.openstack.org/#/c/427525/  )
19:22:28 <catherineD> and
19:22:36 <sslypushenko_> merged =)
19:22:55 <catherineD> sslypushenko_: you are fast!!!
19:23:05 <catherineD> #link     Show message when vendor/product is created  (  https://review.openstack.org/#/c/428478/   )
19:23:09 <sslypushenko_> yeap)
19:23:23 <sslypushenko_> I have merged all of them
19:23:32 <catherineD> sslypushenko_: thank you ...
19:23:47 <sslypushenko_> all patches LGTM
19:24:09 <catherineD> that is great ...
19:24:19 <catherineD> that bring us to the last topic ...
19:24:34 <catherineD> #topic Open discussion
19:25:14 <catherineD> any other discussion  you have in mind ...?
19:26:10 <hogepodge> I know that annegentle was looking at setting up refstack client
19:26:37 <hogepodge> She's been using containers, and trying to simplify the process. Might be something we could take advantage of and integrate into the client.
19:26:43 <hogepodge> Just thinking out loud.
19:27:42 <catherineD> hogepodge:  sslypushenko_: did set up a docker container on refstack-client
19:27:55 <sslypushenko_> there is no problem to pack refstack-client in container
19:28:13 <sslypushenko_> should work almost out-of-the-box
19:29:33 <hogepodge> sslypushenko_: is there documentation for that?
19:29:42 <catherineD> maybe I do not remember it correctly sslypushenko_: the docker container you set up is for refstack or refstack-client?
19:29:44 <sslypushenko_> https://github.com/openstack/refstack-client/tree/master/refstack_client/tests/smoke
19:29:55 <hogepodge> I see runindocker in test_distros.py
19:30:34 <sslypushenko_> that is it... I used this script to test refstack-client setup againts set of linux distros
19:30:43 <hogepodge> ok, I see
19:30:48 <catherineD> sslypushenko_: yup
19:30:55 <sslypushenko_> https://github.com/openstack/refstack-client/blob/master/refstack_client/tests/smoke/test_distros.py#L17
19:31:12 <sslypushenko_> to be precise that is almost it)
19:31:29 <hogepodge> :-D
19:31:39 <sslypushenko_> but I guess it will be a bit convenient to have one-click script
19:32:16 <hogepodge> could be that we publish releases of the client to dockerhub, if we can work out a good way to get the configuration into it.
19:32:35 <hogepodge> my docker skills are admittedly weak...
19:32:47 <sslypushenko_> It is over complication
19:33:12 <sslypushenko_> couple of bash scripts should enough
19:33:27 <sslypushenko_> I have some set of scripts handy
19:33:57 <hogepodge> The bash scripts modify your working environment.Usually not a problem since I'm spinning up a VM to run refstack-client anyway.
19:34:22 <sslypushenko_> I'll try to find some free time to provide a patch
19:34:39 <sslypushenko_> these scripts will be just wrapper for docker commands
19:34:50 <catherineD> sslypushenko_: that is great thanks ..
19:34:53 <sslypushenko_> so no need in VM and could runned locally
19:35:40 <catherineD> for me I use the same VM but create different directory for refstack-client each time I want to upgrade refstack or tempest ...
19:35:58 <catherineD> sicne refstack-client tests in virtual env any way ...
19:36:06 <catherineD> this work perfect for me
19:36:25 <catherineD> I do not need a new VM each time
19:36:53 <hogepodge> Anne was excited about running it in the containers, so I wanted to forward the experience. :-D
19:37:56 <sslypushenko_> Containers are much lighter than VM so
19:38:07 <sslypushenko_> it can be helpful
19:38:17 <catherineD> hogepodge: absolutely ... it is great to have users bringing in new ideas .. that would enrich our project
19:38:40 <garloff> +1
19:40:45 <catherineD> now that we pretty much implemented vendor/product registration, the next big item for RefStack is custom guideline ..
19:40:46 <sslypushenko_> refstack have a way to be run in docker, so refstack client should be able to =)
19:41:09 <catherineD> sslypushenko_: ++
19:41:32 <Rockyg> ++
19:41:38 <mguiney> ++
19:42:00 <Rockyg> We need a white paper or a superuser article to advertise these tools and techniques
19:42:23 <Rockyg> We have so mmuch experience here, we should spread the knowledge.
19:42:38 <catherineD> Rockyg: ++
19:43:02 <sslypushenko_> My thoughts about custom guidelines are that we have to find some early adopters for this feature
19:43:24 <catherineD> sslypushenko_: ++ ..
19:43:32 <sslypushenko_> to get understanding what should be done here
19:43:55 <catherineD> that is one of the topic at PTG ... too bad we do not have sslypushenko_: in person ..
19:44:09 <catherineD> I will try to contact Andrey too
19:44:48 <catherineD> it takes time to get here ... but we finally start working on it
19:45:16 <garloff> We would certainly want to give it a try...
19:45:48 <catherineD> garloff: for sure .. we will
19:46:17 <garloff> ;-)
19:46:59 <catherineD> any last bits any one wants to add ..
19:48:45 <catherineD> hearing nothing.  I think we can close up for today
19:49:09 <catherineD> thanks everyone
19:49:13 <catherineD> bye
19:49:23 <mguiney> have a good day!
19:49:27 <garloff> Bye
19:49:30 <sslypushenko_> Bye
19:49:36 <catherineD> #endmeeting