19:00:39 <catherineD|2> #startmeeting refstack
19:00:40 <openstack> Meeting started Tue Jan 17 19:00:39 2017 UTC and is due to finish in 60 minutes.  The chair is catherineD|2. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:44 <openstack> The meeting name has been set to 'refstack'
19:01:48 <pvaneck> o/
19:01:56 <catherineD|2> #link meeting agenda and notes,  https://etherpad.openstack.org/p/refstack-meeting-17-01-17
19:02:27 <catherineD|2> pvaneck: hi, we will wait for a few minute for other to join ...
19:04:29 <sslypushenko_> o/
19:06:10 <catherineD|2> sslypushenko_: thx for joining ...we really need your expertise for a couple of topic today   let's start .. it should be very quick
19:06:29 <catherineD|2> https://etherpad.openstack.org/p/refstack-meeting-17-01-17
19:06:44 <sslypushenko_> catherineD|2:  yeap, I see couple bugs in agenda )
19:06:50 <catherineD|2> #topic My email address cannot be changed on RefStack
19:07:04 <catherineD|2> #link     Bug: https://bugs.launchpad.net/refstack/+bug/1632773
19:07:04 <openstack> Launchpad bug 1632773 in refstack "My email address cannot be changed on RefStack" [Medium,Confirmed]
19:07:32 <catherineD|2> the question is should we allow user to edit the email address at RefStack ?
19:07:48 <sslypushenko_> I guess - yes
19:08:17 <sslypushenko_> RefStack should sync changes with OID provider
19:08:31 <catherineD|2> my thinking is no ... reason is user profile are copy from OpenID ...
19:08:57 <sslypushenko_> even more... we should not keep this data at all)
19:09:00 <catherineD|2> exactly we should sync with OID provider but not allow edit at our side
19:09:33 <sslypushenko_> =) we can't edit user's email on OID side)
19:09:35 <catherineD|2> because we do not own these data ..
19:09:39 <sslypushenko_> it is impossible
19:09:41 <sslypushenko_> )
19:10:06 <catherineD|2> so it is the OID issue then .. right?
19:10:09 <sslypushenko_> we just need to move email from user DB record to session data
19:10:33 <sslypushenko_> OID returns actual email every login
19:10:57 <sslypushenko_> currently RefStack stores it at first login
19:11:02 <sslypushenko_> and it is a bug
19:11:16 <sslypushenko_> RefStack should not store email in to database
19:11:34 <pvaneck> doesn't it save it in db after every sign in with this: https://github.com/openstack/refstack/blob/master/refstack/api/controllers/auth.py#L164 ?
19:12:19 <sslypushenko_> hm, give me a sec
19:12:39 <sslypushenko_> https://github.com/openstack/refstack/blob/master/refstack/db/sqlalchemy/models.py#L133
19:13:21 <sslypushenko_> so we just need to change all places refers to user's email in DB record
19:13:42 <sslypushenko_> to use user_info instead
19:14:37 <sslypushenko_> https://github.com/openstack/refstack/blob/master/refstack/api/controllers/user.py#L84
19:14:48 <sslypushenko_> this lines needs to be changed
19:14:58 <sslypushenko_> and I guess that is it =)
19:15:01 <catherineD|2> ic ... so by using user_info everywhere the "user info" will present the newest data fetched from the OID?
19:15:10 <sslypushenko_> yeap
19:15:46 <catherineD|2> great ... so basically we all agree that we should not allow editting of user info at RefStack ..
19:16:07 <catherineD|2> this infor will be used as-is as it is fetched from the OID provider ..
19:16:18 <sslypushenko_> +1
19:16:56 <catherineD|2> pvaneck: ?
19:17:34 <pvaneck> can try
19:17:45 <catherineD|2> great thx
19:18:50 <catherineD|2> #agreed Not allowing editing of user infor at RefStack.  User data will be used and save as-is as they are fetched from the OID provider
19:19:13 <catherineD|2> #topic Pending reviews
19:19:28 <catherineD|2> #link     https://review.openstack.org/#/c/410271/ ( Add tool for coverage check )
19:20:12 <catherineD|2> sslypushenko_: I think this patch is ready to merge ... with a comment there ... could you take a look
19:21:24 <sslypushenko_> ok, I'll you do it
19:21:33 <catherineD|2> sslypushenko_: thx you ...
19:23:07 <catherineD|2> sslypushenko_: BTW,  thank yo uso much for working on https://review.openstack.org/#/c/396700/   this has made testing of API much easier with script
19:23:21 <pvaneck> +1
19:23:54 <sslypushenko_> =) it is my pleasure catherineD|2
19:24:09 <catherineD|2> moving on ..
19:24:15 <catherineD|2> #link     https://review.openstack.org/#/c/410443/ ( Added tox target which checks requirements.txt )
19:24:42 <catherineD|2> I do not think this kind of checking works for RefStack ...
19:25:18 <catherineD|2> because some of the package are required to build the server
19:25:42 <catherineD|2> unless we split out the app vs env requirement
19:26:34 <catherineD|2> catherineD|2: pvaneck:  what do you think?
19:26:41 <sslypushenko_> looks like we need requirements.txt and requirements-dev.txt
19:27:23 <sslypushenko_> It is definitely make sence
19:27:29 <catherineD|2> sslypushenko_: yea if we want to enforce the requirement checking
19:28:30 <sslypushenko_> checks are good) Checks bring confidence during deployment)
19:28:38 <pvaneck> but in the case of pymysql, the check seemingly says to remove it, but we need it even if it isnt explicitly imported anywhere
19:29:13 <catherineD|2> pvaneck: what if we put that in requirement-dev.txt ?
19:30:10 <catherineD|2> put all those package that are not explicitly imported to the new file ..
19:30:18 <pvaneck> then puppet-refstack would need to be updated to install the packages in there since production just installs packages in requirements.txt
19:30:35 <catherineD|2> pvaneck: ic
19:30:39 <sslypushenko_> pvaneck:  You right
19:30:59 <sslypushenko_> At least it need to install pymysql
19:31:27 <catherineD|2> yea ..
19:32:07 <catherineD|2> how about let's give us a week to think this through ... we will revisit next week?
19:32:45 <catherineD|2> moving on ..
19:32:46 <sslypushenko_> I guess we already had an agreement on it
19:33:16 <catherineD|2> to split the requirement files?
19:33:26 <sslypushenko_> I just checked some other projects... there is no pymysql in requirements.txt
19:34:02 <sslypushenko_> so yes we need to separate dev requirements in dev-requirements.txt
19:34:14 <sslypushenko_> it should work
19:34:47 <sslypushenko_> and as pvaneck  said we need to update deployment scripts
19:35:06 <sslypushenko_> lets stick to this approach
19:35:27 <pvaneck> maybe can have puppet just explicitly install pymysql independently since it's the only outlier
19:36:08 <sslypushenko_> yeap
19:36:50 <sslypushenko_> it should work
19:36:58 <pvaneck> alternatively, we can use --ignore-module in the pip check command
19:37:02 <catherineD|2> pvaneck: sslypushenko_: I feel like we need  pymysql to show up so where in refstack project because not everyone who build refstack env will look at the puppet
19:37:30 <pvaneck> catherineD|2: that would just be another step in the docs
19:37:47 <sslypushenko_> +1
19:37:50 <catherineD|2> ok ...
19:38:33 <sslypushenko_> puppet + docs update cover all usecases
19:38:36 <catherineD|2> I constantly build dev env from scratch ... let me do some test and we will decide which approaches to take next week?
19:39:01 <garloff> Sounds reasonable
19:39:04 <pvaneck> sure
19:39:17 <catherineD|2> garloff: Hello there ..
19:40:00 <garloff> catherineDI2: Thx for the welcome!
19:40:01 <catherineD|2> #agreed Revisit approaches to enforece the requirment,txt checking next week
19:40:16 <catherineD|2> moving on ...
19:40:41 <catherineD|2> #link     https://review.openstack.org/#/c/419178/ ( Add ability to auto-associate tests )
19:41:00 <catherineD|2> please review ...
19:41:44 <sslypushenko_> ok, I'll review
19:41:52 <catherineD|2> thx
19:42:30 <catherineD|2> next ..
19:42:33 <catherineD|2> #link     https://review.openstack.org/#/c/390881/ ( Change doc references from DefCore to Interop Working Group )
19:43:57 <pvaneck> the name change is official now right?
19:43:57 <catherineD|2> this is just a name change ... DefCore is renamed to Interop WG ... and the Guideline will be name as "OpenStack Powered (TM) Guidelines"
19:45:17 <catherineD|2> I think lucZ: just need to make the update
19:45:45 <catherineD|2> That brings us to the last topic
19:45:48 <catherineD|2> #topic Open discussion
19:46:03 <catherineD|2> #link     Bug https://bugs.launchpad.net/refstack/+bug/1643048
19:46:03 <openstack> Launchpad bug 1643048 in refstack "setup_env removes and reclones tempest" [Wishlist,New]
19:46:55 <sslypushenko_> I guess we can have optional key for this feature
19:47:14 <catherineD|2> personally I feel like it is cleaner to remove and reclone
19:47:57 <sslypushenko_> same thoughts
19:48:21 <sslypushenko_> but we can have optional key for not-to-force recloning
19:49:08 <sslypushenko_> I guess Wishlist is correct priority for it
19:49:43 <catherineD|2> I think will work on the item 4 on line 53 of https://etherpad.openstack.org/p/refstack-ocata-summit
19:50:45 <catherineD|2> there seems to be overlapsed ..
19:51:48 <sslypushenko_> agreed
19:52:38 <catherineD|2> so once we implement that feature ... user can point to whatever env they like ..
19:52:52 <catherineD|2> so I think this bug will remain as wishlist
19:54:21 <sslypushenko_> +1
19:54:54 <catherineD|2> #action Revisit   Bug https://bugs.launchpad.net/refstack/+bug/1643048 after "Add ability to pass in own tempest directory path" is implemented
19:54:54 <openstack> Launchpad bug 1643048 in refstack "setup_env removes and reclones tempest" [Wishlist,New]
19:55:09 <catherineD|2> that is all the topics we have for this week ...
19:55:20 <catherineD|2> any other thought?
19:56:51 <catherineD|2> if not ... thank you so much for attending  ... talk to you next week ..
19:56:52 <sslypushenko_> nothing to add
19:57:05 <catherineD|2> sslypushenko_: thx
19:57:24 <catherineD|2> bye everyone
19:57:27 <catherineD|2> #endmeeting