19:00:09 <catherine_d|1> #startmeeting refstack
19:00:11 <openstack> Meeting started Tue Sep 20 19:00:09 2016 UTC and is due to finish in 60 minutes.  The chair is catherine_d|1. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:15 <openstack> The meeting name has been set to 'refstack'
19:01:32 <pvaneck> o/
19:01:43 <Rockyg> o/
19:02:04 <luzC> o/
19:02:26 <catherine_d|1> #link meeting agenda  https://etherpad.openstack.org/p/refstack-meeting-16-09-20
19:03:07 <andrey-mp> o/
19:03:42 <catherine_d|1> hi everyone ...
19:04:01 <catherine_d|1> first of all, I will be out of the office next week ...
19:05:05 <catherine_d|1> we can cancel the meeting or one of you can help to run the meeting if we need to meet ..
19:05:35 <catherine_d|1> andrey-mp: do you get the agneda link?
19:05:54 <andrey-mp> catherine_d|1 yes
19:06:03 <catherine_d|1> great ...
19:06:18 <andrey-mp> i'll be on vacation too next week
19:06:39 <luzC> andrey-mp agenda:  https://etherpad.openstack.org/p/refstack-meeting-16-09-20
19:06:54 <sslypushenko> o/
19:06:58 <catherine_d|1> looks like it makes sense to skip the meeting next week?
19:07:20 <catherine_d|1> let's decide at the end of this meeting to see whether we need one next week
19:07:43 <catherine_d|1> Let's start ...
19:07:52 <catherine_d|1> #topic Barcelona summit working sessions
19:08:19 <catherine_d|1> we have 2 working sessions on Wednesday fro 5:05 PM to 6:35 PM
19:08:45 <catherine_d|1> as far as I know there is no conflict with EC2API or DefCore
19:09:03 <catherine_d|1> BTW, who is going to the summit?
19:09:11 <catherine_d|1> I am going
19:09:23 <luzC> I'm going too
19:09:26 <sslypushenko> me - not(
19:09:42 <catherine_d|1> sslypushenko: :-(
19:10:09 <Rockyg> I am
19:10:53 <catherine_d|1> I know pvaneck: is .. How about andrey-mp: ?
19:11:24 <andrey-mp> we do
19:11:49 <catherine_d|1> So I started  a etherpad for the sessions .. pls add any topic you think we should discuss ..
19:12:21 <catherine_d|1> #link RefStack Barcelona summit etherpad: https://etherpad.openstack.org/p/refstack-ocata-summit
19:12:43 <catherine_d|1> luzC: seems like the tempest conf blueprint is a good one
19:13:13 <catherine_d|1> moving on ...
19:13:45 <catherine_d|1> #topic Enable vendor/product registration on RefStack website
19:14:17 <catherine_d|1> before that we should merge the feature/vendor code to master ...
19:14:46 <catherine_d|1> there are few more patches needed ...
19:15:42 <catherine_d|1> currently we schedule to have those code merged to feature/vendor   on Oct 7
19:16:30 <andrey-mp> can defcore approve specs?
19:17:24 <catherine_d|1> The patches to be submitted should provide features incliude in this PoC http://refstack.mybluemix.net/#/
19:18:47 <catherine_d|1> andrey-mp: Egle (she is the co-chair) did we should  remind other DefCore members  again ....
19:19:32 <catherine_d|1> luzC: Rockyg: I will not be at the DefCore meeting ... could you remind other members to approve ?
19:19:51 <Rockyg> yes
19:20:06 <catherine_d|1> luzC: Rockyg: including YOU of course
19:20:06 <luzC> yes
19:20:30 <catherine_d|1> I do not think they have meeting link for tomorrow yet
19:21:32 <catherine_d|1> luzC: pls help to add the 2 links to the DefCore agenda when it becomes available .. https://review.openstack.org/#/c/343954/  and  https://review.openstack.org/#/c/332260/
19:21:36 <Rockyg> yup
19:21:55 <luzC> I will
19:22:05 <Rockyg> I think the ethepad came out last wednesday.  Lemme check
19:22:24 <catherine_d|1> I really hope that we can roll out the vendor/product registration feature at the Barcelona summit
19:22:36 <catherine_d|1> Rockyg: thx
19:22:52 <Rockyg> #link https://etherpad.openstack.org/p/DefCoreLunar.18
19:23:23 <catherine_d|1> Rockyg: thx
19:23:29 <luzC> yes... etherpad is still empty but will update it when available :)
19:23:37 <luzC> Rockyg thanks :)
19:23:52 <catherine_d|1> luzC: thx
19:24:07 <catherine_d|1> moving on ...
19:24:10 <Rockyg> Yup get the links out just below the defcore ones so maybe people review ahead od the meeting
19:24:40 <catherine_d|1> #topic Pending reviews
19:25:08 <catherine_d|1> andrey-mp: thx for merging the version UI patch
19:25:23 <andrey-mp> no problem
19:26:21 <catherine_d|1> andrey-mp: I see that you abandon yoiur other patches ... I hope you will update them later to the latest implementation ... those patches of yours are valuable to the users ..
19:26:45 <catherine_d|1> #link     Add ability to associate product version to test (  https://review.openstack.org/#/c/367034/ )
19:26:58 <andrey-mp> yeah, anyone can restore it if needed
19:27:14 <catherine_d|1> andrey-mp: OK will do
19:28:03 <catherine_d|1> for   https://review.openstack.org/#/c/367034/  .. I put a comment .. perhaps pvaneck: can respond later ..
19:28:35 <pvaneck> pvaneck: yea, I will get back on that patch
19:28:42 <pvaneck> woops: catherine_d|1
19:28:49 <catherine_d|1> andrey-mp: do you have chance to review it ?  Of course, we could not merge this one until the spec is reviewed by DefCore and merged
19:29:22 <andrey-mp> i'm waiting for spec - review of api code is no so long
19:29:34 <catherine_d|1> andrey-mp: OK
19:29:54 <catherine_d|1> The next two patches are the specs ...
19:30:19 <catherine_d|1> luzC: will help to ask more DefCore members to review ... ...
19:30:23 <catherine_d|1> luzC: thx
19:30:32 <luzC> NP ;)
19:30:46 <luzC> I'll make time to review the patches as well
19:31:00 <catherine_d|1> The next two patches are luzC: 's
19:31:49 <catherine_d|1> luzC: anything you want to share with us here on the 2 patches ?
19:32:07 <luzC> one of them is the spec... I think we agree on that one... not sure the next step to actually merge it/ approve it
19:32:14 <catherine_d|1> #link     Added Defcore additional properties waiver ( https://review.openstack.org/#/c/370534/  )  --> spec
19:32:31 <catherine_d|1> #link     Implement additional properties Defcore waiver (  https://review.openstack.org/#/c/349213/ )
19:32:45 <luzC> actually https://review.openstack.org/#/c/349213/ is the spec
19:33:19 <catherine_d|1> yea .. everyone .. Let's review the spec again and merge it ...
19:33:29 <catherine_d|1> I will do that before I leave this afternoon
19:34:10 <luzC> thanks...
19:34:19 <luzC> about  https://review.openstack.org/#/c/370534/
19:34:42 <luzC> its almost all the functionality if you can help me with some reviews as well
19:34:50 <catherine_d|1> luzC: For the implementation,  I have not reviewd in details ... but I like that you create a separate file
19:35:35 <luzC> I'm adding a second patch to include missing parts (creating a zip bundle, documentation, etc)
19:36:06 <catherine_d|1> #action RefStack memebers to review https://review.openstack.org/#/c/349213 and  https://review.openstack.org/#/c/370534/
19:36:18 <pvaneck> sure
19:37:59 <catherine_d|1> I am always concerned about code cleanup after it is obsoleted .. a separate file help ..
19:38:27 <catherine_d|1> anything else on this topic?
19:38:35 <luzC> not on my end
19:38:53 <catherine_d|1> let's move on ...
19:39:28 <catherine_d|1> #topic  Tempest Configurator: file creation
19:40:00 <catherine_d|1> #link https://etherpad.openstack.org/p/defcore-tempest-configuration-spec
19:40:35 <catherine_d|1> I do not think any of us have a chance to review this yet ...
19:40:57 <luzC> I just added based on an email from Gema
19:41:04 <sslypushenko> catherine_d|1:  heh, finally !
19:41:11 <catherine_d|1> luzC: thx
19:41:36 <sslypushenko> it will a great move forward)
19:41:37 <luzC> I have some concerns related to the questions/support that will generate in case it lands on refstack-client
19:41:56 <catherine_d|1> My only concern about having a tempest conf creation script is ... does the script work on all cases>
19:42:35 <catherine_d|1> and if it does not ... like luzC: I am concerned about supporting it ..
19:42:51 <Rockyg> I also have a concern in that this is also starting to be a thing again in Rally.  So, we should coordinate/get them to review, maybe?
19:43:54 <catherine_d|1> Rockyg: absolutely .... I also know that Redhat also have some script ... I do not have a link handy ... I can dig it out
19:44:23 <luzC> just today on qa channel there was a person asking about tempest configuration... he was using a  config_tempest.py from RDO which didn't have all the config options so it was missed configured for his environment
19:44:38 <luzC> and tempest was not working
19:44:57 <catherine_d|1> there is also this one http://lists.openstack.org/pipermail/defcore-committee/2016-September/001240.html
19:45:20 <catherine_d|1> all solution I have seen so far does not work for all cases ...
19:45:49 <catherine_d|1> luzC: that is exactly what I am saying
19:46:02 <catherine_d|1> the solution I see so far does not work for all cases ...
19:46:45 <catherine_d|1> it is very difference in providing script that does not work ... comparing to provide best practice advises
19:46:59 <catherine_d|1> so I am very concerned about the supporting issues
19:47:07 <luzC> agree
19:47:28 <catherine_d|1> For example ... today I receie a email saying
19:47:37 <sslypushenko> but somebody should take care of it  at least
19:47:38 <catherine_d|1> I got the following error when i trying to run test. Could you please help me about that?
19:48:10 <catherine_d|1> root@tariku-Latitude-E5440:~/refstack-client# ./refstack-client test -c ./tempest.conf  --test-list test.list Traceback (most recent call last):   File "./refstack-client", line 31, in <module>     raise SystemExit(getattr(test, args.func)())   File "/root/refstack-client/refstack_client/refstack_client.py", line 398, in test     keystone_config = self._get_keystone_config(self.conf)   File "/root
19:48:48 <catherine_d|1> since this is our script so we should help ... but the root of the problem here maybe the config file format itself ...
19:48:52 <luzC> we could have a FAQ with common issues or a "How to configure manually"
19:49:04 <catherine_d|1> luzC: ++
19:50:04 <luzC> we should acknowledge that we might get a lot of this questions
19:50:21 <catherine_d|1> we should do that ... but provide a script is a different issue beause if provide one it should work ... and if does not wrok we need to debug ... but we do not have accesss to those cloud ...
19:50:51 <catherine_d|1> so guidance is one thing ... expectation is a different thing ..
19:51:07 <catherine_d|1> anyway .. I think this is a good topic for the summit ...
19:51:25 <Rockyg> Maybe we include a url in the error message that points to a coomon problem wiki or web page?
19:51:34 <catherine_d|1> Rockyg: ++
19:51:36 <Rockyg> common
19:51:56 <catherine_d|1> totally agree
19:52:21 <Rockyg> it would be great to use ask.openstack, but I don't think it is back to a usable state yet.
19:52:48 <catherine_d|1> Rockyg: I think we could have Q/A sessions on the RefStack website
19:53:27 <luzC> I added the topic on Barcelona summit agenda :)
19:53:49 <sslypushenko> I guess step-by-step wizard can handle with issue
19:55:26 <catherine_d|1> sslypushenko: we can do that for what we know today ... the issues is we may not know all cases ... since we are now testing  real world clouds !!
19:55:43 <catherine_d|1> luzC: thx a lot!
19:55:56 <catherine_d|1> anything else?
19:56:58 <catherine_d|1> Pls actively review whenever there is new patch ... I really hope that we can enable vendor/product registration at Barcelona summit
19:57:31 <catherine_d|1> alrigjt that should be all for today ...
19:57:38 <catherine_d|1> thank you all for your time !
19:57:45 <luzC> thank you :)
19:58:01 <catherine_d|1> #endmeeting