19:03:06 <catherineD> #startmeeting refstack
19:03:07 <openstack> Meeting started Mon Apr 18 19:03:06 2016 UTC and is due to finish in 60 minutes.  The chair is catherineD. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:03:10 <openstack> The meeting name has been set to 'refstack'
19:03:27 <pvaneck> o/
19:03:30 <catherineD> silly me I started the meeting in the DefCore channel :-)
19:03:39 <Rockyg> o/
19:03:43 <pvaneck> again?
19:03:46 <pvaneck> lol
19:04:21 <catherineD> yea :-(
19:04:26 <catherineD> Rockyg: Hi
19:05:11 <catherineD> #link meeting agenda and notes, please feel free to add items https://etherpad.openstack.org/p/refstack-meeting-16-04-18
19:07:28 <Rockyg> it sucks to waste your weekend being sick
19:07:48 <catherineD> Rockyg: oh ... hope you feel better now ..
19:07:53 <andtey-mp> hi
19:07:54 <sslypushenko> o/
19:08:18 <Rockyg> cold.  getting better.
19:08:59 <catherineD> #link meeting agenda and notes, please feel free to add items https://etherpad.openstack.org/p/refstack-meeting-16-04-18
19:10:00 <catherineD> let's start
19:10:12 <catherineD> #topic No meeting for the next 2 weeks
19:10:34 <catherineD> The next meeting iwill be on May 09, 2016
19:11:00 <andtey-mp> ok )
19:11:12 <sslypushenko> catherineD:  I'll have a day-off on May 9
19:11:17 <catherineD> I also want to check whether everyone here is OK if we move the meeting from Monday to Tuesday at the same time 19:00 UTC and #openstack-meeting-alt?
19:11:32 <andtey-mp> I think we will have many conversations on the summit
19:11:46 <sslypushenko> Actually, our Russian colleagues, too)
19:11:49 <catherineD> sslypushenko: if we move the meeting to Tues day are you OK?
19:11:58 <andtey-mp> I'm ok with moving
19:11:58 <sslypushenko> Yeap
19:12:18 <sslypushenko> Tuesday, same time sounds good
19:12:20 <catherineD> sslypushenko: Rockyg: pvaneck: how about you on movinmg
19:12:44 <pvaneck> tuesday is fine for me. is a slot available for 19:00 utc tuesday?
19:12:55 <catherineD> yes the slot is available
19:13:11 <Rockyg> ok by me, but better grab the slot fast
19:13:16 <catherineD> great ...
19:13:25 <catherineD> I will grab the slot after this meeting ...
19:14:21 <catherineD> #agreed Move RefStack IRC meeting to Tuesday 19:00 UTC #openstack-meeting-alt
19:14:37 <catherineD> #action Catherine to submit patch for the move
19:14:56 <catherineD> that is really great that all of us are available
19:15:07 <catherineD> #topic RefStack Newton summit discussion topics
19:15:25 <catherineD> #link     Please add your topics to https://etherpad.openstack.org/p/refstack-newton-summit
19:15:47 <catherineD> andtey-mp: agree that we have a lot to discuss during the summit ...
19:16:02 <catherineD> I am so glad that all of us will be there this time ...
19:16:20 <Rockyg> yay!
19:17:22 <catherineD> andtey-mp: I see your comments on the product REST API patch... Thanks... I will response so we get the conversation going ... but I think it is best that we discuss face-2-face
19:18:24 <andtey-mp> catherineD: ok. I've started implementation of product REST API and I though about this questions
19:18:38 <catherineD> just want to confirm  if meeting at May 10 ok for andtey-mp: and sslypushenko: ?
19:18:52 <catherineD> andtey-mp: yup that is really great ..
19:19:21 <catherineD> the more issues we found now the better because we can discuss face-2-face ..
19:19:21 <sslypushenko> May 10 works for me
19:19:42 <andtey-mp> it's ok for me but I don't know right now about my availability at May 10...
19:19:52 <andtey-mp> but it works for me too
19:19:59 <catherineD> Rockyg: is May 10 Mother's day?  just noted that :-)
19:20:21 <catherineD> andtey-mp: that is fine ...
19:20:27 <catherineD> moving on ...
19:20:35 <Rockyg> mothers day is always a sunday
19:20:54 <catherineD> Rockyg: oh
19:21:05 <catherineD> #topic Vendor registation
19:22:10 <catherineD> andtey-mp: https://review.openstack.org/#/c/302436/ is ready to merge ... but we just want to hold on so that we can merge https://review.openstack.org/#/c/306923/ to cut a release for the live site
19:23:27 <catherineD> speaking of release ... we may as well moving to the next topic ...
19:23:36 <catherineD> #topic RefStack releases update to the live public website.
19:24:44 <andtey-mp> i don't understand what does it mean exactly )
19:24:51 <catherineD> so we used to update the live site with refstack master ... true CICD process :-) ..whatever merge to master will be updated to the live site 15 mins after
19:25:50 <catherineD> a couple months ago , we change to update the live site with tag release only ... that means that  the live site only get updated whenever we push a new tag
19:26:31 <catherineD> with the we have total control of when to push what changes to the live site ... because we are the one who push the tag
19:27:47 <catherineD> pvaneck: and I usually push new changes to the live site on Friday afternoon ..when the activity on the RefStack site is less and we have the weekend to fix issues if there is any ..
19:29:13 <catherineD> However, last week .. there is a change that ..from now on only the release team can create a tag (based on request from the project by submttng a patch to the releases repository for review ...
19:29:50 <catherineD> we basically can not control when the tag is being created (as we prefer on Friday)
19:29:56 <pvaneck> I don't think we'll be pushing releases too often, and release patches are merged fairly quickly. let's just stick with the new release pattern for now.
19:31:03 <catherineD> ok for the time being ... I am more concern about when we have big changes
19:31:05 <Rockyg> You could also request that the push happens on a specific day and probable with a four hour window.
19:31:30 <catherineD> Rockyg: that would be good ..
19:31:49 <Rockyg> If you go to the openstack-release IRC channel, you can usually get someone who can act quickly, also.
19:32:01 <catherineD> Rockyg: and sometime if there is a problem we may want to push a new remedy release after that ..
19:32:33 <catherineD> Rockyg: great suggestion ...
19:32:34 <Rockyg> Right.  IRC channel is good for that and if you can't find someone there, the infra folks can help
19:33:03 <catherineD> I guess we will stick with the official release for now ..
19:33:40 <catherineD> #action RefStack will update live site using the new release pattern
19:34:06 <catherineD> any other thoughts on this topic before we move on?
19:34:41 <Rockyg> I think it would be good to meet with release at summit and discuss this as I think we're the only live website relying on them
19:34:59 <Rockyg> Might want to flesh out an emergency procedure with them.
19:35:27 <catherineD> Rockyg: yea let's do that .. I know that they have a cross project session ... I will add out topic there
19:35:43 <catherineD> Rockyg: thx
19:35:56 <catherineD> #topic Product registration
19:36:18 <catherineD> andtey-mp: thanks for all the comments and implementing the patch ...
19:36:46 <catherineD> I guess this is one of the topic we will discuss a lot face-2-face at the summit
19:36:55 <andtey-mp> sure
19:37:35 <catherineD> anything else before we move to the next very important topic ...
19:38:20 <catherineD> #topic Proposal to add Andrey Pavlov as RefStack core
19:38:35 <catherineD> #link http://lists.openstack.org/pipermail/openstack-dev/2016-April/092470.html
19:39:00 <catherineD> Rockyg: pvaneck: thanks for your response ...
19:39:34 <catherineD> I am so happy that andtey-mp: has joined us for  this cycle ...
19:39:58 <andtey-mp> thank you :)
19:40:05 <Rockyg> Congratulations!!!!
19:40:43 <sslypushenko> Cool!
19:41:24 <catherineD> andtey-mp: you of 100% of the RefStack team's vote ...
19:41:48 <andtey-mp> thank you very much :)
19:41:49 <catherineD> Everyone please welcome our core andtey-mp:   ...
19:42:25 <pvaneck> glad to have you andrey!
19:42:48 <sslypushenko> That is really great! andtey-mp, congrats !
19:43:13 <andtey-mp> thank you all!
19:43:19 <Rockyg> Welcome aboard!
19:43:23 <catherineD> andtey-mp: just some house keeping ...
19:43:36 <catherineD> we try to only merge code with two +2
19:43:51 * docaedo catches up late and is glad to see meeting moving to Tuesday (works better for him!)
19:44:11 <andtey-mp> sure, its a common OpenStack rule as I know
19:44:19 <catherineD> we try to not have the 2 +2  for a patch that is summited by a person from the same company (
19:45:02 <Rockyg> Or the coder ;-)
19:45:06 <pvaneck> you mean merge?
19:45:17 <pvaneck> ah nvm. i got it
19:45:53 <catherineD> andtey-mp: I just add you could you try to see whether the +2 appears for you ...
19:46:21 <catherineD> Rockyg: yea ... again .. we try but sometime we may have exception ...
19:46:52 <andtey-mp> ok ) I see that you and Paul from IBM. maybe someone else?
19:46:53 <catherineD> docaedo: glad that the new time will be better for you :-)
19:47:00 <Rockyg> It is getting easier to not have exceptions as the core team continues to grow:-)
19:47:21 <catherineD> Rockyg: yea that is exactly the reason why we have exception ...
19:47:34 <andtey-mp> catherineD: yeah, I  have +2 from now in review
19:47:48 <catherineD> andtey-mp: that is great !!
19:48:57 <catherineD> andtey-mp: I guess we need to check the email or member profile to see which company  ..
19:49:21 <catherineD> that is all I have today ...
19:49:28 <catherineD> #topic Open discussion
19:49:37 <Rockyg> I've got something
19:50:06 <Rockyg> Lots of devs are now running test clouds that aren't devstack and wondering how to use tempest with them
19:50:22 <Rockyg> We have the solution, we just need to advertise it.
19:50:53 <catherineD> Rockyg: yea thanks for promoting us ....
19:51:07 <Rockyg> Maybe an email to the dev list with all, tempest, refstack that introduces the client and points to repo and docs?
19:51:08 <catherineD> Rockyg: any suggestion on how to do that
19:51:46 <catherineD> Rockyg:  ok that would be a good start
19:52:33 <Rockyg> Also go to one of the QA sessions and let the QA PTL and others know about it.  Maybe have a demo in a brownbag session or lightning talk?  A lightning talk in the Ops sessions would also be good.
19:53:04 <catherineD> Rockyg: we have a speaker session at Austin
19:53:11 <catherineD> with demo
19:53:32 <Rockyg> Also, after the summit, I'd be happy to sponsor a meetup at Huawei where folks can demo it to the SV openstack crowd.
19:53:42 <andtey-mp> Good example will be RefStack when we will finish new model - wher anyone can register his Cloud and run tests with any Guidelines )
19:53:56 <Rockyg> Yeah, but the speaker session is for the enduser stuff.  Not too many devs go to that.
19:53:57 <catherineD> Rockyg: a lighting talk in the Ops session would be a good addition too
19:54:16 <catherineD> andtey-mp: yea
19:54:35 <Rockyg> andtey-mp, most of the devs just want to run tests and look at results.  No interaction with the server
19:55:05 <catherineD> Rockyg: register lighting talk is done on site right?
19:55:24 <andtey-mp> Rockyg: in any case - they will need a Cloud to run on )
19:55:53 <docaedo> refstack-client still requires multiple users in the cloud being tested, right?
19:55:57 <Rockyg> For ops lightning, you go to ops etherpad and just add your talk there.
19:56:18 <catherineD> Rockyg: ok I will do that... thanks
19:56:40 <catherineD> anything else?
19:57:02 <andtey-mp> docaedo: it depends on tempest.conf
19:57:05 <pvaneck> docaedo: at least for defcore tests, i think only one user is needed
19:57:22 <Rockyg> docaedo, to run all tempest, yeah.  But if it's your test cloud, shouldn't be an issue.  Part of tempest config
19:57:30 <docaedo> ok - for the sake of making it easy on newcomers, definitely suggest a little more help with tempest.conf
19:57:38 <docaedo> on my first pass that was the only trouble I had
19:57:50 <Rockyg> docaedo, +1000
19:57:59 <catherineD> docaedo: tempest.conf is one of the topic on the speaker session ..
19:58:01 <docaedo> but big +1 on telling people they can use the client to test their non-devstack clouds easily
19:58:45 <catherineD> next release we will add a help link to RefStack sit and include all RefStack doc ... hopefully it will provide some help
19:58:59 <docaedo> tempest.conf as taken direct from devstack did not work for me - only worked when I changed it to use the accounts yaml and added additional accounts FYI
19:59:13 <docaedo> catherineD: I'll gladly review and test those doc changes
19:59:27 <catherineD> docaedo: thx
19:59:32 <Rockyg> docaedo, could you make sure your experience is reflected in the docs?
19:59:36 <catherineD> need to end meeting now
19:59:43 <docaedo> Rockyg: will do
19:59:43 <Rockyg> Good meeting!
19:59:58 <Rockyg> thanks, docaedo !
20:00:01 <catherineD> see you all at the summit !!!!
20:00:09 <pvaneck> safe travels everyone
20:00:11 <catherineD> #endmeeting