19:00:25 <catherine_d|1> #startmeeting refstack
19:00:26 <openstack> Meeting started Mon Dec 28 19:00:25 2015 UTC and is due to finish in 60 minutes.  The chair is catherine_d|1. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:29 <openstack> The meeting name has been set to 'refstack'
19:01:10 <catherine_d|1> roll call
19:01:37 <alevine> o/
19:02:31 <catherine_d|1> alevine: hello ... let's wait a little bit for Sergey ...
19:03:10 <catherine_d|1> I don't thin anyone else will join ..
19:03:27 <catherine_d|1> most a re on holidays
19:06:19 <sslypushenko> Hi! o/
19:06:44 <catherine_d|1> hello sslypushenko:  let's start
19:06:55 <catherine_d|1> #link meeting agenda and notes, please feel free to add items https://etherpad.openstack.org/p/refstack-meeting-15-12-28
19:07:27 <catherine_d|1> #topic No meeting on Jan 4, 2016
19:07:45 <sslypushenko> +1)
19:07:54 <catherine_d|1> #topic Alex Levin's RefStack Requirements document
19:08:11 <catherine_d|1> #link  https://docs.google.com/document/d/1s_dAIuluztlCC6AZ-WO4_FR2CLje1QyS6kbMxlFHaMk/edit?usp=sharing
19:08:29 <catherine_d|1> sslypushenko: do you have a chance to review the doc?
19:08:41 <sslypushenko> yeap
19:08:48 <sslypushenko> I did
19:08:50 <catherine_d|1> that is great
19:09:56 <sslypushenko> A lot of work  should be done to bring this spec in real)
19:10:30 <catherine_d|1> yep .. we will start with a data model spec which I am writing ...
19:10:47 <catherine_d|1> should submit in the next day or so for everyone to review ...
19:10:58 <alevine> The major reason for this is to sync everyone's understanding on where and how we should move.
19:11:41 <alevine> I guess we should sync it with higher level stakeholders as well later on. They should confirm that the requirements are correct.
19:13:29 <sslypushenko> alevine:  We should ping hogepodge and maybe someone else from DefCore for feedback
19:13:32 <catherine_d|1> the only thing that I think is missing in the version (and alevine: and I agree to defer that to the next release) is the roles of the differtent type of user as describe in page 12 of the document
19:14:27 <catherine_d|1> sslypushenko: alevine: DefCore already has a requiirement spec ..on https://review.openstack.org/#/c/226902/
19:14:44 <catherine_d|1> I think we should review that spec https://review.openstack.org/#/c/226902/
19:14:56 <catherine_d|1> to see whether there is anything in there that we do not agree with
19:15:08 <sslypushenko> it just a small part of the plan
19:15:27 <alevine> This spec is only about one enhancement requirement. However, we need to sync the whole picture which I tried to formulate.
19:15:50 <sslypushenko> alevine:  +1
19:15:54 <catherine_d|1> alevine''s requirement doc is to express whether we understand DefCore requrement
19:16:06 <alevine> We wouldn't want to implement something which is against real demands of stakeholders.
19:16:08 <catherine_d|1> I agree that DefCore only care about that aspec
19:16:27 <catherine_d|1> alevine: exactly that is why we should review their spec
19:16:53 <catherine_d|1> so we would not impelement something again their spec ..
19:17:49 <catherine_d|1> I totally agree that DefCore spec only about whatever they care about ... and not every details in RefStack
19:18:12 <catherine_d|1> we are the one to care about what are in RefStack and meet DefCore requirement ..
19:18:39 <catherine_d|1> so I really urge that we review Marks's https://review.openstack.org/#/c/226902/
19:19:24 <alevine> It's not even about all DefCore care about.
19:20:05 <catherine_d|1> alevine: what they care avout are express in the spec https://review.openstack.org/#/c/226902/
19:20:11 <catherine_d|1> including the comments ..
19:20:29 <sslypushenko> Anyway, it will be to share alevine's doc with Chris Hoge and Rob Hirschfeld
19:20:39 <catherine_d|1> we will ..
19:20:54 <sslypushenko> Or even discuss the doc on Defcore meeting
19:21:18 <catherine_d|1> when they take time to review what we put out ... we should also review what they give us ...
19:21:34 <catherine_d|1> does that seem reasonable ?
19:21:49 <sslypushenko> I will review 226902 ASAP
19:22:04 <catherine_d|1> thank you ...
19:22:19 <alevine> catherine_d: Of course I will too. I actually used first half of it in my reqs.
19:23:10 <sslypushenko> But alevine's doc sounds like plan and refstack definitely needs a sort of one
19:23:12 <catherine_d|1> alevine: exactly ... so let show that we care about what they put out officially by response to https://review.openstack.org/#/c/226902/
19:23:22 <catherine_d|1> sslypushenko: ++1
19:23:36 <catherine_d|1> I spent about 6 hours with alevine: on this doc ...
19:24:23 <catherine_d|1> Of course we want to push it forward .. it just that before we ask them for more ... we should take it serious on what they have giving us ...
19:24:28 <sslypushenko> Doc looks really detailed)
19:24:33 <catherine_d|1> otherwise it just like a cycle ...
19:24:55 <alevine> catherine_d: That's weird. I've actually forgotten for a minute what "to review" means in OpenStack. I thought to myself - I did read it, what else. Then I recalled that I need to show it with +1 :)
19:25:34 <catherine_d|1> alevine: EXACTLY ... and I know you have done all the woirk ...
19:25:47 <alevine> catherine_d: I will, soon.
19:25:56 <catherine_d|1> alevine: THANK YOU ...
19:26:36 <sslypushenko> alevine:  We appreciated your efforts so much)
19:26:45 <catherine_d|1> sslypushenko: +2
19:27:33 <catherine_d|1> one we merge their spec ... we will take alevine: 's doc as our understanding of the spec and our  plan to execute ...
19:27:50 <sslypushenko> RefStack needs some kind of plan, to attract community attention and, as a result, some human resources
19:28:17 <catherine_d|1> sslypushenko: yea .. that is RefStack's issue ..
19:28:28 <catherine_d|1> I have raised that to DefCore ...
19:28:28 <alevine> sslypushenko: Oh, come on. You know we don't need so many niceties here in USSR :)
19:29:23 <sslypushenko> Just kind of a good habit)
19:29:34 <catherine_d|1> that is why I really want to execute alevine: 's doc and pland with his team
19:30:07 <catherine_d|1> so I think we are all good?
19:30:14 <sslypushenko> +1
19:30:49 <alevine> +1
19:31:31 <catherine_d|1> #action Request DefCore to review alevine: 's doc by put that in DefCore's next meeting agenda.
19:32:04 <catherine_d|1> #action Catherine will put that in the DefCore meeting agenda
19:32:22 <catherine_d|1> #topic Vendor registraion spec
19:32:44 <catherine_d|1> #link Vendor registraion spec https://review.openstack.org/#/c/226902/
19:32:45 <sslypushenko> catherine_d|1:  I will review spec ASAP
19:33:09 <catherine_d|1> #acrion sslypushenko: alevine: to review  https://review.openstack.org/#/c/226902/
19:33:12 <sslypushenko> I think is ok, but need to reed final state
19:33:18 <catherine_d|1> sslypushenko: thank you
19:33:37 <sslypushenko> catherine_d|1: np
19:34:03 <catherine_d|1> #topic data model
19:34:29 <alevine> catherine_d: I'll need some more time to reread it. Not right now.
19:35:15 <catherine_d|1> #action Catherine will write a spec to spell out the data model based on alevine: requirement and data model presentation
19:35:24 <catherine_d|1> alevine: please take your time ..
19:35:54 <sslypushenko> catherine_d|1:  Lets put data model on hold while doc in review
19:36:29 <catherine_d|1> most people are on vacation .. DefCore meeting will be in January ... seriously most will be in normal schedule in the second week of January
19:36:47 <alevine> catherine_d: Do you think maybe better to start with detailing the object model? Properties, methods and stuff. And then it'll be clearer how to serialize it into DB. Or just use some object serializer.
19:37:13 <alevine> sslypushenko: +1
19:37:35 <sslypushenko> Agreed with alevine
19:37:55 <alevine> My thinking is that datamodel is a final stage of design.
19:38:02 <catherine_d|1> OK we can do that ..
19:38:51 <sslypushenko> it will take us a week to update schema to meet new expectations
19:39:05 <alevine> catherine_d: I was planning to emphasize on the object model adding the details when all the devs agree on the high-level picture. However I can start since Paul and David are not here soon.
19:39:06 <sslypushenko> so lets focus on paper work))
19:39:12 <catherine_d|1> I did not see a lot of deviation so far between the domian digram and the data model ... but we can wait
19:40:03 <catherine_d|1> alevine: I know that is why I want to start a spec so people can take it seriously ...
19:40:05 <alevine> catherine_d: It's just I remember you worrying about upgrade. We can think about noSQL DB. It'll save us a lot.
19:40:25 <catherine_d|1> alevine: I do worry about the upgrade...
19:40:41 <catherine_d|1> and data integrity
19:40:49 <alevine> catherine_d: You won't have to in case of noSQL or semantic-free DB.
19:41:03 <catherine_d|1> noSQL will be a major upgrade ...
19:41:07 <sslypushenko> alevine:  It depends on how much resources RefStack will have
19:41:32 <sslypushenko> Right now noSQL is not an option
19:41:42 <catherine_d|1> sslypushenko: ++2
19:42:00 <catherine_d|1> alevine: the DB right now is a service in OpenStack infra
19:42:23 <catherine_d|1> I am not sure they offer noSQL service
19:42:25 <alevine> guys, right now major upgrade is not a problem at all, IMO. Because we don't have many clients nor much data. Neither problems with downtime.
19:43:45 <catherine_d|1> IMO noSQL should be future consideration ..
19:43:53 <alevine> We can use SQL as NoSQL - no problem. What I'm saying, we need to think of it. If we decide to, say, just serialize our objects into XML and store in one table - we'll have no troubles with upgrade whatsoever. We'll just need to be sure that there are no contradicting reqs, like performance or something else.
19:44:27 <catherine_d|1> alevine: XML is out of the question for OpenStack IMO
19:44:30 <sslypushenko> alevine: In this case we will meet an performance issues soon
19:44:53 <alevine> I'm not saying that we SHOULD jump to something else right now. I'm saying that we'll see what's best when we get down to this stage from the above and especially when we'll have clarified non-functional reqs.
19:45:02 <alevine> why?
19:45:09 <alevine> I mean, don't answer that.
19:45:24 <alevine> I'm saying that we won't - there are many tactics how to avoid it.
19:45:43 <alevine> In many performance-tight systems of mine I had to get rid of SQL and use other techniques.
19:45:48 <sslypushenko> we should find out compromise between flexibility and ability to build kind of index
19:46:01 <alevine> Because SQL DB didn't satisfy.
19:46:19 <alevine> You can have many ways to build index.
19:46:21 <catherine_d|1> There is a lot of discussion about XMLin OpenStack mostly anti XML .. what I see is that XML support of the interface is taking out of Tempest of ter a long discussion ..
19:46:30 <alevine> You can build it in memory or store separately, you know.
19:46:42 <sslypushenko> alevine: I agreed that MongoDB meets RefStack expectations much closer than mysql
19:47:26 <sslypushenko> but all these changes need people to make it done
19:47:26 <alevine> catherine_d: That was just an example. I'm saying that designing SQL tables now is a bit too early for my thinking.
19:47:43 <catherine_d|1> alevine: ic
19:47:53 <sslypushenko> alevine:  yeap
19:48:05 <catherine_d|1> Let's just focus of achievable tasks for Mitaka
19:48:15 <sslypushenko> +1
19:48:20 <alevine> sslypushenko: Right now we have quite a small DB. We can have it exported into a different design practically in no time - both implementationally and operationally.
19:48:44 <catherine_d|1> so have not amke any major feature added since Liberty ... we only have about 2.5 months to go
19:49:02 <alevine> My thinking is that as soon as we agree - everything I wrote is implementable in Mitaka.
19:49:35 <sslypushenko> Hmmm It is a lof efforts
19:49:41 <alevine> nope :)
19:50:11 <sslypushenko> How big is your team?
19:50:20 <catherine_d|1> alevine:I am not tha optimistic ... look at https://review.openstack.org/#/c/226902/  it was submit on  Sept 23
19:50:42 <alevine> I guess 1 person full-time I can contribute. Maybe 0.5 more :)
19:51:17 <alevine> However, many features I wrote are already implemented in our prototype refstack site. And it did not take long.
19:51:17 <sslypushenko> So, you definitely overoptimistic)
19:51:35 <catherine_d|1> I agree
19:51:52 <alevine> Have you seen our refstack? Obviously you have.
19:52:09 <sslypushenko> Yeap, I have
19:52:09 <catherine_d|1> but I truly believe that we can make progress if we focus on achievable tasks
19:52:19 <catherine_d|1> alevine: I have ...
19:52:46 <alevine> We already have Guidelines registration, clouds registration and some other stuff.
19:54:03 <alevine> Ah, the only think I'd postpone is tempest auto-configuration, however even this is achievable to some extent.
19:54:08 <catherine_d|1> alevine: I want to be optimistic but the reallity on working on this project for the last 2 years really bring doubt to my mind
19:54:28 <sslypushenko> if we add here vendor registration it will be cool enough for Mitaka cycle
19:54:38 <catherine_d|1> sslypushenko: +++++2
19:54:47 <alevine> catherine_d: I wouldn't say this if we didn't dig very deep into this yet. We did rework and enhance it a lot. I don't see real showstoppers.
19:55:38 <alevine> How about this. Let's agree the reqs with the DefCore. And in the meantime I'll detail the design and then we'll create a prototype.
19:55:53 <catherine_d|1> 5 mins to go we have a couple actions items already ... let's execute that ...we will discuss about db in the next meeting
19:55:56 <catherine_d|1> anything else
19:55:59 <catherine_d|1> ?
19:56:06 <sslypushenko> alevine:  It looks like you are not really familiar with community driven development)
19:56:21 <alevine> sslypushenko: I am.
19:56:31 <sslypushenko> It took us half a year to get just hosting for RefStack)
19:56:39 <catherine_d|1> sslypushenko: +1
19:56:50 <alevine> sslypushenko: However, I'm talking about the prototype. And we're talking about being fast, right?
19:57:18 <sslypushenko> alevine: I hope your plans will come true)
19:57:21 <catherine_d|1> an once we hosted it .. we have several unexpected issues (like caching, network ...)
19:57:25 <alevine> sslypushenko: That's great job, so you'll know how to add the Testing Server :)
19:58:13 <alevine> catherine_d: Perfect, that's the way to divide the work. The prototype would demonstrate functionality and proof of concepts. I'll detail what will be done in it and what not.
19:58:30 <sslypushenko> oh, no) I'm prefer to get testing stage some where out of community resources)
19:58:35 <alevine> catherine_d: And then we'll need to propertly host it and many other things.
19:59:05 <catherine_d|1> the is no prototype ... anything you commit will show up on RefStack webstie 15 mins later ...
19:59:09 <alevine> catherine_d: Sorry, let's get back to those two more things.
19:59:19 <catherine_d|1> we need to end this meeting
19:59:26 <catherine_d|1> we can talk on #refstack
19:59:28 <alevine> catherine_d: There is. We have it right now.
19:59:32 <sslypushenko> +1
19:59:37 <catherine_d|1> #endmeeting