19:00:24 <catherineD> #startmeeting refstack
19:00:25 <openstack> Meeting started Mon Aug 31 19:00:24 2015 UTC and is due to finish in 60 minutes.  The chair is catherineD. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:29 <openstack> The meeting name has been set to 'refstack'
19:00:40 <catherineD> roll call
19:00:48 <pvaneck> o/
19:01:06 <dliu> Hello
19:01:14 <sslypushenko__> o/
19:01:35 <catherineD> #link meeting agenda and notes, please feel free to add items https://etherpad.openstack.org/p/refstack-meeting-15-08-31
19:02:01 <catherineD> hello everyone ...
19:02:01 <Rockyg> o/
19:02:13 <catherineD> let's start ...
19:02:17 <sslypushenko__> catherineD hi!
19:02:53 <dliu> Hello Catherine
19:02:54 <catherineD> first of all, I want to introduce dliu: ...who is from IBM China ...
19:03:00 <pvaneck> hi dliu
19:03:11 <pvaneck> welcome
19:03:14 <dliu> Hi pvaneck
19:03:27 <dliu> thanks a lot
19:03:30 <sslypushenko__> Hi, dliu!
19:03:40 <catherineD> dliu: will join us on the RefStack project ...
19:03:41 <dliu> Hi sslypushenko
19:03:41 <Rockyg> Welcome.  Sorry for the early meeting...
19:03:53 <dliu> It's ok
19:04:07 <dliu> my pleasure to meet all you guys
19:04:16 <catherineD> dliu: what is your time now?
19:04:17 <dliu> Hi Rockyg
19:04:36 <dliu> 3:00 in the morning
19:04:39 <catherineD> wow
19:04:45 <dliu> :-)
19:04:57 <catherineD> dliu: sorry ...
19:05:03 <dliu> Iti
19:05:11 <sslypushenko__> really early)
19:05:14 <dliu> It's ok, don't worry
19:05:29 <catherineD> #topic No RefStack IRC next Monday (September 7) -- US holiday
19:05:47 <catherineD> sslypushenko__: and it is really late for you?
19:06:02 <sslypushenko__> not so much
19:06:13 <catherineD> #topic Relocate RefStack Project
19:06:40 <catherineD> we are now in "Big Tent" ..
19:06:53 <sslypushenko__> That is great
19:07:03 <pvaneck> :)
19:07:23 <dliu> cool
19:07:35 <catherineD> yep ... the next step is to move the repos ... I will look into creating a patch for that if needed
19:07:54 <catherineD> #topic Infra hosting
19:08:05 <Rockyg> I think Ops will handle that, but not positive
19:08:17 <catherineD> Rockyg: that would be good ....
19:08:36 <catherineD> pvaneck: any status on your patch ?
19:08:39 <Rockyg> I'll ping them on the infra channel...
19:08:43 <pvaneck> #link https://review.openstack.org/#/c/214950/
19:08:50 <pvaneck> is the puppet-refstack patch that is needed
19:08:52 <catherineD> Rockyg: thank you ....
19:09:02 <pvaneck> it has one +2
19:09:24 <pvaneck> and is just awaiting another
19:09:28 <catherineD> pvaneck: should we get on their IRC meeting  ?
19:09:45 <Rockyg> That's tomorrow at noon PDT
19:10:01 <Rockyg> But, yeah.  That would be good
19:10:10 <pvaneck> i've brought it up already with jim
19:10:18 <pvaneck> should hopefully have a review soon
19:10:20 <sslypushenko__> We need to speedup hosting process
19:10:55 <Rockyg> sslypushenko__, good luck with that ;-)
19:11:03 <catherineD> Let's get on infra IRC  if there is no progress ...
19:11:29 <pvaneck> still need to update the puppet-refstack refstack.conf template to account for new additions and changes
19:11:55 <catherineD> pvaneck: so we need one more patch?
19:12:06 <Rockyg> Can you have that done by noon tomorrow?  I'll go see where their meeting agenda is....
19:12:24 <pvaneck> catherined: yes, I will submit one
19:12:59 <pvaneck> yea, updating the refstack.conf should be straightforward
19:13:12 <catherineD> #action pvaneck: to submit a patch to update puppet-refstack restack.conf
19:13:46 <catherineD> Rockyg: do we need to add ourself to the infra agenda
19:14:10 <Rockyg> I'm checking now...
19:14:16 <catherineD> Rockyg: thx ..
19:14:48 <catherineD> with that  can go the next topic which is kind of related to this one ...
19:15:10 <catherineD> #topic Disable anonymous data upload now that user can decide to share data anonymously
19:15:25 <catherineD> I really would like to disable that when we move to infra ....
19:16:01 <Rockyg> ++
19:16:27 <catherineD> with anonymous data upload we can not delete data ....
19:16:32 <sslypushenko__> +1
19:16:56 <pvaneck> a key thing we need is instructions on the import key page for directions on signing keys (i.e. use refstack-client)
19:17:02 <pvaneck> i will create a bug
19:17:08 <sslypushenko__> catherine we can add admin role with right to delete public data
19:17:29 <catherineD> sslypushenko__: the problem is we do not know which data to delete ...
19:17:50 <sslypushenko__> but anyway there is not reason to keep anonymous upload
19:17:50 <catherineD> or we have no criteria on which data should be deleted ....
19:17:58 <catherineD> sslypushenko__: ++
19:18:27 <sslypushenko__> pvaneck You are 100% right, we need updated docs
19:18:31 <catherineD> since we all agree here ... let's submit a patch to disable anonymous upload ...
19:19:01 <catherineD> #action Disable anonymous data upload to RefStack
19:19:24 <sslypushenko__> catherineD Lets update docs first
19:19:36 <catherineD> sslypushenko__: agree
19:20:52 <catherineD> #agreed Anoymous data upload should only be disabled after RefStack docs are updated with instruction for key importing
19:21:19 <catherineD> anything else?  ready for the next topic?
19:21:35 <sslypushenko__> lets roll
19:21:41 <catherineD> #topic Vendor registration process
19:22:22 <catherineD> Vendor registration and comparing data are the two items left from the Vancouver f2f meeting action items ...
19:22:39 <catherineD> I have asked for a specification on the DefCore IRC meeting ...
19:23:05 <catherineD> DefCore asked that I send a email to the DefCore ML ...
19:23:12 <catherineD> I will send that email out today ...
19:23:55 <hogepodge> o/
19:24:06 <catherineD> the specification should come from DefCore and the Foundation (hogepodge: )
19:24:07 <sslypushenko__> catherineD I think vendor registration should be considered as out of scope for current cycle
19:24:13 <catherineD> hogepodge: just in time ....
19:24:44 <sslypushenko__> Spec for that item will be enought
19:24:52 <catherineD> hogepodge: we are discussing vendor registration process ...
19:25:46 <catherineD> sslypushenko__: yea ... at lease we should get a spec for that to plan our work ...
19:26:16 <catherineD> to prepare for that .... let's get to the next item
19:26:23 <Rockyg> If we can get the requirements/spec through the DefCore committee, that would be a great accomplishment.  That is for Liberty
19:26:45 <catherineD> Rockyg: sslypushenko__: I think so ....
19:26:55 <sslypushenko__> Rockyg Fully agreed
19:26:57 <hogepodge> It's not critical short term.
19:27:10 <hogepodge> I trust that vendors will send valid test results we can link to externally
19:28:52 <catherineD> #agreed Target for vendor resgistration for the Liberty cycle is to mergte a DefCore requirement specification  patch
19:29:40 <catherineD> ok next discuss the next item ...
19:29:54 <catherineD> #topic User/public key/result data relationship discussion
19:30:18 <catherineD> to prepare for vendor registration ... we need to review what we implemented today ...
19:31:00 <catherineD> today, data is associated to the key not user ...
19:31:24 <catherineD> if the key is deleted the data is zombie ...
19:31:39 <sslypushenko__> not 100% right
19:31:57 <dliu> that means we need to change the db table?
19:31:57 <catherineD> sslypushenko__: please explain ...
19:32:16 <sslypushenko__> if user upload this key back test results will be associated back
19:32:54 <catherineD> sslypushenko__: I am thinking of in the case when the user no longer works for a vendor ...
19:33:08 <catherineD> and that key belongs to the user ...
19:33:16 <sslypushenko__> хм...
19:33:20 <sslypushenko__> hmmm)
19:33:21 <catherineD> how would the vendor keep the data?
19:33:57 <sslypushenko__> It need some time to think
19:35:00 <catherineD> sslypushenko__: yea I think so .... we need to consider the relation ship among user, data and vendor ....
19:35:00 <sslypushenko__> Basically, I think that vendor will have special accoutn
19:35:26 <sslypushenko__> so vendor will act as user
19:35:50 <sslypushenko__> maybe with some additional extra features
19:36:37 <Rockyg> So, what happens if the vendor decides to change his key?  The person assigned to do the uploads leaves, and the vendor for security, changes the keys.....
19:36:45 <sslypushenko__> we can add possibility to move test results from user account to vendor one
19:36:45 <catherineD> maybe there should be a master key that is owned by the vendor (master user)
19:37:40 <sslypushenko__> sure... vendor should have a specific key
19:38:20 <catherineD> sslypushenko__: Rockyg: I am thinking that each set of data will belongs to 2 keys (user key and vendor key)
19:38:47 <sslypushenko__> Sounds not bad)
19:39:09 <catherineD> when the user leaves the company, vendor will delete the user key and add outher use key if needed ...
19:39:37 <catherineD> I know we are discussiong all of this before we have a spec ..
19:39:56 <Rockyg> sounds reasonable.  But perhaps we should invite the security team in OpenStack to weigh in?
19:40:09 <catherineD> but I would like is to think about these scenario and match it to the way we implemented today ...
19:40:28 <Rockyg> They might know industry standards and opensource SW for the keys/management/etc
19:40:40 <catherineD> Rockyg: absolutely ... for now I would like all of us to give some thoughts on the topic ...
19:41:00 <Rockyg> Sounds good
19:41:33 <sslypushenko__> We already have anought
19:41:40 <catherineD> #info RefStack team to review the relationship among user/data/vendore
19:41:44 <sslypushenko__> *eought thing to think
19:42:03 <catherineD> sslypushenko__: I know I know ...
19:42:17 <catherineD> that bring us to the next topic ....
19:42:24 <catherineD> #Open discussion
19:42:35 <catherineD> #topic Open discussion
19:42:55 <Rockyg> Ah.  So, looks like the project teams files the patch to move the repos
19:43:20 <Rockyg> example:  https://review.openstack.org/200730
19:43:23 <catherineD> Rockyg: that is super ... not thing for us to do .... thx for checking
19:44:07 <Rockyg> Once filed, Ifra adds it to its list of Project renames, which are separate from the less heavy repo moves
19:44:36 <catherineD> Rockyg: that definitely is more efficient ...
19:44:55 <catherineD> sslypushenko__: so our speaker session is not selected :-(
19:45:02 <Rockyg> once approved, it gets scheduled by Ops.  The repo move is scheduled for 10/17.  I don't know if they'd do projects first or at the same time.
19:45:06 <sslypushenko__> I know(
19:45:49 <sslypushenko__> Hope next time will be luckier )
19:46:15 <sslypushenko__> But what about f2f?
19:46:18 <catherineD> sslypushenko__: I hope so ... I was hoping for us to demo all the new features
19:46:33 <Rockyg> Next time, I think the foundation will do it as one of the main sessions....
19:46:40 <Rockyg> Or at least demo it as such.
19:46:45 <Rockyg> Maybe even this time.
19:47:19 <catherineD> Rockyg: if they do that we can recommend sslypushenko__: ?
19:47:49 <Rockyg> I would think so... as the demo runner...
19:47:58 <catherineD> anyway I was having high hope to demo to the community ...
19:48:05 <sslypushenko__> catherineD wow wow)) not so fast)
19:48:32 <sslypushenko__> I think I can't be a good demo runner)
19:48:44 <catherineD> sslypushenko__: why not?
19:49:36 <sslypushenko__> My English is really far from good enougth)
19:50:40 <catherineD> sslypushenko__: that would not be too much problem  if we are demoing to a technical committee ...
19:51:02 <sslypushenko__> May be)
19:51:34 <catherineD> sslypushenko__: no pressure ... just that you have done such an amazing contribution to the project ...
19:51:50 <catherineD> back to the f2f ...
19:51:57 <sslypushenko__> But I really prefer to take part in Austin summit)
19:52:19 <sslypushenko__> If I will have a chance)
19:52:38 <catherineD> one of the major topic for the f2f is to discuss vendor registration ...
19:53:06 <catherineD> the other topic is non-tempest testing ...
19:53:44 <catherineD> for the vendor registration we just decide that the target for Liberty is a spec ...
19:53:59 <catherineD> so the only topic is non-tempest testing ....
19:54:30 <sslypushenko__> I can share some results related with this topic
19:54:32 <catherineD> Rockyg: I am thinking of inviting Randy Bias's team for t he EC2 testing ...
19:54:52 <sslypushenko__> https://review.openstack.org/#/c/214571/
19:54:55 <Rockyg> Sounds good.  Only need one or two, but that makes it easier.
19:55:39 <catherineD> sslypushenko__: that is great .... Let me check the date for a f2f with Randy's people and maybe checking with some RackSpace peole too ..
19:55:40 <sslypushenko__> It is results of work on running swift tests using tempest
19:56:06 <sslypushenko__> It is far away from ready solution
19:56:25 <catherineD> #action catherineD: to select a date for a one day f2f meeting for non-tempest testing in RefStack ///
19:56:33 <sslypushenko__> but as proof of concept it is working
19:56:48 <catherineD> sslypushenko__: that is great ... will take a look ...
19:56:59 <catherineD> anything else before we close?
19:57:22 <sslypushenko__> so we cancel f2f this week&
19:57:26 <sslypushenko__> ?
19:57:31 <Rockyg> just we need someone to write the repo move patch
19:57:49 <Rockyg> I *might* be able to do it....
19:57:54 <catherineD> sslypushenko__: yes we decided last week that we will reschedule ...
19:58:04 <sslypushenko__> okay
19:58:21 <Rockyg> But pretty easy for pvaneck or sslypushenko__
19:58:23 <catherineD> sslypushenko__: I hope we did not mess you up  ...
19:58:33 <sslypushenko__> Me too)
19:58:37 <catherineD> on the reschedule ...
19:59:23 <catherineD> Rockyg: go for it ...
19:59:35 <catherineD> let's end the meeitng ..
19:59:53 <catherineD> #endmeeting