19:00:22 <catherineD> #startmeeting refstack
19:00:23 <openstack> Meeting started Mon Aug 17 19:00:22 2015 UTC and is due to finish in 60 minutes.  The chair is catherineD. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:26 <openstack> The meeting name has been set to 'refstack'
19:00:54 <catherineD> #link meeting agenda and notes, please feel free to add items https://etherpad.openstack.org/p/refstack-meeting-15-08-17
19:01:10 <catherineD> Roll call
19:01:31 <davidlenwell> o/
19:01:34 <pvaneck> o/
19:01:49 <sslypushenko__> o/
19:02:22 <catherineD> #topic Relocate RefStack Project
19:03:02 <catherineD> As of Aug 3.. Refstack was approved  to be moved to openstack-infra .. (we have not move the repos yet ..)
19:03:45 <catherineD> last week Chris inform me that Foundation staff general consensus is that Rfstack should be a big tent project
19:04:20 <davidlenwell> that was part of why I voted on moving into openstack .. but was out voted
19:04:21 <catherineD> so I put https://review.openstack.org/#/c/205777/  on hold ....
19:04:44 <catherineD> yea we will have to move again ...
19:05:07 <pvaneck> we never really moved though
19:05:14 <pvaneck> did you submit a governance patch?
19:05:37 <catherineD> pvaneck: I have a patch ready .. just need to push it up ...
19:05:52 <catherineD> before I do that I would like to discuss about Refstack official name ...
19:05:53 <davidlenwell> I was supposed to do that .. but I failed to not get distracted by the day job
19:06:45 <catherineD> davidlenwell: np
19:07:36 <catherineD> #link  Refstack is adopted as the official tools for DefCore  http://superuser.openstack.org/articles/openstack-continues-to-strengthen-its-commitment-to-interoperability
19:08:12 <catherineD> in that link hogepodge: refer Refstack as RefStack ....
19:09:04 <catherineD> I also see many blog, paper, presentation from other people use the RefStack  name ....
19:10:02 <pvaneck> was the capitalization originally meant to mirror the 'OpenStack' capitalization?
19:10:10 <catherineD> #link our wiki is also using RefStack https://wiki.openstack.org/wiki/RefStack
19:10:29 <catherineD> pvaneck: I am not sure ...
19:10:53 <pvaneck> seems so, and it makes sense
19:11:00 <catherineD> so before I send the next governance patch (I have it ready) ... I would like us to settle our name ..
19:11:34 <catherineD> I propose to use RefStack as our name .... what does everyone think?
19:12:00 <davidlenwell> I've always been a fan of keeping it all lowercase
19:12:24 <catherineD> davidlenwell: I know ...
19:12:46 <davidlenwell> but I won't object..as long as we keep it consistant
19:13:00 <catherineD> yes that is my problem now ...
19:13:05 <davidlenwell> I am going to loose signal in a second.. I'll catch up with you later catherineD
19:13:27 <Rockyg> o/
19:13:29 <catherineD> davidlenwell: thx will do I know your vote on the f2f dates
19:13:39 <davidlenwell> thanks!
19:13:46 <catherineD> Rockyg: Hi ..
19:14:11 * Rockyg waves
19:14:37 <pvaneck> i prefer the uppercase, and am okay with 'RefStack'
19:14:38 <catherineD> Rockyg: We try to decide on a consistant name for Refstack ... I propose "RefStack"  we are about to vote ..
19:14:53 <sslypushenko__> +1 for RefStack
19:15:11 <Rockyg> k.  I'm pretty neutral
19:16:15 <pvaneck> let's just go with RefStack to staty consistent with OpenStack capitilization
19:16:20 <pvaneck> stay*
19:16:57 <catherineD> @infor Use "RefStack" as our project name: Yes (pvaneck: sslypushenko__: catherineD: ), neutral (Rockyg: ), davidlenwell: prefer lowercase but don't objective
19:17:12 <Rockyg> Either way works.  Harder to type RefStack, but not much
19:17:47 <catherineD> #agreed RefStack as project name
19:17:54 <catherineD> thank you everyone
19:18:23 <pvaneck> Catherine, you want to do all the updates? :D
19:18:36 <catherineD> I will send a governance patch to move RefStack to openstack today ..
19:18:45 <catherineD> pvaneck: yes I will
19:18:45 <pvaneck> wiki, documentation, and website header need updating,
19:18:54 <pvaneck> and also the about section of refstack.net
19:19:01 <catherineD> pvaneck: yea
19:19:32 <catherineD> #topic Face-2-face meeting
19:19:55 <catherineD> #info from last week meeting: Tentative date&time: 9/2 or 9/3 from 10:00 AM - 2:00 PM PDT (17:00 UTC - 21:00 UTC)
19:21:07 <pvaneck> still fine by me
19:21:13 <catherineD> I just disucss with davidlenwell: ... he thinks we need 2 days .. planning and work session ...
19:21:43 <catherineD> form last week we try to plan on topic ahead .. and then one day for work session ...
19:22:08 <catherineD> the topics are in the agenda ...
19:22:34 <Rockyg> works for me. Especially if Boris turns up, we'll need more time.
19:22:54 <catherineD> Rockyg: will you be able to join the f2f meeting  on 9/2 and 9/3?
19:23:05 <Rockyg> yes
19:23:39 <sslypushenko__> +1
19:23:48 <catherineD> sslypushenko__: 1 or 2 days?
19:24:16 <sslypushenko__> both
19:24:24 <catherineD> 2 days?
19:25:02 <pvaneck> whichever
19:26:00 <catherineD> #agreed RefStack face-2-face will be 9/2 and 9/3 from 10:00 AM - 2:00 PM PDT (17:00 UTC - 21:00 UTC)
19:26:05 <sslypushenko__> 2 day will be ok
19:26:46 <catherineD> I will create a f2f agenda now that we have decided to have a f2f meeting ...
19:27:20 <catherineD> #topic infra hosting
19:28:18 <catherineD> pvaneck:  do you have a chance to look at the puppet module for https://review.openstack.org/#/c/198869/
19:28:55 <catherineD> do we need to ask krotscheck: to help?
19:29:03 <pvaneck> yea a little bit,
19:29:06 * krotscheck perks up?
19:29:12 <pvaneck> and yea
19:30:09 <pvaneck> krotscheck: cant seem to get the gate to patch and it seems to have to do with puppet-python
19:30:11 <catherineD> krotscheck  please help us with https://review.openstack.org/#/c/198869/
19:30:12 <pvaneck> error message here: http://logs.openstack.org/69/198869/6/check/gate-infra-puppet-apply-bare-trusty/6185973/puppetapplytest28.final.out
19:31:06 <catherineD> from fungi: last comment.. it is realate to refstack puppet module ..
19:32:13 <krotscheck> pvaneck: Will take a quick look.
19:32:50 <catherineD> krotscheck: thx
19:33:10 <catherineD> alrighit let's move on ...
19:33:30 <catherineD> #topic OpenStackID integration
19:33:45 <catherineD> sslypushenko__: thx for all the updates ...
19:34:16 <sslypushenko__> You are welcome)
19:34:55 <sslypushenko__> It still needs some JS tests and docs
19:35:07 <catherineD> sslypushenko__:  question on https://review.openstack.org/#/c/207807/  ... why is CPID removed on the latest pathes?  For data uploaded with signed user, we plan to display CPID
19:35:08 <sslypushenko__> But it would be a following work
19:35:11 <pvaneck> sure I can help with that
19:35:53 <sslypushenko__> hmm...
19:35:55 <pvaneck> perhaps we can override default_allowed_keys in the case of where cpid is needed?
19:36:38 <sslypushenko__> We discussed this issue with hogepodge, he also think that displaying cpid is not good idea
19:37:00 <sslypushenko__> but I can bring it back
19:37:11 <catherineD> sslypushenko__: it is not a good idea for public display .. but for signed display that would help ...
19:37:27 <catherineD> I envision that a user may upload data for multiple clouds ...
19:37:30 <Rockyg> catherineD, +1
19:37:30 <sslypushenko__> hm... Okay
19:37:48 <sslypushenko__> Np, I will update patch
19:38:11 <catherineD> sslypushenko__: thx ... that is the only reason why that patch is not merged ...
19:38:39 <sslypushenko__> Ok, I think I can doing right now....
19:39:03 <catherineD> Rockyg: with sslypushenko__: latest patches ... we can now send that with signed user.... a very important feature ... for now user can decide to expose the data to public and even delete the data ...
19:39:45 <Rockyg> kewl
19:40:08 <catherineD> sslypushenko__: thank you very much ... great works!
19:40:15 <Rockyg> hogepodge will love that.
19:40:41 <Rockyg> And the corporate certification folks, too.
19:40:46 <catherineD> Rockyg: yea next we will need to associate user to vendor ... and that is an important topic for the f2f ...
19:41:12 <Rockyg> Much more reassuring with that that the results are real
19:41:34 <catherineD> yes ... because vendor can now control and make decision on their data ...
19:41:55 <catherineD> of course we still support anonymous upload ...
19:43:19 <catherineD> sslypushenko__: pleae review pvaneck: 's https://review.openstack.org/#/c/212295/  ... since the signed user feature can only work with API and UI hosted on one domain ... we need to merge the new README
19:43:51 <catherineD> Rockyg: on the f2f we will also discuss about EC2 testing ...
19:44:03 <sslypushenko__> catherineD I think anonymous upload is not really great idea
19:44:44 <sslypushenko__> We need to protect our API from trash uploading somehow
19:45:38 <Rockyg> I think we need to keep anonymous upload data separate from "official" data.  So a compare and contrast capability with some of the visualization tools
19:45:41 <sslypushenko__> Right now it is to easy upload for example 1000 fake test results
19:46:10 <catherineD> sslypushenko__: I know it really encourage irresponsible upload ... but to not intimidate people and encourage user to provide us with more data
19:46:36 <pvaneck> perhaps a filter for only showing signed results on the community results page
19:46:48 <sslypushenko__> people can upload signed data and stay anonymous
19:47:03 <Rockyg> how about not anonymous, but data doesn't have sdubmitter info attached to it on display of it.
19:47:09 <catherineD> I agree with sslypushenko__: it is very dangerous ...
19:47:29 <catherineD> Rockyg: that exist with the new patches that sslypushenko__: submitted
19:48:40 <catherineD> I think we will turn anonymous upload off in the near future ... but we will keep anonymous public result dispaly
19:48:51 <Rockyg> That should be how "anonymous" works.  You can't submit anonymously, but your submissions are all part of aggregate data  That provides the anonymity for the user.  No one know who submitted the data except for the foundation.
19:48:57 <sslypushenko__> I think that we should restrict submitting unsigned resutls, after clear howto upload result with signature are readt
19:50:03 <pvaneck> so every test result will then have an associated openstackid?
19:50:06 <catherineD> sslypushenko__: Let's discuss how to announce this change in the next meeting with hogepodge: presents
19:50:28 <sslypushenko__> catherineD We can continue allow users to upload signed result anonymously
19:51:00 <Rockyg> pvaneck,  yes.
19:51:12 <catherineD> sslypushenko__: but I think it can cause irrepomsible upload and the data could be bias ..
19:51:40 <sslypushenko__> pvaneck Every result is associated with pubkey
19:51:45 <catherineD> That fear had been in my mind ...
19:52:23 <catherineD> sslypushenko__: what if user delete the public key?
19:53:43 <sslypushenko__> catherineD nothing happend) Users pubkey is hardly connected with signature pubkey
19:53:50 <sslypushenko__> *is not
19:53:59 <catherineD> #info Add to next week agenda: Turn off anonymous upload, keep anomymous display on public results
19:54:15 <sslypushenko__> Such result became unowned
19:55:03 <sslypushenko__> Right now unowned results aren't displayed anyone
19:55:44 <catherineD> sslypushenko__: wow we do not want to have unowned results which is useless to  us ...
19:55:52 <catherineD> let's discuss this next week ...
19:56:21 <pvaneck> just need to tie it to openstackid if available
19:56:53 <catherineD> pvaneck: people may move ...
19:57:10 <catherineD> data should really tie to vendor ..
19:57:16 <sslypushenko__> catherineD Maybe I cann't attend this meeting next time. I will traveling
19:57:33 <catherineD> sslypushenko__: ok thx for letting me know
19:57:34 <pvaneck> also, regarding the refstack-client patch: https://review.openstack.org/#/c/200589/
19:57:37 <pvaneck> i left some comments
19:58:04 <pvaneck> one being that -i for sign should be a required arg since there is no default
19:58:15 <pvaneck> another regarding the logger level
19:58:33 <pvaneck> i think the default logger level for the client should be info
19:59:03 <sslypushenko__> agreed
19:59:05 <pvaneck> was not a fan of silent by default
19:59:21 <pvaneck> leaves several users confused
19:59:42 <pvaneck> so i propose to add a patch to change default level to INFO
19:59:48 <sslypushenko__> but what about required -i flag?
20:00:25 <pvaneck> since there is no default for -i, we need it required
20:00:31 <catherineD> pvaneck: +1 let's do it
20:00:33 <pvaneck> out of time
20:00:42 <catherineD> we need to end the meeting
20:00:46 <catherineD> talk more on #refstack
20:00:59 <catherineD> #endmeeting