19:01:15 <catherineD|2> #startmeeting refstack
19:01:16 <openstack> Meeting started Mon Aug 10 19:01:15 2015 UTC and is due to finish in 60 minutes.  The chair is catherineD|2. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:20 <openstack> The meeting name has been set to 'refstack'
19:01:33 <catherineD|2> Roll call
19:01:50 <pvaneck> o/
19:01:51 <sslypushenko__> o/
19:02:18 <catherineD|2> hello pvaneck: sslypushenko__:
19:02:32 <sslypushenko__> catherineD|2 hi!
19:02:50 <pvaneck> hello
19:03:16 <catherineD|2> sslypushenko__: I put https://review.openstack.org/#/c/192709 one the agenda under Open Discussion ... Let's get to it later ... if we run out of time we can discuss that on #refstack
19:03:38 <sslypushenko__> ok
19:03:51 <catherineD|2> #link meeting agenda and notes, please feel free to add items https://etherpad.openstack.org/p/refstack-meeting-15-08-10
19:04:23 <catherineD|2> while waiting for others to join, we can discuss topic #3 first
19:04:35 <catherineD|2> #topic OpenStackID integration
19:05:26 <catherineD|2> sslypushenko__: Current patches only work with Refstack UI and API server using same domain ... is that by design?
19:05:48 <sslypushenko__> I think it  is not
19:05:55 <catherineD|2> I think both pvaneck: and I are OK with it ....
19:06:08 <sslypushenko__> My setup is one-domain
19:06:11 <catherineD|2> if we choose it this way we will need to change oaur README file
19:06:38 <sslypushenko__> I think we can fixed if is neccessary
19:06:47 <catherineD|2> yea 2 domain does not work ....
19:06:53 <pvaneck> some cors issues
19:07:03 <sslypushenko__> Lets stik to one-domain setup for now
19:07:08 <pvaneck> but it seems like we will be sticking with one domain
19:07:15 <pvaneck> and i prefer the dingle domain
19:07:16 <catherineD|2> sslypushenko__: either you fix it or we just update the README file ... I have no problem with either way
19:07:18 <pvaneck> single*
19:07:45 <pvaneck> haha, easier to just update the readme
19:07:53 <sslypushenko__> +1)
19:07:56 <catherineD|2> let's vote then ..
19:08:14 <pvaneck> we should have run-in-docker documentation, and the refstack-api in app-dev-mode method
19:08:28 <sslypushenko__> for sure
19:08:43 <sslypushenko__> I will add some docs
19:08:44 <pvaneck> so yea, +1 on just the documentaiton updates
19:08:50 <sslypushenko__> hope this week
19:09:25 <catherineD|2> #startvote Refstack will update to only support one domain for API and UI server.  Vote yes|no
19:09:25 <openstack> Unable to parse vote topic and options.
19:09:36 <catherineD|2> #startvote Refstack will update to only support one domain for API and UI server
19:09:37 <openstack> Unable to parse vote topic and options.
19:09:50 <catherineD|2> I don't know how to do it
19:10:10 <pvaneck> haha don't worry about it
19:10:12 <sslypushenko__> Lets stick on readme update and move on
19:10:16 <pvaneck> seems like we are agreed
19:10:31 <catherineD|2> +1 to update README
19:11:24 <pvaneck> I can submit a patch for using refstack-api (i.e. pecan) for serving the website
19:11:26 <catherineD|2> #agreed Update Refstrack README to only support hosting API and UI server on one domain
19:11:38 <catherineD|2> pvaneck: please do thanks
19:12:15 <sslypushenko__> and I will update docker doc
19:12:18 <pvaneck> then we can get rid of the 'npm start' docs in refstack-ui
19:12:21 <catherineD|2> #action pvaneck: will submit a patch for using refstack-api for serving the website
19:12:34 <pvaneck> leads to confusion
19:12:38 <catherineD|2> #action sslypushenko__: will update docker doc
19:12:49 <catherineD|2> pvaneck: what confusion?
19:13:02 <catherineD|2> pvaneck: got it
19:13:17 <pvaneck> multidomain wont be supported
19:13:57 <catherineD|2> #agreed multidomain won't be supported until further notice.
19:14:48 <catherineD|2> sslypushenko__: all your patches for signed upload work for me ... do you see the comments I left on that patches?
19:15:01 <sslypushenko__> Yeap
19:15:22 <sslypushenko__> About "Profile" against user-name
19:15:33 <sslypushenko__> It is - by desing)
19:16:01 <sslypushenko__> You can try last patch
19:16:02 <catherineD|2> sslypushenko__: ic ...
19:16:18 <sslypushenko__> It is fully functional
19:17:09 <catherineD|2> sslypushenko__: will do .... I can't wait until those patches merged .... they bring Refstack to a different level ... Thanks for all you hardwork ...
19:17:12 <sslypushenko__> I'm planning cover all new code in this patch and then remove WIP
19:17:36 <sslypushenko__> I hope i will finish this week
19:17:55 <sslypushenko__> catherineD|2 Thx )
19:18:17 <pvaneck> from when i pulled everything last week, it all worked fine :)
19:18:22 <catherineD|2> sslypushenko__: that is great .... once we have those patches merged we can start the vendors registration use case ...
19:19:03 <sslypushenko__> Sounds resonable
19:19:10 <catherineD|2> I really hope that our speaker session got accepted .... we do have a lot to cover on the session ... and hope to see all Refstack cores at the summit ///
19:19:46 <sslypushenko__> Do you know something about vote results?
19:20:26 <catherineD|2> not yet ... they will publish soon I think ... I hope Mirantis let you go ...
19:20:26 <sslypushenko__> I think, voting was finished last
19:20:49 <catherineD|2> yes voting finished .. they need to calculate the results ...
19:21:17 <catherineD|2> anthing else on this topic ...
19:21:40 <sslypushenko__> If our talk is accepted, I think there was no problems here
19:22:00 <catherineD|2> sslypushenko__: that is great ...
19:22:16 <catherineD|2> #topic Refstack face-2-face meeting
19:22:21 <sslypushenko__> Also I hope Foundation will continue work with Mirantis)
19:22:39 <catherineD|2> sslypushenko__: is there an end date?
19:22:56 <catherineD|2> I hope it does not ...
19:22:59 <sslypushenko__> end of August
19:23:04 <catherineD|2> wow
19:23:58 <sslypushenko__> So I hope that Foundation and Mirantis come to new agreement on next half of the year
19:24:27 <catherineD|2> I hope they continue too ...
19:24:55 <sslypushenko__> ok, let move on
19:25:01 <catherineD|2> sslypushenko__: I hope you think the Refstack work is meaningful ...
19:25:18 <sslypushenko__> For sure)
19:25:47 <catherineD|2> #info Do we need a face-2-face to discuss the topics listed i nthe agenda?
19:26:50 <catherineD|2> #info 1) Non-tempest testing 2) DefCore use cases. 2.1) compare results. 2.2) Vendor registration
19:27:27 <sslypushenko__> I think it would be good
19:27:50 <catherineD|2> it just mean that we decicate sometime to focust on that ...
19:28:18 <catherineD|2> sslypushenko__: if you are joining us ... we need to find reasonable time for you ...
19:28:37 <catherineD|2> we may only need one day ...
19:28:43 <pvaneck> tentative 9/2?
19:29:05 <catherineD|2> sslypushenko__: is 9/2 good for you?
19:29:40 <sslypushenko__> just a sec
19:30:01 <sslypushenko__> I think it will be ok
19:30:49 <catherineD|2> catherineD|2: how about the time ? give me the best time for you ...
19:32:02 <catherineD|2> sslypushenko__: that message is to you not to me :-) ... which  4 hours block is good for you?
19:32:23 <catherineD|2> also could both of you check your 9/3 schedule just in case ...
19:33:16 <pvaneck> im good whenever
19:33:21 <sslypushenko__> time calculations) just a sec
19:34:36 <sslypushenko__> I can be up till 21:00 UTC
19:35:21 <catherineD|2> 21 UTC will be 2:oo PM PDT that is good ...
19:35:27 <catherineD|2> how about start time?
19:36:00 <sslypushenko__> so let it be from 10AM to 2PM PDT
19:36:27 <catherineD|2> that is great for us .... but it will be your dinner time :-(
19:36:53 <sslypushenko__> after dinner time) but it is ok)
19:37:28 <pvaneck> so for now, schedule from 10am-2pm pdt, 9/2?
19:37:53 <catherineD|2> #info Refstack face-2-face meeting tentatively will be either 9/2 or 9/3 from 10:00 AM - 2:00 PM PDT (17:00 UTC - 21:00 UTC)
19:37:58 <pvaneck> hopefully others can join
19:38:10 <catherineD|2> pvaneck: I will check with David and Rocky on the date ..
19:38:32 <catherineD|2> and Rob too
19:38:50 <catherineD|2> then we decide next week on whether it is 9/2 or 9/3
19:39:03 <sslypushenko__> I think we will have some updates on non-tempest testing to that time
19:39:23 <catherineD|2> sslypushenko__: great ..
19:39:38 <catherineD|2> moving on ...to the related topic
19:39:56 <catherineD|2> #topic EC2 API JSON Entry for RefStack
19:40:36 <catherineD|2> that is also non-tempest test ... based on  a note send out by Rocky ..
19:41:30 <catherineD|2> Personally,  I think this is a good topic for the face-2-face?  What do you think?
19:41:41 <sslypushenko__> Right now we are working on tempest plugin for running swift test. I think we will get some experience with this
19:42:15 <catherineD|2> so let's defer this topic to face-2-face ..
19:42:20 <sslypushenko__> +1
19:42:26 <pvaneck> yep
19:42:36 <notmyname> sslypushenko__: what is thise?
19:42:49 <notmyname> running swift's tests via tempest plugins?
19:43:15 <notmyname> sslypushenko__: ^
19:43:57 <sslypushenko__> Defcore team decide to include some in-tree swift tests in required list
19:44:08 <catherineD|2> notmyname: background info  https://review.openstack.org/#/c/164865/
19:44:20 <sslypushenko__> So in refstack we need to run this tests some how
19:44:32 <notmyname> sslypushenko__: right. if you're working on some things, please talk to hurricanerix who is working in swift on getting the swift tests using test-repository
19:44:51 <notmyname> catherineD|2: yeah, that's my patch ;-)
19:45:03 <sslypushenko__> Oh! Great thx!
19:45:16 <notmyname> anyway, I saw "swift" in IRC. I wanted to make sure I made the connection if other people are doing stuff too
19:45:42 <catherineD|2> notmyname: Hello  sorry did not regconize your IRC name ...
19:45:48 <notmyname> no worries :-)
19:45:50 <sslypushenko__> We need some assistance from swift team
19:46:17 <notmyname> sslypushenko__: yeah, hurricanerix is woking on it in swift, and I'm happy to be a point of contact as the PTL
19:46:32 <sslypushenko__> Great!
19:47:09 <notmyname> please work with hurricanerix and let me know how I can help
19:47:23 <sslypushenko__> Will do
19:47:39 <catherineD|2> sslypushenko__: yea notmyname: and mtreinish: should be informed/involved on this discussion ....
19:48:04 <sslypushenko__> He is already informed
19:48:29 <sslypushenko__> I have talk about plugins with him
19:49:34 <sslypushenko__> It looks like plugins  will be very helpful for Refstack in terms of runnig in-tree tests from other projects
19:49:58 <catherineD|2> #info sslypushenko__: and team will work with notmyname: and mtreinish: on plugins to bring non-tempest test to Refstack...
19:50:31 <catherineD|2> #agreed defer EC2 API JSON Entry for RefStack  to face-2-face meeting
19:51:05 <catherineD|2> notmyname: thx a lot!
19:51:16 <notmyname> happy to help :-)
19:51:48 <catherineD|2> #topic      Relocate RefStack Project
19:52:55 <catherineD|2> #info waiting for  https://review.openstack.org/#/c/205777/ which is under reviewed
19:53:14 <catherineD|2> #Infra hosting
19:53:36 <catherineD|2> #topic infra hosting
19:53:54 <catherineD|2> Paul's https://review.openstack.org/#/c/203764/ merged
19:54:42 <catherineD|2> Still have Jenkin issue with https://review.openstack.org/#/c/198869/
19:54:58 <pvaneck> the issue seems to stem from here: http://logs.openstack.org/69/198869/6/check/gate-infra-puppet-apply-bare-trusty/6185973/puppetapplytest28.final.out
19:55:37 <catherineD|2> does that only happen to our patch?
19:56:48 <pvaneck> yes, since the log is refstack-related
19:56:56 <catherineD|2> ok
19:57:28 <catherineD|2> I guess we need to ask for help on infra IRC
19:58:13 <pvaneck> i will investigate a bit more
19:58:45 <catherineD|2> #action pvaneck: will investigate and  ask for help on infra IRC channel
19:59:25 <catherineD|2> I guess we run out of time ... sslypushenko__: let's discuss https://review.openstack.org/#/c/192709 on #refstack
19:59:37 <sslypushenko__> ok
19:59:38 <catherineD|2> #endmeeting