19:00:46 <catherineD> #startmeeting refstack
19:00:47 <openstack> Meeting started Mon Aug  3 19:00:46 2015 UTC and is due to finish in 60 minutes.  The chair is catherineD. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:50 <openstack> The meeting name has been set to 'refstack'
19:01:15 <catherineD> #link meeting agenda and notes, please feel free to add items https://etherpad.openstack.org/p/refstack-meeting-15-08-03
19:02:15 <pvaneck> o/
19:02:32 <sslypushenko__> o/
19:02:59 <catherineD> hello pvaneck: sslypushenko__:
19:03:23 <pvaneck> hello all
19:04:33 <catherineD> let's start ... did you see the agenda link  ..
19:04:51 <sslypushenko__> yeap
19:04:59 <catherineD> ok
19:05:20 <catherineD> #topic Relocate RefStack Project
19:05:37 <hogepodge> o/
19:05:53 <catherineD> hello hogepodge:
19:06:00 <sslypushenko__> hi hogepodge:
19:06:58 <catherineD> #topic  https://review.openstack.org/#/c/205609/   was merged this morning .... so openstack-infra has adopted Refstack !!!
19:08:07 <catherineD> hogepodge: I know we have discussed to move Refstack under OpenStack ... Is the Foundation OK with Refstack under Infra?
19:08:26 <hogepodge> yes, it's really the team's call
19:08:46 <sslypushenko__> Good news!)
19:08:50 <hogepodge> you might want to get on a TC agenda to make sure that refstack qualifies for ATC for active contributors
19:09:14 <hogepodge> It's not clear if that's automatic with the merge to infra, but I feel like the team members deserve it.
19:09:20 <catherineD> so I will proceed by pushing an update to https://review.openstack.org/#/c/205777/
19:09:35 <hogepodge> Note that because Defcore is a board project and not a TC project, ATC is not available for Defcore contributors
19:09:38 <catherineD> hogepodge: thx for the suggestion ... Yes I will do that ///
19:10:23 <catherineD> yes our team deserve to be ATC ...
19:11:22 <catherineD> #action Catherine to get on a TC agenda to make sure that Refstack contributors qualify for ATC
19:12:38 <catherineD> the only reason https://review.openstack.org/#/c/205777/ has a -1 is because I did not put down that Refstack uses Storryboard ...
19:12:59 <catherineD> all project under Infra use Storyboard ...
19:13:39 <Rockyg> o/
19:13:44 <catherineD> #info The Refstack team decided on the Vancouver f2f meeting that we will not use Storyboard
19:14:35 <pvaneck> seems more like he thought it was an oversight and not intentional
19:14:37 <Rockyg> Infra is looking at and likely going with phabricator
19:14:38 <catherineD> #action Catherine to update patch  https://review.openstack.org/#/c/205777/ with reason why Storyboard was not included
19:14:38 <sslypushenko__> Storyboard is not suitable for failing bugs
19:15:29 <catherineD> Rockyg: not sure you see the earlier converstaion but the good news is Refstack is approved to be under openstack-infra
19:16:19 <catherineD> so I take that the Refstack team still want to keep our decision of not using Storyboard
19:16:19 <sslypushenko__> But if infra team insist  on storyboard, I think thar using a Storyboard will be a big issue
19:16:49 <catherineD> sslypushenko__: I think if they insist .... we should use both ...
19:17:19 <sslypushenko__> we can use launchpad only as bag tracker
19:17:57 <catherineD> sslypushenko__: agree
19:18:46 <catherineD> #agreed Refstack will use launchpad for bugs  report
19:19:07 <catherineD> #topic  Infra Hosting
19:20:04 <catherineD> hogepodge: we need help on https://review.openstack.org/#/c/198869/  it failed Jenkins ..
19:21:16 <catherineD> Rockyg: hogepodge: do you know anyone in Infra can help?
19:22:09 <Rockyg> Yeah.  We just have to go over to openstack-infra and ask.
19:23:06 <hogepodge> looking
19:23:31 <hogepodge> couldn't stat console?
19:24:21 <hogepodge> I'll try a recheck to see it it's on the infra side
19:24:32 <pvaneck> seems to have been consistently failing just the trusty job
19:25:25 <catherineD> hogepodge: thank you!
19:26:16 <catherineD> #action hogepodge: will try to recheck https://review.openstack.org/#/c/198869/
19:26:52 <catherineD> pvaneck: you will aks for review on https://review.openstack.org/#/c/203764/ ?
19:27:23 <pvaneck> yep
19:27:28 <catherineD> pvaneck: thx
19:27:32 <catherineD> moving on ..
19:27:43 <catherineD> #topic OpenStackID integration
19:28:07 <catherineD> This should be our priority for the  next 2 weeks
19:28:43 <catherineD> sslypushenko__: are the patches still WIP?
19:29:17 <sslypushenko__> They are still WIP because they need unittest coverage
19:29:48 <sslypushenko__> I'm planing to finish test results sharing first
19:29:59 <catherineD> ic  ... I know pvaneck: had run some tests .... I will run some tests this week ...
19:30:09 <sslypushenko__> and than start covering that patches with tests
19:31:04 <catherineD> ok ... will there be db update on any of this patches?
19:31:08 <sslypushenko__> I'm planing to finish test result deleting and sharing this week
19:31:11 <catherineD> these
19:31:22 <sslypushenko__> Yes
19:31:35 <catherineD> are you adding new column?
19:31:43 <sslypushenko__> Adding new table
19:31:57 <sslypushenko__> for storing user public keys
19:32:16 <sslypushenko__> You can use run-in-docker script
19:32:28 <catherineD> ic
19:32:38 <sslypushenko__> It solves such kind on problem)
19:32:54 <catherineD> while we are in this topic ... could we look at item 5.2.2 on https://etherpad.openstack.org/p/refstack_f2f_may_2015
19:33:18 <catherineD> under action items
19:33:36 <sslypushenko__> We can add tags
19:33:48 <sslypushenko__> in next step
19:34:05 <pvaneck> yep
19:34:18 <catherineD> so would the tags be in a new table?
19:34:48 <catherineD> I am thinking tag woukd be a key/value pair ...
19:34:56 <sslypushenko__> current db schema and API allows to do it easily
19:35:06 <catherineD> one of which could be the publice key
19:35:19 <catherineD> would that make sense?
19:35:22 <sslypushenko__> tags will be stored into metadata table
19:36:16 <sslypushenko__> public keys are stored into this table to
19:36:18 <catherineD> sslypushenko__: I take that you would like the public key to be on its own table
19:36:57 <catherineD> sslypushenko__: so public keys are stored into the metadata table too?
19:36:59 <sslypushenko__> pubkeys owned by user need an separate table
19:37:23 <catherineD> sslypushenko__: ok got it thx ...
19:38:02 <sslypushenko__> no problem)
19:38:13 <catherineD> will review your patches ... This is my priority this week ...
19:38:37 <catherineD> enything else on this topic?
19:38:38 <sslypushenko__> Ok, I will update commit messages to help
19:38:57 <sslypushenko__> lets move on
19:39:26 <catherineD> I will skip topic 4 on ghe agenda because we had discussed it earlier ...
19:40:16 <catherineD> #action OpenStackID integration should be the priority for the Refstack team in the next 2 weeks
19:40:31 <catherineD> #topic Refstack Discussion Topics at DefCore f2f meeting
19:41:16 <catherineD> hogepodge: was at the Board meeting while Rob demoed Refstack ...
19:42:25 <catherineD> Refstack was well accepted  .... hogepodge: anything else to add ?
19:43:10 <hogepodge> foundation staff really enjoyed the demo also
19:43:27 <hogepodge> especially the new ui patches showing pass/fail
19:44:17 <sslypushenko__> Great thx to pvaneck for refstack UI)
19:44:29 <catherineD> pvaneck: good job ... you should remove the workflow block so we can merge that patch ...
19:44:58 <pvaneck> already did
19:45:24 <catherineD> hogepodge: we thought that YES/NO would be controversial ...
19:45:47 <hogepodge> definitely not. It's a big help
19:46:47 <catherineD> hogepodge:  I feel  really happy for the entire Refstack team .... We start to see the results of our hard work  ..
19:47:39 <catherineD> Another subject discussed at the DefCore f2f meeting is for Refstack  to run non-tempest test
19:47:41 <hogepodge> We're going to be looking at how we can intrgrate refstack with marketplace,
19:48:06 <catherineD> hogepodge: wow that is really good news for Refstack !!!!
19:48:28 <catherineD> #topic EC2 API JSON Entry for RefStack
19:49:33 <catherineD> Do you all have a chance to review a note Rockyg:  sent out about the EC2 test subject?  I make a copy of her note https://etherpad.openstack.org/p/refstack-meeting-EC2-API-JSON-Entry
19:49:40 <catherineD> so we can review it ...
19:51:17 <catherineD> do you have a chance to review this note?
19:51:52 <sslypushenko__> in any way it leads us to necessity to run non-tempest test
19:52:06 <sslypushenko__> w]
19:52:12 <sslypushenko__> sorry)
19:52:28 <catherineD> sslypushenko__: I think sooner or later we have to be able to support non-tempest test ...
19:52:57 <catherineD> for this set of tests ... they are not only non-tempest they are also non-DefCore ...
19:53:03 <Rockyg> they all run under tempest
19:53:28 <sslypushenko__> Yeap, and after it refstack can be used for that purpose easily, but not now
19:54:09 <catherineD> Rockyg: it does not seems so from my first review ,... I can follow up with Alex ...
19:54:43 <Rockyg> ok.  Icould easily be wrong
19:54:45 <sslypushenko__> Rockyg Asfar as I understand they run functional tests for ec2api project
19:54:46 <catherineD> How about we defer this topic until next week .... Let me take a closer look to see ...
19:54:58 <sslypushenko__> +1
19:55:32 <catherineD> #action Review EC2 test week of 2015-08-10
19:55:53 <sslypushenko__> run non-tempest tests is a next big step for Refstack
19:56:04 <catherineD> sslypushenko__: yea ....
19:56:13 <sslypushenko__> actually for Tempest and Refstack
19:56:17 <catherineD> And we need to support that
19:56:25 <sslypushenko__> We will
19:56:39 <pvaneck> +1
19:56:49 <sslypushenko__> Chris asks Mirantis team to support this process
19:56:54 <catherineD> Rockyg: thx for bringing this test set to us .... it will be our first exercise ...
19:57:18 <catherineD> sslypushenko__: support unitest in Refstack?
19:57:49 <catherineD> only 3 mins left
19:57:59 <catherineD> #topic Open Discussion
19:58:14 <sslypushenko__> support adoption to run external functional tests in tempest
19:58:27 <catherineD> I start to see people asking questions and file bugs in launchpad for Refstack
19:58:55 <sslypushenko__> qa-team has already been working on that from tempest side
19:59:11 <catherineD> that is an indication of people start to use Refstack ...
19:59:32 <catherineD> sslypushenko__: great that the Tempest team start working on that ...
19:59:33 <pvaneck> yea will pay more attention to that
20:00:03 <catherineD> need to end this meeting .... thank you everyone !!!
20:00:14 <catherineD> #endmeeting