19:00:48 <catherineD|2> #startmeeting refstack
19:00:49 <openstack> Meeting started Mon Jul 27 19:00:48 2015 UTC and is due to finish in 60 minutes.  The chair is catherineD|2. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:53 <davidlenwell> o/
19:00:53 <openstack> The meeting name has been set to 'refstack'
19:01:28 <catherineD|2> #link meeting agenda and notes, please feel free to add items https://etherpad.openstack.org/p/refstack-meeting-15-07-27
19:01:41 <catherineD|2> Roll call
19:02:14 <sslypushenko__> o/
19:02:15 <catherineD|2> hogepodge:is traveling so won't attend today ...
19:02:22 <pvaneck> o/
19:02:41 <catherineD|2> Let's start ...
19:03:06 <catherineD|2> #topic      Tokyo Refstack  sessions ...
19:03:39 <catherineD|2> #link please vote for Refstack session: https://www.openstack.org/summit/tokyo-2015/vote-for-speakers/presentation/5256
19:03:49 <sslypushenko__> catherineD|2 Can you please share agenda link?
19:04:30 <catherineD|2> #link agenda link https://etherpad.openstack.org/p/refstack-meeting-15-07-27
19:04:35 <sslypushenko__> thx)
19:04:54 <catherineD|2> sslypushenko__: np
19:05:39 <catherineD|2> I think deadline is this Friday for voting
19:06:18 <sslypushenko__> I have already voted. Lets cross fingers)
19:06:39 <pvaneck> catherine, add a picture for your speaker profile
19:07:07 <catherineD|2> We have asked Chris to see  if it is possible to schedule a room for Refstack design meeting at Tokyo.  but I do not think this is important ...
19:07:35 <catherineD|2> pvaneck: thx for reminder ..sslypushenko__: davidlenwell: you update your bio?
19:08:00 <sslypushenko__> oh! thx for reminder!
19:08:09 <davidlenwell> yes
19:08:10 <catherineD|2> sslypushenko__: will Mirantis let you travel if the session is accepted?
19:08:27 <sslypushenko__> I hope, so)
19:09:00 <catherineD|2> we hope so too ... everyone asks your friends and co-workers to vote for us OK? :-)
19:09:07 <catherineD|2> ok moving on ..
19:09:15 <sslypushenko__> Usually our company supports session speakers
19:09:22 <catherineD|2> #topic Relocate RefStack Project
19:10:01 <catherineD|2> davidlenwell:  could you take a look at the comments on https://review.openstack.org/#/c/205609/
19:10:46 <catherineD|2> at least Andreas Jaeger 's and  Thierry Carrez's feed back that Refstack should not be relocated to openstack-infra ...
19:11:29 <davidlenwell> I'll take a look
19:11:57 <catherineD|2> I know that we voted for moving to infra ... but other people do not think so ...
19:12:16 <catherineD|2> davidlenwell: you have discussed with Jim Blair right?
19:12:16 <davidlenwell> we can take their input into account
19:12:22 <davidlenwell> catherineD|2: yes I did
19:12:27 <catherineD|2> davidlenwell: I think so
19:12:28 <davidlenwell> he doesn't object..
19:12:31 <davidlenwell> let me make some comments on that
19:12:50 <catherineD|2> davidlenwell: please do ... Thanks!
19:13:55 <catherineD|2> we need to get  https://review.openstack.org/#/c/205609/  approved ....before working on the actual move patch  https://review.openstack.org/#/c/205777/
19:15:13 <catherineD|2> davidlenwell: we will wait for feedbacks after your comment on  https://review.openstack.org/#/c/205609
19:15:34 <davidlenwell> okay
19:15:40 <catherineD|2> any other input before we move on ..
19:15:46 <davidlenwell> no[
19:15:55 <sslypushenko__> move on
19:15:59 <catherineD|2> #action  Infra Hosting
19:17:29 <catherineD|2> we are stuck witth https://review.openstack.org/#/c/198869/    ... it failed Jenkin ... don't know how to fix it ...
19:18:00 <catherineD|2> who can help?
19:19:21 <sslypushenko__> We need puppet guru help)
19:20:07 <catherineD|2> sslypushenko__: davidlenwell: do you know any one ?
19:20:33 <pvaneck> not sure why it is failing specifically on the trusty job
19:20:49 <sslypushenko__> Unfortunately, no
19:20:50 <catherineD|2> fungi: could you please help with the Jenkin failure in https://review.openstack.org/#/c/198869/...
19:20:51 <davidlenwell> crinkle and nibalizer in #openstack-infra are both awesome with the puppet
19:21:55 <catherineD|2> I guess we will need to voice for help in openstack-infra IRC ...
19:22:10 <davidlenwell> yeah .. its a good idea
19:22:20 <catherineD|2> that is where we stuck at ... without this patch I don't think we can get any where ...
19:22:59 <catherineD|2> #topic Pending reviews
19:24:30 <catherineD|2> the Refstack patches are all failed for unit tests ... .Paul's fix just merged https://review.openstack.org/#/c/205929/  ... I guess we all need to rebase our patches
19:25:08 <sslypushenko__> Sure thing
19:25:21 <catherineD|2> Not much discussion here ...  until after rebase
19:25:32 <pvaneck> i will address comments in https://review.openstack.org/#/c/191610/9 , which is the schema versioning stuff
19:25:45 <pvaneck> hopefully we can get this merged before the defcore f2f
19:26:09 <pvaneck> since i think thats when they will be releasing the new capabilities
19:26:35 <catherineD|2> pvaneck: I know that DefCore will change schema often .. susceptible are we with their changes?
19:27:15 <pvaneck> as long as big changes get new versions, we should be fine
19:27:32 <pvaneck> as we seem to get a long runway before a new version is released
19:27:35 <catherineD|2> pvaneck: that is good
19:28:08 <sslypushenko__> +1 current solution looks fine to meet new schema changes
19:28:10 <catherineD|2> Refstack is a discussion topic on Wednesday DefCore f2f mid-cycle meeting
19:28:23 <pvaneck> so board of directors meeting is tomorrow right?
19:28:54 <catherineD|2> we need https://review.openstack.org/#/c/204742/ and https://review.openstack.org/#/c/191610/ merged ... so we can show DefCore what we have for their feedback
19:29:45 <pvaneck> should be able to by wednesday
19:29:50 <catherineD|2> pvaneck: I think so ... hogepodge: is traveling for the meeting .. hogepodge: mentioned about Refstack demo to board sometime ago ..
19:30:04 <catherineD|2> He may demo to them tomorrow ...
19:30:15 <catherineD|2> let's get it done by tomorrow if we can ...
19:30:47 <catherineD|2> pvaneck: thx for reminder about board meeting .... I was only thinking about DefCore meeting /...
19:31:17 <catherineD|2> I have tested both patches ...
19:31:37 <catherineD|2> so please let rebase ...
19:31:49 <catherineD|2> anuthing else on this topic ?
19:32:09 <catherineD|2> #topic Open discussion
19:32:26 <pvaneck> I will focus on getting these patches fixed up
19:32:38 <catherineD|2> I will be at the DefCore f2f meeting ....
19:33:23 <catherineD|2> pvaneck: thx ..
19:33:27 <fungi> catherineD|2: i'm not around at the moment, but hogepodge said he was going to help with that patch
19:33:43 <sslypushenko__> Hmm... how we can show new schema handling without new schema?
19:33:44 <catherineD|2> fungi: thx ... I know ...
19:33:44 <fungi> https://review.openstack.org/198869 specifically
19:35:12 <pvaneck> sslypushenko__: do you mean testing that the handling works with the new schema?
19:35:30 <sslypushenko__> only 2015.next.json contains new schema, refstack don't show it
19:35:38 <pvaneck> what i have been doing was adding <option value="2015.next.json">2015.next</option> for testing purposes
19:36:01 <pvaneck> once it turns to 2015.07.json, the new schema will be available on refstack.net
19:37:13 <sslypushenko__> sure, but it hasn't released yet.
19:37:56 <sslypushenko__> So there is no hurry here, I think
19:38:00 <catherineD|2> davidlenwell: we start to get some bug report and ask question on launchpad  ... could you add sslypushenko__: pvaneck: and me as supervisor so we get notify on activites ..
19:38:14 <davidlenwell> sure
19:39:09 <pvaneck> I'm expecting it to be released in the next few days based on https://review.openstack.org/#/c/203474/
19:39:11 <catherineD|2> pvaneck: thx...
19:39:31 <pvaneck> so it would be good for refstack.net to be able to immediately handle it whenever that merges
19:40:10 <catherineD|2> yup ... so let focus on merging pvaneck: 's 2 patches ..
19:40:53 <sslypushenko__> I think both of them are good enought)
19:41:25 <catherineD|2> yea just the unit tests failure were gating on us ...
19:41:43 <pvaneck> i can easily address your inline comments, sergey, working on that now
19:42:11 <pvaneck> can do grouping in a later patch
19:42:29 <sslypushenko__> thx) everything else LGTM
19:42:51 <sslypushenko__> Lets left gourppinh
19:43:05 <catherineD|2> sslypushenko__: that was a good comment ... and should be implemented ...now or later ..
19:43:06 <sslypushenko__> *grouping for future work
19:43:39 <catherineD|2> anything else?
19:45:26 <catherineD|2> if not this will be the first time that we end the meeting early ...
19:45:30 <sslypushenko__> catherineD|2 Refstack UI defenately needs some care to improve UX )
19:46:03 <catherineD|2> agree ... on the results tab?
19:46:20 <sslypushenko__> catherineD|2 Can ask you to review https://review.openstack.org/#/c/200486/
19:46:58 <catherineD|2> sslypushenko__: for sure ... https://review.openstack.org/#/c/200486/
19:47:22 <sslypushenko__> We need to push it forward
19:48:08 <catherineD|2> sslypushenko__: will take a look ... sometime it takes me sometime to review because I really spend time reading and testing the code if possible ,,,, expecially tempest (a lot to learn)
19:48:23 <sslypushenko__> All our refstack-related work on tempest depends on it
19:48:53 <catherineD|2> sslypushenko__: will review ...
19:48:59 <sslypushenko__> Thx)
19:49:23 <catherineD|2> anything else?
19:49:25 <sslypushenko__> Did look on subunit2sql?
19:49:58 <catherineD|2> yes ... but I have not see away to use it at the refstck-client side
19:50:02 <catherineD|2> even the API ...
19:50:14 <catherineD|2> even at the API level ..
19:50:48 <sslypushenko__> I have same opinion
19:50:57 <catherineD|2> unless we want to send the subunit file to the server side ...
19:51:12 <catherineD|2> it is not very useful for ...
19:51:19 <sslypushenko__> There a lot of useful code here
19:51:39 <sslypushenko__> but our goals a preety differs
19:52:11 <catherineD|2> yes a lot of useful code expecially if the database is there at the client side ...
19:53:01 <sslypushenko__> If subunit2sql supports sqlite it will be really useful thing
19:53:17 <catherineD|2> the issue is we only wan to send pass test ... that is why the subunit processing should be done at the client side
19:53:56 <catherineD|2> sslypushenko__: ic .. then we will have a simple db just for subunit processing ...
19:54:13 <catherineD|2> the goal is refstack-client should be as simple as possible ...
19:54:26 <catherineD|2> to enable people to test ...
19:54:28 <sslypushenko__> fully agreed
19:55:24 <catherineD|2> in the future refstack-client may need to support other test suite ... so it will be more complicate ... but we should try to keep it as simple as possible
19:55:47 <sslypushenko__> I have already talked to Chris that we should drop idea to identify cloud by cpid
19:56:13 <sslypushenko__> Because it is to complicated in general
19:56:24 <catherineD|2> then what do we use to identify Cloud?
19:56:40 <catherineD|2> reliablely identify a cloud?
19:56:43 <sslypushenko__> We should trust user in this point
19:57:08 <catherineD|2> so user will input a cloud id?
19:57:20 <sslypushenko__> There is no other working way for the time beening
19:57:33 <catherineD|2> or we should ask user to input there cloud keystone id?
19:57:37 <sslypushenko__> User could input some tag
19:57:39 <davidlenwell> sslypushenko__: ++
19:57:55 <catherineD|2> yes because to get keystone id we need admin credential ..
19:58:00 <sslypushenko__> cloud specific tag
19:58:25 <catherineD|2> what would be the format of the tad .. or do we care to define the tag format ?
19:58:32 <igueths> o/
19:58:37 <catherineD|2> tad --> tag
19:58:54 <sslypushenko__> Lately we can implement some non admin endpoint in keystone for cloud indetification
19:59:22 <catherineD|2> igueths: we are still in #restack meeting ...
19:59:35 <sslypushenko__> Let move discussion in refstack channel
19:59:43 <catherineD|2> we should end soon let's discuss on #refstack ...
19:59:52 <catherineD|2> #endmeeting