19:02:00 <catherineD> #startmeeting refstack
19:02:01 <openstack> Meeting started Mon Jun 29 19:02:00 2015 UTC and is due to finish in 60 minutes.  The chair is catherineD. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:04 <openstack> The meeting name has been set to 'refstack'
19:02:04 <sslypushenko__> o/
19:02:11 <Rockyg> o/
19:02:20 <catherineD> Roll call
19:02:35 <davidlenwell> o/
19:03:06 <catherineD> hello every one ..  Chris won't be able to make today's meeting ..
19:03:14 <pvaneck> o/
19:03:24 <catherineD> please see agenda #link https://etherpad.openstack.org/p/refstack-meeting-15-06-29
19:03:47 <catherineD> #topic Relocate RefStack Project
19:04:27 <sslypushenko__> With Rob's vote, I think Infra wins)
19:04:44 <catherineD> We were tied during last week's vote ... but I think zehecle: broke the tie
19:04:50 <catherineD> sslypushenko__: yes
19:05:32 <davidlenwell> did rob vote?
19:05:35 <catherineD> davidlenwell: do you know what is the next step
19:05:57 <sslypushenko__> Actually, I think there is no big real difference. So let it be "Infra"
19:06:02 <catherineD> not officially by he sent me a note and I forward to everyine ...
19:06:36 <catherineD> davidlenwell: I sent to your gmail ... could you check?
19:06:37 <davidlenwell> making the move is easy ..
19:06:57 <zehicle> o/
19:07:02 <davidlenwell> I have no email from you catherineD
19:07:16 <catherineD> sorry my typo is really bad today ..
19:07:24 <davidlenwell> The issue is that I have a full plate until tuesday when I go on vacation until monday
19:07:35 * zehicle confirms +1 on Infra
19:07:39 <davidlenwell> So I can take care of getting us moved into infra.. but It will have to be next week
19:08:07 <catherineD> zehicle: thx for your vote  ...
19:08:31 <Rockyg> That should be fine.  I might be able to start the ball rolling.  I'm doing a couple of other repos right now.
19:08:51 <catherineD> #agreed Moving Refstack under Infra's namespace
19:09:20 <krotscheck> o/
19:09:28 <catherineD> #action davidlenwell: to take care of the next steps to move Refstack into Infra
19:10:05 <davidlenwell> cool .. like I said .. when I get back next week I'll handle it
19:10:15 <catherineD> davidlenwell: thx
19:10:30 <catherineD> #topic Infra Hosting
19:10:43 <davidlenwell> our spec was merged.. https://review.openstack.org/#/c/188207/
19:11:27 <davidlenwell> from what I understand we are waiting on a review from jeblair on this .. https://review.openstack.org/#/c/182437/
19:11:50 <catherineD> davidlenwell: hogepodge:  Good job!  Thank you!
19:12:27 <catherineD> #link https://review.openstack.org/#/c/188207/  merged !!!
19:12:46 <catherineD> Wating for jeblair's +2 on #link https://review.openstack.org/#/c/188207/
19:13:23 <catherineD> anything else to discuss on this topic?
19:13:31 <Rockyg> catherineD: got the last review number wrong...
19:13:48 <davidlenwell> yeah .. those last two links are the same
19:13:50 <catherineD> Rockyg: thx
19:14:42 <catherineD> Wating for jeblair's +2 on #link https://review.openstack.org/#/c/182437/
19:15:20 <catherineD> #topic Set up eavesdrop for refstack channel
19:15:48 <catherineD> This is Chris' action item ... will check  with him next week ...
19:16:43 <catherineD> #action Check with hogepodge: on status next week
19:17:17 <catherineD> #topic OpenStackID integration
19:18:01 <catherineD> sslypushenko__: I guess https://review.openstack.org/#/c/176335/ need bebase
19:18:32 <sslypushenko__> catherineD I got email from you and I tried to reproduce that error but failed (
19:19:08 <catherineD> sslypushenko__: thx ... we can discuss more on #refstack ..
19:19:10 <sslypushenko__> I will send you email with details
19:19:21 <sslypushenko__> agreed
19:20:02 <sslypushenko__> Patch rebased
19:21:06 <catherineD> We just need to resolve some of the issues ... but I have no doubt that we will merge it .... let's disucss some of the topics related to it ...
19:21:16 <sslypushenko__> pvaneck Did you try this patch?
19:21:38 <davidlenwell> its just a matter of gettings the silly tests to pass ..
19:22:01 <pvaneck> i tried it with the run-in-docker script, but had to modify the osid_endpoint in the refstack.conf.tmpl
19:22:19 <pvaneck> it worked okay with my local openstackid
19:22:33 <sslypushenko__> Good news)
19:23:10 <sslypushenko__> I will think how to provide osid_endpoint little bit accurate
19:23:11 <catherineD> good news indeed .... let me compare my env with pvaneck:'s
19:24:12 <sslypushenko__> oh! This might help
19:24:12 <catherineD> Currently, we identify a cloud by using Keystone UUID as its cpid (cloud provider id) ...
19:25:31 <catherineD> sslypushenko__: pvaneck: let me know if you are ready to discuss next topic cpid ...
19:25:48 <sslypushenko__> I'm ready)
19:25:56 <catherineD> thx
19:26:20 <catherineD> we need to have admin credential to fecth keystone UUID ...
19:26:44 <sslypushenko__> But don't have solution)
19:27:05 <sslypushenko__> Without admin creds keystone api is really small
19:27:45 <catherineD> zehicle: davidlenwell: Rockyg: that means that Refstack will always require admin credential .. not for test ... but for fetching cloud id
19:28:16 <davidlenwell> to clarify refstack-client will need admin creds
19:28:21 <davidlenwell> which we decided early on was fine
19:28:36 <zehicle> yy, that's a reality we have to accept
19:28:47 <davidlenwell> the refstack api / database does not store any creds to clouds
19:28:55 <zehicle> would be nice for it to be addressed over time so that end users could submit
19:29:10 <sslypushenko__> It is fine for now. But in future it will be not fine, I think
19:29:17 <davidlenwell> we have a lot of work to do with q/a before that can be a reality
19:29:38 <catherineD> This means that Refstack will always need to be tested on-premise .. we will not be able to graduate to have a centralized test
19:29:39 <davidlenwell> I'm not saying we shouldn't do it .. im just saying that this is not new information
19:29:40 <Rockyg> +1
19:30:28 <davidlenwell> centralized testing would be nice .. but I don't think its realistic
19:30:55 <davidlenwell> how can you test admin api's from outside the admin network.. you just can't .. there are more problems here than just creds
19:31:17 <davidlenwell> logistically the test needs to be ran inside an enviornment
19:31:22 <Rockyg> amen to that
19:31:34 <davidlenwell> we can revist tcup as a solution
19:31:40 <catherineD> So I take that we all agree that we will consider this topic but will defer it to later
19:31:45 <davidlenwell> but I don't think trust is really a problem here
19:31:48 <sslypushenko__> I don't think that getting cpid with refstack-client is really necessary
19:32:07 <catherineD> sslypushenko__: how would we identify a cloud?
19:32:09 <davidlenwell> with signed results it isn't as nescesary depending on what you plan on doing with the data
19:32:22 <sslypushenko__> User can specify it
19:32:27 <davidlenwell> yeah
19:32:29 <davidlenwell> that works too
19:32:35 <davidlenwell> good thinking sslypushenko__
19:32:43 <catherineD> so user will pass in keystone uuid?
19:33:03 <davidlenwell> use "can"
19:33:07 <sslypushenko__> Some thing like name, will be good enought
19:33:20 <davidlenwell> but the refstack client needs admin creds anyways .. so I don't understand the point of this discussion
19:33:33 <sslypushenko__> or something more unique
19:33:57 <davidlenwell> okay.. I have to run now.. sorry gang.. hit me up in #refstack if anyone wants to chat about this further
19:34:09 <sslypushenko__> davidlenwell q/a are moving fast)
19:35:06 <catherineD> davidlenwell: with the latest change using yaml file ... I believe a lot of the test results that Chris received were collected without admin credential  .. we can confirm with Chris on that ...
19:36:32 <catherineD> so do we agree to use cpid for now or we decide that all data upload will be signed and user needs to pass in cloud  ID (name or UUID)
19:37:02 <sslypushenko__> cpid for now is ok
19:37:40 <catherineD> sslypushenko__:  +1
19:37:46 <sslypushenko__> if something will change we will adjust to changes easly
19:38:03 <pvaneck> yea, that's fine for now
19:38:50 <catherineD> Rockyg: zehicle: your thoughts?
19:39:29 <Rockyg> agreed.  We can "enhance" later
19:39:48 <zehicle> sorry - have to catch up
19:41:02 <zehicle> my understanding is catherineD is right - if you know the CPID then you have rights for that CPID
19:41:26 <zehicle> at some point, we'll have to be able to cluster them into user accounts
19:41:49 <catherineD> #agreed Using Keystone UUID as cpid for now. Thus refstack-client still require admin credential.
19:42:30 <catherineD> #agreed Revisit the CPID tonpic in the next cycle
19:42:59 <zehicle> is there a refstack mid-cycle planned?
19:43:43 <catherineD> not yet .. but that is one of today's topic ...
19:44:41 <catherineD> let's continue on the user authentication topic ...
19:44:53 <zehicle> kk, thanks
19:45:07 <catherineD> Currently, on refstack.net, the results are displayed anonymously .. once user can log in with their own ID .. we need to add a page that displayed their own data ...
19:45:53 <sslypushenko__> sure, I'm working on that
19:46:11 <catherineD> great ... thx sslypushenko__:
19:47:04 <sslypushenko__> I'm working on endpoint for updating user profile. It will allow to upload user pubkey
19:47:38 <sslypushenko__> So after that we can add filter to UI for user's own tests
19:49:24 <catherineD> #action sslypushenko__: working on user;s own Refstack test result pages
19:50:12 <pvaneck> so to associate data with accounts, all youd have to do is use the --sign arg in refstack-client?
19:50:34 <sslypushenko__> yeap
19:50:42 <catherineD> we have 10 mins ... let's just discuss the 2 items in the Open Discussion ... that means we skip topic 5, 6, 7 for now?
19:51:24 <catherineD> #topic Open discussion
19:51:34 <catherineD> Do we need a Refstack mid-cycle f2f?
19:52:02 <sslypushenko__> I think, uit would be helpful
19:52:06 <pvaneck> weren't you at least planning on meeting with Rocky and David in the bay?
19:53:10 <Rockyg> yep.  but I can't remember for what
19:54:27 <catherineD> Rockyg: I think we were to meet for deciding where to relocate  Refstack ... but we have made our decision today ..
19:54:57 <catherineD> I am thinking of a f2f to discuss  action items #5 in https://etherpad.openstack.org/p/refstack_f2f_may_2015
19:54:57 <Rockyg> Hmm.  I thought it was to write something???
19:55:25 <pvaneck> lol would have to go back and check logs
19:56:04 <catherineD> I will check the log but I think it is for relocation of Refstack ...
19:56:33 <pvaneck> it's okay. We can still schedule another f2f if need be for other items
19:56:56 <catherineD> let discuss f2f next week ...
19:57:20 <catherineD> #action Discuss midcycle f2f meeting next week
19:57:49 <catherineD> 3 mins for next dicussion :  Do we want to submit a speaker session for Tokyo summit?
19:58:42 <pvaneck> do you have any topics youd wish to talk about?
19:59:34 <pvaneck> deadline i think is the 15th of July
19:59:47 <catherineD> I am thinking of we should have a session to discuss the new features added to refstack and refstack-client since Kilo cycle
20:00:11 <Rockyg> ++
20:00:11 <catherineD> we need to end meeting
20:00:25 <catherineD> #endmeeting